[erledigt] Eingehende Calls brechen nach ~30-60s ab.

Malcreatiure

Neuer User
Mitglied seit
29 Jul 2010
Beiträge
16
Punkte für Reaktionen
0
Punkte
1
Gegenstelle ist eine Fritzbox 7240 mit Firmware 73.05.22 (aktuell).
Nach einer Minute Gespräch (mal länger, mal kürzer) legt die Fritzbox auf (SIP 103 BYE, Reason: SIP; cause=502; text="no ACK for 200"). Schaut man das Gespräch vor dem BYE an, sieht man die Fritzbox beständig "200 OK" Nachrichten senden. Der DUS-Net Server antwortet jedoch nie mit einem "ACK".

Ein Testanruf über SIPgate zeigt dieses Verhalten nicht: Der Sipgate-Server sendet ein "ACK", die Fritzbox sendet darauf hin auch keine "200 OK" Nachrichten mehr, der Anruf bleibt bestehen.

Kann jemand dieses Verhalten nachvollziehen?
 
Zuletzt bearbeitet:

pln234

Mitglied
Mitglied seit
21 Jun 2010
Beiträge
265
Punkte für Reaktionen
0
Punkte
0
Ich habe 3 min eingehend mit Dus.net getestet, es bricht nicht ab. Alles perfekt. Überhaupt ist meine Sichtweise, dass Dus.net den SIP-Service ganz erheblich verbessert hat. Selbst der nächtliche Kurzausfall um 3:37 (Neustart eines Dienstes?) ist seit einiger Zeit nicht mehr da.
 

rmh

Aktives Mitglied
Mitglied seit
6 Jul 2008
Beiträge
1,870
Punkte für Reaktionen
13
Punkte
38
Eine Störung seitens Dus.net kann ich ebenfalls ausschließen. An mehreren Anschlüssen läuft alles wie es soll.
 

Malcreatiure

Neuer User
Mitglied seit
29 Jul 2010
Beiträge
16
Punkte für Reaktionen
0
Punkte
1
hat sich erledigt: Das Problem tritt nicht mehr auf, Das ACK kommt jetzt korrekt und damit findet die Fritzbox auch alles gut.
 

fr6nco

Neuer User
Mitglied seit
7 Jan 2014
Beiträge
2
Punkte für Reaktionen
0
Punkte
0
Hello Malcreatiure, how you solved this issue? The provider is sending ACK messages already to the 200 OK? We have a customer with the same problem, we do not send ACK to 200 ok either and sometimes the fritzbox responses with Bye message with reason Reason: SIP;cause=502;text="no ACK for 200". Should we enable the ACK message or are there any other possibilities to solve this issue on the fritzbox?

Sorry for the English text, I do not speak German very well, just translated it.

Thomas
 

LooserOuting

Neuer User
Mitglied seit
28 Nov 2011
Beiträge
85
Punkte für Reaktionen
0
Punkte
0
ich vermute malFritzbox ist hinter einem Router und nicht direkt am Internet angeschlossen. Das ACK was du (irgendwo) gesehen hast, ging an einem anderen Port, was daran liegt, dass das Contact-Feld im 200 OK nicht richtig ist. Der wird nämlich für das Routing in SIP ausgewertet.
Mit einem STUN-Server und einem Keepalive ("Portweiterleitung des Roueters aktiv halten")sollte das nicht geschehen. Außer man startet den Router neu, ohne dass die Fritzbox aktuallisiert wird(diese am besten dann auch nochmal neu starten).
Der Timer der für das Abbrechen nicht vollständig aufgebauter Anrufe ist 64 * T1-Timer. Der Standardwert für den T-timer ist 500ms. Es wird in diesem Fall also nach 32sekunden getrennt. :wiejetzt:

wenn dies bei sipgate funktioniert, dann nur weil nicht ganz standardkonform gearbeitet wird. In den meisten Fällen stellt dies zwar kein Problem. In einigen seltenen Fällen aber schon, naja und es nicht nicht halt standardkonform.
Deswegen kann man über derartigen Methoden streiten. :wippe:

Ein Provider sollte aber meiner Meinung stets die Standards einhalten. :meinemei:


:(:confused::noidea::-?:gruebel::doktor::???::doof::bluescre:
 
Zuletzt bearbeitet:

fr6nco

Neuer User
Mitglied seit
7 Jan 2014
Beiträge
2
Punkte für Reaktionen
0
Punkte
0
Well my bad. Of course we send an ACK message, but as you mentioned the 200 OK contained the private address of the device, so our system did not captured the SIP message on the interface, so it was not visible in our debugs. I have sent instructions to the customer, how to set up STUN on the FritzBox, I hope it will solve this issue.

Thank you for your help, I appreciate it.

Thomas
 

Afreaka

Neuer User
Mitglied seit
7 Sep 2011
Beiträge
21
Punkte für Reaktionen
0
Punkte
1
Ich habe seit rund 10 Tagen (vorher lief jahrelang alles bestens) das gleiche Problem: eingehende Gespräche via DUS.net brechen nach genau 32 Sekunden ab. Fehlermeldung in der Fritzbox 7490: Reason: SIP; cause=502; text="no ACK for 200". :(
Ausgehend ist alles ok. Auch 2 andere VOIP-Provider machen keine Probleme.
 
3CX

Neueste Beiträge

Statistik des Forums

Themen
235,582
Beiträge
2,062,853
Mitglieder
356,342
Neuestes Mitglied
computerfuchs