[Erledigt] Funktionierende OpenVPN Version?

AndreR

Aktives Mitglied
Mitglied seit
4 Jan 2006
Beiträge
1,579
Punkte für Reaktionen
0
Punkte
0
Hallo,

hier gibt es ja viele OpenVPN-Versionen, das ich ehrlich gesagt den Überblick verloren habe. Da gabs statisch gelinkte, dynamisch gelinkte...Und dann gabs noch Probleme mit OpenSSL, was nur jpses oder so richtig hinbekommen hat...

Was ich brauche, ist eigentlich folgendes:

ein binary, das keine weiteren Bibliotheken braucht, möglichst mit der aktuellen 0.9.8c Version von OpenSSL gelinkt. Ist das hier schon? Wenn ja, wo? oder mag mir die jemand zur Verfügung stellen.

Und (vielleicht sind wir hier doch bei Wünsch-dir-was) wenns noch einer drauf sein soll hätt ich gerne sowohl die letzte stabile (2.0.6 glaub ich) und die 2.1_beta14...

Vielen Vielen Dank schonmal
 
Zuletzt bearbeitet:

jspies

Neuer User
Mitglied seit
7 Mai 2005
Beiträge
39
Punkte für Reaktionen
0
Punkte
0
AndreR schrieb:
...
Was ich brauche, ist eigentlich folgendes:
ein binary, das keine weiteren Bibliotheken braucht, möglichst mit der aktuellen 0.9.8c Version von OpenSSL gelinkt...
Hier ist die aktuelle OpenVPN 2.1.Beta15 auf OpenSSL 0.9.8c. Das Binary läuft unter der Standard AVM 29.04.15 Version ohne weitere "shared libraries".

EDIT: Attachment entfernt - neue Version : siehe hier
MfG Jürgen
 
Zuletzt bearbeitet:

AndreR

Aktives Mitglied
Mitglied seit
4 Jan 2006
Beiträge
1,579
Punkte für Reaktionen
0
Punkte
0
Oh vielen Dank. Du stehst jetzt in meinem Buch der coolen Leute!

Dann werd ich die mal benutzen!
 

deller

Neuer User
Mitglied seit
2 Sep 2005
Beiträge
79
Punkte für Reaktionen
0
Punkte
0
hi,

mit comp-lzo Unterstützung?


p.s.: stehts bei mir schon lange im Buch der coolen Leute - ebenso wie die anderen Fritzbox-Tunner aus diesem Forum ;-)
 

Hellspawn

Neuer User
Mitglied seit
1 Dez 2005
Beiträge
63
Punkte für Reaktionen
0
Punkte
0
jspies schrieb:
Hier ist die aktuelle OpenVPN 2.1.Beta15 auf OpenSSL 0.9.8c. Das Binary läuft unter der Standard AVM 29.04.15 Version ohne weitere "shared libraries".
MfG Jürgen
Cool! Vielen Dank jspies! Könntest du das gleiche nochmal mit OpenSSL 0.9.8d kompilieren? (Ob statisch oder nicht, weiß ich net, davon habe ich keine Ahnung *g*)
Denn OpenSSL 0.9.8c hat wohl eine Sicherheitslücke, siehe: http://www.heise.de/newsticker/meldung/78842

Vielen Dank! Das wäre echt super!!!
 

deller

Neuer User
Mitglied seit
2 Sep 2005
Beiträge
79
Punkte für Reaktionen
0
Punkte
0
Da sag ich auch mal flux Danke :)
 

Zurzeit aktive Besucher

3CX PBX - GRATIS
Linux / Win / Cloud

Statistik des Forums

Themen
232,901
Beiträge
2,027,917
Mitglieder
351,033
Neuestes Mitglied
thburkhart