[erledigt] USB Zugriffsrechte auf Ordner mit unterschiedlichen Usern

Albino2004

Neuer User
Mitglied seit
8 Okt 2006
Beiträge
97
Punkte für Reaktionen
0
Punkte
0
Hallo, ich möchte folgendes realisieren und habe hier im Forum, wie auch im entsprechenden WiKi nicht vergleichbares gefunden :noidea:
kann mir aber irgendwie nicht vorstellen, dass ich der erste bin, der sowas braucht.

USB-Platte (250GB) an Fritz!Box 7170 (erstmal Test mit USB-Stick), darauf drei Ordner mit unterschiedlichen Zugriffsrechten/Freigaben für unterschiedliche User unter Windows (XP Pro SP3).
User "Ernie" hat schreibenden Zugriff auf Ordner 'Ernie'.
User "Bert" hat schreibenden Zugriff auf Ordner 'Bert'.
User "Ernie" und Bert haben schreibenden Zugriff auf Ordner 'Public'.
(User "Admin" hat schreibenden Zugriff auf Ordner 'Ernie', 'Bert' und 'Public'.)
+++ edit -> Ergänzung:
User "Ernie" und Bert haben lesenden Zugriff auf Ordner 'Lesen'.
User "Admin" hat schreibenden Zugriff auf Ordner 'Ernie', 'Bert', 'Public' und 'Admin'(entspricht Ordner 'Lesen')

Dafür wird wohl Samba benötigt, habe mich dazu erstmals erfolgreich mit Freetz auseinandergesetzt.
In der Konfiguration für das Image (freetz-devel-2683) habe ich folgendes gewählt:

-------- Patches ----------

* Remove help
* Remove assistant
* Remove tr069 stuff
* Patch USB storage names, make FAT filesystems word-writeable, automount feature
* Automount filesystems
* ext2
* ext3
* NTFS

----- Standard Packages ------

* Samba 3.0.24 smbd (Filesharing)
* Samba 3.0.24 nmbd (Nameservices)


Nun finde ich allerdings keine Anleitung, wie meine Vorstellungen z.B. in der Fritz!Box unter Samba:Freigaben (Freetz - shares) bzw. Samba:Erweitert (Freetz - sharesx) umzusetzen sind.
Muss noch etwas anderes in der Imageerstellung ausgewählt werden ?
Muss evtl. auch noch die smb.conf angepaßt werden (->Gruppenrechte) ?

(wollte es auf der 7170 testen und dann letztendlich mit der 7270 umsetzen (daran dann "WD My Book 2TB"), sollte es funktionell erst mit der 7270 möglich sein, bitte Info.)

Für Hinweise wäre ich jetzt schonmal dankbar :bier:

Gruss
Albino2004

+++++ gelöst +++++++++ edit 08.11.2008 +++++ gelöst +++++++++
( bis #37 ) Firmware-Version 29.04.59freetz-devel-2683M

Zusammenfassung im Anhang (7170_freetz_stable_Samba_3User_Doku.txt), viel Erfolg ! :rock: :bier:
(Anm.: getestet mit USB-Platte mit FAT32 oder NTFS)
++++++++++++++++++++++++++++++++++++++++++++++++++++

+++++ gelöst +++++++++ edit 10.11.2008 +++++ gelöst +++++++++
Firmware-Version 29.04.59freetz-devel-2683M

Erweiterung um lesenden Zugriff im Anhang (7170_freetz_trunk_Samba_3User_Doku.txt)

(Anm.: getestet mit USB-Platte mit FAT32 oder NTFS)

++++++++++++++++ zurückgestellt +++++++++++++++++++++++++++
( ab #38 ) freetz-1.0-stable-2716

... warte Entscheidung ab ...
++++++++++++++++++++++++++++++++++++++++++++++++++++


+++++++++++++++++ aufgeben ++++++++++++++++++++++++++++
( ab #65 - #92)
Firmware-Version 29.04.59freetz-devel-2683M

Test mit USB-Platte mit ext3
leider nicht erfolgreich !!!
++++++++++++++++++++++++++++++++++++++++++++++++++++

User "Ernie" hat schreibenden Zugriff auf Ordner 'Ernie'.
User "Bert" hat schreibenden Zugriff auf Ordner 'Bert'.
User "Ernie" und Bert haben schreibenden Zugriff auf Ordner 'Public'.
(User "Admin" hat schreibenden Zugriff auf Ordner 'Ernie', 'Bert' und 'Public'.)

+++ edit -> Ergänzung:
User "Ernie" und Bert haben lesenden Zugriff auf Ordner 'Lesen'.
User "Admin" hat schreibenden Zugriff auf Ordner 'Ernie', 'Bert', 'Public' und 'Admin'(entspricht Ordner 'Lesen')




+++++++++++++++++ 7270 mit NTFS Freetz-1.0.1 ++++++++++++++++++++++++++++
( ab #94 - #104)

funktioniert, bis auf Sonderzeichen (ä,ö,ü, ß usw.) , diese sind nicht sichtbar
++++++++++++++++++++++++++++++++++++++++++++++++++++
 

Anhänge

Zuletzt bearbeitet:

Silent-Tears

IPPF-Promi
Mitglied seit
3 Aug 2007
Beiträge
7,456
Punkte für Reaktionen
0
Punkte
0
Wie wäre es, wenn du dazu die Samba-Doku mal betrachten würdest? Diese allerdings ist nicht Freetz-Spezifisch. Die Sache mit den Usern allerdings wird hier im Forum häufig durchgekaut, und sollte mit Hilfe der Suchfunktion durchaus auffindbar sein.
 

Albino2004

Neuer User
Mitglied seit
8 Okt 2006
Beiträge
97
Punkte für Reaktionen
0
Punkte
0
Hi Silent-Tears,
ich benutze schon den ganzen Nachmittag die Suchfunktion, aber nix bei rausgekommen.
Bin ich wenigstens mit meinen Ansatz auf dem richtigen Weg ?
Hast Du sowas am Laufen ?

Gruss
Albino2004
 

Darkyputz

Aktives Mitglied
Mitglied seit
27 Jul 2005
Beiträge
2,321
Punkte für Reaktionen
0
Punkte
36
meine shares:
Code:
/ 1.Root 1 0
/var/media/NEW_LINK/ 2.Platte 1 0
/var/media/NEW_LINK/movies/ Aufnahme 1 0
meine erweiterten samba configs:
Code:
log level = 1
socket options = TCP_NODELAY IPTOS_LOWDELAY 
read raw = yes
write raw = yes
oplocks = yes
max xmit = 65535
dead time = 15
getwd cache = yes
lpq cache = 30
die usergeschichte iss dann ach nciht weiter schwierig...
per cronjob, rc.customs oder libfreetz die user in die passwd einspielen, der platte ext2 geben als dateisystem und dann entsprechend via chown die ordner so bearbeiten das deine lese/schreibrechte richtig verteilt sind....
 

matze1985

Aktives Mitglied
Mitglied seit
17 Feb 2007
Beiträge
1,537
Punkte für Reaktionen
0
Punkte
0
Ich kann dir auch mal ein paar Tips geben.
Du kannst all deine Wünsche mit Samba erfüllen.

Ich habe in meiner Konfig aktuellen 2 Shares, einen Share für den Admin und einen für 2 Benutzter. Auf den Admin-Share kann nur der Admin zugreifen, auf den anderen alle 3, Gäste gibt es überall nicht.
Die passende Config(Der Erweiterte Abschnitt aus dem WebIF) sieht so aus
Code:
character set = ISO8859-1
client code page = 850
[stick]
 comment = stick
 path = /var/media/ftp/stick
 write cache size = 65536
 read only = no 
 guest ok = no
 valid users = admin
[disk]
 comment = disk
 path = /var/media/ftp/disk
 write cache size = 65536
 read only = no
 guest ok = no
 valid users = admin,user1,user2
Das mit dem Lese und Schreibzugriff kann man über write list und read list erreichen (aus dem Kopf, dafür in die Samba docu schauen).
Alle Benutzter müssen zuerst in der /etc/passwd eingetragen sein, dazu den Patch von hier am besten verwenden, da sie sonst immer gelöscht werden. Dan die User per adduser ... hinzufügen mit auch mittels "modsave all" speichern.
Damit die User jetzt noch über Samba erreichbar sind musst du die /mod/etc/smbpasswd erstellen mit deinen Usern.
Ich habe es sogemacht, da das smbpasswd der Box ein abgespecktes ist und ich nicht weiß wie die smbpasswd.cleartext (oder so) aussehen muss, dass ich auf nem Linux-System die passwd erstellt hab mit smbpasswd [-a] user. und dann auf die Box kopiert habe. (Vorher vlt. die User-ID's anpassen). Meine hab ich unter /tmp/flash abgelegt und gespeicht und kopiere sie in der rc.custom beim start an die richtige stelle.

Das ganze klappt ganz gut, frag halt wenn was ist.
 

Albino2004

Neuer User
Mitglied seit
8 Okt 2006
Beiträge
97
Punkte für Reaktionen
0
Punkte
0
Danke Euch beiden (Darkyputz & matze1985), werde mich mal übers Wochenende dran machen, mal sehen wie weit ich komme ...

Gruss
Albino2004
 

moosbart

Neuer User
Mitglied seit
20 Aug 2007
Beiträge
144
Punkte für Reaktionen
0
Punkte
0
genau dein Szenario habe ich bei mir am laufen,allerdings mit ner separaten Installation siehe hier

der Link ist glaub ich allerdings nicht ganz richtig,versuch mal
danach mit
apt-get install samba
Samba installieren

dann die Nutzer anlegen (2 mal,einmal als Linux und einmal als Samba-user)
wenn du möchtest kannst du auch noch gruppen anlegen und die user entsprechen zuweisen

dann erstellst du nur noch die Freigaben und konfigurierst die smb.conf in
/etc/samba/smb.conf
zum Schluss noch Zugriffsrechte mit chmod und chown vergeben

ps:is bei mir schon nen augenblick her und ich bin ein Linux-legastheniker also Nachsicht wenn sich Fehler eingeschlichen haben
 

matze1985

Aktives Mitglied
Mitglied seit
17 Feb 2007
Beiträge
1,537
Punkte für Reaktionen
0
Punkte
0
natürlich kann man das auch mit nem debootstrap-debian machen, dafür musste du dann aber halt dieses installieren, das gleiche kann man auch mit dem freetz-samba machen, auf die gleiche weise :)
 

moosbart

Neuer User
Mitglied seit
20 Aug 2007
Beiträge
144
Punkte für Reaktionen
0
Punkte
0
ach,echt-hab damals nur wegen der Benutzerverwaltung gewechselt weil snbpasswd keine Nutzer angelegt hat
 

matze1985

Aktives Mitglied
Mitglied seit
17 Feb 2007
Beiträge
1,537
Punkte für Reaktionen
0
Punkte
0
griunsäzlich braut man da 3 dinge, damit das funzt:
1. Linux-Benutzer-Verwaltung: diese läuft in Freetz, allerdings gibt es ein paar Probleme, da sie manchmal von avm überschrieben wird, mit dem Patch aus Ticket 61 ist das bei mir gelöst.

2. Samba-Benutzer-Verwaltung: Es gibt beim Samba-Packet eine abgespeckte smbpasswd, die eine cleartext-Datei in die smbpasswd übersetzt, wie diese funktioniert weiß ich nicht, deswegen hab ich meine smbpasswd auf einem andern Host erstellt und kopiert.

3. Samba-Config: Die sollte halt richtig erstellt werden, Samba sollte Samba sein. Kann höchstens sein das AVM ein paar Sachen wie (write lists) oder so rausgepachted hat, weiß ich aber nicht, meine konfig geht mit den 3 Usern und verscheidenen Shares. (kann ja mal begelegenheit nen readonly User versuchen (Das wäre ja der einzige Unterschied).


Ich gebe keine Garantie, aber denke man kann es versuchen. :)
 

Albino2004

Neuer User
Mitglied seit
8 Okt 2006
Beiträge
97
Punkte für Reaktionen
0
Punkte
0
Hi matze1985 & die anderen Ideengeber,
bin dank euren Tipps und vielen erneutem Suchen und lesen, lesen ...ein klein wenig weiter, der Patch ist drin, die User "Ernie" & "Bert" sind angelegt, jetzt scheitere ich gerade an der smbpasswd. Habe nur ein StinkyLinux hier unter VM am laufen, wie mach ich das dort mit der smbpasswd ?

Danke & Gruss
Albino2004
 

Silent-Tears

IPPF-Promi
Mitglied seit
3 Aug 2007
Beiträge
7,456
Punkte für Reaktionen
0
Punkte
0

Albino2004

Neuer User
Mitglied seit
8 Okt 2006
Beiträge
97
Punkte für Reaktionen
0
Punkte
0
O.K. wenn ich's als Newbie bzgl. StinkyLinux richtig verstanden habe, dann Wechsel auf User "root" über 'su', dann tippte ich folgendes:

smbpasswd -a Ernie
New SMB password:
Retype new SMB password:

aber dann kam:

Failed to modify password entry for user Ernie

Was mache ich falsch ? wie lautet eigentlich der Pfad für die Datei "smbpasswd", in der dann das Passwort angelegt wird ???
Jou, so ist's manchmal als Newbie ...:heul:

-> Korrektur:
User "ernie" über System/Systemverwaltung/Benutzer und Gruppen angelegt, damit auch das Passwort !
Anders bringe ich's nicht hin ... vielleicht erbarmt sich ja doch noch ein hilsbereiter User ... D A N K E

Und wo steht nun das Teil, damit ich den Inhalt übernehmen kann ?
 
Zuletzt bearbeitet:

Albino2004

Neuer User
Mitglied seit
8 Okt 2006
Beiträge
97
Punkte für Reaktionen
0
Punkte
0
griunsäzlich braut man da 3 dinge, damit das funzt:
...
2. Samba-Benutzer-Verwaltung: Es gibt beim Samba-Packet eine abgespeckte smbpasswd, die eine cleartext-Datei in die smbpasswd übersetzt, wie diese funktioniert weiß ich nicht, deswegen hab ich meine smbpasswd auf einem andern Host erstellt und kopiert.
...

- Wie funktioniert das unter StinkyLinux, wo steht dort die Ergebnisdatei "smbpasswd" ?

Danke
Albino2004
 

matze1985

Aktives Mitglied
Mitglied seit
17 Feb 2007
Beiträge
1,537
Punkte für Reaktionen
0
Punkte
0
hey,
bin gerade nicht immer verfügbar, deswegen dauert es manchmal etwas.

Die Datei heißt
Code:
/etc/samba/smbpasswd
Manchmal wird allerdings ein neueres Backend für die Passwörter verwendet, dafür musst du dann in der /etc/samba/smb.conf (in StinkyLinux)
Code:
passdb backend = smbpasswd
aktivieren. Ich hab leider kein Stinky, deswegen kann ich es dir nicht Schritt für Schritt sagen. (Frag halt nochmal)

#############################################################################
edit:
Ich habe jetzt nochmal etwas gespielt mit dem smbpasswd der box.
Du kannst das ganze auch auf der Box machen.
Erstelle die Datei /var/tmp/smbpasswd.cleartext und füge user im Format
Code:
<USERNAME>:<UID>:<PASSWORT>:[UX         ]:LCT-00000001:
hinzu.
also z.b. für einen User Ernie, der die ID 1001 hat (in der passwd nachschauen, muss übereinstimmen) und der das PW testpw(unverschlüsselt) haben soll, und einen Bert mit 1002
Code:
Ernie:1001:testpw:[U          ]:LCT-00000001:
Bert:1002:testpw:[U          ]:LCT-00000001:
Was die Spalten mit [U ] und LCT-00000001 bedeuten soll schaue ich nochmal nach.

Danach ein
Code:
smbpasswd
, auf der Box ausführen und er müsste sagen, dass er 2 User übernommen hat.

Dann schaue mal in die /mod/etc/smbpasswd, ob er die User übernommen hat.

edit2:
[U ]:=sind Accountflags
U - This account is a standard user account.
D - This account is currently disabled and Samba should not allow any logins.
N - This account has no password associated with it.
W -This is a workstation trust account that can be used to configure Samba as a primary domain controller (PDC) when allowing Windows NT machines to join its domain.

LCT-00000001:=Last Change Time
 
Zuletzt bearbeitet:

Albino2004

Neuer User
Mitglied seit
8 Okt 2006
Beiträge
97
Punkte für Reaktionen
0
Punkte
0
Upps, jetzt aber mal langsam ;-)
Werde mich mal dransetzen - vorab vielen Dank !

-> bin fündig geworden bei http://oreilly.com/catalog/samba/chapter/book/ch06.pdf (page 174ff.).

Jetzt muss sich aber langsam auch bei mir mal ein Erfolgserlebnis einstellen, bin mal gespannt, mehr HILFE kann man(n) ja kaum noch erwarten ... :D

Gruss
Albino2004
 

Albino2004

Neuer User
Mitglied seit
8 Okt 2006
Beiträge
97
Punkte für Reaktionen
0
Punkte
0
@matze1985:

So, danke dass war nachvollziehbar, bei mir ist allerdings lt. /etc/passwd "Ernie:1000" & "Bert:1001", habe das somit in der /var/tmp/smbpasswd.cleartext angepasst und smbpasswd ausgeführt -> konnte so "Ernie" & "Bert" in /mod/etc/smbpasswd übernehmen.

Wie geht es nun weiter, noch sehe ich im Explorer (//fritz.box) unter Windoof nix was meine müden Augen erfreuen könnte.
Nach Reboot der Fritz!Box ist das alles auch wieder weg, was muss ich nun noch tun.
Zudem verstehe ich überhaupt noch nicht, was nun im "Freetz" unter shares als Code reinkommt und was unter sharesx ???
Habe mal Post #5 als Hinweis genommen und so sieht das nun bei mir aus:

Code:
[uStor01_Ernie]
 comment = Ernie
 path = /var/media/ftp/uStor01/Ernie
 write cache size = 65536
 read only = no 
 guest ok = no
 valid users = Admin, Ernie
[uStor01_Bert]
 comment = Bert
 path = /var/media/ftp/uStor01/Bert
 write cache size = 65536
 read only = no
 guest ok = no
 valid users = Admin, Bert
Im Windoof-Explorer kommt nun ein Fenster mit Passwort-Abfrage, wenn ich auf den sichbaren Ordner "uStor01_Ernie" klicke, der Benutzer ist voreingestellt (ausgegraut) "Fritz.box/Gast", mein vorhin vergebenes Passwort
funzt nicht ! Wo kann ich hier den User Ernie hinterlegen ???

... voller ERWARTUNG ...
Gruss Albino2004
 

matze1985

Aktives Mitglied
Mitglied seit
17 Feb 2007
Beiträge
1,537
Punkte für Reaktionen
0
Punkte
0
das ganze sieht doch schonmal nicht schlecht aus.

Samba scheinst du ja auch gestartet zu haben, denn du siehst die shares und der Login kommt, bedeutet, dass die Beschränkung erstmal auch groß geht.

Also ich habe es so gemacht, dass ich mit eine funktionierend smbpasswd erstellt hab und die dann nach /var/tmp/flash kopiert habe.
Code:
cp /mod/etc/smbpasswd /var/tmp/flash
dann mit einem
Code:
modsave flash
gespeichert. Damit bleibt die schonmal auf der Box, und muss beim Start nur noch an die richtige Stelle, dazu habe ich in der rc.custom (kann über das WebIF gemacht werden) ein
Code:
cat /var/tmp/flash/smbpasswd > /mod/etc/smbpasswd
hinzugefügt.

Jetzt zu den anderen Problemen, eine wichtige Frage ist hier, welche Win-Version hast du? Mit Home kann man sich nicht per User an einem Samba anmelden, nur als Gast leider.

Hast du Samba(Netzfreigabe) im AVM-Webif Aktiviert? (ich habe es nicht, sollte aber keinen Unterschied machen)
Poste mal bitte:
Code:
/mod/etc/smb.conf
ls -lah /var/media/ftp/
ls -lah /var/media/ftp/uStor01
 
Zuletzt bearbeitet:

moosbart

Neuer User
Mitglied seit
20 Aug 2007
Beiträge
144
Punkte für Reaktionen
0
Punkte
0
@ matze Komisch bei mir geht das !
Jetzt zu den anderen Problemen, eine wichtige Frage ist hier, welche Win-Version hast du? Mit Home kann man sich nicht per User an einem Samba anmelden, nur als Gast leider.
Außerdem kannst du doch per Telnet die logs auslesen,vielleicht weißt du dann warum du dich nicht mit der Freigabe verbinden kannst

wenn du die Freigabe als Netzlaufwerk verbinden willst: Arbeitsplatz - oben auf Extras,Netzlaufwerk verbinden - durchsuchen,den Ordner auswählen - dann " Verbindung unter anderem Benutzernamen herstellen"

oder unter Netzwerkumgebung - Arbeitsgruppencomputer anzeigen

achso,muß man nicht die Arbeitsgruppe in der smb.conf angeben ?
 
Zuletzt bearbeitet:

Zurzeit aktive Besucher

3CX PBX - GRATIS
Linux / Win / Cloud

Statistik des Forums

Themen
232,904
Beiträge
2,028,015
Mitglieder
351,047
Neuestes Mitglied
sboom