.titleBar { margin-bottom: 5px!important; }

FB 7170 / Freetz 1.2 / Dropbear startet nicht

Dieses Thema im Forum "Freetz" wurde erstellt von cyrus06, 3 Dez. 2011.

  1. cyrus06

    cyrus06 Neuer User

    Registriert seit:
    1 Juni 2011
    Beiträge:
    21
    Zustimmungen:
    0
    Punkte für Erfolge:
    0
    #1 cyrus06, 3 Dez. 2011
    Zuletzt bearbeitet: 3 Dez. 2011
    Hi,

    ich bin der Verzweiflung nahe...
    Will gerade Dropbear einrichten und der Dienst startet aber nicht. kommt jedes Mal die Fehlermedung:
    Starting dropbear SSH server ... failed.

    die Ausgabe von sh -x /etc/init.d/rc.dropbear start ergibt:
    Code:
    + DAEMON=dropbear
    + DAEMON_LONG_NAME=dropbear SSH server
    + . /etc/init.d/modlibrc
    + export PATH=/mod/sbin:/mod/bin:/mod/usr/sbin:/mod/usr/bin:/sbin:/bin:/usr/sbin
    :/usr/bin
    + export LD_LIBRARY_PATH=/mod/lib:/mod/usr/lib
    + : dropbear SSH server
    + : dropbear
    + : dropbear_ENABLED
    + : /mod/etc/dropbear.conf
    + : dropbear
    + : /var/run/dropbear.pid
    + [ -n dropbear ]
    + modlib_loadconfig
    + local CONF_FILE=/mod/etc/conf/dropbear.cfg
    + [ ! -r /mod/etc/conf/dropbear.cfg ]
    + . /mod/etc/conf/dropbear.cfg
    + export DROPBEAR_ENABLED=yes
    + export DROPBEAR_OPTIONS=
    + export DROPBEAR_PORT=22
    + export DROPBEAR_PWDAUTH=yes
    + export DROPBEAR_ROOTONLY=yes
    + modlib_start
    + local DAEMON_ENABLED=
    + [  == no ]
    + [  == inetd -a ! -x /etc/init.d/rc.inetd ]
    + modlib_check_running
    + [ -n  ]
    + [ -x /etc/init.d/rc.inetd ]
    + echo dropbear_ENABLED
    + tr [:lower:]- [:upper:]_
    + eval echo $DROPBEAR_ENABLED
    + echo yes
    + [ yes == inetd ]
    + [ -n  ]
    + local fn=/var/run/dropbear.pid
    + [ ! -s /var/run/dropbear.pid ]
    + return 3
    + start
    + [ yes = yes ]
    + cat /etc/shadow
    + grep -q ^root:[*!]:
    + [ yes = yes ]
    + DROPBEAR_OPTIONS=-R
    + set -o noglob
    + modlib_startdaemon dropbear -p 22 -R
    + echo -n Starting dropbear SSH server ...
    Starting dropbear SSH server ... + config
    + :
    + which dropbear
    + [ ! -x /usr/sbin/dropbear ]
    + env - PATH=/mod/sbin:/mod/bin:/mod/usr/sbin:/mod/usr/bin:/sbin:/bin:/usr/sbin:
    /usr/bin LD_LIBRARY_PATH=/mod/lib:/mod/usr/lib dropbear -p 22 -R
    + local rv=1
    + [ 1 -ne 0 ]
    + echo failed.
    failed.
    + exit 1
    hat jemand noch eine Ahnung wie ich den Dienst vielleicht doch gestartet bekomme?
     
  2. RalfFriedl

    RalfFriedl IPPF-Urgestein

    Registriert seit:
    22 Apr. 2007
    Beiträge:
    12,343
    Zustimmungen:
    0
    Punkte für Erfolge:
    0
    Was steht denn im Sysog?

    Und ändere bitte oben das QUOTE in CODE, das ist besser lesbar.
     
  3. cyrus06

    cyrus06 Neuer User

    Registriert seit:
    1 Juni 2011
    Beiträge:
    21
    Zustimmungen:
    0
    Punkte für Erfolge:
    0
    das ist das relevante aus dem Syslog, nachdem ich den Dropbear Dienst gestartet habe, oder besser, versucht habe zu starten.

    Code:
    Dec  3 14:44:19 fritz authpriv.warn dropbear[3119]: Failed reading '/mod/etc/ssh/rsa_host_key', disabling RSA
    Dec  3 14:44:19 fritz authpriv.warn dropbear[3119]: Failed reading '/mod/etc/ssh/dss_host_key', disabling DSS
    Dec  3 14:44:19 fritz authpriv.info dropbear[3119]: Premature exit: No hostkeys available
     
  4. HartmutB

    HartmutB Neuer User

    Registriert seit:
    7 Okt. 2008
    Beiträge:
    12
    Zustimmungen:
    0
    Punkte für Erfolge:
    0
    - Ohne hier ein Fachmann sein zu wollen - fehlen Dir wohl die host-key files, die beim ersten Start von dropbear hätten erstellt werden müssen.

    Hier rennt Dropbear auf einer 7170 mit Freetz 1.2, aber ich hatte Dropbear schon auf der 1.1 drauf und dann abgedated (key-files waren also schon vorher da).

    Check mal die Existenz der beiden key-files, sieht bei mir so aus:
    Code:
    root@fritz:/var/mod/etc/ssh# ls -l
    lrwxrwxrwx    1 root     root            32 Oct 31 10:02 dss_host_key -> /tmp/flash/dropbear/dss_host_key
    lrwxrwxrwx    1 root     root            32 Oct 31 10:02 rsa_host_key -> /tmp/flash/dropbear/rsa_host_key
    root@fritz:/var/mod/etc/ssh#

    Die eigentlichen Dateien müssen natürlich auch da sein und dürfen nur für Root lesbar sein:
    Code:
    root@fritz:/var/tmp/flash/dropbear# ls -l
    -rw-------    1 root     root           459 Aug 14  2009 dss_host_key
    -rw-------    1 root     root           427 Aug 14  2009 rsa_host_key
    root@fritz:/var/tmp/flash/dropbear#
    Die Dateien sollte auch ein
    sh -x /etc/init.d/rc.dropbear (ohne Parameter bzw. mit Parameter "load") automatisch erstellen.

    Gruß
    Hartmut
     
  5. cyrus06

    cyrus06 Neuer User

    Registriert seit:
    1 Juni 2011
    Beiträge:
    21
    Zustimmungen:
    0
    Punkte für Erfolge:
    0
    Hallo Hartmut,
    Fachmann hin oder her, du hast mir sehr geholfen, jetzt läuft alles wie geschmiert! Vielen Dank!
     
  6. HartmutB

    HartmutB Neuer User

    Registriert seit:
    7 Okt. 2008
    Beiträge:
    12
    Zustimmungen:
    0
    Punkte für Erfolge:
    0
    :)

    Na wunderbar, freut mich.

    Gruß
    Hartmut
     
  7. RalfFriedl

    RalfFriedl IPPF-Urgestein

    Registriert seit:
    22 Apr. 2007
    Beiträge:
    12,343
    Zustimmungen:
    0
    Punkte für Erfolge:
    0
    Hast Du auch eine Vermutung, warum die Keys nicht automatisch erstellt worden sind? Normalerweise sollte das nämlich passieren.
     
  8. cyrus06

    cyrus06 Neuer User

    Registriert seit:
    1 Juni 2011
    Beiträge:
    21
    Zustimmungen:
    0
    Punkte für Erfolge:
    0
    #8 cyrus06, 4 Dez. 2011
    Zuletzt bearbeitet: 4 Dez. 2011
    öhm nö, erstmal nicht...
    Falls jemand eine Ahnung hat, warum das geschieht - bitte schreiben! :)

    Nach einen Neustart sind natürlich die Keys weg und es werden keine neuen erstellt. Kann ich das irgendwo hart verdrahten, dass beispielsweise bei jedem Start Keys erstellt werden, bzw wo kann ich das eintragen?

    EDIT:
    Ich hab es jetzt bei rc.custom eingetragen und die Keys werden auch erzeugt. Jedoch dauert die Erzeugung einige Zeit. Danach wird dropbear gestoppt und erneut gestartet. Ich glaube jedoch, dass die Befehle vor zum stoppen und straten von Dropbear ausgeführt werden, bevor die Erstellung der Keys abgeschlossen ist. Kann ich die Ausführung der Befehle etwas in die Länge zögern, oder eine Wartezeit festlegen?
     
  9. RalfFriedl

    RalfFriedl IPPF-Urgestein

    Registriert seit:
    22 Apr. 2007
    Beiträge:
    12,343
    Zustimmungen:
    0
    Punkte für Erfolge:
    0
    Wenn Dropbear automatisch gestartet wird, werden immer zuerst die Keys erstellt und gespeichert, bevor Dropbear gestartet wird.

    Was genau hast Du denn in rc.custom eingetragen, dass Dropbear gestoppt und neu gestartet wird?
    Und wie hast Du überhaupt den Dropbear gestartet?
     
  10. cyrus06

    cyrus06 Neuer User

    Registriert seit:
    1 Juni 2011
    Beiträge:
    21
    Zustimmungen:
    0
    Punkte für Erfolge:
    0
    Jop, Fragen über Fragen. Sorry, hier die Antworten.
    Dropbear wird automatisch gestartet (noch), jedoch (warum auch immer) werden NIE Keys erzeugt. Die Erzeugung kann ich aber händisch machen und habe diese mit dem Befehl
    Code:
    /etc/init.d/rc.dropbear
    in die rc.custom eingetragen. Der Gedankengang war, dass ich mir die Keys mit dem Parameter erstelle und danach Dropbear starte. Der Erstellvorgang dauert jedoch relativ lange (bis zu 20 Sekunden) und wenn direkt nach der Ausführung des Befehls zur Keyerzeugung der Befehl zum Start von Dropbear
    Code:
    /etc/init.d/rc.dropbear (re)start
    ausgeführt wird habe ich keinen Erfolg. Ich denke es liegt einfach daran, dass der Generierungsprozess zu lange dauert. Habe versucht diese Zeit zu überbrücken,in dem ich 40 Mal die Befehl
    Code:
    /etc/init.d/rc.dropbear stop
    ausgeführt habe. Immer noch ohne Erfolg... :/
    aber naja vielleicht hat doch noch jemand eine zündende Idee oder kann mir Helfen.
     
  11. RalfFriedl

    RalfFriedl IPPF-Urgestein

    Registriert seit:
    22 Apr. 2007
    Beiträge:
    12,343
    Zustimmungen:
    0
    Punkte für Erfolge:
    0
    Mit /etc/init.d/rc.dropbear werden bei Bedarf die Keys erstellt, aber auf jeden Fall danach Dropbear gestartet. Es gibt also keinen Grund, danach den Dropbear zu stoppen oder zu starten. Außerdem sollten die Keys, wenn sie erstellt worden sind, dauerhaft gespeichert werden.
     
  12. cyrus06

    cyrus06 Neuer User

    Registriert seit:
    1 Juni 2011
    Beiträge:
    21
    Zustimmungen:
    0
    Punkte für Erfolge:
    0
    Also so wie ich das gestern getestet habe, werden die Keys definitv nicht gespeichert.
    Ich habe als letztes gestern Abend noch ein anderes Freetz Image getestet und mit dem läuft es ohne Probleme! :/ Nunja, entweder hats einfach was bei der inst. zerhauen oder es stimmt was mit dem Image nicht.
     
  13. olistudent

    olistudent IPPF-Urgestein

    Registriert seit:
    19 Okt. 2004
    Beiträge:
    14,756
    Zustimmungen:
    2
    Punkte für Erfolge:
    0
    Beruf:
    Softwareentwickler
    Ort:
    Kaiserslautern
    Was steht denn in mod_log zu den Vorgängen?

    Gruß
    Oliver