[Problem] Fehlermeldung beim Freetz-Bauen: ERROR: ld.so: object 'libfakeroot.so' from LD_PRELOAD cannot be preloaded (wrong ELF class: ELFCLASS64): ignored.

Herbie_2005

Mitglied
Mitglied seit
31 Mrz 2007
Beiträge
322
Punkte für Reaktionen
3
Punkte
18
Hi!

Ich habe einen PC mit Windows 10 x64, auf dem ein Virtualbox mit Gastsystem Ubuntu 20.04 läuft. Freetz-Pakete sind installiert.

Wenn ich ein Freetz-Image (Trunk) bauen möchte, kommt sehr häufig diese Fehlermeldung:
Code:
ERROR: ld.so: object 'libfakeroot.so' from LD_PRELOAD cannot be preloaded (wrong ELF class: ELFCLASS64): ignored.
Das Freetz-Image wird gebaut, scheint auch zu funktionieren. Trotzdm würde mich interessieren, womit der Fehler genau zu tun hat und wie man ihn beheben kann.

Sieht das zufällig jemand auf der Grundlage der vorhandenen Informationen?
 

sonyKatze

Aktives Mitglied
Mitglied seit
6 Aug 2009
Beiträge
2,563
Punkte für Reaktionen
227
Punkte
63
ls /usr/lib/i386-linux-gnu/libfakeroot/libfakeroot-0.so
 

Herbie_2005

Mitglied
Mitglied seit
31 Mrz 2007
Beiträge
322
Punkte für Reaktionen
3
Punkte
18
Danke für Deine Anregung. Wenn ich die Anweisung eingebe, kommt, daß dieses Objekt nicht existiert. Das ist wohl nich gut. Ich habe im Netz gelesen, daß hier die 32-Bit-Fakeroot-Unterstützung (i386) auf 64-Bit-Computern fehlen könnte. Leider habe ich es bisher nicht geschafft, das Problem zu beheben.
 

Herbie_2005

Mitglied
Mitglied seit
31 Mrz 2007
Beiträge
322
Punkte für Reaktionen
3
Punkte
18
Ja, genauer: „libfakeroot:amd64 1.24-1 amd64“

Mit Freetz-Paketen haben ich die Linux-Softwarepakete gemeint, die hier aufgelistet sind.
 
Zuletzt bearbeitet:

alis123

Neuer User
Mitglied seit
13 Mrz 2016
Beiträge
28
Punkte für Reaktionen
8
Punkte
3
Versuche mal folgenden Befehl:

fehlende Freetz-Pakete nachladen 64-Bit:

Code:
sudo apt-get -y install imagemagick subversion git gcc g++ binutils autoconf automake autopoint libtool-bin net-tools make bzip2 libncurses5-dev libreadline-dev librsvg2-dev librsvg2-bin libxml2-dev imagemagick imagemagick-doc zlib1g-dev flex bison patch texinfo tofrodos gettext pkg-config ecj fastjar perl ncftp libstring-crc32-perl ruby ruby1.8 gawk python libusb-dev unzip intltool libacl1-dev libcap-dev libc6-dev-i386 lib32z1-dev lib32ncurses5-dev gcc-multilib g++-multilib lib32stdc++6 libglib2.0-dev build-essential inkscape unar
Das sollte deine VM auf aktuellen Stand bringen

Hier gefunden : Hier ein kleines HowTo zum selberbauen einer eigenen Freetz-Linux-VM Pkt.6
 
Zuletzt bearbeitet:

Herbie_2005

Mitglied
Mitglied seit
31 Mrz 2007
Beiträge
322
Punkte für Reaktionen
3
Punkte
18
Danke. Hatte ich bereits gemacht, hatte das Problem aber nicht gelöst. Mit den jüngsten Änderungen von Freetz scheint das Problem allerdings gelöst zu sein.
 
  • Like
Reaktionen: alis123

Erhalten Sie 3CX für 1 Jahr kostenlos!

Gehostet, in Ihrer privaten Cloud oder on-Premise! Ganz ohne Haken. Geben Sie Ihren Namen und Ihre E-Mail an und los geht´s:

3CX
Für diese E-Mail-Adresse besteht bereits ein 3CX-Konto. Sie werden zum Kundenportal weitergeleitet, wo Sie sich anmelden oder Ihr Passwort zurücksetzen können, falls Sie dieses vergessen haben.
oder via