[Problem] FreePBX mit Fritzbox als PJSIP-Trunk: Anrufe nach Extern sind immer anonym

R

Ramster

Guest
Hi,

ich habe ein paar Snom-Telefone an einer FreePBX-Anlage hinter einer Fritzbox 7590 an einem Telekom-Geschäftskundenanschluss. Die Rufnummern sind per tr069 in der Fritzbox automatisch eingerichtet worden. Die Fritzbox ist als PJSIP-Trunk in der FreePBX eingerichtet. Die Telefone können untereinander kommunizieren, herausrufen und eingehende Anrufe kommen an.
Leider wird bei ausgehenden Anrufen die Telefonnummer immer als "Anonym" übertragen. Weder in der FreePBX noch in den Snom-Telefonen ist, soweit ich es erkennen kann, die Rufnummernunterdrückung aktiviert. Der Account auf der Fritzbox hat als Login die Telefonnummer, die in der Fritzbox eingerichtet ist.

Ich habe jetzt schon eine Weile dieses Problem verfolgt, aber ich finde einfach keine Lösung. Auch eine andere Fritzbox und ein Neuaufsetzen der Anlage hat nichts gebracht. Ich habe zwar ein paar Berichte gelesen, wo aber die Nummer einfach nur anders als gewünscht übertragen wurde. Die brachten mich aber leider auch nicht weiter.
Ich habe mich in die Materie erst eingelesen und kenne mich damit noch nicht so gut aus. Ich hoffe aber sehr, dass vielleicht jemand mir hier helfen kann. Mein Verdacht ist, dass die Fritzbox die Nummer in irgendeiner ganz bestimmten Form in einem Header oder so ähnlich übermittelt haben möchte, und dass da vielleicht etwas schief läuft.
 

Meester Proper

Mitglied
Mitglied seit
24 Mai 2014
Beiträge
233
Punkte für Reaktionen
26
Punkte
28
Hast du denn schon einmal einen PCAP oder SIP-Trace der Kommunikation zwischen FreePBX und Fritzbox, sowie Fritzbox und Telekom-Server gemacht?
 
  • Like
Reaktionen: Ramster

Joe_57

IPPF-Promi
Mitglied seit
5 Mrz 2006
Beiträge
5,765
Punkte für Reaktionen
125
Punkte
63
Schau mal in der FRITZ!Box bei Telefoniegeräte [Merkmale des Telefoniegerätes] ob da die Rufnummenunterdrückung (CLIR) angehakt ist.
 
  • Like
Reaktionen: Ramster
R

Ramster

Guest
Vielen Dank für Eure Antworten!
Ich bin noch dabei, Logs anzusehen und mich in das Pakettracing reinzulesen.

Aber mir ist durch die Antwort über mir etwas interessantes aufgefallen. Da IP-Telefone in der Fritzbox den Tab "Merkmale des Telefoniegerätes" gar nicht haben, habe ich ein analoges Telefon testweise angeschlossen.
Und es ist kaum zu glauben, aber obwohl CLIR nicht angehakt ist, steht auf dem Display des angerufenen weiterhin "Anonym".

Es sieht jetzt also, da ja alles von der Telekom automatisch eingerichtet ist, außer das Telefoniegerät, so aus, als ob der Fehler gar nicht bei mir liegt... Ist das realistisch? Kann es sein, dass die Telekom selbst einen Fehler im System hat?
 

Meester Proper

Mitglied
Mitglied seit
24 Mai 2014
Beiträge
233
Punkte für Reaktionen
26
Punkte
28
Hast du im Kunden-/Telefoniecenter mal geschaut, ob du dort zufällig CLIR aktiviert hast?
 
  • Like
Reaktionen: Ramster
R

Ramster

Guest
Vielen Dank für die Hilfe! Es war bei der Telekom die Rufnummernunterdrückung aktiviert. Es gab zwar vorher schon Gespräche, aber dass das aktiv sein könnte und man es einfach deaktivieren kann, habe ich bisher nicht wirklich herausgehört (bis auf vage Andeutungen von unverständlichen Optionen, die aber angeblich wahrscheinlich auch nicht helfen würden).
Dass ich die Option jetzt direkt ansprechen konnte, hat viel geholfen.
 

stoney

Moderator
Teammitglied
Mitglied seit
7 Okt 2015
Beiträge
5,618
Punkte für Reaktionen
464
Punkte
83
Es gibt auch spezielle "VorwahlCodes" um das fallweise Unterdrücken bzw Anzeigen der eigenen Rufnummer zu steuern.