.titleBar { margin-bottom: 5px!important; }

[Gelöst] Freetz1.2 - FritzBox 7170 - OpenVPN (Client)

Dieses Thema im Forum "Freetz" wurde erstellt von TuX20, 12 Nov. 2011.

Status des Themas:
Es sind keine weiteren Antworten möglich.
  1. TuX20

    TuX20 Neuer User

    Registriert seit:
    27 Sep. 2010
    Beiträge:
    17
    Zustimmungen:
    0
    Punkte für Erfolge:
    0
    Beruf:
    Student
    Ort:
    Niefern bei Pforzheim
    #1 TuX20, 12 Nov. 2011
    Zuletzt von einem Moderator bearbeitet: 14 Nov. 2011
    Hallo zusammen,

    ich habe heute versucht meine eine VPN-Verbindung zwischen meiner FritzBox und einem Rootserver aufzubauen. Alle Parameter sind eingestellt, doch scheinbar scheint es irgendwelche Probleme geben aus welchen ich nicht ganz schlau werde:

    Beim Start von OpenVPN über die GUI kommt folgende Fehlermeldung:

    ln: /mod/sbin/openvpn: File exists
    /mod/etc/init.d/rc.openvpn: line 162: openvpn: not found
    /mod/etc/init.d/rc.openvpn: line 162: openvpn: not found
    Starting openvpn ... creating static.key ... failed.


    Sowie mich google belehrt hat wird bei der Zertifkat-Variante nichtmals ein statischer Schlüssel benötigt, noch finde ich einen Fehler warum dieser nicht erzeugt werden kann.

    Ich hoffe sehr auf eure Hilfe, evtl. weiß der ein oder andere woran es liegen könnte.
    Die Einstellungen sollten jedenfalls so funktionieren, mit meinem Laptop kann ich mich mit den erzeugten Zertifikaten problemlos mit meinem Server verbinden.
    Scheint also ein Fehler von Freetz zu sein. Bin für jeden Rat dankbar :)

    Gruß
    Patrick

    Meine Freetz-Konfig, sowie die Einstellung sind beigefügt
    Ausgelagert sind:

    libpcre.so.0.0.1
    curl
    php-cgi
    smbpasswd
    screen.bin
    libncurses.so.5.7
    liblzo2.so.2.0.0
    netcat
    openvpn
    libcurl.so.4.2.0
    libssl.so.0.9.8
    libpopt.so.0.0.0
    libcrypto.so.0.9.8
    smbd
    nmbd
    libresolv-0.9.29.so
     

    Anhänge:

  2. olistudent

    olistudent IPPF-Urgestein

    Registriert seit:
    19 Okt. 2004
    Beiträge:
    14,756
    Zustimmungen:
    2
    Punkte für Erfolge:
    0
    Beruf:
    Softwareentwickler
    Ort:
    Kaiserslautern
    Kannst du uns mal bitte ein Screenshot von deinen external-Einstellungen anhängen? Und dann noch das Ergebnis von folgendem posten: "ls -l /mod/sbin/openvpn".

    Gruß
    Oliver
     
  3. TuX20

    TuX20 Neuer User

    Registriert seit:
    27 Sep. 2010
    Beiträge:
    17
    Zustimmungen:
    0
    Punkte für Erfolge:
    0
    Beruf:
    Student
    Ort:
    Niefern bei Pforzheim
    Hallo Oliver,

    root@fritz:/var/tmp# ls -l /mod/sbin/openvpn
    lrwxrwxrwx 1 root root 17 Nov 12 15:23 /mod/sbin/openvpn -> /usr/sbin/openvpn


    Da ich nicht genau weiß welche external-Einstellungen du willst habe ich mal 2 Reiter gescreent die mit external zu tun haben.

    Bin leider erst seit heute unter den Freetz-Usern, kenn mich also noch nicht so gut aus

    Gruß
    Patrick
     

    Anhänge:

  4. olistudent

    olistudent IPPF-Urgestein

    Registriert seit:
    19 Okt. 2004
    Beiträge:
    14,756
    Zustimmungen:
    2
    Punkte für Erfolge:
    0
    Beruf:
    Softwareentwickler
    Ort:
    Kaiserslautern
    Kannst du bitte mal noch den External Abschnitt aus der Log-Sektion posten?

    Gruß
    Oliver
     
  5. TuX20

    TuX20 Neuer User

    Registriert seit:
    27 Sep. 2010
    Beiträge:
    17
    Zustimmungen:
    0
    Punkte für Erfolge:
    0
    Beruf:
    Student
    Ort:
    Niefern bei Pforzheim
    Starting external (/var/media/ftp/uStor01/external):
    Waiting for mod-startup: ...... done.
    Looking for group 'openvpn' ... created - now saving to data buffer ... done.
    Looking for user 'openvpn' ... created - now saving to data buffer ... done.
    openvpn is disabled
    Looking for user 'ftpuser' ... created - now saving to data buffer ... done.
    Samba-smbd is disabled.
    Starting external finished.

    Bitte schön
     
  6. olistudent

    olistudent IPPF-Urgestein

    Registriert seit:
    19 Okt. 2004
    Beiträge:
    14,756
    Zustimmungen:
    2
    Punkte für Erfolge:
    0
    Beruf:
    Softwareentwickler
    Ort:
    Kaiserslautern
    Und wenn du dann openvpn per Webinterface startest kommt die Meldung von oben?

    Gruß
    Oliver
     
  7. TuX20

    TuX20 Neuer User

    Registriert seit:
    27 Sep. 2010
    Beiträge:
    17
    Zustimmungen:
    0
    Punkte für Erfolge:
    0
    Beruf:
    Student
    Ort:
    Niefern bei Pforzheim
    Genau so sieht es aus.
    Ich werde einfach nicht schlau daraus, normal sollten ihm ja die Zertifikate reichen, sodass er den statischen Schlüssel selbst generiert.
    Was mich noch wundert ist die Fehlermeldung von wegen "/mod/etc/init.d/rc.openvpn: line 162: openvpn: not found" .
    Das ist die vorletzte Zeile vom Startscript oder bezieht er sich damit auf das gesamte Script?

    Gruß
    Patrick
     
  8. olistudent

    olistudent IPPF-Urgestein

    Registriert seit:
    19 Okt. 2004
    Beiträge:
    14,756
    Zustimmungen:
    2
    Punkte für Erfolge:
    0
    Beruf:
    Softwareentwickler
    Ort:
    Kaiserslautern
    Das Startskript findet die openvpn Datei nicht. Das lässt mich vermuten, dass dein oben gezeigter Symlink ins Leere geht. Kannst du mal den Pfad zum openvpn Binary auf deiner Box (external) posten? Bitte nicht hinschreiben, sondern mit ls -l oder ins Verzeichnis wechseln und dort ls...

    Gruß
    Oliver
     
  9. TuX20

    TuX20 Neuer User

    Registriert seit:
    27 Sep. 2010
    Beiträge:
    17
    Zustimmungen:
    0
    Punkte für Erfolge:
    0
    Beruf:
    Student
    Ort:
    Niefern bei Pforzheim
    Ja da stimmt definitiv was nicht.

    root@fritz:/usr/sbin# ls -l
    lrwxrwxrwx 1 root root 17 Oct 31 16:22 chroot -> ../../bin/busybox
    lrwxrwxrwx 1 root root 17 Oct 31 16:22 crond -> ../../bin/busybox
    lrwxrwxrwx 1 root root 17 Oct 31 16:22 httpd -> ../../bin/busybox
    lrwxrwxrwx 1 root root 17 Oct 31 16:22 inetd -> ../../bin/busybox
    lrwxrwxrwx 1 root root 21 Oct 31 16:22 openvpn -> /mod/external/openvpn
    lrwxrwxrwx 1 root root 17 Oct 31 16:22 rdate -> ../../bin/busybox
    lrwxrwxrwx 1 root root 17 Oct 31 16:22 setlogcons -> ../../bin/busybox
    lrwxrwxrwx 1 root root 17 Oct 31 16:22 telnetd -> ../../bin/bu

    Der zeigt damit ins Leere.
    root@fritz:/var/media/ftp/uStor01/external# ls -l
    drwxrwxrwx 2 root root 4096 Nov 12 15:19 lib
    drwxrwxrwx 4 root root 4096 Nov 12 15:19 usr


    Das Binary befindet sich meines Erachtens aber in:
    root@fritz:/var/media/ftp/uStor01/external/usr/sbin# ls -l
    -rwxrwxrwx 1 root root 1261400 Nov 12 15:12 openvpn


    Ich habe keine Ahnung was da schief gelaufen ist.

    Gruß
    Patrick
     
  10. RalfFriedl

    RalfFriedl IPPF-Urgestein

    Registriert seit:
    22 Apr. 2007
    Beiträge:
    12,343
    Zustimmungen:
    0
    Punkte für Erfolge:
    0
    Kann es sein, dass EXTERNAL_SUBDIRS nicht gesetzt war, als das Image erstellt wurde? Dann werden die Dateien alle in einem Verzeichnis gesucht und nicht in entsprechenden Unterverzeichnissen.
     
  11. TuX20

    TuX20 Neuer User

    Registriert seit:
    27 Sep. 2010
    Beiträge:
    17
    Zustimmungen:
    0
    Punkte für Erfolge:
    0
    Beruf:
    Student
    Ort:
    Niefern bei Pforzheim
    Eigentlich schon, habe sowohl ein neues Image, wie auch das passende external-Image erzeugt.
    Ich machs grad nochmal, dann sehen wir weiter ;)
     
  12. TuX20

    TuX20 Neuer User

    Registriert seit:
    27 Sep. 2010
    Beiträge:
    17
    Zustimmungen:
    0
    Punkte für Erfolge:
    0
    Beruf:
    Student
    Ort:
    Niefern bei Pforzheim
    Also Problem ist gelöst... es lag tatsächlich am toten Symlink. Mit dem neuen image + external geht es ;)

    Danke euch beiden
     
  13. olistudent

    olistudent IPPF-Urgestein

    Registriert seit:
    19 Okt. 2004
    Beiträge:
    14,756
    Zustimmungen:
    2
    Punkte für Erfolge:
    0
    Beruf:
    Softwareentwickler
    Ort:
    Kaiserslautern
    Sehr schön. Ich mach dann hier mal zu.

    Gruß
    Oliver
     
Status des Themas:
Es sind keine weiteren Antworten möglich.