Fritz!Box nach Firewalländerung nicht mehr erreichbar

ERFier

Neuer User
Mitglied seit
29 Nov 2008
Beiträge
3
Punkte für Reaktionen
0
Punkte
0
Hallo,
ich habe meine alte Fritz!Box Fon mit der neuen Freetz Firmware gefalsht. Mit kompiliert habe ich unteranderem auch das Webinterface für die AVM-Firmware, da ich die eigentlich nicht mehr im Betrieb befindliche Box zur Firewall und Proxy umfunktionieren will. Ich habe, dann in der Config die Zeile hinzugefügt dass jede IP nicht auf das lokale Subnetz zugreifen kann. Zu diesem Zeitpunkt lief die Box noch als IP-Client im Netzwerk und ich konnte auf die Box zugreifen, trotz bereits aktivierter Regel. Wärend meiner weiteren Probiererei habe ich dann die Box wieder zum Router gemacht und direkt an den PC an geschlossen, also beide aus dem LAN genommen und zusammen gesteckt. Seit dem ich die Box wieder zum Router gemacht habe kann ich nicht mehr auf die Box zugreifen weder per Webinterface noch per Telnet. Ich habe auch schon versucht die Fritz!Box per AVM Recover zurück zusetzen, aber sie wird von der aktuellen Version nicht mal gefunden. Die ältere Version findet die Box zwar angeblich kann aber die Version nicht auslesen. Jetzt meine Fragen: Welchen grundlegenden Fehler habe ich bei der Regelerstellung gemacht? Gibt es eine Möglichkeit, wie auch immer, auf die Box zuzugreifen und die Config wieder zu ändern oder zu löschen?
 

ERFier

Neuer User
Mitglied seit
29 Nov 2008
Beiträge
3
Punkte für Reaktionen
0
Punkte
0
Wenn ich das richtig verstanden habe tut das Recover ja auch nichts anderes als per Netzwerk auf die Box zuzugreifen, oder? Wenn dass aber der Fall ist müsste die Firewall, wenn sie wirklich falsch eingestellt ist, ja auch dass blocken oder wird die Firewall erst ein paar sekunden nach dem Einschalten aktiv? Arbeitet das Push_image Skript anders als das Recover von AVM?
Dabei fällt mir ein ich hatte die DSL funktionalität aus dem Image entfernt. Kann es daran liegen dass ich nicht mehr auf die Box zugreifen kann. Dass ich praktisch versucht habe etwas zu aktivieren was nicht da war/ist und die Box jetzt bei jedem Start versucht das zu starten. Und eins noch habe ich nun den Zugriff auf die Box untersagt oder, so wie es gedacht war, nur den Zugriff vom WAN Port auf das LAN, wenn ich die Lowinput Chainpolicy auf DENY setze?
Danke schon mal im vorraus.
 

olistudent

IPPF-Urgestein
Mitglied seit
19 Okt 2004
Beiträge
14,779
Punkte für Reaktionen
10
Punkte
38
Die Firewall ist zu der Zeit zu der recover wird nicht aktiv. Push_firmware löscht die Einstellungen nicht, sondern erneuert nur die Firmware.

MfG Oliver
 

ERFier

Neuer User
Mitglied seit
29 Nov 2008
Beiträge
3
Punkte für Reaktionen
0
Punkte
0
Das heißt also entweder ich war zu dumm die richtige Version runter zu laden oder es gibt noch ein anderes Problem. Aber das Recover hätte doch wenigstens die Box erkennen müssen auch wenn es tatsächlich eine falsche Version war oder? Hat es eigentlich einen tieferen Sinn, dass die alte Version dieses Recover auf der 192.168.178.2 sucht und die neue aber auf der 192.168.178.1? Ich meine die alte Version hat die Box ja gefunden - angeblich jedenfalls - aber konnte die Version der Firmware halt nicht auslesen. Unter der Annahme, dass die Bootip der Fritz!Box von der 1 auf die 2 geändert wurde. Gibt es dann eine Möglichkeit das Recover dazu zu bewegen auf der 2 zu suchen bzw. ist das überhaupt möglich?
 

RalfFriedl

IPPF-Urgestein
Mitglied seit
22 Apr 2007
Beiträge
12,343
Punkte für Reaktionen
1
Punkte
0
Das Recover sucht die Box nicht unter einer Adresse, das Recover weist der Box eine Adresse zu.
Solange also diese Adresse mit der am Rechner konfigurierten Adresse zusammen paßt, sollte es keine Probleme geben.
 

3CX PBX - GRATIS
Linux / Win / Cloud

Statistik des Forums

Themen
234,009
Beiträge
2,041,507
Mitglieder
353,289
Neuestes Mitglied
octitdi