Fritzbox 7390 Dynamic DNS mit eigenem Server

olli2000

Neuer User
Mitglied seit
21 Jun 2012
Beiträge
5
Punkte für Reaktionen
0
Punkte
0
Hallo Leute!

Ich habe folgendes Problem:

Ich lese die Anruflisten meiner Fritzbox per Fernwartung von unserem Web-Server aus ein, um Sie einer dort laufenden Web-Anwendung zur Verfügung zu stellen - funktioniert auch alles bestens.
Hierzu muss der Server natürlich die IP der Fritzbox kennen.

Ich verwende die Dynamic DNS Funktion der Fritzbox, um dem Server die aktuelle IP der Fritzbox zu übermitteln. Hierbei verwende ich folgende Einstellungen:

Update-URL: www.XXXXX.net/intern/dyndns.aspx?username=<username>&password=<pass>&hostname=<domain>&myip=<ipaddr>

Domainname: www.xxxxx.net/home

Die Update URL funktioniert, das Skript auf der dyndns.aspx Seite kann die IP auslesen und speichern.
Über www.xxxxx.net/home erfolgt eine Weiterleitung auf die IP der Fritzbox, wo wiederum ein Portforwarding auf die IP eines hausinternen Webservers eingerichtet ist.
Dieser ist bei Eingabe von www.xxxxx.net/home im Browser auch erreichbar.

Ich erhalte jedoch immer die Fehlermeldung: Dynamic DNS-Fehler: Der angegebene Domainname kann nicht aufgelöst werden.

Bisher konnte ich das ignorieren, da die Fritzbox wegen der Fehlermeldung immer wieder das DNS Update versucht hat und dementsprechend immer die aktuelle IP der Fritzbox auf dem Webserver zur Verfügung stand (wie gesagt: die Update-Anfrage der Fritzbox kann auf dem Webserver problemlos ausgewertet werden).

Seit neuestem kommt aber noch diese Meldung dazu:

Dynamic DNS-Fehler: Die Dynamic DNS-Aktualisierung wird bis zur Änderung der Dynamic DNS-Anmeldedaten deaktiviert.

Jetzt ist also Schluss mit dem fehlerhaften DNS-Update, der Server kennt die aktuelle IP der Fritzbox nicht mehr und die Anruflisten lassen sich nicht mehr auslesen.

Lange Rede kurzer Sinn:

Woran kann der Fehler liegen: Erwartet die Fritzbox eine bestimmte Rückmeldung beim DNS-Update?
Oder liegt es am Domainnamen und der Weiterleitung auf den hausinternern Webserver?
 
Ich erhalte jedoch immer die Fehlermeldung: Dynamic DNS-Fehler: Der angegebene Domainname kann nicht aufgelöst werden.

Seit neuestem kommt aber noch diese Meldung dazu:

Dynamic DNS-Fehler: Die Dynamic DNS-Aktualisierung wird bis zur Änderung der Dynamic DNS-Anmeldedaten deaktiviert.

Woran kann der Fehler liegen: Erwartet die Fritzbox eine bestimmte Rückmeldung beim DNS-Update?
Oder liegt es am Domainnamen und der Weiterleitung auf den hausinternern Webserver?
Lt. AVM liegt der Fehler an:
Code:
Der in der Aktualisierungsanforderung angegebene Domainname existiert nicht. Überprüfen Sie den Domainnamen in den Einstellungen im Menü "Internet / Freigaben / Dynamic DNS".
 
Die FB erwartet halt die aktuelle IP der genannten Domain. Und da der Webserver der ja weiterleitet andere IP hat meckert die FB.

Verwende sonst einfach den myfritz DNS Dinst von der FB, und lege dir von deiner Domain eine Subdomain an und stelle dort bei DNS auf CNAME und gibst dort den myfritz Hostname ein. Nun ist deine FB über die Subdomain erreichbar ganze ohne http weiterleitung.
 
Erst mal Danke für die Antworten!

@ sf3978: Welchen Domainnamen meinen die? Der Domainname in der Aktualisierungsanfrage (also www.XXXXX.net/intern/dyndns.aspx?username=...) oder das, was bei Domainname in den DNS Einstellungen angegeben ist (also www.xxxxx.net/home)

Beides existiert aber und funktioniert auch. Wie gesagt, wenn die FB eine Aktualisierungsanfrage sendet, empfängt mein Server die korrekt und kann die auch ganz normal auswerten.
Auch das www.xxxxx.net/home Ding funktioniert. Wurde durch die FB vor der DynamicDns deaktivierung einmal eine Anfrage gesendet, hab ich die IP und man landet über www.xxxxx.net/home auf meinem Heimserver.

@ HabNeFritzbox: Klar könnte ich myfritz oder DynDNS usw. verwenden. Nur warum? Ich brauche ja nur die IP der FB. Das Dynamic DNS brauche ich eigentlich nicht. Diese www.xxxxx.net/home Geschichte habe ich ausschließlich gebaut, damit ich bei der FB was in das entsprechedne Feld eintragen kann.

Ich meine, letztendlich machen myfritz und DynDNS ja auch nix anderes. Deren Server kennen meine IP und leiten dann eine definierte Webadresse auf meine wechselnde IP um.

Ich denke, es liegt daran, dass die FB bestimmte Reaktionen bei einer Aktualisierungsanfrage erwartet, die ich nicht kenne, und deswegen der FB nicht liefern kann.
Will sagen, bei einer Aktualisierungsanfrage sendet die FB ja eine http-Anfrage mit o.g. URL an meinen Server, und kriegt von dem ne Antwort. Muss diese Antwort also bestimmte Daten enthalten oder ein bestimmtes Format haben, oder ist das erstmal egal?

Oder versucht die FB nach der Aktualisierungsanfrage den angegebenen Domainnamen (also www.xxxxx.net/home) zu testen, indem sie auch dahin eine Anfrage sendet, die bei korrekter Umleitung wieder bei ihr selbst landet?

Das müsste ich halt wissen.
 
@ sf3978: Welchen Domainnamen meinen die?
Die meinen den Domainnamen, der mit dig ausgewertet, die externe (öffentliche) IP-Adresse deiner FritzBox ergibt. Z. B. so:
Code:
dig +short <der-Domainname-deiner-FritzBox>
Hast Du so einen Domainnamen für deine FritzBox?
 
Die FB versucht den genannten Domainnamen aufzulösen, und der Webserver wird wohl nicht die FB sein, und erhält dahher eine andere IP. Es wäre halt besser direkt DynDNS zunutzen, da die Domain dann der IP Adresse der FB entspricht, und nicht als http Weiterleitung läuft.
 
So langsam steige ich dahinter.

Ich habe im Feld Domainname die URL einer Webseite angegeben (also www.xxxxx.net/home), die auf einem externen Server liegt, der eine IP-Adresse hat, die sich von meiner FB unterscheidet.
Die FB erwartet aber eine URL, die aufgelöst der IP der FB entspricht.

Hab ich das so richtig zusammengefasst?

Ich habe inzwischen einen myfritz-Account angelegt und rufe die Anruflisten nun darüber ab.
Also nicht mehr über https://IP-DER-FB/cgi-bin/webcm, sondern über https://ACCOUNTID.myfritz.net/cgi-bin/webcm.

Funktioniert so auch gut, jedoch wurmt es schon ein bisschen, dass sich das bisher nicht auf die ursprünglich geplante Methode lösen lässt und ich trotz eigenen Servers auf myfritz angewiesen bin.
Ich wollte das ursprünglich ja ohne externe Komponente lösen.

Ich habe bei den Einstellungen fürs Dynamic DNS mal die myfritz Domain meiner FB als Domainnamen angegeben und die entspricht aufgelöst ja definitiv der IP meiner FB.
Dabei habe ich die alte Update-URL (www.XXXXX.net/intern/dyndns.aspx?username=<username>&password=<pass>&ho stname=<domain>&myip=<ipaddr>) gelassen.
Ich kriege aber trotzdem die übliche Fehlermeldung, also: Der angegebene Domainname kann nicht aufgelöst werden.

Wieso das denn nun?
 
Richte dir lieber eine Subdomain ein und legen beim DNS einfach CNAME fest auf die accountid.myfritz.net und lässt den dyndns Änderung mit der URL ganz weg.

Wieso es noch den Fehler gibt, weis ich nicht, wenn du als Domainnamen nur diese accountid.myfritz.net drinnen hast im Feld.
 
Zuletzt bearbeitet von einem Moderator:
Ich lese die Anruflisten meiner Fritzbox per Fernwartung von unserem Web-Server aus ein, um Sie einer dort laufenden Web-Anwendung zur Verfügung zu stellen - funktioniert auch alles bestens.
Hierzu muss der Server natürlich die IP der Fritzbox kennen.
Ich wollte das ursprünglich ja ohne externe Komponente lösen.
Mit einer modifizierten Box (z. B.: curl, cronjob oder onlinechanged, evtl. ein ftp-Client), könntest Du eine Textdatei, die immer nur die aktuelle externe (öffentliche) IP-Adresse deiner Box beinhaltet, von deiner Box auf deinen Web-Server uploaden. D. h., ein (externer) dyndns-Provider wird dann nicht benötigt.
 
Hallo sf3978!

Ich habe per Telnet ein Shell-Script in die Box eingespielt, das jedesmal, wenn ein Anruf eingeht eine http-Anfrage mit den Anrufdaten an meine Webanwendung senden.
Aus dieser Anfrage hole ich mir inzwischen die Aktuelle IP der Box. Leider habe ich dann aber logischerweise nur eine aktuelle IP, wenn nach der Verbindung mit dem Internet ein Anruf eingegangen ist.
Der onlinechanged-Begriff, den du erwähnst, ist das auch eine Möglichkeit ein Skript auszuführen, wenn die Box sich neu mit dem Internet verbindet?
 
Hallo HabNeFritzbox!

Das mit der Subdomain und CNAME würde ich machen, wenn ich mich per Hand von unterwegs mit der Box verbinden möchte (damit ich mir halt die accountid.myfritz.net nicht merken muss).
Bei der derzeitigen Anwendung ist das wohl nicht erforderlich.

Ich glaub, ich lass dann wirklich die DynDNS-Geschichte weg.
Wäre halt die einfachste Möglichkeit die aktuelle IP an den Server zu schicken - leider fällt die durch die Domainprüfung der FB wohl weg.

Ich hab auch mal bei meinem Provider (Server4You) angefragt, ob es da eine Möglichkeit für eine dynamische IP Zuweisung zu einer Subdomain gibt - der Support hat das aber verneint.

Naja - über myfritz läufts ja nun.
 
Kannst du nicht in der Webseite den myfritz Hostname verwenden?
 
Kostenlos!

Statistik des Forums

Themen
248,914
Beiträge
2,304,891
Mitglieder
378,623
Neuestes Mitglied
mwsss