Hallo Leute!
Ich habe folgendes Problem:
Ich lese die Anruflisten meiner Fritzbox per Fernwartung von unserem Web-Server aus ein, um Sie einer dort laufenden Web-Anwendung zur Verfügung zu stellen - funktioniert auch alles bestens.
Hierzu muss der Server natürlich die IP der Fritzbox kennen.
Ich verwende die Dynamic DNS Funktion der Fritzbox, um dem Server die aktuelle IP der Fritzbox zu übermitteln. Hierbei verwende ich folgende Einstellungen:
Update-URL: www.XXXXX.net/intern/dyndns.aspx?username=<username>&password=<pass>&hostname=<domain>&myip=<ipaddr>
Domainname: www.xxxxx.net/home
Die Update URL funktioniert, das Skript auf der dyndns.aspx Seite kann die IP auslesen und speichern.
Über www.xxxxx.net/home erfolgt eine Weiterleitung auf die IP der Fritzbox, wo wiederum ein Portforwarding auf die IP eines hausinternen Webservers eingerichtet ist.
Dieser ist bei Eingabe von www.xxxxx.net/home im Browser auch erreichbar.
Ich erhalte jedoch immer die Fehlermeldung: Dynamic DNS-Fehler: Der angegebene Domainname kann nicht aufgelöst werden.
Bisher konnte ich das ignorieren, da die Fritzbox wegen der Fehlermeldung immer wieder das DNS Update versucht hat und dementsprechend immer die aktuelle IP der Fritzbox auf dem Webserver zur Verfügung stand (wie gesagt: die Update-Anfrage der Fritzbox kann auf dem Webserver problemlos ausgewertet werden).
Seit neuestem kommt aber noch diese Meldung dazu:
Dynamic DNS-Fehler: Die Dynamic DNS-Aktualisierung wird bis zur Änderung der Dynamic DNS-Anmeldedaten deaktiviert.
Jetzt ist also Schluss mit dem fehlerhaften DNS-Update, der Server kennt die aktuelle IP der Fritzbox nicht mehr und die Anruflisten lassen sich nicht mehr auslesen.
Lange Rede kurzer Sinn:
Woran kann der Fehler liegen: Erwartet die Fritzbox eine bestimmte Rückmeldung beim DNS-Update?
Oder liegt es am Domainnamen und der Weiterleitung auf den hausinternern Webserver?
Ich habe folgendes Problem:
Ich lese die Anruflisten meiner Fritzbox per Fernwartung von unserem Web-Server aus ein, um Sie einer dort laufenden Web-Anwendung zur Verfügung zu stellen - funktioniert auch alles bestens.
Hierzu muss der Server natürlich die IP der Fritzbox kennen.
Ich verwende die Dynamic DNS Funktion der Fritzbox, um dem Server die aktuelle IP der Fritzbox zu übermitteln. Hierbei verwende ich folgende Einstellungen:
Update-URL: www.XXXXX.net/intern/dyndns.aspx?username=<username>&password=<pass>&hostname=<domain>&myip=<ipaddr>
Domainname: www.xxxxx.net/home
Die Update URL funktioniert, das Skript auf der dyndns.aspx Seite kann die IP auslesen und speichern.
Über www.xxxxx.net/home erfolgt eine Weiterleitung auf die IP der Fritzbox, wo wiederum ein Portforwarding auf die IP eines hausinternen Webservers eingerichtet ist.
Dieser ist bei Eingabe von www.xxxxx.net/home im Browser auch erreichbar.
Ich erhalte jedoch immer die Fehlermeldung: Dynamic DNS-Fehler: Der angegebene Domainname kann nicht aufgelöst werden.
Bisher konnte ich das ignorieren, da die Fritzbox wegen der Fehlermeldung immer wieder das DNS Update versucht hat und dementsprechend immer die aktuelle IP der Fritzbox auf dem Webserver zur Verfügung stand (wie gesagt: die Update-Anfrage der Fritzbox kann auf dem Webserver problemlos ausgewertet werden).
Seit neuestem kommt aber noch diese Meldung dazu:
Dynamic DNS-Fehler: Die Dynamic DNS-Aktualisierung wird bis zur Änderung der Dynamic DNS-Anmeldedaten deaktiviert.
Jetzt ist also Schluss mit dem fehlerhaften DNS-Update, der Server kennt die aktuelle IP der Fritzbox nicht mehr und die Anruflisten lassen sich nicht mehr auslesen.
Lange Rede kurzer Sinn:
Woran kann der Fehler liegen: Erwartet die Fritzbox eine bestimmte Rückmeldung beim DNS-Update?
Oder liegt es am Domainnamen und der Weiterleitung auf den hausinternern Webserver?