FritzBox Fon 7270 und ICMP(-Forwardings)

tomix1024

Neuer User
Mitglied seit
4 Feb 2011
Beiträge
7
Punkte für Reaktionen
0
Punkte
0
Hallo alle zusammen,

ich habe eine FritzBox Fon 7270 bei der ich gerne das "automatische" Antworten auf Pings abschalten möchte und statt dessen die Packete an einen anderen Rechner (eine FritzBox Fon 5050) oder an die 7270er Box selber weiterleiten, so dass ein Programm was auf einer der Boxen läuft diese beantworten kann.

Wenn ich (egal welche der beiden Boxen) im LAN anpinge, kann ich die Packete abfangen und auch beantworten. Allerdings werden dann 2 Echo-Replys für 1 Echo-Request gesendet und bräuchte deshalb auch eine Möglichkeit die "natürlichen" Pingantworten zu unterdrücken. (die 2te Antwort kommt zwar an, wird aber nicht vom "Client" verarbeitet)

also:
- ich habe eine (zur not auch 2) FritzBox(en)
- ich möchte vom Internet aus angepingt werden und die Requests NICHT automatisch verarbeiten lassen, sondern die Aufgabe von einem Programm auf der Box erledigen lassen.

wenn ich bei der 7270 forwardrules in der ar7.cfg eintrage
(über telnet die ar7.cfg mit cp von /var/flash nach /var/tmp verschieben und dann über ftp lesen / verändern / zurückschrebein und dann mit cp wieder zurück schreibe und die box dann neu starten)
sind meine Änderungen nicht mehr vorhanden.
auch wenn ich Exposed Host aktiviere (alle IP Packete an die 2te Box weiterleiten) kommen die ICMP Packete (die nach meinem Wissen auf dem IP Protokoll aufbauen, genau wie TCP) nicht an.

mfg
 

sf3978

IPPF-Promi
Mitglied seit
2 Dez 2007
Beiträge
7,771
Punkte für Reaktionen
10
Punkte
38

tomix1024

Neuer User
Mitglied seit
4 Feb 2011
Beiträge
7
Punkte für Reaktionen
0
Punkte
0
danke für deine schnelle Antwort!

hab grade freetz mit iptables aufgespielt und kann bis jetzt das lokale anpingen der FritzBox verhindern (immerhin ;) )
aber irgendwie krieg ich es nicht hin das Forwarding so einzustellen dass die ICMP Packete zum 2ten Router weitergeleitet werden :(

habe ein FORWARD von ANY nach 192.168.1.2 (die 2te Box) für das Protokoll icmp eingetragen. Als Output-Interface hab ich dann eth0 angegeben.
ich hoffe dass der Eintrag nicht all zu falsch ist ;)

ps: mit den Netzwerkadapterbezeichnungen von Linux bin ich nicht gerade vertraut.
 

3CX PBX - GRATIS
Linux / Win / Cloud

Statistik des Forums

Themen
233,682
Beiträge
2,037,232
Mitglieder
352,557
Neuestes Mitglied
seso23