.titleBar { margin-bottom: 5px!important; }

[gelöst]: freetz-trunk-2790: Could not find a glib-genmarshal in your PATH

Dieses Thema im Forum "Freetz" wurde erstellt von rolsch, 24 Nov. 2008.

  1. rolsch

    rolsch Neuer User

    Registriert seit:
    28 Okt. 2004
    Beiträge:
    180
    Zustimmungen:
    0
    Punkte für Erfolge:
    16
    #1 rolsch, 24 Nov. 2008
    Zuletzt bearbeitet: 25 Nov. 2008
    Muss ich diese lib in der stinky-installation nachinstallieren
    oder fehlt da zur Zeit etwas im freetz-trunk?

    checking for glib-genmarshal... no
    configure: error: Could not find a glib-genmarshal in your PATH
    make: *** [source/glib-2.18.2/.configured] Fehler 1
    slightly@StinkyLinux:~/freetz-trunk$
     
  2. matze1985

    matze1985 Aktives Mitglied

    Registriert seit:
    17 Feb. 2007
    Beiträge:
    1,537
    Zustimmungen:
    0
    Punkte für Erfolge:
    0
    das ist wahrscheinlich beim configure was schief gelaufen.
    mach mal
    Code:
    make glib-dirclean
     
  3. rolsch

    rolsch Neuer User

    Registriert seit:
    28 Okt. 2004
    Beiträge:
    180
    Zustimmungen:
    0
    Punkte für Erfolge:
    16
    #3 rolsch, 24 Nov. 2008
    Zuletzt bearbeitet: 24 Nov. 2008
    Nö,
    schon gemacht...

    - svn up
    # Revision 2790.
    - make dirclean
    - make glib-dirclean
    - make menuconfig
    - make config-clean-deps

    -> obiges Ergebniss

    Weiter oben im Log ist noch ein Warning:

    checking for sys/inotify.h... yes
    checking for FAMOpen in -lfam... no
    configure: WARNING: *** FAM support will not be built (FAM library not found) ***
     

    Anhänge:

  4. olistudent

    olistudent IPPF-Urgestein

    Registriert seit:
    19 Okt. 2004
    Beiträge:
    14,761
    Zustimmungen:
    5
    Punkte für Erfolge:
    38
    Beruf:
    Softwareentwickler
    Ort:
    Kaiserslautern
  5. rolsch

    rolsch Neuer User

    Registriert seit:
    28 Okt. 2004
    Beiträge:
    180
    Zustimmungen:
    0
    Punkte für Erfolge:
    16
    trunk-2795

    Labor für 7270: FRITZ.Box_Fon_WLAN_7270.Labor.54.04.63-12904.image

    make dirclean
    make glib2-dirclean
    svn up
    >Revision 2795.
    make

    applying USB storage patch
    applying patch file ./patches/cond/usbstorage_7270_labor_all.patch
    patching file etc/hotplug/run_mount
    Hunk #3 FAILED at 96.
    1 out of 3 hunks FAILED -- saving rejects to file etc/hotplug/run_mount.rej
    ----------------------------------------------------------------------
    ERROR: modpatch: Error in patch-file ./patches/cond/usbstorage_7270_labor_all.patch
    make: *** [firmware-nocompile] Fehler 2
    slightly@StinkyLinux:~/freetz-trunk$

    Danke für den nächtlichen Patch, immerhin lief der make nun fast durch ;-)
     
  6. rolsch

    rolsch Neuer User

    Registriert seit:
    28 Okt. 2004
    Beiträge:
    180
    Zustimmungen:
    0
    Punkte für Erfolge:
    16
    Ok,
    mit der neuen Laborsoftware FRITZ.Box_Fon_WLAN_7270.Labor.54.04.63-13046.image
    läuft make durch!
     
  7. billygeen

    billygeen Neuer User

    Registriert seit:
    23 Mai 2007
    Beiträge:
    124
    Zustimmungen:
    0
    Punkte für Erfolge:
    16
    hallo zusammen, hab selbiges problem, allerdings funktioniert der oben genannte lösungsweg nicht! Wie kann ich diese lib denn nachinstallieren?

    hab auch schon den ganzen trunk gelöscht und alles neu geladen, allerdings ohne erfolg!

    anbei ein screenshot des fehlers
     

    Anhänge:

    • test.jpg
      test.jpg
      Dateigröße:
      379.6 KB
      Aufrufe:
      16
  8. olistudent

    olistudent IPPF-Urgestein

    Registriert seit:
    19 Okt. 2004
    Beiträge:
    14,761
    Zustimmungen:
    5
    Punkte für Erfolge:
    38
    Beruf:
    Softwareentwickler
    Ort:
    Kaiserslautern
    Hatten wir die Tage schonmal. Du musst das libglib-2.0dev Paket installieren. Steht doch in der Fehlermeldung.

    MfG Oliver
     
  9. billygeen

    billygeen Neuer User

    Registriert seit:
    23 Mai 2007
    Beiträge:
    124
    Zustimmungen:
    0
    Punkte für Erfolge:
    16
    ja, das hab ich schon gelesen, aber wie installier ich das??
     
  10. colonia27

    colonia27 Guest

    #10 colonia27, 8 März 2010
    Zuletzt von einem Moderator bearbeitet: 8 März 2010
    so wie Pakete eben unter div. Linux-varianten nachinstalliert werden.
    Code:
     sudo apt-get install <paketname>
    Wie ich sehe, nutzt du immer noch ein recht veraltetes Stinky-Linux. Wenn du keine GUI brauchst, wozu auch immer man die überhaupt zur Imageerstellung brauchen sollte,
    kannst du auch auf das aktuelle "freetz-linux" von Silent-Tears umsteigen.
    Ist unter Anderem ressourcenschonender und schneller. Ausserdem ist schon alles drin was du aktuell benötigst.
    Oli, ich korrigier mal eine Kleinigkeit, bevor er sagt, das Paket gibts nicht:
    Richtig heißt es libglib2.0-dev
     
  11. Silent-Tears

    Silent-Tears IPPF-Promi

    Registriert seit:
    3 Aug. 2007
    Beiträge:
    7,456
    Zustimmungen:
    0
    Punkte für Erfolge:
    0
    Ort:
    BI
    Wir sind hier keine debian- oder ubuntu-basierende Linuxdistributioen-updatehilfe. Das ist sowas von einfach und findet sich so oft im Netz, dass ich mich schämen würde, das hier nachzufragen, ebenso wie es langsam aber sicher möglich sein sollte, putty zu nutzen um den content zu kopieren, und nicht screenshots zu posten.