[Problem] ( gelöst) Samba auf external ausgelagert -> im Freetz-Menü nicht sichtbar

ploieel

Aktives Mitglied
Mitglied seit
13 Mrz 2005
Beiträge
1,735
Punkte für Reaktionen
5
Punkte
38
Hallo;
im Titel steht schon mein Problem.
Auf meiner FRITZ!Box Fon Speedport W 900V Firmware-Version 34.04.87freetz-devel-7804 ist im Freetz-Menü im Moment sichtbar:

Status
System
Freetz
AVM-Dienste
AVM-Firewall
gw6
Inetd
radvd
Samba
SSH
Syslogd

und ich bräuchte ein wenig Platz für Dropbear.

Ich habe Samba auf einen Stick ausgelagert, aber im Freetz-Menü wird Samba nicht angezeigt.
Ebensowenig gelingt mir die Anzeige, wenn ich gw6 oder radvd (oder beides) auslagere. Irgendwas mache ich falsch und bitte um einen Hinweis. Selbstverständlich habe ich das Firmwareupdate auf den Stick und danach auf die Box durchgeführt... daran kanns nicht liegen.

Viele Grüße.
 
Zuletzt bearbeitet:

RalfFriedl

IPPF-Urgestein
Mitglied seit
22 Apr 2007
Beiträge
12,343
Punkte für Reaktionen
0
Punkte
0
Kann es sein, dass der Stick nicht als external-Stick erkannt wird? Normalerweise sollten die Dienste gestartet werden, sobald der Stick erkannt wird.
 

olistudent

IPPF-Urgestein
Mitglied seit
19 Okt 2004
Beiträge
14,779
Punkte für Reaktionen
10
Punkte
38
External hat einen eigenen Log-Abschnitt im Webinterface. Was steht denn dort?

Gruß
Oliver
 

ploieel

Aktives Mitglied
Mitglied seit
13 Mrz 2005
Beiträge
1,735
Punkte für Reaktionen
5
Punkte
38
Hi,
ich habe Freetz jetzt wieder OHNE external installiert, deshalb kann ich das Log nicht zeigen. Ich melde mich morgen wieder dazu; vielen Dank.
 

ploieel

Aktives Mitglied
Mitglied seit
13 Mrz 2005
Beiträge
1,735
Punkte für Reaktionen
5
Punkte
38
Hallo,
das Problem besteht nicht mehr. Ich habe auf eure Hinweise hin den Stick mit ext3 formatiert und das externalisierte Samba eingebunden. Es vergehen einige Sekunden, bis Samba im Freetz-Menü sichtbar wird, weil der Stick offensichtlich erst mounted sein muss, bevor external etwas läuft. EDIT 3: Es dauert einige Sekunden, bovor die eexternalisierten Dienste laufen und im Freetz-Interface angezeigt werden; man darf da nicht ungeduldig sein. Scheint vom mount-status unabhängig zu sein.

Der Hinweis von olistudent mit dem Log von external war sehr hilfreich, aber auch der Hinweis von RalfFriedl hat mich zum Ziel geführt. Danke euch beiden nochmals.

EDIT:
Nachdem nunmehr external auf der Box problemlos läuft, habe ich auch noch Dropbear, gw6 und radvd externalisiert; läuft.
Ich bin jetzt zuversichtlich, dass ich weitere interessante Dienste auf der Box externalisieren kann. Z. B. mediatomb, denn der von AVM integrierte Mediaserver überzeugt mich nicht wirklich. Von drei angeschlossenen USB-Platten wird dort nur eine eingebunden... liegt aber vielleicht auch nur an deren Formatierung. Eingebunden in den Mediaserver wird zur Zeit die NTFS-Platte, die vfat wird vom System erkannt, aber in den Mediaserver nicht eingebunden. Aber das ist sicher in einem anderen Thread besser aufgehoben.

EDIT 2:
Hmmm, mediatomb (binary only); ich habe mit Linux fast null Kenntnisse. Gibts da was, womit das mediatomb auf den Stick oder wenigstens in die Box integriert werden kann?

Viele Grüße.
 
Zuletzt bearbeitet:

3CX PBX - GRATIS
Linux / Win / Cloud

Statistik des Forums

Themen
232,863
Beiträge
2,027,497
Mitglieder
350,975
Neuestes Mitglied
user7008