.titleBar { margin-bottom: 5px!important; }

Keine Anrufe in manche Länder möglich!?!

Dieses Thema im Forum "Asterisk Allgemein" wurde erstellt von zeckrich, 16 Okt. 2008.

  1. zeckrich

    zeckrich Neuer User

    Registriert seit:
    20 Juni 2006
    Beiträge:
    72
    Zustimmungen:
    0
    Punkte für Erfolge:
    0
    #1 zeckrich, 16 Okt. 2008
    Zuletzt bearbeitet: 16 Okt. 2008
    Hallo,

    stehe hier vor einem Problem, welches ich mir nicht ganz erklären kann.
    Habe einen Asterisk (1.4) am Multiplexer hängen. Generell funktionieren auch Telefonate in die meisten Länder.
    Nun gibt es jedoch einige, bei denen es nicht funktioniert. Egal wo man anruft, es ist sofort besetzt mit Hangupcause 16. Der Anschluss ist jedoch in keinem Fall besetzt. Ein Anruf über ein Handy funktioniert tadellos.

    Mein Gedanke war nun, dass es etwas mit der Übertragung der Rufnummer zu tun hat, genauer gesagt mit dem Teil, welcher über die zapata.conf gesetzt wird. Diese sieht wie folgt aus:

    Code:
    [trunkgroups]
    
    [channels]
    language=de
    context=pstn-in
    nationalprefix=
    internationalprefix=00
    localprefix=meineOrtsvorwahl
    privateprefix=meineOrtsvorwahl und Prefix des Anlagenanschlusses
    unknownprefix=
    pridialplan=local
    overlapdial=yes
    facilityenable=yes
    priindication=outofband
    callerid=asreceived
    usecallerid=yes
    hidecallerid=no
    callwaiting=yes
    usecallingpres=yes
    callwaitingcallerid=yes
    threewaycalling=yes
    transfer=yes
    canpark=yes
    cancallforward=yes
    callreturn=yes
    echocancel=yes
    echocancelwhenbridged=yes
    relaxdtmf=yes
    rxgain=0.0
    txgain=0.0
    group=1
    callgroup=1
    pickupgroup=1
    
    immediate=no
    
    ;Sangoma A102 port 1 [slot:4 bus:8 span:1] <wanpipe1>
    switchtype=euroisdn
    context=from-pstn
    group=0
    signalling=pri_cpe
    channel =>1-15,17-31
    ;Sangoma A102 port 2 [slot:4 bus:8 span:2] <wanpipe2>            
    switchtype=euroisdn
    context=from-i55
    group=1
    signalling=pri_net
    channel =>32-46,48-62
    

    Was vielleicht auch damit zu tun haben kann, ist das Problem, dass zu manchen Auslandsanschlüssen nur die zentrale Rufnummer übertragen wird. Die CallerID wird mit Hilfe von Set(CALLERID(num)) im Wählplan immer auf die gleiche Weise gesetzt.

    Ist natürlich auch möglich, dass es an etwas ganz anderem liegt.
    Bin also für alle Meinungen offen und für jede Hilfe dankbar.

    Viele Grüße
    zeckrich

    PS: Hatte auch schon eine andere Asterisk Version im Einsatz. Mit dem gleichen Ergebnis.

    EDIT: Habe gerade mal probiert über einen angeschlossenen ISDN-Basisanschluss in die zuvor nicht erreichbaren Ziele zu telefonieren und das funktioniert. Scheint also etwas mit ZAP oder so im Argen zu sein.
    Der PMX läuft übrigens über das rost T.
     
  2. Burmann

    Burmann Mitglied

    Registriert seit:
    16 Feb. 2005
    Beiträge:
    372
    Zustimmungen:
    0
    Punkte für Erfolge:
    0
    Das der Provider keine Interconnectionverträge dorthin hat kann vorkommen, aber bei T-Com? :gruebel:

    Bleibt nur zu schauen wo der Unterschied im D-Kanal liegt zu funktionierenden Gesprächen...