.titleBar { margin-bottom: 5px!important; }

Keine Sipgate Registrierung mit Asterisk

Dieses Thema im Forum "sipgate" wurde erstellt von joe-voip, 21 Dez. 2004.

  1. joe-voip

    joe-voip Neuer User

    Registriert seit:
    20 Apr. 2004
    Beiträge:
    55
    Zustimmungen:
    0
    Punkte für Erfolge:
    0
    Hallo,

    ich hab jetzt schon einige Zeit im Forum gesucht und auch diverse Konfigs getestet, aber ich bekomme einfach keine Registrierung bei Sipgate hin.

    Ich bekomme immer die Meldung:
    Wenn ich sip show peers mache ist dort NAT nicht aktiv? Hänge aber hinter einer IPCop Firewall und hab nat=yes in der sip.conf:
    Code:
    ;
    ; SIP Configuration for Asterisk
    ;
    [general]
    language=de
    context=default                 ; Context to be used in extensions
    port=5060                       ; Port to bind to
    bindaddr=0.0.0.0                ; Address to bind SIP channel to
    nat=yes
    
    ;srvlookup=yes                  ; Enable DNS SRV lookups on outbound calls
    ;pedantic=yes                   ; Enable slow, pedantic checking for Pingtel
    ;tos=lowdelay                   ; IP QoS parameter, either keyword or value
    ;maxexpirey=3600                ; Max length of incoming registration we allow
    ;defaultexpirey=120             ; Dflt length of incoming/outoing registration
    ;defaultexpirey=160
    ;notifymimetype=text/plain      ; Allow overriding of mime type in NOTIFY
    ;videosupport=yes               ; Turn on support for SIP video
    
    disallow=all                    ; Disallow all codecs
    allow=ulaw
    allow=alaw
    allow=gsm
    
    localnet = 10.30.1.0/255.255.255.0
    externip = rechner.dyndns.org 
    
    ;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;
    ; Accounts ;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;
    ;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;
    
    ;sipgate
    register => 12345678:pass@sipgate.de/12345678
    
    [sipgate]
    type=friend
    username=12345678
    secret=pass
    host=sipgate.de
    fromuser=12345678
    fromdomain=sipgate.de
    qualify=yes
    nat=yes
    canreinvite=no
    insecure=very 
    
    [300]
    type=friend
    username=300
    secret=pass
    host=dynamic
    nat=no
    context=170      ; Inbound calls from this host go here
    dtmfmode=rfc2833 
    canreinvite=no 
    mailbox=101
    
    [301]
    type=friend
    username=301
    secret=pass
    host=dynamic
    nat=no
    context=171      ; Inbound calls from this host go here
    dtmfmode=rfc2833 
    canreinvite=no 
    mailbox=101
    
    
    [302]
    language=de
    type=friend
    username=302
    secret=pass
    host=dynamic
    nat=no
    context=172      ; Inbound calls from this host go here
    dtmfmode=rfc2833 
    canreinvite=no 
    mailbox=102
    
    [​IMG]

    Wäre klasse wenn mir jemand helfen könnte.
    Danke schonmal, Jochen
     
  2. Netview

    Netview IPPF-Promi

    Registriert seit:
    1 Apr. 2004
    Beiträge:
    3,366
    Zustimmungen:
    0
    Punkte für Erfolge:
    36
    Beruf:
    Dipl.-Inf.
    Ort:
    Westerwald
    Setze qualify auf 'no'!
     
  3. joe-voip

    joe-voip Neuer User

    Registriert seit:
    20 Apr. 2004
    Beiträge:
    55
    Zustimmungen:
    0
    Punkte für Erfolge:
    0
    Hallo Netview,

    danke für die schnelle Antwort.
    Ich habe das mit dem qualify=no in einem anderen Betrag schon gelesen, aber das hat auch nichts gebracht. Er bringt dann die Meldung halt nicht mehr so oft, aber das Verbinden klappt trotzdem nicht.

    Hast Du weitere Tips für mich?

    Jochen

    P.S: Jetzt hat er diese Meldung noch:
    Code:
    Dec 21 10:39:19 WARNING[131080]: Maximum retries exceeded on call 643c98696633487374b0dc5119495cff@10.30.1.3 for seqno 112 (Critical Request)
    Dec 21 10:39:33 NOTICE[131080]: Registration for '12345678@sipgate.de' timed out, trying again
    Dec 21 10:39:33 DEBUG[131080]: ##### Testing 217.10.79.9 with 10.30.1.0
    Dec 21 10:39:33 DEBUG[131080]: Target address 217.10.79.9 is not local, substituting externip
    Dec 21 10:39:33 DEBUG[131080]: Scheduled a timeout # 31
     
  4. Netview

    Netview IPPF-Promi

    Registriert seit:
    1 Apr. 2004
    Beiträge:
    3,366
    Zustimmungen:
    0
    Punkte für Erfolge:
    36
    Beruf:
    Dipl.-Inf.
    Ort:
    Westerwald
    Ja, du solltest noch dns-Anfragen zulassen.

    ;srvlookup=yes nimm hier mal das ';' raus!

    und

    maxexpirey=3600
    defaultexpirey=120
     
  5. joe-voip

    joe-voip Neuer User

    Registriert seit:
    20 Apr. 2004
    Beiträge:
    55
    Zustimmungen:
    0
    Punkte für Erfolge:
    0
    NetView: Vielen Dank erstmal dass Du dir Zeit für mich nimmst!

    Hab jetzt:
    srvlookup=yes ; Enable DNS SRV lookups on outbound calls
    maxexpirey=3600 ; Max length of incoming registration we allow
    defaultexpirey=120 ; Dflt length of incoming/outoing registration

    Geht aber immer noch nicht.
    Ich kann sipgate.de aber anpingen und mit nslookup habe ich ein positives Ergebnis:
    Stimmt doch alles soweit?!

    Jochen
     
  6. joe-voip

    joe-voip Neuer User

    Registriert seit:
    20 Apr. 2004
    Beiträge:
    55
    Zustimmungen:
    0
    Punkte für Erfolge:
    0
    Hm, was will er mir damit sagen? :
    Code:
    Dec 21 10:52:54 NOTICE[131080]: Registration for '12345678@sipgate.de' timed out, trying again
    Dec 21 10:52:54 VERBOSE[131080]:     -- parse_srv: SRV mapped to host proxy.de.sipgate.net, port 5060
    Dec 21 10:52:54 DEBUG[131080]: ##### Testing 217.10.79.9 with 10.30.1.0
    Dec 21 10:52:54 DEBUG[131080]: Target address 217.10.79.9 is not local, substituting externip
    Dec 21 10:52:54 DEBUG[131080]: Scheduled a timeout # 39
    Dec 21 10:53:00 WARNING[131080]: Maximum retries exceeded on call 643c98696633487374b0dc5119495cff@10.30.1.3 for seqno 117 (Critical Request)
    
     
  7. joe-voip

    joe-voip Neuer User

    Registriert seit:
    20 Apr. 2004
    Beiträge:
    55
    Zustimmungen:
    0
    Punkte für Erfolge:
    0
    Hallo,

    hat sonst noch jeamnd ne Idee?
    Hab auf dem Pocket PC XLite per WLAN im gleichen Netz am laufen. Nur Asterisk will sich nicht bei Sipgate registrieren.

    Bitte helft mir, Jochen
     
  8. Netview

    Netview IPPF-Promi

    Registriert seit:
    1 Apr. 2004
    Beiträge:
    3,366
    Zustimmungen:
    0
    Punkte für Erfolge:
    36
    Beruf:
    Dipl.-Inf.
    Ort:
    Westerwald
    Hast du auch die ports 5060 (udp) und 10000-20000 (udp - default gemäss. rtp.conf) an den asterisk geforwarded?

    Es sieht so aus als würde von sipgate auf dem port 5060 nichts zurückkommen!
     
  9. joe-voip

    joe-voip Neuer User

    Registriert seit:
    20 Apr. 2004
    Beiträge:
    55
    Zustimmungen:
    0
    Punkte für Erfolge:
    0
    Hatte die Portweiterleitung in der Tat vergessen :-(.
    Aber es funktioniert immer noch nicht.
    Wieso funktioniert es aber mit dem XLite, wegen STUN?
    Es muss irgendwas mit der Firewall zu tun haben?!

    Ich suche weiter...
     
  10. Netview

    Netview IPPF-Promi

    Registriert seit:
    1 Apr. 2004
    Beiträge:
    3,366
    Zustimmungen:
    0
    Punkte für Erfolge:
    36
    Beruf:
    Dipl.-Inf.
    Ort:
    Westerwald
    Wahrscheinlich wegen stun!

    Dafür gibt es in der sip.conf [general] die externip (in Verbindung mit NAT), was im Prinzip am Ende das gleiche Resultat erbringt!

    Wird denn 'rechner.dyndns.org' korrekt aufgelöst???
     
  11. joe-voip

    joe-voip Neuer User

    Registriert seit:
    20 Apr. 2004
    Beiträge:
    55
    Zustimmungen:
    0
    Punkte für Erfolge:
    0
    Ja, das funktioniert. Dahinter läuft noch ein Webserver und ein VPN Server.
    externip hab ich ja gesetzt. Echt komisch das ganze.
     
  12. Netview

    Netview IPPF-Promi

    Registriert seit:
    1 Apr. 2004
    Beiträge:
    3,366
    Zustimmungen:
    0
    Punkte für Erfolge:
    36
    Beruf:
    Dipl.-Inf.
    Ort:
    Westerwald
    welchen Router setzt du ein?
    eventuell auch eine Firewall?
     
  13. joe-voip

    joe-voip Neuer User

    Registriert seit:
    20 Apr. 2004
    Beiträge:
    55
    Zustimmungen:
    0
    Punkte für Erfolge:
    0
    Hab IPCop 1.4.2 als Router und Firewall.
    Zusätzlich hab ich noch das Block Outgoing Traffic Addon installiert.
    Aber das ist deaktiviert, es kann momentan alles raus.
    Die Portweiterleitung auf den Asteriskserver hab ich alles UDP:
    -5060
    -5004
    -5005
    -5006
    -5007
    -5008
    -10000
     
  14. Netview

    Netview IPPF-Promi

    Registriert seit:
    1 Apr. 2004
    Beiträge:
    3,366
    Zustimmungen:
    0
    Punkte für Erfolge:
    36
    Beruf:
    Dipl.-Inf.
    Ort:
    Westerwald
  15. joe-voip

    joe-voip Neuer User

    Registriert seit:
    20 Apr. 2004
    Beiträge:
    55
    Zustimmungen:
    0
    Punkte für Erfolge:
    0
    Hab in dem Forum leider nichts gefunden.
    Bei den Routern hier im Forum wird ja geschrieben dass es kein Problem mit IPCop gibt. Auch bei Google bin ich nicht fündig geworden.

    Wenn ich nur draufkommen würde an was es liegt?!
    Ich muss mal die Firewall Logs durchforsten.

    Gruss, Jochen