[HowTo] Kleine Anleitung - Sip-Settings/Login mit Asterisk / Elastix - Deutsche Telekom

Bruchteil

Neuer User
Mitglied seit
15 Nov 2016
Beiträge
18
Punkte für Reaktionen
1
Punkte
3
Hiho zusammen,

Inzwischen habe ich 2 Anlagen mit dem selben System am laufen. Da aber beide mit vollständig anderer Konfiguration funktionieren, informiere ich euch hier einmal, da ich denke es wird noch mehr mit Problemen bei der Telekom geben.

Anlage 1 - Keine eMail-Adresse bei der Telekom eingerichtet(!) Wichtig!

Registrierungsreihenfolge

Code:
Tel-Nummer-mit-Vorwahl:Passwort:[email protected]/Tel-Nummer-mit-Vorwahl~481
(Die ~481 übergibt nix weiter als TTL, kann man auch weg lassen)

Verbindungsdetails:

Code:
type=peer
username=Tel-Nummer-mit-Vorwahl
fromuser=Tel-Nummer-mit-Vorwahl
secret=Passwort
remotesecret=Passwort
host=tel.t-online.de
fromdomain=tel.t-online.de
dtmfmode=rfc2833
allowguest=no
bindport=5060
qualify=yes
qualifyfreq=1000
nat=yes
canreinvite=update
localnet=192.168.104.0/255.255.255.0
autocreatepeer=yes
insecure=port,invite
tcpenable=no
allowsubscribe=yes
notifyringing=yes
notifyhold=yes
directmedia=no
directrtpsetup=no
disallow=all
allow=ulaw&alaw&gsm
language=de
defaultexpirey=540
maxexpirey=3600
allowoverlap=yes
keepalive=yes

Benutzer Context und Details bleiben leer


Anlage 2 - Eine eMail-Adresse bei der Telekom eingerichtet(!) Wichtig!


Registrierungsreihenfolge

Code:
Tel-Nummer-mit-Vorwahl:Passwort:eMail-Adresse (OHNE! @t-online.de!) @tel.t-online.de~481

Code:
username=eMail-Adresse (OHNE! @t-online.de!)
type=friend
tcpenable=yes
secret=Passwort
remotesecret=Passwort
realm=tel.t-online.de
qualifyfreq=1000
qualify=yes
notifyringing=yes
notifyhold=yes
nat=yes
maxexpirey=3600
localnet=192.168.110.0/255.255.255.0
language=de
keepalive=yes
insecure=port,invite
host=tel.t-online.de
fromuser=Tel-Nummer-mit-Vorwahl
fromdomain=tel.t-online.de
dtmfmode=rfc2833
disallow=all
directrtpsetup=no
directmedia=yes
defaultexpirey=540
canreinvite=update
bindport=5060
bindaddr=0.0.0.0
autocreatepeer=yes
allowsubscribe=yes
allowoverlap=yes
allowguest=yes
allow=ulaw&alaw&gsm

Für alle die noch eine Firewall betreiben, der Registrierungsserver (SIP) unterscheidet sich vom RTP-Server! Ihr müsst also in der Firewall (oder dem Routing) zwei verschiedene Einträge machen. Es genügt auf der Firewall jedoch für den Anfang der Kommunikation _NUR_ die ausgehenden Ports udp 5060 zu öffnen. Es braucht, vorausgesetzt ihr habt eine korrekt eingerichtete Firewall, kein Portforwarding oder ähnliches.

Das wars so weit.

Viel Spaß

- - - Aktualisiert - - -

Ach ja, Nachtrag - weil vergessen

Beide Anlagen loggen sich derzeit über ein und die selbe IP-Adresse bei der Telekom ein. Ich habe das Problem, dass ich mit der zweiten Anlage hinter einem Router stecke, der partout nicht das tut was er soll.

Beide Anlagen laufen in einer Virtuellen Maschine (Proxmox)

Anlage 1

Telefonanlage -> Vhost -> Router (Home) -> Telekom


Anlage 2

Telefonanlage - > Vhost -> Router (Work) -> OpenVPN -> Router (Home) -> Telekom

Da auf Router (Work) der allgemeine Internet-Traffic ganz normal ins Internet geht, wurde ein Hostrouting angelegt, damit alles was mit VoIP im Zusammenhang steht, einen anderen Weg über das VPN und Router (Home) geht. Mit 217.0.4.167 (tel.t-online.de) und 217.0.23.100 (RTP-Server), sind auch die aktuell bei mir verwendeten IP-Adressen der Telekom bezeichnet. Ohne die Host-Route zum RTP, kann man zwar jeden anrufen, man hört aber nix.

Code:
[email protected]:/config/serverconfig# route -n
Kernel-IP-Routentabelle
Ziel            Router          Genmask         Flags Metric Ref    Use Iface
0.0.0.0         172.22.0.254    0.0.0.0         UG    0      0        0 eth0
10.8.0.0        0.0.0.0         255.255.255.0   U     0      0        0 tap0
10.9.0.0        10.9.0.2        255.255.255.0   UG    0      0        0 tun0
10.9.0.2        0.0.0.0         255.255.255.255 UH    0      0        0 tun0
172.16.11.0     10.8.0.2        255.255.255.0   UG    0      0        0 tap0
172.22.0.0      0.0.0.0         255.255.255.0   U     0      0        0 eth0
192.168.103.0   10.8.0.2        255.255.255.0   UG    0      0        0 tap0
192.168.104.0   10.8.0.2        255.255.255.0   UG    0      0        0 tap0
192.168.110.0   0.0.0.0         255.255.255.0   U     0      0        0 eth1
217.0.4.167     10.8.0.2        255.255.255.255 UGH   0      0        0 tap0
217.0.23.100    10.8.0.2        255.255.255.255 UGH   0      0        0 tap0
- - - Aktualisiert - - -

tststs .. und noch etwas vergessen ;o)

Ich nutze Elastix 4.0.0.1, basierend auf FreePBX 2.11.0.22 und Asterisk 11.20.0 auf centos - Linux x86_64

Das einzige was tatsächlich noch herum hupt ist das Faxsystem.

Das wars jetzt .... hoffe ich.
 
R

rentier-s

Guest
Da hast Du eine ganz schön ungestüme Config zusammengebastelt ;-)

Ein paar Anmerkungen dazu:

- Die Max Expiry mit der ~ am Ende des register kann bei der Telekom ein "Interval too brief" beheben, also lieber etwas größer setzen.
- username heißt in den neuer Versionen defaultuser
- Entweder secret + invite, oder remotesecret
- allowguest, bindport, localnet, tcpenable, allowsubscribe, notifyringing, notifyhold und qualifyfreq gehören alle ins [general]. Auf Peer Basis sind die unwirksam.
- canreinvite gibt es nicht mehr, dafür ist jetzt directmedia

In der zweiten sip.conf hast Du type=friend zusammen mit insecure. Dadurch kann eine Sicherheitslücke entstehen, weil ein User Element ohne Authentifizierung erzeugt wird. type=peer reicht vollkommen.

Die Telekom verwendet Load Balancer, Firewall oder Routing auf einzelne Server festzulegen kann über kurz oder lang ein Problem werden.
 

Bruchteil

Neuer User
Mitglied seit
15 Nov 2016
Beiträge
18
Punkte für Reaktionen
1
Punkte
3
Da hast Du eine ganz schön ungestüme Config zusammengebastelt ;-)
Das habe ich in der Tat. Es ist aber auch dem Zeitraum geschuldet, in der ich das Problem versucht habe zu lösen. 4 Monate etwa, habe ich immer wieder probiert und getestet. Oft so lange, bis die Telekom mir wegen zu vieler Logins den Zugang blockierte.

Ein paar Anmerkungen dazu:

- Die Max Expiry mit der ~ am Ende des register kann bei der Telekom ein "Interval too brief" beheben, also lieber etwas größer setzen.
Ja, es ist im Moment Eine Sekunde über dem Limit. Resultiert aus den vielen Einzelfehlern, die ich zu bewältigen hatte.

- username heißt in den neuer Versionen defaultuser
Gut zu wissen ... die Doku der telekom bringt mich an den Rand der Verzweiflung.

- Entweder secret + invite, oder remotesecret
- allowguest, bindport, localnet, tcpenable, allowsubscribe, notifyringing, notifyhold und qualifyfreq gehören alle ins [general]. Auf Peer Basis sind die unwirksam.
- canreinvite gibt es nicht mehr, dafür ist jetzt directmedia
Werde ich bei Gelegenheit noch mal testen. Im Moment läufts und ich bin froh darüber ...

In der zweiten sip.conf hast Du type=friend zusammen mit insecure. Dadurch kann eine Sicherheitslücke entstehen, weil ein User Element ohne Authentifizierung erzeugt wird. type=peer reicht vollkommen.
Das ist mir beim lesen nach dem veröffentlichen des Posts auch aufgefallen. Noch steht es so in der Konfiguration drinnen bei mir. Sollte aber auch keine große Gefahr sein, da eben jene Anlage hinter zwei Firewalls/Routern sitzt, die keinerlei direkten Zugang zum Internet haben. Nur per VPN vielleicht, aber das Login hat auch nicht jeder.

Die Telekom verwendet Load Balancer, Firewall oder Routing auf einzelne Server festzulegen kann über kurz oder lang ein Problem werden.
Das ist wahr und in der Tat ein Problem. Leider musste ich das erst mal in Kauf nehmen, um eine funktionierende Anlage hinzubekommen. Das muss jetzt so lange funktionieren bis die alte ISDN-Anlage abgeschaltet werden kann um danach auf VoIP umbauen zu können. (Habe an der Stelle dann zwei Internetanschlüsse)

Mein Problem ist ja mit dem ganzen Umbau noch nicht beendet. Ich muss noch ein 33,6er Modem zum laufen bekommen. Mit Einwahl von außen nach innen und Selbstwahl von innen nach außen. Das dürfte noch spannend werden. Wenn das alles läuft, dann kann die Telekom ISDN meinetwegen abschalten. ;o)

Aber danke auf jeden Fall für die Hinweise.
 

Poldi1970

Neuer User
Mitglied seit
6 Jun 2016
Beiträge
38
Punkte für Reaktionen
0
Punkte
6
Hallo,
wo muß ich die oben genanten daten eintragen?

Gruß
Poldi
 

Bruchteil

Neuer User
Mitglied seit
15 Nov 2016
Beiträge
18
Punkte für Reaktionen
1
Punkte
3
Hallo,
wo muß ich die oben genanten daten eintragen?
In den Trunk-Settings - "Peer-Name" (frei wählbar) und den Rest in die "Peer-Details".
Der "Register-String" natürlich ganz normal in die Registration eintragen.

Die "Incoming-Settings" als auch "User Context/Details" bleiben frei.
 

3CX PBX - GRATIS
Linux / Win / Cloud

Statistik des Forums

Themen
232,086
Beiträge
2,018,571
Mitglieder
349,414
Neuestes Mitglied
Biddle