.titleBar { margin-bottom: 5px!important; }

Knacken nach Stille, Echocancel wird nicht akt. im NT Modus

Dieses Thema im Forum "Asterisk ISDN mit Bristuff (hfc, zaptel)" wurde erstellt von NeoMagic, 4 Sep. 2004.

  1. NeoMagic

    NeoMagic snom-Mitarbeiter

    Registriert seit:
    19 Juli 2004
    Beiträge:
    82
    Zustimmungen:
    0
    Punkte für Erfolge:
    0
    Hallo liebe Gemeinschaft,


    ich habe mit dem Sternchen noch 2 kleine ISDN/HFC Probleme:

    1. Nach einer Stille im Gespräch knackst es ganz leise wenn wieder was gesprochen wird (anscheinend nur bei mir im Hörer). Es ist nicht laut aber doch auf dauer nervig.

    2. Hab ich in der zapata.conf, echocancel=yes eingetragen. Wenn ich nun in der Konsole "zap show channel 1" eingebe, steht da Echo Cancellation currently OFF, andere Leute bemerken ein Hintergrundecho wenn ich sie über SIP anrufe.

    Also hat sonst noch jemand das knacksen in der Leitung? hab Asterisk nochmal neu auf einem anderem Rechner installiert genau dasselbe. Warum lässt sich die Echounterdrückung nicht aktivieren?

    Hier meine Rechner Config:
    Code:
    ASUS P2B-DS 1012 Bios
    2 x P3-700
    768 MB Ram
    
    Adaptec 7890 U2W onboard
    Matrox G200
    Acer 128 isdn pci
    3COM 100 Mbit NIC
    
    18 GB Seagate U2W Platte (SCSI)
    LiteOn CDRom (IDE)
    
    Mandrake 10 Linux (Freitag Nacht frisch gezogen)
    
    Zapata.conf:
    Code:
    [channels]
    switchtype	= euroisdn
    signalling	= bri_net_ptmp
    echocancel	= yes
    echotraining	= yes
    language	= de
    ;pridialplan	= local
    immidiate	= no
    overlapdial	= yes
    group 		= 1
    context		= default
    channel 	=> 1-2
    
    zaptel.conf
    Code:
    # hfc-s pci a span definition
    # most of the values should be bogus because we are not really zaptel
    loadzone=nl
    defaultzone=nl
    
    span=1,1,3,ccs,ami
    bchan=1-2
    dchan=3
    

    und noch die Konsolenausgabe für Channel 1 (die entsprechende Zeile ist mit >>>>> von mir markiert:
    Code:
    Channel: 1*CLI>
    File Descriptor: 17
    Span: 1ler*CLI>
    Extension: CLI>
    Dialing: noCLI>
    Context: default
    Caller ID string:
    Destroy: 0*CLI>
    Signalling Type: PRI Signalling
    Owner: <None>
    Real: <None>
    Callwait: <None>
    Threeway: <None>
    Confno: -1
    Propagated Conference: -1
    Real in conference: 0
    DSP: no
    Relax DTMF: no
    Dialing/CallwaitCAS: 0/0
    Default law: alaw
    Fax Handled: no
    Pulse phone: no
    >>>>> Echo Cancellation: 0 taps unless TDM bridged, currently OFF
    PRI Flags:
    PRI Logical Span: Implicit
    Actual Hookstate: Onhook
    
    So ich hoffe ich hab alles beisammen, falls noch was fehlt bitte melden.

    Währe nett wenn jemand ein paar Ideen hätte.

    EDIT:

    Ach ja benutze die aktuellste BRIStuff vom 18.8. RC4a oder so, naja die neuste halt :)
     
  2. schakal2k

    schakal2k Mitglied

    Registriert seit:
    16 Aug. 2004
    Beiträge:
    309
    Zustimmungen:
    0
    Punkte für Erfolge:
    0
  3. NeoMagic

    NeoMagic snom-Mitarbeiter

    Registriert seit:
    19 Juli 2004
    Beiträge:
    82
    Zustimmungen:
    0
    Punkte für Erfolge:
    0
    Hab deinen Beitrag gelesen, aber du scheinst ja ganz andere Probleme zu haben, bei mir ists nur ein leises knacken, sonst geht ja alles!

    Auf deine Probleme kann ich mir leider keinen Reim machen sorry.

    EDIT:
    alle ECHO Befehle werden nicht angenommen, habe auch schon die Reiehenfolge der Befehle in der Zaptel.conf verändert, hat auch nix gebracht.
     
  4. NeoMagic

    NeoMagic snom-Mitarbeiter

    Registriert seit:
    19 Juli 2004
    Beiträge:
    82
    Zustimmungen:
    0
    Punkte für Erfolge:
    0
    So nochmal eine Präzisierung des Echoproblems:

    Das Echo tritt nur auf wenn ich raustelefoniere, bei eingehenden Gesprächen gibt es kein Echo, sehr sehr seltsam Büdde Büdde helft mir doch ^^
     
  5. wrrdlbrrmpft

    wrrdlbrrmpft Mitglied

    Registriert seit:
    17 Juli 2004
    Beiträge:
    263
    Zustimmungen:
    0
    Punkte für Erfolge:
    0
    Hallo,

    wenn der zap channel momentan nicht benutzt wird, steht da wohl immer "Echo Cancellation: ... taps, currently OFF", nur um das erstmal zu klären.
    Auf voip-info.org findet man so einiges zum Thema Echo. Unter Anderem findet man dort folgendes:
    Man kann auch versuchen, mit echocancel herumzuspielen, z. B. echocancel=256. Was man damit ändert, habe ich jedoch nicht verstanden. Ich habe auch noch keine sinnvolle Übersetzung für den Parameter "taps" gefunden. Vielleicht kann mich hier mal jemand aufklären. Sehr merkwürdig finde ich auch, dass das Problem nur beim raustelefonieren besteht. Was für ein Unterschied besteht denn zu einem eingehenden Gespräch, wenn die Verbindung bereits aufgebaut ist?
    Naja, und dann könnte man noch an rxgain und txgain in zapata.conf rumschrauben. Vielleicht bringt auch das etwas Besserung.

    Ciao!
    Benno
     
  6. sion

    sion Neuer User

    Registriert seit:
    18 Sep. 2004
    Beiträge:
    129
    Zustimmungen:
    0
    Punkte für Erfolge:
    0
    Habe mal beim Telefonieren "zap show channel 1" eingegeben, auch da zeigt er bei mir "Echo Cancellation: 128 taps, currently OFF" an. Wie also läßt sich dieses Biest aktivieren, das Echo klingt alles andere als schön?!

    Hier meine zapata.conf:
    Code:
    [channels]
    switchtype=euroisdn
    signalling=bri_net_ptmp
    pridialplan=local
    echocancel=yes
    echocancelwhenbridged=yes
    immediate=no
    overlapdial=yes
    group=1
    context=default
    channel=>1-2
    
    Den Informationen auf voip-info.org zufolge sollte es mit den Einstellungen ja eigentlich aktiviert sein - oder muß ich das in Asterisk nochmal woanders konfigurieren?
     
  7. sion

    sion Neuer User

    Registriert seit:
    18 Sep. 2004
    Beiträge:
    129
    Zustimmungen:
    0
    Punkte für Erfolge:
    0
    Habe mal beim Telefonieren "zap show channel 1" eingegeben, auch da zeigt er bei mir "Echo Cancellation: 128 taps, currently OFF" an. Wie also läßt sich dieses Biest aktivieren; das Echo klingt alles andere als schön?!

    Hier meine zapata.conf:
    Code:
    [channels]
    switchtype=euroisdn
    signalling=bri_net_ptmp
    pridialplan=local
    echocancel=yes
    echocancelwhenbridged=yes
    immediate=no
    overlapdial=yes
    group=1
    context=default
    channel=>1-2
    
    Den Informationen auf voip-info.org zufolge sollte es mit den Einstellungen ja eigentlich aktiviert sein - oder muß ich das in Asterisk nochmal woanders konfigurieren?
    Bitte helft uns Echo-Geschädigten! :cry:

    Update: Wenn ich angerufen werden, zeigt mir obiger Befehl, daß Echo Cancellation eingeschaltet ist. Es ist also nur aus, wenn ich jemanden anrufe! Das sollte man doch irgendwie hinbekommen, daß das immer an ist, oder?!
     
  8. sion

    sion Neuer User

    Registriert seit:
    18 Sep. 2004
    Beiträge:
    129
    Zustimmungen:
    0
    Punkte für Erfolge:
    0