[Gelöst] Mehr als 2 Rufnummern bei Telekom registrieren

astrakid

Neuer User
Mitglied seit
24 Apr 2011
Beiträge
89
Punkte für Reaktionen
0
Punkte
6
hi,
nachdem mein * langsam ans Rennen kommt (Outbound klappt noch nicht), versuche ich, die Fehler nun langsam einzugrenzen.
Dabei ist folgender Fehler noch offen:
Ich habe 10 MSNs, die jetzt auch per VoIP erreichbar sind.
In Asterisk habe ich das durch 10 register-Zeilen realisiert. mit sip show registry kann ich alle sehen, jeweils erfolgreich.

sip.conf:
Code:
register => 12345:passwort:[email protected]/12345
register => 23456:passwort:[email protected]/23456
register => 34567:passwort:[email protected]/34567
register => 45678:passwort:[email protected]/45678
[...]
aufgefallen ist mir, dass alle rufnummern nach den ersten beiden registrierungen nicht erreichbar sind - asterisk sagt nichts dazu im log, im hörer des anrufers erscheint nur stille.
wenn ich anschließend die nummern aber im w723v registriere, klappt alles... kann das jemand erklären / nachvollziehen / bestätigen / nicht bestätigen?

gruß,
astrakid
 
Zuletzt bearbeitet:

astrakid

Neuer User
Mitglied seit
24 Apr 2011
Beiträge
89
Punkte für Reaktionen
0
Punkte
6
im verlauf des gestrigen und heutigen tages musste ich feststellen, dass es wohl auch probleme bei 2 rufnummern gibt... jetzt habe ich nur die hauptnummer regsitriert, dann klappt es... aber die anderen rufnummern brauche ich auch...?
hat einer eine idee oder es gelöst? wenn ja, wie?

gruß,
astrakid
 

astrakid

Neuer User
Mitglied seit
24 Apr 2011
Beiträge
89
Punkte für Reaktionen
0
Punkte
6
hi,
sip.conf:
Code:
register => 12345:<passwort>:[email protected]/12345
register => 23456:<passwort>:[email protected]/23456
register => 34567:<passwort>:[email protected]/34567
register => 45678:<passwort>:[email protected]/45678
[...]
es funktioniert, wenn ich den teil hinterm slash weglasse, also:
register => 12345:<passwort>:[email protected]
register => 23456:<passwort>:[email protected]

dann registrieren sich sauber alle rufnummern bei der telekom. ABER: es kommen alle eingehenden anrufe auf sämtlichen nummern unter der "hauptnummer" ein. und das schlimmste dabei: es werden keine weiteren infos wie dnid mitgegeben, um festzustellen, für welche rufnummer der call gedacht war. somit habe ich dann keinen mehrwert mehr.
hat einer eine idee, wie ich das lösen kann?

gruß,
astrakid
 
Zuletzt bearbeitet:
R

rentier-s

Guest
Schau mal ob Du im SIP Header "TO" brauchbare Informationen findest.
 

astrakid

Neuer User
Mitglied seit
24 Apr 2011
Beiträge
89
Punkte für Reaktionen
0
Punkte
6
danke für den tipp. leider bin ich auf die schnelle nicht fündig geworden.
aber ich habe weiter rumprobiert und entgegen aller anleitungen die telnummer nach dem slash nun mit vorwahl angegeben - und es klappt...
der fall ist also gelöst, der registry-string muss folgendermaßen aussehen:
register => <rufnummerinklvorwahl>:<pw>:<emailvordererteil>@tel.t-online.de/<rufnummerinklvorwahl>