.titleBar { margin-bottom: 5px!important; }

NEWBIE Frage - Eingehende ISDN Anrufe nach SIP weiterleiten

Dieses Thema im Forum "Asterisk Allgemein" wurde erstellt von KjM, 5 Okt. 2004.

  1. KjM

    KjM Neuer User

    Registriert seit:
    5 Okt. 2004
    Beiträge:
    10
    Zustimmungen:
    0
    Punkte für Erfolge:
    0
    Hi zusammen

    Ich habe mir mal Asterisk 1.0 gezogen und installiert. Ich habe die Sache soweit installiert das Asterisk auf eine meiner MSN's reagiert und dort seinen 'You have successful install...' labert. Ebenfalls habe ich meinen existierenden SIP Account in die sip.conf eingetragen und wie's scheint wir das auch alles akzeptiert. Was ich nun machen will, ist dass eingehende Anrufe auf die MSN dann an meinen SIP Account xxx.xxx@sip.web.de weitergeleitet werden.
    Leider habe ich in den Configfiles noch nicht so richtig den Durchblick um selbst auf die Loesung zu kommen.

    Also -> Bitte Hilfe :)

    Das steht in meiner sip.conf (Mein Netz ist MASQ und DefGW = 192.168.1.4)

    [web_de]
    type=peer
    host=192.168.1.2
    fromuser=xxx.xxxx
    secret=secret
    fromdomain=web.de

    Und hier die modem.conf

    driver=i4l
    dtmfmode=i4l
    group=1
    dialtype=tone
    connected
    mode=immediate
    msn=540139
    device => /dev/ttyI0


    Und schon jetzt mal Danke fuer Hinweise :)

    Gruss KjM
     
  2. fabe

    fabe Neuer User

    Registriert seit:
    13 Juli 2004
    Beiträge:
    72
    Zustimmungen:
    0
    Punkte für Erfolge:
    0
    schau dir mal etwas genauer die dialplan logik an. (extensions.conf).
    im grunde brauchst du sowas wie exten => deinemsn,1,Dial(SIP/deinsipaccount)
     
  3. KjM

    KjM Neuer User

    Registriert seit:
    5 Okt. 2004
    Beiträge:
    10
    Zustimmungen:
    0
    Punkte für Erfolge:
    0
    Ok, also habe ich mal [demo] deaktiviert und folgendes bei [default] eingetragen:

    exten => 540139,1,Dial(SIP/sipaccount:sippwd@sip.web.de,,r)

    Asterisk gestartet und die 540139 angerufen.
    Resultat
    *CLI> == Starting Modem[i4l]/ttyI0 at remote,540139,1 failed so falling back to exten 's'
    == Starting Modem[i4l]/ttyI0 at remote,s,1 still failed so falling back to context 'default'
    Oct 14 10:13:15 WARNING[16400]: pbx.c:1877 ast_pbx_run: Channel 'Modem[i4l]/ttyI0' sent into invalid extension 's' in context 'default', but no invalid handler
    -- Hungup 'Modem[i4l]/ttyI0'

    Was laeuft noch schief?

    Gruss KjM