.titleBar { margin-bottom: 5px!important; }

Openvpn für aktuelle Beta Firmware 7390

Dieses Thema im Forum "FRITZ!Box Fon: Modifikationen" wurde erstellt von axbl, 9 Jan. 2012.

  1. axbl

    axbl Neuer User

    Registriert seit:
    2 Feb. 2009
    Beiträge:
    26
    Zustimmungen:
    0
    Punkte für Erfolge:
    1
    #1 axbl, 9 Jan. 2012
    Zuletzt bearbeitet: 9 Jan. 2012
    Moin,
    hat jemand eine funktionierende Openvpn-Binary für die aktuelle beta Firmware 84.05.07-21400 der 7390 ?
    Mein Openvpn binary läuft nicht mehr:

    line 1: syntax error: unexpected "("

    Grüße,axbl
     
  2. MaxMuster

    MaxMuster IPPF-Promi

    Registriert seit:
    1 Feb. 2005
    Beiträge:
    6,924
    Zustimmungen:
    0
    Punkte für Erfolge:
    36
    "aktuelle Beta Firmware" ... Von welchem Gerät?
     
  3. axbl

    axbl Neuer User

    Registriert seit:
    2 Feb. 2009
    Beiträge:
    26
    Zustimmungen:
    0
    Punkte für Erfolge:
    1
    Hi,
    Sorry, habe meinen Beitrag aktualisiert (s.o.)
     
  4. MaxMuster

    MaxMuster IPPF-Promi

    Registriert seit:
    1 Feb. 2005
    Beiträge:
    6,924
    Zustimmungen:
    0
    Punkte für Erfolge:
    36
    Bist du sicher, dass du auch ein Binary für diese Box hattest, und das das binär übertragen wurde? Die Fehlermeldung sieht eher nach "falscher Übertragung" aus...

    Ich hänge trotzdem mal ein aktuelles, statisch gebautes Binary an.

    EDIT Bitte gib mal eine Rückmeldung, weil das 2.2.2-er ganz "frisch" ist...
     

    Anhänge:

  5. axbl

    axbl Neuer User

    Registriert seit:
    2 Feb. 2009
    Beiträge:
    26
    Zustimmungen:
    0
    Punkte für Erfolge:
    1
    Hey, Danke, läuft damit !
    Baust Du das Binary über Freetz ?
     
  6. MaxMuster

    MaxMuster IPPF-Promi

    Registriert seit:
    1 Feb. 2005
    Beiträge:
    6,924
    Zustimmungen:
    0
    Punkte für Erfolge:
    36
    Ja, da gibt es für eine ganze Reihe Programme einen Punkt, um "statische Binaries" zu bauen. Die sollten dann ohne Abhängigkeiten von Libraries usw. auch auf "ungefreetzten" Boxen laufen.
     
  7. MaxMuster

    MaxMuster IPPF-Promi

    Registriert seit:
    1 Feb. 2005
    Beiträge:
    6,924
    Zustimmungen:
    0
    Punkte für Erfolge:
    36
    Ich hänge mal die aktuellen OpenVPN 2.3.0 Binaries an, einmal mit OpenSSL, einmal mit PolarSSL (nur halb so groß).

    Das Polarssl-Binary ist mit Polarssl-1.2.3 gebaut und das habe ich so gepatched, dass es auch den Standard-Cipher (BF-CBC mit 128 Bit Key) unterstützt.
     

    Anhänge: