PC aufwecken über WoL - Wake on Lan

qu1gon

Neuer User
Mitglied seit
7 Jan 2016
Beiträge
32
Punkte für Reaktionen
0
Punkte
6
Hallo,

ich habe mehrere Foreneinträge gelesen, aber es klappt nicht so wie es soll: PC von über WAN (LAN nicht so wichtig) aufwecken über mein Smarphone mit der App WolOn - Wake on LAN von bitklog (hab LAN WOL und WAN WOL eingerichtet).

Problem: Es funktioniert, aber mal geht es und dann wieder nicht und auch das ganz unterschiedlich. Mal gar nicht. Mal nur kurz nach dem ich den PC heruntergefahren habe auch dann mal nur LAN oder WAN oder per App gar nicht, aber über
das Einloggen in die FritzBox und dessen eigene Funktion "Computer starten". Nach einer gewissen Zeit nachdem der Rechner heruntergefahren wurde geht auch manchmal gar nichts - z.B. am nächsten Tag. Egal welche Einstellungen ich probiere
ich bekomme das nicht hin.

Infos/aktuelle Einstellungen: Win 10, Realtek Netzwerkkarte, Energieoptionen - Schnellstart aktiviert, FritzBox - "Diesen Computer automatisch starten..." aktiviert / Immer die gleiche IP für meinen PC aktiviert / Prot 9 47551 eingerichtet,
Netzerkkarte Einstellungen - "Computer kann Gerät ausschalten..." aktiviert / "Gerät kann den Computer aus dem Ruhezustand aktivieren" aktivert / "Nur Magic Paket kann Computer aus dem Ruhezustand aktivieren" deaktiviert /
"Magic Paket aufwecken" aktiviert / "ARP-Abladen" aktivert / Energy-Efficient Ethernet... deaktiviert / "Green Ethernet" deaktiviert

Hat das denn überhaupt jemand je hinbekommen? Wenn ja, bitte ich um genaue Einstellungen. Ich will ja eigentlich nur ganz einfach das es "immer funktioniert" und über WAN. Nicht mal gehts, mal nicht. Mal WAN aber nicht LAN und umgekehrt usw..

Ich hoffe es kann mir jemand weiterhelfen. Danke sehr.
 

qu1gon

Neuer User
Mitglied seit
7 Jan 2016
Beiträge
32
Punkte für Reaktionen
0
Punkte
6
Damit wird dem PC erlaubt, die Netzwerkkarte abzuschalten, wenn er meint daß die nicht gebraucht wird.
Danke, das hatte ich mir auch gedacht und auch das hatte ich schon deaktiviert - kanns nochmal testen.
Jedoch wird in Anleitungen hingewiesen, das alle drei aktiviert sein sollen, es sind ja drei Eisntelunngen (s. Screenshot).

Dann ist noch der Punkt, wenn es aktiviert ist kann ich die Einstellung darunter "Gerät kann den Computer aus dem Ruhezustand aktivieren" aktivieren.
Heißt doch, das es trotz aktiviertem "Computer kann Gerät ausschalten.." auch wieder aktivieren kann oder verstehe ich das falsch.
 

Anhänge

stoney

Moderator
Teammitglied
Mitglied seit
7 Okt 2015
Beiträge
5,359
Punkte für Reaktionen
407
Punkte
83
Welche F!B mit welchem OS ist denn überhaupt im Einsatz (in älteren Versionen gab es vermehrt Probleme mit dem MagicPacket)?

Wird denn der PC vollständig heruntergefahren (sodass da Windows nicht mehr auf die Netzwerkkarte zugreifen/steuern kann) oder in den Energiesparmodus?

Die Settings im BIOS sind ebenfalls korrekt (sollte sie eigentlich, denn entweder an oder aus)?

Die Einstellungen unter Erweitert (im Screenshot)
Bei Magic Pcket aufwecken​
WoL / Link-Geschwindigkeit reduzieren​
sehen bei Dir wie aus?

Die Treiber der Netzwerkkarte sind auch aktuell?
 

qu1gon

Neuer User
Mitglied seit
7 Jan 2016
Beiträge
32
Punkte für Reaktionen
0
Punkte
6
Hab die Option "Computer kann Gerät ausschalten..." deaktivert - PC heruntergefahren und gleich mit App WAN probiert und ging an.

FB 4040 OS 7.14 - PC wird vollständig heruntergefahren. BIOS anfänglich WOL aktivert, ging aber nicht, aber dann noch eine zweite Option aktivert und es ging.
Diese: Advanced\ACPI Configuration\PCIE Devices Power On
 

stoney

Moderator
Teammitglied
Mitglied seit
7 Okt 2015
Beiträge
5,359
Punkte für Reaktionen
407
Punkte
83
Du hast ja bereits geschrieben, dass es manchmal geht und manchmal nicht.

Ich würde hier jetzt noch ein paar Tests machen (von allen benötigten/gewünschten Seiten) - in verschiedenen Zeitintervallen.

Wobei ich ja von WAN-Seite her eher eine VPN-Lösung iVm einem Tool welches das MP aus dem LAN heraus sendet bevorzugen (Sicherheit geht vor)
 

qu1gon

Neuer User
Mitglied seit
7 Jan 2016
Beiträge
32
Punkte für Reaktionen
0
Punkte
6
Achso noch: Magic Paket ist aktiviert und WoL Link ist 10 MBit/s. VPN ist mir im Moment nicht wichtig - aber dennoch behalte ich das im Hinterkopf.

Was meinst du mit benötigten/gewünschten Seiten? Meinst WAN, LAN und da nochmal testen?
Also LAN brauch ich eig. nicht. Geht mir nur darum, falls ich mal unterwegs bin um den PC dann aufwecken zu können.
 

stoney

Moderator
Teammitglied
Mitglied seit
7 Okt 2015
Beiträge
5,359
Punkte für Reaktionen
407
Punkte
83
Was meinst du mit benötigten/gewünschten Seiten? Meinst WAN, LAN und da nochmal testen?
ja, genau. Ich wollte es nur nicht unerwähnt lassen.

Dann drücke ich die Daumen, dass es nun immer auf Anhieb funktioniert. Lass uns alle doch dann daran teilhaben, welche Einstellung nun zum gewünschten Erfolg geführt haben.
 
  • Like
Reaktionen: qu1gon

qu1gon

Neuer User
Mitglied seit
7 Jan 2016
Beiträge
32
Punkte für Reaktionen
0
Punkte
6
Was ist mit dem android tool aus diesem thread
https://www.ip-phone-forum.de/threads/wake-on-lan-klappt-per-fritz-oberfläche-aber-nicht-per-remotedesktopverbindung.256826/post-2345529
Ich lasse immer 5 Pakete im Abstand von 1s senden. Nicht über broadcast. Geht.
Danke. Das hatte ich auch installiert (habs auch aus dem Thread), aber es machte keinen Unterschied ob ich das eine oder andere benutzt habe.
Wie gesagt, es funktioniert ja - nur nicht wie es soll bzw. immer.
 

qu1gon

Neuer User
Mitglied seit
7 Jan 2016
Beiträge
32
Punkte für Reaktionen
0
Punkte
6
Bisher folgende Ergebnisse:

1. PC über Nacht ausgeschaltet. Aufwecken ging heute weder über die App (Lan (im Wlan eingeloggt) o. Wan (im Mobilfunknetz eingeloggt)) noch über den Snartphonebrowser, also in
die FB einloggen und "Computer starten" klicken nicht.

2. Was definitiv (reproduzierbar) auch nicht geht: Wenn ich den PC anschalte u. bis zum Login boote, also nicht mein PW eingebe um zum Desktop zu gelangen und dann gleich den PC
herunterfahre, dann kann ich den PC auch nicht auffwecken - ebenfalls weder mit App noch über Smartphonebrowser "Computer starten". Also ich probiere das gleich nach dem der PC
sich ausgeschaltet hat (nach ein paar Sekunden).
Wenn ich allerdings bis auf den Desktop boote, PC herunterfahre und gleich (nach ein paar Sekunden) auffwecke - funktioniert es sowohl mit der App als auch mit "Computer starten".

3. Boote bis zum Desktop, fahre den PC herunter, allerdings warte ich nun 2 Minuten anstatt es gleich nach ein paar Sekunden zu probieren - jetzt kann ich nur noch über "Computer starten"
den PC aufwecken (selbiges auch nach gut 20 Minuten).
 

stoney

Moderator
Teammitglied
Mitglied seit
7 Okt 2015
Beiträge
5,359
Punkte für Reaktionen
407
Punkte
83
Welches Mainboard ist denn im PC verbaut?

Bitte füge Screenshots, ok das wird im BIOS schwer, dann lieber Fotos, deiner Einstellungen bei.

Windows dürfte eig. garnichts damit zu tun haben, da es rein auf Netzwerkebene (MAC-Adresse der Netzwerkkarte) ablaufen müsste.
 

qu1gon

Neuer User
Mitglied seit
7 Jan 2016
Beiträge
32
Punkte für Reaktionen
0
Punkte
6
Hab eben diesen aktuellen Thread gefunden: https://www.computerbase.de/forum/threads/wol-fehler-ueber-internet.1855866/

Scheint wohl an dem ARP-Zeugs zu liegen. Jedenfalls wenn ich das richtig verstanden habe bleibt mir nur, mich über mein Smarphone von unterwegs immer in der FB-Oberfläche
anzumelden und über "Computer starten" den PC aufzuwecken. Aber wie ich weiter oben schon erwähnte, geht das ja auch nicht mehr sobald der PC über Nacht aus war bzw. nach
einer bisher unbestimmten Zeit (muss halt morgen nochmal testen).

Hab ein ASrock B450m Pro4 - Die Einstellung auf Bild 1 "Systemstart per Onboard-LAN" hat nicht ausgereicht. Damit es funktioniert, musste ich die Einstellung Bild 2 auch tätigen.
 

Anhänge

stoney

Moderator
Teammitglied
Mitglied seit
7 Okt 2015
Beiträge
5,359
Punkte für Reaktionen
407
Punkte
83
Das Phänomen ist allerdings auch schon etwas länger bekannt, es gibt dutzende Posts hier im IPPF welche sich damit beschäftigen.

Wurde eine Suche auch korrekt angewand? (oft ist ja das über die Boardmittel oder über eine Suchmaschine doch nicht ganz so einfach wie man sich das denkt. Wähle zB mal eine Suchmaschine welche site: [Suchbegriff(e)] untestützt.
 

PeterPawn

IPPF-Urgestein
Mitglied seit
10 Mai 2006
Beiträge
12,685
Punkte für Reaktionen
906
Punkte
113
Die Einstellung auf Bild 1 "Systemstart per Onboard-LAN" hat nicht ausgereicht. Damit es funktioniert, musste ich die Einstellung Bild 2 auch tätigen.
"Eingedeutschte" Beschreibungen sind zwar immer Gülle und teilweise schwer zu interpretieren ... aber die Option im ersten Bild dürfte auf einen Start des PCs AUS dem Netzwerk hinauslaufen (da wird also das zu startende OS von einem Netzwerk-Server geladen) und nur die Option im zweiten Bild wird tatsächlich etwas mit "Wake on LAN" zu tun haben.

Darüber, was da wann funktioniert bzw. funktionieren sollte, haben wir vor kurzer Zeit erst wieder geschrieben (da ging es darum, ob bzw. wann "Wake over WiFi" funktioniert) - wer sich mal etwas genauer mit den Stromsparzuständen befaßt (insb. die Sx-Zustände), der versteht dann auch (früher oder später), wie das Ganze funktioniert. Man kann jedenfalls nur sehr schwer ein "echtes 'magic packet'" per App durch einen Router mit einer ordentlichen Firewall senden und bei der FRITZ!Box mit ihrem PCP-Support ist das doppelt schwer, weil der Port 9 (das ist ja offiziell das "discard"-Protokoll, wo jedes eingehende Pakete einfach verworfen wird) für die Keepalive-Mechanismen des PCP benutzt wird.

Bei einer FRITZ!Box mit funktionierender, automatischer(!) WoL-Funktion braucht es nur einen passend freigegebenen Port, damit die Box bei "inaktivem" Client (das ist spätestens dann der Fall, wenn der im GUI nicht mehr mit der Weltkugel oder der grünen "LED" angezeigt wird, sondern mit der grauen) erst einmal ein WoL-Paket erzeugt (das braucht auch nur die Adressierung auf Layer2 - also die MAC-Adresse - und ist auf Layer3 - also IP-Adressen und ARP-Request/-Responses - gar nicht angewiesen) ... nur muß der PC dann natürlich auch erst einmal starten und somit wird ihn das erste Paket (welches das Aufwecken ausgelöst hat) mit einiger Sicherheit gar nicht erreichen.

Hier sollte man also auf TCP-Verbindungen zum Aufwecken setzen, denn bei diesen wird - sofern keine Reaktion auf das erste SYN-Paket erfolgt - eine automatische Wiederholung verwendet und wenn das Timing (des PCs beim Aufwachen) einigermaßen paßt, kriegt der dann wenigstens dieses zweite Paket mit. Allerdings muß er dazu dann innerhalb der Timeout-Zeitspanne zumindest auch seine Netzwerk-Karte neu initialisiert haben (das kann bei DHCP eine Weile dauern), denn die anderen Pakete sind natürlich auf einen funktionierenden Layer3 angewiesen.

Witzig ist es bei AVM eigentlich nur, daß (zumindest nach dem, was ich bisher gesehen habe) die Möglichkeit zur Einstellung des "automatischen Aufweckens" im GUI gar nicht davon abhängig ist, ob für das betreffende Gerät überhaupt eine Portfreigabe eingerichtet wurde und somit ein Zugriff aus dem Internet auf das Gerät überhaupt möglich wäre.

Wenn der "Computer starten"-Button (mal abgesehen von der "Festlegung", daß das dann ein Computer sein müsse bzw. der offenen Frage, was ein Netzwerkgerät (der "übliche" Sprachgebrauch von AVM im GUI) von einem "Computer" unterscheiden mag) für ein Gerät ohne Freigaben angezeigt wird und auswählbar ist, kann man das nachvollziehen - das macht für den "manuellen Start" absolut Sinn. Aber wie ein automatischer Start beim Zugriff ohne Portfreigaben (bzw. ohne "exposed host"-Eigenschaft für dieses Gerät) aussehen sollte, der über "Diesen Computer automatisch starten, sobald aus dem Internet darauf zugegriffen wird." eingestellt werden kann, verstehen sicherlich auch nicht viele, die sich mit Netzwerken auskennen.
 

qu1gon

Neuer User
Mitglied seit
7 Jan 2016
Beiträge
32
Punkte für Reaktionen
0
Punkte
6
@stoney Stimmt. Hab ja im Eingangspost erwähnt, das ich einige Posts auch hier im Forum schon gelesen habe und nichts wirklich geholfen hat.
Inzwischen ist meine Motivation entsprechend im Keller :( momentan.
Mal sehen wie es morgen ausschaut, wenn der Rechner wieder über Nacht aus war. Im Grunde reicht es mir, wenn es auf dauer funktioniert.
Ob jetzt über die App oder das umständlichere Einloggen in die FB (was jetzt auch nicht schlimm ist). Wenn das aber so bleibt, sprich nach einer
gewissen Zeit geht gar nix, macht es ja so dann keinen Sinn mehr. Bis hierhin auf jeden Fall mal Danke an alle. Melde mich wieder.

@PeterPawn Gerade beim Antworten deinen Post gesehen. Danke. Aber hui, kann dir nur teilweise folgen. Wegen den teilweise Fachausdrücken
und dazu langen Sätzen bin ich etwas überfordert - somit habe ich unterm Strich nicht ganz verstanden, was du mir genau mitteilen willst. :)
 
Zuletzt bearbeitet:

qu1gon

Neuer User
Mitglied seit
7 Jan 2016
Beiträge
32
Punkte für Reaktionen
0
Punkte
6
Moin, also wie vermutet geht (PC über Nacht aus) heute wieder gar nichts.

@PeterPawn Also danke nochmal für deine Worte und deine Mühe - und entschuldigung wenn ich das jetzt so salopp formuliere. Es ist zu kompliziert und echt schwierig zu lesen,
da teilweise sehr lange Sätze + Nebensätze + noch was in Klammern etc... dann noch (Fach)Ausdrücke die ich und vermutlich nicht jeder versteht.
Kann teilweise folgen, manches sinngemäß aber unterm Strich verstehe ich jetzt nicht warum du mir das geschrieben hast bzw. weiß ich trotzdem nicht was ich jetzt machen soll.
War das als Lösung irwie gemeint, soll ich überhaupt was machen....

Meine Bitte wäre wenn es eine gibt, eine Lösung oder Tips - simpel nach dem Motto - stelle das ein oder mache dies und jenes.
Ich meine, ich bin doch nicht der einzige wo seinen PC von unterwegs aufwecken möchte bzw. wenn es jemand gibt der es eingerichtet hat, kann er doch einfach schreiben wie.
Also ich denke nicht das es bei niemandem auf der Welt funktioniert oder?
 

Olaf Ligor

Mitglied
Mitglied seit
21 Mai 2019
Beiträge
243
Punkte für Reaktionen
29
Punkte
28
Peter baut viel auf verstehendes Lesen und es ist manchmal etwas schwierig den Diamant in der Asche zu finden, vor allem wenn die Aufmerksamkeitsspanne nur noch für die Länge von SMS, Whatsapp- und Twitternachrichten reicht.

Wecken über WAN funktionierte bei mir auf der 7590 v7.12 per:
  1. WebIF mit HTTPS-Zugriff
  2. VPN und dem TR-064-PowerShell-Script von PeterPawn, dazu benötigt man einen Box-User ohne weitere Rechte
  3. Teamviewer mit Port7-Freigabe
  4. wolcmd von Depicus mit Port9-Freigabe
Das AVM-Auto-WOL "Diesen Computer automatisch starten, sobald aus dem Internet darauf zugegriffen wird." ist bei v7.12 mehrfach bestätigt ohne Funktion.
 

qu1gon

Neuer User
Mitglied seit
7 Jan 2016
Beiträge
32
Punkte für Reaktionen
0
Punkte
6
Danke Olaf.

Ist nicht gegen dich Olaf oder sonst jemand hier im Thread gerichtet sondern einfach ganz generell mein Unmut:

Ok das ist mir dann zuviel bzw. wollte ich da jetzt keinen großen Act starten für eine besch****** Funktion. Das ist echt lächerlich, das die das nicht hinbekommen - AVM oder wer auch immer.

Ich versteh es nicht. Probleme mit WoL gibt es offensichtlich seit Jahren und man muss sich ein Bein herausreißen mit VPN, TeamViever, Script etc. oder sontigen Lösungen.
Womöglich müsste ich auch noch Geld für ein Abo bei einem VPN-Anbieter ausgeben, oder?

Also für mich ist das Ergebnis inzwischen ganz simpel. WoL mit der FritzBox zumindest funktioniert im wahrsten Sinne des Wortes "einfach" nicht. Funktioniert schon aber nur für eine
kurze Zeit und das entspricht für mich quasi dem, wie wenn es gar nicht funktinieren würde.
Wer keine Lust auf ewiges Herumprobieren hat oder sich mühsam Infos zu erlesen die einen auch nicht weiterbringen bzw. nur wenn man Experte/Profi in dem Bereich ist, der hat einfach verloren.

Danke sehr nochmal. Entschuldigt meinen Unmut, aber das musste raus und es nervt mich inzwischen tierisch. Unfähigkeit z.B. seitens AVM das zu fixen. Hab Posts gelesen von glaube
2012 oder so - evtl. gibts noch ältere. Wieviel Zeit brauchen die noch? Jedenfalls gibts eine einfache Lösung - bleibt der Rechner halt manchmal an und die Sch**** von WoL kommt mir
jetzt weg - kein Bock mehr :mad::confused: *grummel*
 

PeterPawn

IPPF-Urgestein
Mitglied seit
10 Mai 2006
Beiträge
12,685
Punkte für Reaktionen
906
Punkte
113
Das liegt aber nicht an AVM, sondern an den Benutzern, die ihre Geräte, die da "aufgeweckt" werden sollen, nicht vernünftig konfigurieren können.

Der Kardinalfehler beginnt nämlich bereits da, wo nicht sauber zwischen den Funktionen des OS (unter Nutzung von ACPI zum Zugriff auf die Hardware des Mainboards) und den Möglichkeiten eines speziellen BIOS unterschieden wird.

Ja, es gibt BIOS-Versionen und -Klone, die auch selbst in der Lage sind, die Hardware des Mainboards so zu konfigurieren, daß der LAN-Adapter auf ein "magic packet" hin das System startet (und zwar auch aus S5). Das ist aber eher die Ausnahme als die Regel, denn dabei sind einige Umstände (korrekt) zu beachten und heutzutage funktioniert das i.d.R. ohnehin nur noch für LAN-Adapter, die direkt auf dem Mainboard integriert sind, weil schon die Steckerleisten für die Übergabe eines WoL-Signals von einer zusätzlichen LAN-Karte an das Mainboard nicht vorhanden sind. Zwar verfügt auch jeder PCIe-Slot über ein passendes Signal, aber wie weit dieses zu berücksichtigen ist, wird eben wieder über ACPI geregelt und damit bei modernen OS mit ACPI-Support über das OS und nicht über das BIOS.

Solange man also kein Mainboard hat, bei dem definitiv auch das Starten des PC aus dem S5-Zustand (https://de.wikipedia.org/wiki/Advanced_Configuration_and_Power_Interface) funktioniert (und das sind tatsächlich nicht sooo viele), MUSS man immer das OS richtig konfigurieren, damit das "Aufwecken" dann auch funktioniert. Und das heißt am Ende, daß das System tatsächlich nur "schlafen" darf (Sleep-Zustand) ... sonst hieße die Funktion eher "Power-On over LAN" und nicht "Wake on LAN".

Und wenn man jetzt einfach mal die eigenen Gehirnwindungen bemüht, wird einem auch sehr schnell klar werden, daß selbst für sauber funktionierendes "Aufwecken" schon noch ein paar Voraussetzungen erfüllt sein müssen. So, wie beim Menschen i.d.R. ein Wecker den "richtigen" Zeitpunkt signalisieren sollte (außer man schläft solange, bis man genug hat), muß eben ein solcher Wecker auch für den PC existieren und vor allem - das ist hier der Knackpunkt - auch über die gesamte Dauer des "Schlafes" funktionieren.

Bei einer Netzwerkkarte (oder auch einem LAN-Anschluß auf einem Mainboard) heißt das, daß sie (oder er oder "divers" - wobei ich nicht weiß, was Taucher an dieser Stelle zu suchen haben) über die gesamte Dauer des höheren Sx-Zustands (höher hier anhand der Ziffer) auch mit Strom zu versorgen ist und daß natürlich auch der "Empfänger" des Wecksignals (im "real life" der Mensch, der für erfolgreiches Wecken auch noch am Leben sein sollte) noch vorhanden ist und auf das Signal wartet. Hat der "Ohropax" eingeführt oder schläft drei Zimmer weiter und nicht neben dem Wecker, kann der Wecker sich bemühen, so viel er will - das Aufwecken wird nicht klappen.

Wer sich ein wenig mit den Sx-Zuständen vertraut gemacht hat (habe ich oben schon einmal empfohlen, iirc), der erwartet zunächst mal auch nur, daß der PC sich aus S2 oder S3 wieder aufwecken läßt durch "Wake over LAN" ... alles andere darüber hinaus, wäre reine "Zugabe" (bei S4) und bei S5 ohne BIOS-Unterstützung (und das meint nicht nur die "generelle Freigabe" des WoL, wie im zweiten Bild irgendwo weiter vorne) auch nicht möglich.

Leider gibt es immer noch zuviele fehlerhafte ACPI-Implementierungen in den verschiedensten BIOS-Versionen - wenn das Aufwecken aus S4 nicht funktioniert, ist daran aber das jeweilige Gerät schuld und nicht der Router ... und damit auch nicht AVM, was die "Beschimpfungen" in #19 einigermaßen unsinnig erscheinen läßt - zumindest richten sie sich an den falschen Adressaten.

Aber nicht zuletzt sind auch immer wieder falsche Einstellungen durch die Benutzer (u.a. auch bei solchen, die sie eben nicht richtig verstehen, wie (mit hoher Wahrscheinlichkeit) die Einstellung im ersten Bild weiter oben für das verwendete UEFI-BIOS) daran schuld, wenn sich solche "zeitabhängigen" Probleme ergeben.

Wenn ich mein System so konfiguriere, daß es nach 30 Minuten in den S3-Zustand wechselt (das wäre "Suspend to RAM", im Windows auch "Sleep" genannt - nicht mit S1 zu verwechseln), dann wird das bei den meisten Geräten (zumindest bei vielen) auch mit dem Aufwachen nach diesen 30 Minuten noch funktionieren (vorausgesetzt, ich habe auch noch den richtigen Geräten erlaubt, das System aus einem Energiesparzustand zu holen).

Wenn aber gleichzeitig noch der Wechsel nach S4 (Suspend to Disk - im Windows auch "Hibernate" (bzw. "Ruhezustand") genannt) nach einer weiteren Zeitspanne konfiguriert ist (nehmen wir mal 60 Minuten dafür an) und das System sich so weit herunterfährt, dann muß das BIOS (und das ACPI gehört zum BIOS, wenn auch zum "unsichtbaren" Teil) auch in der Lage sein, das System für das Aufwachen aus S4 korrekt zu konfigurieren, wenn es nach diesen 60 Minuten geweckt werden soll.

Wer also Probleme wie die hier oben beschriebenen hat, der sollte zunächst mal bei sich selbst suchen und nicht immer zuerst bei anderen ... wenn das Aufwachen aus S3 sauber funktioniert und aus S4 dann nicht mehr, muß man eben den Wechsel nach S4 verhindern ... selbst wenn das ein wenig mehr Energie im "Bereitschaftsmodus" verbraucht. .Wer das nicht will, muß sich eben die richtige Hardware zulegen und zwar eine, bei der das BIOS bereits in der Lage ist, selbst einen Start aus S5 zu garantieren (und zwar über ein WoL-Paket und nicht nur über den Taster). Da muß dann eben die gesamte Hardware für ausgelegt sein - üblicherweise hat ausgewiesene "Business-Hardware" die entsprechenden Funktionen, damit Updates und Backups zentral und außerhalb der Arbeitszeit ausgeführt werden können.

Wie das eigene System sich in den verschiedenen Stromsparzuständen verhält, kann man jederzeit mit einem anderen Gerät in seinem eigenen LAN überprüfen ... wenn es auch anderen Geräten nicht gelingt, ein System aus S5 (oder selbst aus S4) per WoL zu starten, kann man wohl kaum erwarten, daß dieses dann der FRITZ!Box auf irgendeine magische Art und Weise doch noch gelingt. Erst dann, wenn so ein System nachweislich von einem anderen Gerät per WoL gestartet oder aufgeweckt werden kann und von der FRITZ!Box hingegen nicht (und hier rede ich vom "Computer starten"-Button und nicht der Automatik), dann ist der Zeitpunkt gekommen, die Schuld bei der FRITZ!Box zu suchen und sich das Ganze genauer anzusehen.

======================================================================================

AVM hat schon so manches Mal auch die WoL-Funktion "versaut" ... es ist also denkbar, daß es in einigen FRITZ!OS-Versionen tatsächlich gar nicht funktioniert. Aber für ein "geht ... geht nicht ... geht ... geht nicht" mit ein und derselben Version sollte es schon eine (am besten auch noch plausible) Erklärung geben.

Mindestens über den "Computer starten"-Button sollte sich eigentlich immer ein WoL-Paket erzeugen lassen (das kann man ja jederzeit selbst mit einem Paketmitschnitt überprüfen) ... die "Automatik" zum Wecken eines Gerätes ist sicherlich deutlich fragiler und am Ende ja eigentlich auch eher ein "Bonus" als Zusatzfunktion. Wenn das dann (meist durch Änderungen am Packet-Accelerator (PA) - also an der Art und Weise, wie Pakete "in Hardware" durch die Box geschleust werden, ohne die (schwache) CPU der Box damit zu belasten) mal nicht funktioniert, ist das zwar auch ärgerlich, aber noch lange kein Grund zum "Ausrasten".

Man darf eben nicht vergessen, daß üblicherweise für freigegebene Geräte "feste Regeln" in den Hardware-Tabellen hinterlegt werden, welche Pakete durchgereicht werden sollen und welche nicht. Werden diese weitergeleitet, erfolgt das i.d.R. direkt an das Gerät und die CPU sieht davon gar nichts ... ebenso gilt das (bei aktivem PA) für die abgewiesenen Pakete. Wenn jedes von extern ankommende Paket, das eigentlich gar nicht "angefordert" wurde (also keine Antwort im Rahmen einer ausgehenden Verbindung ist), erst durch den Flaschenhals zwischen dem (internen) Switch und der CPU müßte, wäre es sehr einfach, eine FRITZ!Box zu überlasten (an einem Anschluß mit entsprechenden Datenraten).

Wenn man jetzt ein Netzwerkgerät bei eingehendem Verkehr automatisch wecken lassen will, muß ja irgendjemand das dazu notwendige Netzwerkpaket (als "magic packet") erst mal erzeugen ... das wird i.d.R. die CPU sein (ich kenne jedenfalls keine Spezifikation für ein Router-SoC, wo das eine Hardware-Funktion ist - Gegenbeispiele nehme ich aber gerne). Dazu muß diese aber erst mal davon in Kenntnis gesetzt werden, daß jetzt ein Zugriff auf ein solches Gerät erfolgen soll ... die (eingehenden) Pakete müssen also (immer noch unter der Annahme, daß der PA eingeschaltet ist) mindestens mal zur CPU gespiegelt werden, damit diese davon Kenntnis erhält.

Im schlechtesten Fall benutzt man dann für eingehende Verbindungen zu einem solchen Gerät den PA gar nicht mehr, damit müßte dann JEDES Paket in dieser Verbindung durch die CPU, was den Durchsatz entsprechend niedrig hält. Im besten Fall programmiert das FRITZ!OS eine direkte Weiterleitung der Pakete mit Spiegelung an die CPU nur dann, wenn es davon ausgeht, daß das betreffende Netzwerkgerät ein "magic packet" braucht, um wieder seine Arbeit aufzunehmen und schaltet dann (wenn das Gerät wieder läuft) die Spiegelung zur CPU (aus Performance-Gründen) wieder ab, solange das Gerät arbeitet.

Hier ist die Behandlung von TCP-Verbindungen natürlich wieder leichter, wenn man davon ausgeht, daß das Gerät beim "Schlafengehen" zuvor alle offenen TCP-Verbindungen sauber beendet und damit auch der Router mitbekommt, daß das Gerät jetzt keine aktiven Verbindungen mehr hat und man bei der nächsten eingehenden Verbindung (schon "prophylaktisch" bei einem SYN-Paket) ein WoL-Paket vorausschicken sollte. Bei UDP kann man das nur mit entsprechenden "Timeouts" machen (wenn für eine bestimmte Zeit keine Daten mehr in dieser Verbindung transportiert wurden, wird sie als "beendet" angesehen), weil es dort keine explizite "Beendigung" einer Verbindung gibt (ja, eigentlich gibt es nicht mal "Verbindungen" dort). Bei UDP müßte man also wieder alle Pakete durch die CPU leiten oder zumindest zu ihr spiegeln, weil es ein spezifisches Merkmal wie das SYN-Flag beim TCP für eine "neue" Verbindung gar nicht gibt. Hier wären also UDP und TCP auch wieder getrennt zu behandeln.

Beim Aufwecken über den "Computer starten"-Button ist das alles wieder einfacher ... erstens hat man einen eindeutigen Trigger (eben den Druck auf den Button) und zweitens wird dieser Trigger ohnehin auf der CPU verarbeitet - diese kann (und wird) hier also einfach das Paket zum Aufwecken erzeugen. Die Konditionen, wann man nun ein Paket zum "automatischen Wecken" senden sollte und wann nicht (es macht ja auch keinen Sinn, JEDES eingehende Paket mit einem zusätzlichen WoL-Paket zu versehen), sind eben deutlich komplizierter ... am sichersten dürfte das noch funktionieren, wenn man den PA generell abschaltet (sollte auf der Support-Seite ja möglich sein) - nur verliert man dadurch eben auch an Durchsatz, aber die CPU "sieht" damit auch jedes eingehende Paket.

Daß das mit dem PA generell nicht immer so ganz einfach ist, sieht man schon daran, daß immer wieder mal Probleme auftauchen in der Firmware, die mit diesem in Verbindung stehen - auch die Tatsache, daß in Paketmitschnitten auf dem WAN-Interface gerne mal Daten fehlen, ist ja i.d.R. darauf zurückzuführen, daß entweder die Spiegelung zur CPU bei aktiviertem PA nicht eingeschaltet wurde oder daß der PA nicht (generell) abgeschaltet wurde und damit automatisch jedes Paket über die CPU muß.

Wer also die Ursache für nicht funktionierendes, automatisches Aufwecken in der FRITZ!Box suchen möchte, der sollte als Erstes mal den PA deaktivieren und prüfen, ob das Problem damit behoben ist. Das sollte zwar kein Dauerzustand sein, aber daß bei der Programmierung der (closed source-)Komponenten des AVM-WAN-Stacks auch gerne mal mit dem Gesäß etwas eingerissen wird, was zuvor mit den Händen aufgebaut wurde und funktioniert hat, ist ein offenes Geheimnis und (deutlich mehrfach) hier auch oft genug festgestellt im IPPF.

Zwar kennen wir alle den Quelltext für diese Komponente (dsld bzw. kdsldmod.ko) nicht, aber man kann schon anhand von alten Funktionsnamen in den (notwendigerweise) exportierten Symbolen darauf schließen, daß da jede Menge - teils uralter - Schrott mit "durchgezogen" wird und ich rate mal, daß jeder Software-Architekt einen Herzkasper kriegen würde, wenn er das zum ersten Mal sieht (und den Aspekt des "ist historisch gewachsen" nicht berücksichtigt). Aber AVM ist ja auch dort etwas am "Aufräumen" und "Entwirren", wie man schon daran sehen kann, daß jetzt das VPN in einen eigenen Daemon wandert.

========================================================================================

EDIT:
Wer sich noch einmal genauer mit den "Schlafzuständen" von Windows befassen und herausfinden will, was diese mit der Fähigkeit zum "Wake on LAN" zu tun haben, der kann ja mal diese Seite besuchen:


- da findet sich (am Ende) auch der Hinweis, daß ein Aufwachen aus S5 mit Windows nichts zu tun hat und nur Sache des BIOS/der Hardware ist.

Auch die Tatsache, daß "fast startup" (System wird neu gestartet und dann dieses "frisch gestartete System" als "Ruhezustand" gesichert beim "Herunterfahren" bzw. der Benutzer wird abgemeldet vor dem "Ruhezustand") unter Windows das ACPI so programmiert, daß ein WoL nicht möglich ist, kann man dort noch einmal nachlesen. Hier helfen also manchmal schon die richtigen Einstellungen unter Windows und das sind beileibe nicht immer die Standardeinstellungen - m.W. ist nämlich "fast startup" zumindest unter Windows 10 der Standard. Wie man das dann deaktiviert ("fast startup" oder auch "fast boot"), ist in diversen "Tipps" im Internet hinreichend beschrieben ... manchmal hilft schon diese "Kleinigkeit", damit ein System sich auch aus S4 starten läßt.
 
Zuletzt bearbeitet:

3CX PBX - GRATIS
Linux / Win / Cloud

Statistik des Forums

Themen
234,446
Beiträge
2,046,706
Mitglieder
354,217
Neuestes Mitglied
mcermak