S675 IP am Asterisk

DomRoc

Neuer User
Mitglied seit
2 Aug 2007
Beiträge
118
Punkte für Reaktionen
0
Punkte
0
Hallo,

habe gerade ein S675 IP zum Testen am Asterisk angemeldet. Im Prinzip verrichtet das Telefon seinen Dienst ja ganz ordentlich, aber etwas ist mir aufgefallen.
Wenn man zwei Telefonate gleichzeitig führt und die beiden Teilnehmer direkt verbinden will, dann kann ich das ja über die Optionstaste und dann "Anruf weiterleiten" tun.

Das ganze klappt auch, nur bekommt das Siemens Telefon nach ein paar Sekunden einen Rückruf und auf der CLI von Asterisk kommt folgende Meldung:
chan_sip.c:13896 handle_request_invite: Unable to create/find SIP channel for this INVITE

Wenn man den Rückruf annimmt passiert freilich nix, das "Gespräch" ist weg und das echte transferierte Gespräch läuft auch ohne Probleme weiter.

Woran könnte das denn liegen?


Grüße,
DomRoc
 

froeschi62

Neuer User
Mitglied seit
13 Okt 2006
Beiträge
115
Punkte für Reaktionen
0
Punkte
0
Hallo,

exakt das gleiche Problem habe ich mit dem Siemens an meiner Lancom TK-Anlage. Auch das Verbinden funktioniert bei mir einwandfrei aber anschließend bekomme ich diesen Rückruf.

Gruß
Dietmar
 
Zuletzt bearbeitet:

mario2006

Mitglied
Mitglied seit
25 Nov 2006
Beiträge
294
Punkte für Reaktionen
0
Punkte
0
Testbericht von Bin-wech zum S675IP

Hallo,

ich hatte vorgestern mein S675IP an meine Asterisk angeschlossen, diese befindet sich im LAN wie das Siemens. Zitat von bin-wech
Hier stellte ich dann entsetzt fest, dass sich zwei von vier Voip-Nummer abgemeldet hatten. Hier stand auf einmal statt Angemeldet - Anmeldung fehlgeschlagen. Nach mehrmaligem Bearbeiten-Sichern und Aktivieren-Deaktivieren des jeweiligen Eintrages war dieser dann wieder angemeldet. Auch einen Tag später war eine Voip-Nummer wieder abgemeldet.
Woran dies lag kann ich nicht genau sagen. Evtl. lag es an 1und1.
Genau das gleiche Problem habe ich auch an der Asterisk. Ich habe auch kein Zugriff mehr auf das Webinterface, muß dies Stromlos machen, erst dann meldet sich das S675IP wieder am Asterisk an.

Wie ist Eure Konfig? Im Grunde kann man gar nichts falsch machen.

Gruß Mario
 

DomRoc

Neuer User
Mitglied seit
2 Aug 2007
Beiträge
118
Punkte für Reaktionen
0
Punkte
0
Hi Mario,

Mehrfachanmeldung hab ich noch garnicht getestet, aber wenn es hier auch Probleme gibt, dann sollte Siemens wohl erstmal die Firmware ordentlich hinbekommen bevor man die Geräte verkauft!

Vom Siemens Support hab ich seit Tagen nichts gehört wegen dem Rückrufproblem beim Transfer...

Grüße,
DomRoc
 

mario2006

Mitglied
Mitglied seit
25 Nov 2006
Beiträge
294
Punkte für Reaktionen
0
Punkte
0
Hallo,

ich hatte mich bereits an den Siemens Support gewandt. Dieser teilte mir mit, daß alle Einstellungen am Asterisk und in der Basisstation richtig seinen und daß bald eine neue FW bereit gestellt wird.

Hier die Antwort:

Originalnachricht folgt:
------------------------
Hallo Herr xxxxxx,

was heißt in Kürze erscheint eine neue Firmware version?

Ab wann ist diese verfügbar?

Haben Sie vielleicht eine Beta für mich?

Viele Grüße
xxxxxxx
Sehr geehrter Herr xxxxx,

vielen Dank für Ihre Information.

Die neue Firmware ist für Kalenderwoche 50 avisiert.

Wir wünschen Ihnen eine schöne Woche.

Mit freundlichen Grüßen

Christian Wxxxxx
Siemens Customer Care Center
 

froeschi62

Neuer User
Mitglied seit
13 Okt 2006
Beiträge
115
Punkte für Reaktionen
0
Punkte
0
Mario2006, Du hast ein Registrierungsproblem, was aber eigentlich nicht Thema dieses Threads ist. Wir haben das Wiederanrufproblem nach einem Gesprächstransfer. Also 2 verschiedene Dinge! Ob die neue Firmware auch den nervigen Wiederanruf eleminiert, bleibt abzuwarten.

Gruß
Dietmar
 

froeschi62

Neuer User
Mitglied seit
13 Okt 2006
Beiträge
115
Punkte für Reaktionen
0
Punkte
0
Hi,

leider ist der nervige Rückruf auch mit der neuen Siemensfirmware 97 nicht behoben.

Gruß
Dietmar
 

DomRoc

Neuer User
Mitglied seit
2 Aug 2007
Beiträge
118
Punkte für Reaktionen
0
Punkte
0
Hi,

leider ist der nervige Rückruf auch mit der neuen Siemensfirmware 97 nicht behoben.

Gruß
Dietmar

Hallo,

habs auch gleich getestet heute morgen und bin auch schwer enttäuscht. Der Rückruf aus dem Nirvana nach der Gesprächsübergabe kommt immernoch!

Zudem habe ich jetzt mal global canreinvite=no gesetzt, da mir während des Testens ab und an die (reinen SIP-)Verbindungen einfach weggebrochen sind. Ist wohl besser der Asterisk managet das ganze!


Gesamtfazit für das Siemens bislang:
Es hat sich nicht gerade mit Ruhm bekleckert, aber in dieser Preisklasse muss man wohl damit und mit den restlichen Einschränkungen leben!


Grüße,
DomRoc
 

DomRoc

Neuer User
Mitglied seit
2 Aug 2007
Beiträge
118
Punkte für Reaktionen
0
Punkte
0
Hallo,

wie schaut's denn bei Euch so aus? Die 97er Firmware hat ja keine Besserung gebracht. Seit Ihr auch noch von dem Problem betroffen?

Hier ist mal das per SIP-Debug mitgeloggte Trauerspiel mit dem unnützen SIP-Invite:

Code:
<--- SIP read from 192.168.67.81:5060 --->
INVITE sip:%[email protected] SIP/2.0
Via: SIP/2.0/UDP 192.168.67.81:5060;branch=z9hG4bK3fd0c03d4556d89d1f8bf1af11b69a64;rport
From: "Chef" <sip:[email protected]>;tag=305118504
To: <sip:%[email protected]>;tag=as75517b90
Call-ID: [email protected]_168_67_81
CSeq: 6 INVITE
Contact: <sip:[email protected]:5060>
Proxy-Authorization: Digest username="6343", realm="asterisk", algorithm=MD5, uri="sip:%[email protected]", nonce="4c366e4a", response="70540311b659943924f9cc477665cf38"
Max-Forwards: 70
User-Agent: S675IP020970000000
Supported: replaces
Allow: INVITE, ACK, CANCEL, BYE, OPTIONS, INFO, REFER, SUBSCRIBE, NOTIFY
Content-Type: application/sdp
Content-Length: 180

v=0
o=6343 5004 79 IN IP4 192.168.67.81
s=-
c=IN IP4 192.168.67.81
t=0 0
m=audio 5004 RTP/AVP 8 101
a=rtpmap:8 PCMA/8000
a=rtpmap:101 telephone-event/8000
a=fmtp:101 0-16

<------------->
--- (14 headers 9 lines) ---
Sending to 192.168.67.81 : 5060 (NAT)
Using INVITE request as basis request - [email protected]_168_67_81
[Mar  6 15:33:38] NOTICE[4391]: chan_sip.c:14086 handle_request_invite: Unable to create/find SIP channel for this INVITE
TK1-W*CLI>
<--- Reliably Transmitting (NAT) to 192.168.67.81:5060 --->
SIP/2.0 503 Unavailable
Via: SIP/2.0/UDP 192.168.67.81:5060;branch=z9hG4bK3fd0c03d4556d89d1f8bf1af11b69a64;received=192.168.67.81;rport=5060
From: "Chef" <sip:[email protected]>;tag=305118504
To: <sip:%[email protected]>;tag=as75517b90
Call-ID: [email protected]_168_67_81
CSeq: 6 INVITE
User-Agent: Asterisk PBX
Allow: INVITE, ACK, CANCEL, OPTIONS, BYE, REFER, SUBSCRIBE, NOTIFY
Supported: replaces
Contact: <sip:%[email protected]>
Content-Length: 0


<------------>
Scheduling destruction of SIP dialog '[email protected]_168_67_81' in 32000 ms (Method: INVITE)
TK1-W*CLI>
<--- SIP read from 192.168.67.81:5060 --->
ACK sip:%[email protected] SIP/2.0
Via: SIP/2.0/UDP 192.168.67.81:5060;branch=z9hG4bK3fd0c03d4556d89d1f8bf1af11b69a64;rport
From: "Chef" <sip:[email protected]>;tag=305118504
To: <sip:%[email protected]>;tag=as75517b90
Call-ID: [email protected]_168_67_81
CSeq: 6 ACK
Contact: <sip:[email protected]:5060>
Proxy-Authorization: Digest username="6343", realm="asterisk", algorithm=MD5, uri="sip:%[email protected]", nonce="4c366e4a", response="70540311b659943924f9cc477665cf38"
Max-Forwards: 70
User-Agent: S675IP020970000000
Content-Length: 0


<------------->
--- (11 headers 0 lines) ---
TK1-W*CLI>
<--- SIP read from 192.168.67.81:5060 --->
BYE sip:%[email protected] SIP/2.0
Via: SIP/2.0/UDP 192.168.67.81:5060;branch=z9hG4bK731719b27c7398508f4009437e7f481e;rport
From: "Chef" <sip:[email protected]>;tag=305118504
To: <sip:%[email protected]>;tag=as75517b90
Call-ID: [email protected]_168_67_81
CSeq: 7 BYE
Contact: <sip:[email protected]:5060>
Proxy-Authorization: Digest username="6343", realm="asterisk", algorithm=MD5, uri="sip:%[email protected]", nonce="4c366e4a", response="4ac314a89dbfd1882260e8b3e1639618"
Max-Forwards: 70
User-Agent: S675IP020970000000
Content-Length: 0


<------------->
--- (11 headers 0 lines) ---
Sending to 192.168.67.81 : 5060 (NAT)
Scheduling destruction of SIP dialog '[email protected]_168_67_81' in 32000 ms (Method: BYE)

<--- Transmitting (NAT) to 192.168.67.81:5060 --->
SIP/2.0 200 OK
Via: SIP/2.0/UDP 192.168.67.81:5060;branch=z9hG4bK731719b27c7398508f4009437e7f481e;received=192.168.67.81;rport=5060
From: "Chef" <sip:[email protected]>;tag=305118504
To: <sip:%[email protected]>;tag=as75517b90
Call-ID: [email protected]_168_67_81
CSeq: 7 BYE
User-Agent: Asterisk PBX
Allow: INVITE, ACK, CANCEL, OPTIONS, BYE, REFER, SUBSCRIBE, NOTIFY
Supported: replaces
Contact: <sip:%[email protected]>
Content-Length: 0


<------------>
TK1-W*CLI>
Asterisk-Server und alle Basisstationen/Telefone befindet sich übrigens im gleichen Subnet 192.168.67.0/24. Das "%23" das manchmal vorkommt ist übrigens die Raute "#", damit hatte ich heute auch schon diverse Probleme...

Kann man das evtl. doch irgendwie selbst in den Griff bekommen, z.B. durch irgendwelche Einstellungen? Siemens scheint nicht sonderlich fix zu sein bei der Behebung dieses Problems!

Schöne Grüße,
DomRoc
 

cibi

Mitglied
Mitglied seit
6 Apr 2005
Beiträge
561
Punkte für Reaktionen
0
Punkte
0
Das Problem mit dem Phantom Anruf habe ich auch mit einem nagelneuen S685IP.
(FW im Webinterface: 020970000000 / 043.00 )

%23 bei #: Eventuell wie bei den SNOMs:
http://www.ip-phone-forum.de/showthread.php?t=111776

Edit: Ich habe gerade eben eine Anfrage an den Siemens Support gestellt.
Das Problem ist recht nervig.
 
Zuletzt bearbeitet:

mario2006

Mitglied
Mitglied seit
25 Nov 2006
Beiträge
294
Punkte für Reaktionen
0
Punkte
0
Ich habe mein IP675 Siemens Telefon zwischenzeitlich verschenkt. Hatte zig mal Kontakt mit dem Support per mail. Letztes war, ich solle die Basistation einsenden zur Überprüfung. Die kam zurück mit einem anschreiben, daß alles in Ordnung sei. Funktionierte dann immer noch nicht.

Habe mir ein Snom M3 zugelegt, das funktioniert tadellos am Asterisk. Ich bin für alles offen, aber nie wieder Siemens!

Grüße
Mario

Hier noch die mail, das war im Dezember 2007

Sehr geehrter Herr XXXX,

vielen Dank für Ihre Information.

Bitte senden Sie nur die Basis, ohne Zubehör, mit einer Kopie des Kaufbeleges an:

Siemens
Service Deutschland
Schlavenhorst 66
46395 Bocholt

Wir wünschen Ihnen eine schöne Woche.

Mit freundlichen Grüßen

XXX
Siemens Customer Care Center

Classic Line 0180 5 333 220 (0,14 EUR/Min aus dem Festnetz der Deutschen Telekom. Für Anrufe aus den Mobilfunknetzen können abweichende Preise gelten.)

Premium Line 0900 1 745 820 (1,24 EUR/Min aus dem Festnetz der Deutschen Telekom. Für Anrufe aus den Mobilfunknetzen können abweichende Preise gelten.)

(Montag ? Freitag: 8:00 Uhr ? 20:00 Uhr, Samstag: 8:00 Uhr ? 16:00 Uhr)

E-Mail: [email protected]
Website: http://gigaset.siemens.com
 

Jirka

Mitglied
Mitglied seit
25 Apr 2008
Beiträge
543
Punkte für Reaktionen
2
Punkte
18
Hallo zusammen,

Das Problem mit dem Phantom Anruf habe ich auch mit einem nagelneuen S685IP.
Ja, andere (mich eingeschlossen) scheinbar auch.

Edit: Ich habe gerade eben eine Anfrage an den Siemens Support gestellt.
Hältst Du uns bitte auf dem Laufenden, wenn es diesbezüglich Statements gibt? Und verweist den Siemens-Support ggf. auf meinen nachfolgend angegebenen SIP-Trace? Vielen Dank!

Ich habe mein IP675 Siemens Telefon zwischenzeitlich verschenkt.
...ich hätte es Dir gerne für 50 EUR abgekauft!

Habe mir ein Snom M3 zugelegt, das funktioniert tadellos am Asterisk.
Zu dem snom m3 gab es hier im Forum aber schon sehr viel negative Bemerkungen. Es käme nicht annähernd an schnurgebundene snom-Telefone ran und so weiter. (z. B. http://www.ip-phone-forum.de/showthread.php?t=155537)
Ich habe hier einiges gelesen, um mich zwischen Gigaset IP-Telefon und snom m3 zu entscheiden. Prinzipiell gefällt mir der Ansatz beim snom m3 sogar besser: 3 IP-Gespräche gleichzeitig möglich und kein analoger Festnetzanschluss. Aber die besseren Detaillösungen hat Siemens. Und bis auf wenige Bugs und einigen Feature-Wünschen (http://www.ip-phone-forum.de/showthread.php?t=165266) bin ich eigentlich ganz zufrieden.


So, nun zum Thema Wiederanruf (Phantom-Anruf) nach Gesprächsübergabe am Gigaset.

Sollte es jemanden geben, der den Fall genauer untersuchen würde/möchte/könnte, biete ich hiermit meine Mithilfe in Form von Traces aller Art an.

Hier http://www.lancom-forum.de/lancom-systems-voip-router-f42/gigaset-c475ip-verbinden-t7301.html#p41889 findet sich ein kommentierter SIP-Trace, den ich gestern gemacht habe und heute zu dem Problem gepostet habe. Damit müßte man die Ursache evt. leichter feststellen können.

Viele Grüße,
Jirka
 
Zuletzt bearbeitet:

DomRoc

Neuer User
Mitglied seit
2 Aug 2007
Beiträge
118
Punkte für Reaktionen
0
Punkte
0
Hallo,

vor ein paar Monaten hatte mir der Siemens Support den Bug bestätigt. Einen SIP-Trace habe die damals von mir auch bekommen. Angeblich wird seitdem an einer neuen Firmware gearbeitet. Aber da es bislang keine neue Version gibt, kann man die Support-Aussagen eigentlich als reine Beschwichtigung abtun. Anscheinend hat man es bei Siemens nicht nötigt sich um seine Kunden richtig zu kümmern, Hauptsache das produkt ist erst einmal verkauft.
Da stellt sich natürlich auch die Frage, ob das SNOM M3 nicht die bessere Wahl gewesen wäre. Schlechter als das Siemens geht ja kaum noch!

Grüße,
DomRoc
 

cibi

Mitglied
Mitglied seit
6 Apr 2005
Beiträge
561
Punkte für Reaktionen
0
Punkte
0
Ein klein wenig Hoffnung hatte ich...
Wie von meinem Kollegen mitgeteilt, wird es eine neue Firmware geben, die Ihr Anliegen behebt. Uns liegen noch keine Informationen vor, wann eine neue Firmware zur Verfügung gestellt wird.
... aber das hört sich nicht gut an, wenn das die Standardantwort seit Monaten ist.
Warum so ein fataler Fehler nicht behoben wird ist für mich unverständlich :sad:

Schade, denn eigentlich ist das S6x5IP ein gutes Telefon/Basis, wären da nur nicht diese nervigen Kleinigkeiten...
 

cibi

Mitglied
Mitglied seit
6 Apr 2005
Beiträge
561
Punkte für Reaktionen
0
Punkte
0
Auf der Siemens Gigaset Seite wird ein FW Update gelistet:

Readme
Gigaset C470 IP, C475 IP, S675 IP and S685 IP

Firmware Update 07/2008 Version V02123:
---------------------------------------

New Features:
- Compatibility with A58H and C38H Handsets (including Infoscreensaver as Liveticker)
- New languages: Brazilian Portuguese, Russian (country and handset dependent)
- BEL, NLD: Autoconfigurationcode-enquiry added in the Handset's connection assistant


Improvements:

- NAT Traversal improved
- STUN can be disabled for Gigaset.net
- Email-Notification: display of date and subject improved, lenght of Email address up to 74 characters
- Display IP-Address without leading "0"s during the paging call
- Entries out of the calls list will be fully copied into the telephone directory, if the name was displayed from online phonebook.
- Web configurator: does not show "********" for empty password
- SMS Status Report function improved
- SIP Protocol implementation improved
- Incorrect recall after a successful call transfer fixed

- Display Scandinavian characters
- Answering machine functionality improved
Das sollte (eventuell) das Problem lösen - ich konnte es aber noch nicht testen, da mein S685IP noch kein Update findet.

Update:
FW mittlerweile verfügbar, Rückrufproblem scheint (kurzer Test) gelöst zu sein.
 
Zuletzt bearbeitet:

Jirka

Mitglied
Mitglied seit
25 Apr 2008
Beiträge
543
Punkte für Reaktionen
2
Punkte
18
Hallo cibi,

vielen Dank für die Nachricht!
Ich kann ebenfalls bestätigen, dass das Problem damit behoben ist!

Habe mehrmals probiert das Firmware-Update runterzuladen - vor einer Stunde hat es dann geklappt und dann habe ich es auch gleich ausprobiert.

Neue Features sind ja nicht wirklich dabei - schade.

Viele Grüße,
Jirka
 

Macro

Neuer User
Mitglied seit
23 Okt 2004
Beiträge
76
Punkte für Reaktionen
0
Punkte
6
Nun Bugfixes sind ja fast wichtiger weder neue Features.

Gruss Macro
 

detejo

Mitglied
Mitglied seit
17 Jul 2006
Beiträge
502
Punkte für Reaktionen
0
Punkte
0
dauert die Benachrichtigung (MWI) bei euch auch so lange?
Das Symbol kommt zwar immer irgendwann - aber ob nach 2 Minuten oder 1,5 Stunden scheint Glückssache zu sein.
 

Jirka

Mitglied
Mitglied seit
25 Apr 2008
Beiträge
543
Punkte für Reaktionen
2
Punkte
18

detejo

Mitglied
Mitglied seit
17 Jul 2006
Beiträge
502
Punkte für Reaktionen
0
Punkte
0
das S675 IP ist an einer SIP-mailbox angemeldet (Subscribe). ich spreche testweise etwas auf.
Bis dann die neue Nachricht am Gerät angezeigt wird (MWI), blinkende Mailbox-Leuchte, vergehen zwischen 2 Minuten und bis zu 3 Stunden.
Warum es mal schneller geht und mal langsamer, ist unklar - eigentlich erwarte ich, dass die Leuchte sofort blinkt, wenn eine neue Nachricht da ist.

Nachtrag: falls dies bei jemandem anders ist, dann wäre interessant, welcher Software am anderen Ende werkelt, also Asterisk-Version, Konfiguration o.ä.

Nachtrag #2: es ist ein * BUG:

http://bugs.digium.com/view.php?id=12828

Workaround:

Code:
qualify=no
im entsprechenden Abschnitt der sip.conf für das S675 IP
 
Zuletzt bearbeitet:
3CX

Statistik des Forums

Themen
235,334
Beiträge
2,059,474
Mitglieder
355,968
Neuestes Mitglied
Bilderpaul