Snom M900 Multizelle SIP Anrufprobleme

bigmag62

Neuer User
Mitglied seit
22 Jul 2021
Beiträge
4
Punkte für Reaktionen
0
Punkte
1
Hallo Zusammen

ich habe eine Snom Multizelle mit 3 x DECT Station M900 in Serie (1=Primär, 2=Ebene 1, 3=Ebene 2 mit Abständen von je ca 60 - 70 m und Sichtverbindung) aufgebaut. Dazu 6 x Snom M80 mit je einem SIP Account von einem 3CX Server.
die DECT Signale zwischen den 3 DECT Stations: 1 zu 2 = -60dBm // 2 zu 3 = -62dBm // 1 zu 3 = je nach Wetter -80dBm oder ꝏ, die 3 Station sind auf einer Linie

Mein Problem ist nun, wenn alle Mobiles M80 an der Primär Station (1) angemeldet sind, funktioniert alles einwandfrei, sobald ich mit einem Mobile herumlaufe und mich längere Zeit bei einer anderen DECT Station als der primären (Ebene 1 oder Ebene 2)aufhalte, so wird der SIP Identitätsstatus auf die verbunden DECT Station verschoben und es kommen keine eingehende SIP Telefonate mehr rein, gehe ich wieder zur Basis Station zurück, bleibt der SIP Identitätsstatus für gefühlte 60 Minuten "kleben" und sobald die SIP Identitätsstatus wieder auf der Primär DECT Station ist funktioniert alles wieder.
Ausgehende SIP Telefonate und die Push to Talk Funktion gehen immer.

Kann ich die SIP Accounts auf der Primär Station fixieren oder so?

Vielen Dank für eure Hilfe...
 
Zuletzt bearbeitet:

sonyKatze

IPPF-Promi
Mitglied seit
6 Aug 2009
Beiträge
3,561
Punkte für Reaktionen
330
Punkte
83
Hast Du Dir das SIP-Log bereits angeschaut (oder noch besser den Datenverkehr einmal im WAN und einmal im LAN mitgeschnitten)? Klingt so, als hätte Deine Firewall nicht mitbekommen, dass sie die Anrufe nach einem Basis-Wechsel weiterhin durchzulassen hat. Daher: Welche Firewall nutzt Du? Wenn Du an deren WAN und an deren LAN den Datenverkehr mitschneiden könntest, dann würdest Du Wireshark damit füttern und wir könnten gemeinsam nachschauen, was genau passiert bzw. passieren sollte.
 

bigmag62

Neuer User
Mitglied seit
22 Jul 2021
Beiträge
4
Punkte für Reaktionen
0
Punkte
1
Vollzitat von darüber gemäß Boardregeln entfernt by stoney
Hallo sonyKatze
vielen Dank für dein Feedback, das SIP log sagt, dass der Anruf bei der 1.DECT Station reinkommt (wo das Mobile gerade war), aber der SIP Identitätsstatus des angerufenen SIP Account ist in diesem Moment auf einer anderen DECT Station da er gerade gewechselt hat, mache ich nun einen SIP Anruf, dann funktioniert es oder wenn ich einige Zeit warte (ca 15-45 min - sehr unterschiedlich), dann funktioniert es auch irgendwann wieder, bis wieder der SIP Identitätsstatus wechselt, dann geht das Spiel wieder von vorne los.
Ich habe die Multizelle auch mal von DECT Sync auf LAN sync umgestellt, keine Besserung.

Kann man der Multizelle nicht sagen, dass die SIP Account z.B. immer auf der Primären DECT Station bleiben sollen, denn ich habe festgestellt, dass der SIP Identitätsstatus der Mobiles den Wechsel nicht sofort vollziehen und solange funktioniert es auch, das Mobile hat die DECT Verbindung sofort wechselt.
 
Zuletzt bearbeitet von einem Moderator:

sonyKatze

IPPF-Promi
Mitglied seit
6 Aug 2009
Beiträge
3,561
Punkte für Reaktionen
330
Punkte
83
Ich meinte mit dem SIP-Log die SIP-Nachrichten an sich, also die REGISTER und die INVITE. Wir müssten schauen, ob die INVITEs dort ankommen, wo sie sollen. Und dann überprüfen, warum vielleicht nicht. Normal ist nämlich, das Registrierung mitzieht, weil eine Zelle nicht viele Registrierungen fahren kann. Also ist das etwas, was zu funktionieren hat. Klar, in Deinem Fall hast Du gar nicht soviele Registrierungen und Du willst es so herum beheben. Aber was ich meine: Eigentlich müsste es tun. Die Frage ist, warum es in Deinem Szenario nicht tut.
 

bigmag62

Neuer User
Mitglied seit
22 Jul 2021
Beiträge
4
Punkte für Reaktionen
0
Punkte
1
Vollzitat von darüber gemäß Boardregeln entfernt by stoney
Hallo sonyKatze
erstmals vielen Dank für deine Hilfe,
ich konnte den "Sündenbock" herausfinden, es ist die Firewall Ubiquiti Dream Machine Pro (UDMpro -- Conntrack Moduls =SIP + H.323 disable).
Ich habe eine Testumgebung aufgebaut mit 1x UDM Pro, 2x Snom M700, 2x Snom M80 + Computer mit Wireshark und eigenem externen 3CX Server
Bei meiner Snom DECT Station Multizelle ist default eingestellt, dass die SIP Accounts mit dem DECT Signal zur verbundenen DECT Station wechselt, dies wird auch sofort an den externen 3CX Server übermittelt und korrekt angezeigt, nur irgendwie kriegt das die Firewall UDMPro nicht mit und blockt alle einkommenden Pakete zu dem gerade gewechselt SIP Account und dies für unbestimmte Zeit, irgendwann geht es dann plötzlich wieder.
Nach meinen Recherchen habe ich festgestellt, dass dieses UDM Pro "VOIP Problem" schon einige festgestellt habe, aber ich habe dazu keine Lösung von Seiten Ubiquiti gefunden, die meisten haben die Firewall gewechselt oder für VOIP ein eigenes Gateway mit anderer Firewall als Ubiquiti.
Ich habe danach mit einer Fortigate Firewall anstelle der UDM pro getestet und es funktionierte immer, mit Wireshark konnte ich dann die ganz Sache analysieren unter anderem wurde der RTP Stream geblockt

Zwischenzeitlich habe ich die Snom DECT Multizelle die "Server" Einstellungen "Use One TCP Connection per SIP Extension" auf aktiv gesetzt, so bleiben die SIP Accounts "kleben", dies bis es eine Lösung von Ubiquiti gibt, die funktioniert...
 
Zuletzt bearbeitet von einem Moderator:

sonyKatze

IPPF-Promi
Mitglied seit
6 Aug 2009
Beiträge
3,561
Punkte für Reaktionen
330
Punkte
83
Ja, Du musst dann die UDM Pro „debuggen“. 3CX kann SIP-over-TLS. Probiere mal das. In solch einen Datenstrom kann die UDM Pro nicht hineinschauen. Wenn es dann immer noch hakt, sind vielleicht die NAT-Bindings zu kurz. Mehr dazu hier …
 

bigmag62

Neuer User
Mitglied seit
22 Jul 2021
Beiträge
4
Punkte für Reaktionen
0
Punkte
1
Ja, Du musst dann die UDM Pro „debuggen“. 3CX kann SIP-over-TLS. Probiere mal das. In solch einen Datenstrom kann die UDM Pro nicht hineinschauen. Wenn es dann immer noch hakt, sind vielleicht die NAT-Bindings zu kurz. Mehr dazu hier …
Wir haben den 3CX Server mit 300 Telefonnummer als Dienst "eingekauft" und keinen Admin Zugang zum 3CX Server, die technische Unterstützung ist und war bis anhin sehr mager, leider haben wir noch eine vertragliche Verpflichtung und können nicht schnell zu einem anderen Anbieter wechseln. In der Zwischenzeit konnte ich es etwas eleganter mit einem 3CX SBC lösen, ohne die "arme" Snom Multizelle zu verbiegen :)
 

sonyKatze

IPPF-Promi
Mitglied seit
6 Aug 2009
Beiträge
3,561
Punkte für Reaktionen
330
Punkte
83
Vermutlich ist egal, ob 3CX oder nicht. Dann känntest Du auch mal einen Zugang bei DUStel, Easybell oder Sipgate bestellen. Mit UDP anfangen, TCP testen und dann TLS probieren. Wenn sich das Verhalten zwischen TCP und TLS gravierend ändert, schnüffelt die Firewall noch in die Datenpakete. Ich selbst habe keine UDM Pro hier, um konkret zu helfen. Wir hatten mal einen Thread, indem wir ein wenig weiter gekommen sind … nur finde ich den auf die Schnelle nicht.
 

Erhalten Sie 3CX für 1 Jahr kostenlos!

Gehostet, in Ihrer privaten Cloud oder on-Premise! Ganz ohne Haken. Geben Sie Ihren Namen und Ihre E-Mail an und los geht´s:

3CX
Für diese E-Mail-Adresse besteht bereits ein 3CX-Konto. Sie werden zum Kundenportal weitergeleitet, wo Sie sich anmelden oder Ihr Passwort zurücksetzen können, falls Sie dieses vergessen haben.
oder via