[Problem] Speedport2Fritz ( mit Freetz) --> Skript läuft nicht sauber durch

Tecnetium

Neuer User
Mitglied seit
19 Jun 2010
Beiträge
23
Punkte für Reaktionen
0
Punkte
0
Hallo,

habe vor ca. 6 Monaten meinen W920 (mit Freetz Option) erfolgreich mit dem s2f-Skript geflashed.

Heute wollte ich diese mit den identischen Freetz-Paketen aktualisieren, jedoch läuft das Skript nicht mehr sauber durch und bleibt bei STEP 2: MODIFY hängen.

Code:
STEP 2: MODIFY
applying symlinks, deleting additional webinterfaces in: usr/www usr/www.nas
applying patches
  applying patches (7270_v2_preview-de)
    applying patch file ./patches/7270_v2_preview/105-S06-logging.sh
    applying patch file ./patches/7270_v2_preview/115-S20-modload.sh
    applying patch file ./patches/110-multid-wait.patch
    patching file etc/init.d/rc.net
    ----------------------------------------------------------------------
    applying patch file ./patches/110-system_status.patch
    patching file usr/bin/system_status
    ----------------------------------------------------------------------
    applying patch file ./patches/7270_v2_preview/110-S08-tffs-mknod.patch
    patching file etc/init.d/S08-tffs
    Hunk #1 FAILED at 110.
    1 out of 1 hunk FAILED -- saving rejects to file etc/init.d/S08-tffs.rej
    ----------------------------------------------------------------------
ERROR: modpatch: Error in patch-file ./patches/7270_v2_preview/110-S08-tffs-mknod.patch
make: *** [firmware-nocompile] Fehler 2
---------------------------------------------------------------------------------------------------------------
modimage=
Lasse ich die Freetz-Option in s2f deaktiviert, läuft alles normal durch.
Scheint also ein Freetz-Fehler zu sein.


Wie ich gelesen habe, kann man den W920V auch nativ mit dem ruKernelTool eine 7570 FW flashen.

Nun war meine Überlegung die 7570 mit freetz-devel zu modifizieren und aus der erzeugten FW dann das kernel.image zu extrahieren, um es mit dem ruKernelTool zu flashen.

Würde dies so funktionieren?
 

Ernest015

IPPF-Promi
Mitglied seit
12 Jan 2007
Beiträge
3,136
Punkte für Reaktionen
1
Punkte
36
Es könnte folgende Ursache haben: du verwendest als Basis eine internationale (mehrsprachige) Firmware-Version. Wenn im Freetz-Menü als Firmware Language dann "Deutsch" anstatt "Englisch" eingestellt ist, funktionieren die Patches nicht. Die Sprache, die letztendlich auf der Weboberfläche erscheint, ist im Menü der modifizierten Box auswählbar.

Zu der verwendeten Firmware wäre noch zu sagen, dass sie anscheinend nicht alle Funktionen der 7270-Firmware bietet, siehe auch hier in der ersten Zeile:
Code:
[B]deleting additional webinterfaces[/B] in: usr/www usr/www.nas
Mit anderen Worten, die NAS-Oberfläche und damit der vereinfachte Zugriff auf Inhalte von angeschlossenen USB-Geräten etc. fällt weg.

Sollte es sich um eine Preview-Version mit einem neueren Kernel handeln (zu erkennen an der 05 in der Mitte der Versionsnummer, z.B.: 54.05.05), wäre diese Version auf einem Speedport nicht lauffähig. Auf Grund der Hardware-Unterschiede zwischen einem W920v und einer Fritzbox 7270 müssen Hardware-Treiber ausgetauscht werden. Diese stammen entweder aus der originalen TCOM-Firmware oder der Firmware einer Fritzbox 7570. Diese Treiber sind jedoch bislang nur in einer älteren Kernel-Version vorhanden und passen nur zu Firmware-Versionen, die eine 04 in der Mitte haben.

mfg
 

Tecnetium

Neuer User
Mitglied seit
19 Jun 2010
Beiträge
23
Punkte für Reaktionen
0
Punkte
0
Hi,

habe meine Vorgehensweise mal als Screenshots dokumentiert.
Vielleicht kannst Du ja was erkennen, was ich übersehe.


- S2F startet und ich habe die 2 gelb markieren Haken aktiviert/deaktiviert (Bild 1)

- S2F hat folgende Dateien heruntergeladen:
* Speedport_W_920V.AnnexB.65.04.78.image
* FRITZ.Box_Fon_WLAN_7270_16.AnnexB.en-de-es-it-fr.54.04.90.image
* FRITZ.Box_Fon_WLAN_7570_vDSL.en-de-fr.75.04.91.image

- S2F zeigt folgende Ausgabe (Bild 2), Pakete müssen ebenfalls nicht aktualisiert werden (Bild 3)

- S2F gibt nach "freetz-trunk" einen Fehler aus (Bild 4) Habe diesen mal rot markiert

- make menuconfig wird aber gestartet (Bild 5)

- make bricht bei Step 2 ab (Bild 6)
 

Anhänge

Marsupilami

IPPF-Promi
Mitglied seit
31 Jan 2006
Beiträge
4,999
Punkte für Reaktionen
0
Punkte
36
- S2F hat folgende Dateien heruntergeladen:
* Speedport_W_920V.AnnexB.65.04.78.image
* FRITZ.Box_Fon_WLAN_7270_16.AnnexB.en-de-es-it-fr.54.04.90.image
* FRITZ.Box_Fon_WLAN_7570_vDSL.en-de-fr.75.04.91.image
Was versprichst du dir denn von der Kombination?
 

Tecnetium

Neuer User
Mitglied seit
19 Jun 2010
Beiträge
23
Punkte für Reaktionen
0
Punkte
0
Das war voreingestellt und hat S2F automatisch heruntergeladen.

Was dann S2F aus welchen Image herauszieht, kann ich Dir aber auch nicht sagen. ;)
 

Marsupilami

IPPF-Promi
Mitglied seit
31 Jan 2006
Beiträge
4,999
Punkte für Reaktionen
0
Punkte
36
Dann frage ich mal anders: Warum benutzt du überhaupt Speedport2Fritz?
 

Ernest015

IPPF-Promi
Mitglied seit
12 Jan 2007
Beiträge
3,136
Punkte für Reaktionen
1
Punkte
36
Auch nach dem Einbau zusätzlicher Pakete in eine 7270-Firmware per Freetz ist das immer noch eine 7270-Firmware. Freetz erstellt keine "Alien-Variante" für ein Speedport W920v, also muss speed-to-fritz verwendet werden, um die bereits modifizierte 7270-Firmware auf dem W920v lauffähig zu machen.

mfg
 

Zurzeit aktive Besucher

3CX

Neueste Beiträge

Statistik des Forums

Themen
235,961
Beiträge
2,068,324
Mitglieder
357,026
Neuestes Mitglied
TomTom92