[Frage] Swyx Quadbri und Asterisk Installation/Einrichtung

sparkie

Aktives Mitglied
Mitglied seit
13 Nov 2005
Beiträge
1,551
Punkte für Reaktionen
14
Punkte
38
ich habe bei mir ein 32-bit System am Laufen. Bei dir sind es jedoch 64-bit . Gibt es dafuer einen speziellen Grund? Ich weiss nicht inwieweit das fuer dahdi/isdn ein Problem sein koennte. Ich meine mal irgendwas derartiges gelesen zu haben.
 

jensdipo

Neuer User
Mitglied seit
12 Jul 2013
Beiträge
26
Punkte für Reaktionen
0
Punkte
0
dann setze ich einfach mal ein 32 bit System auf und teste damit mal.

Am 32bit scheint es nicht zu liegen habe gerade neu aufgesetzt und die selben Sachen nachgeguckt und alles beim alten.
Alles sieht genauso aus wie auf dem 64bit System
 
Zuletzt bearbeitet von einem Moderator:

sparkie

Aktives Mitglied
Mitglied seit
13 Nov 2005
Beiträge
1,551
Punkte für Reaktionen
14
Punkte
38
ich werde die Tage bei mir mal 32-bit jessie aufsetzen. Wollte ich sowieso schon laengst mal gemacht haben. Dann koennen wir es nochmal zusammen durchgehen. es waere schoen wenn dabei ein kleines Howto heraus kaeme.
 

jensdipo

Neuer User
Mitglied seit
12 Jul 2013
Beiträge
26
Punkte für Reaktionen
0
Punkte
0
Warum nicht. Sich alleine durch die Welt zu quälen bringt ja nichts.
Ich hab da allerdings jetzt noch was anderes versucht:
http://webservices.jnetdns.de/~junghanns.net/downloads/jnet-dahdi...
Download it to /usr/src/ and unpack it. Then do the following steps:
4. cd /usr/src/jnet-dahdi-drivers-1.0.1/
5. ./install.sh
6. cd qozap/
cp system.conf.quadBRI /etc/dahdi/system.conf
7. edit the file /etc/dahdi/modules and replace the line "wcb4xxp"
with "qozap"
8. reboot your machine
jetzt wird mir die Karte auch in den files angezeigt allerdings habe ich die Funktion noch nicht testen können.
Kann das überhaupt Funktionieren oder such ich hier an der falschen Stelle?
 

sparkie

Aktives Mitglied
Mitglied seit
13 Nov 2005
Beiträge
1,551
Punkte für Reaktionen
14
Punkte
38
qozap kenne ich nicht. Bei mir steht in '/etc/dahdi/modules' der Treiber "wcb4xxp". Vermutlich weil der dahdi_genconf -v das dorthin kopiert hat. Das setzt evtl. voraus, dass zu dem Zeitpunkt wcb4xxp bereits geladen wurde. Ich kann das im Rahmen meiner geplanten jessie-Installation nochmal durchspielen. Und genauer protokollieren was ich (vielleicht auch unbewusst) gemacht habe damit es funktioniert.
 

jensdipo

Neuer User
Mitglied seit
12 Jul 2013
Beiträge
26
Punkte für Reaktionen
0
Punkte
0
Wenn ich dir irgendwie von hier aus behilflich sein kann dann sag einfach bescheid.
 

sparkie

Aktives Mitglied
Mitglied seit
13 Nov 2005
Beiträge
1,551
Punkte für Reaktionen
14
Punkte
38
ich habe gerade zufaellig noch was entdeckt. Im File

/usr/share/perl5/Dahdi/Hardware/PCI.pm

stehen die genauen Abhaengigkeiten Treiber <-> Hardware. Wir haben doch nicht genau die gleichen Karten. Deine liefert naemlich:
Code:
[email protected]:~# lspci  -d 1397: -vv -nn
04:04.0 ISDN controller: Cologne Chip Designs GmbH ISDN network Controller [HFC-4S] (rev 01)
        Subsystem: Cologne Chip Designs GmbH ISDN network Controller [HFC-4S] [1397:08b4]
bei mir steht:

Code:
05:00.0 ISDN controller: Cologne Chip Designs GmbH ISDN network Controller [HFC-4S] (rev 01)
        Subsystem: Cologne Chip Designs GmbH HFC-4S [Swyx 4xS0 SX2 QuadBri] [1397:b540]
bei mir liefert
Code:
# dahdi_hardware -v

pci:0000:05:00.0     wcb4xxp+     1397:08b4 Swyx 4xS0 SX2 QuadBri
nun habe ich zufaellig noch eine andere 4-port Karte bei mir gefunden (die entspricht wohl genau deiner mit [1397:08b4] )
Da bekomme ich tatsaechlich:

Code:
# dahdi_hardware -v

pci:0000:05:00.0     qozap-       1397:08b4 Generic Cologne ISDN card
du musst also wohl wirklich einen 'qozap' irgendwo herbekommen.

so, habe noch weiter recherchiert. Anscheinend sind die Treibersourcen selbst im relativ aktuellen jessie zu alt fuer bestimmte Hardware.
Teste mal bitte folgendes:

Code:
git clone git://git.asterisk.org/dahdi/linux dahdi-linux
cd dahdi-linux
make
make install
depmod -a
init 6
modprobe wcb4xxp
dahdi_genconf -v
dann werden bei mir die Files erzeugt. Auch mit dem wcb4xxp und der [ '1397:08b4/1397:08b4' ] Karte. Der 'qozap' bleibt also ueberfluessig
 
Zuletzt bearbeitet von einem Moderator:

jensdipo

Neuer User
Mitglied seit
12 Jul 2013
Beiträge
26
Punkte für Reaktionen
0
Punkte
0
Moin,
hab das gerade mal getestet aber geht immer noch nicht.
wenn ich dahdi_hardware aufrufe steht da immer noch qozap-.
oder kann das jetzt noch sein das ich den nochmal aufsetzen muss da ich die qozap Treiber aufgespielt habe?
das mit den qozap scheint allerdings auch nicht zu funktionieren da auch keine LED an der Karte angeht.
 

sparkie

Aktives Mitglied
Mitglied seit
13 Nov 2005
Beiträge
1,551
Punkte für Reaktionen
14
Punkte
38
wenn ich (allerdings derzeit auf jessie) mache:
Code:
dahdi_hardware -v
dann bekomme ich:
Code:
dahdi_hardware -v
driver should be 'qozap' but is actually 'wcb4xxp'
pci:0000:05:00.0     qozap+       1397:08b4 Generic Cologne ISDN card
das kommt daher, dass in
Code:
/usr/share/perl5/Dahdi/Hardware/PCI.pm
kein Eintrag fuer die [ '1397:08b4/1397:08b4' ] vorhanden ist und er dann glaubt unbedingt den 'qozap' nehmen zu muessen.
Das ist aber nur Kosmetik und ohne Belang. Wenn es stoert einfach noch die Zeile:
Code:
'1397:08b4/1397:08b4'   => { DRIVER => 'wcb4xxp', DESCRIPTION => 'Generic Cologne ISDN card' },
hinzufuegen et voila:
Code:
dahdi_hardware -v

pci:0000:05:00.0     wcb4xxp+     1397:08b4 Generic Cologne ISDN card
welcher Treiber ist bei dir aktiv? Es muss der 'wcb4xxp' aus dem 'git' von oben sein. Sonst geht es nicht.
Wenn dieser Treiber geladen ist dann ergibt:
Code:
dahdi_genconf -v
Default parameters from /etc/dahdi/genconf_parameters
Generating /etc/dahdi/assigned-spans.conf
Generating /etc/dahdi/system.conf
Generating /etc/asterisk/dahdi-channels.conf
und alles funzt soweit
 

sparkie

Aktives Mitglied
Mitglied seit
13 Nov 2005
Beiträge
1,551
Punkte für Reaktionen
14
Punkte
38
falls es noch Probleme geben sollte:
kannst du mal den Output von
Code:
lspci  -d 1397: -vv -nn
ausgeben?
Dein Posting von oben ist noch ohne '-nn' Option. Aber selbst da sagt er irgendwas von
Code:
Subsystem: Cologne Chip Designs GmbH Device b742
eventuell muss in
Code:
drivers/dahdi/wcb4xxp/base.c
eine Zeile mit
Code:
{0x1397, 0x08b4, 0x1397, 0xb742, 0, 0, (unsigned long)&hfc4s_SW},
ergaenzt werden. Die '0xb742' ist dort gar nicht bekannt. Welcher Kartentyp ist das?
Es steht zur Auswahl hfc8s hfc4s_OV hfc4s_BN hfc4s_SW...

sollte es eine SWYX sein dann passt wohl am ehesten hfc4s_SW
 
Zuletzt bearbeitet:

jensdipo

Neuer User
Mitglied seit
12 Jul 2013
Beiträge
26
Punkte für Reaktionen
0
Punkte
0
Hy sparkie,
Sorry wenn ich heute nicht viel Zeit hatte aber bei uns ist die Hölle los.
Hab den debian nochmal neu aufgesetzt und siehe da meine karte zeigt was an.
allerdings nur mit deinem letzten tipp mit der Installation von dahdi-linux und den Eintrag in die base.c "{0x1397, 0x08b4, 0x1397, 0xb742, 0, 0, (unsigned long)&hfc4s_SW},".
werde die Karte jetzt noch testen ob ich auch wirklich telefonieren kann und melde mich dann nochmal.
 

jensdipo

Neuer User
Mitglied seit
12 Jul 2013
Beiträge
26
Punkte für Reaktionen
0
Punkte
0
Kann mir jemand vielleicht noch ein paar Tipps geben was in die extensions.conf rein muss da ich weder angerufen noch raustelefonieren kann?
MFG
Jens
 

sparkie

Aktives Mitglied
Mitglied seit
13 Nov 2005
Beiträge
1,551
Punkte für Reaktionen
14
Punkte
38
ich habe gerade diverse Maschinen hier aktualisiert. Obwohl ich ihn nicht benoetige bin ich dabei auf eine einfache Art gestossen den 'qozap' zu installieren. Bei manchen Evaluation Boards, die keine explizite Typ-Konfiguration haben funktioniert das Treiber-Probing nicht immer zuverlaessig. Da ist dann aktuell 'qozap' evtl. doch noch die bessere Loesung. Basis ist hier am besten debian wheezy (wegen Kompatibilitaet zu dahdi 2.6.1). Damit es baut muessen alle Voraussetzungen gegeben sein, die ein "module-assistant -t auto-install dahdi" erfordert.

folgendes muss gemacht werden:
Code:
wget http://www.junghanns.net/downloads/jnet-dahdi-drivers-1.0.14.tar.gz
tar xfv jnet-dahdi-drivers-1.0.14.tar.gz
cd jnet-dahdi-drivers-1.0.14
install.sh
weitere Hinweise in den READMEs. In '/etc/dahdi/modules' reicht der eine EIntrag 'qozap'.

die Jumper Einstellungen fuer NT/TE mode muessen beim qozap explizit angegeben werden.
Beispiel:
Code:
Nov  7 17:15:34 x kernel: [   19.050777] qozap: CologneChip HFC-4S evaluation board configured at io port 0xd000 IRQ 20 HZ 250
Nov  7 17:15:34 x kernel: [   19.086515] qozap: S/T ports: 4 [ NT TE TE NT ]
Nov  7 17:15:34 x kernel: [   19.126070] qozap: 1 multiBRI card(s) in this box, 4 BRI ports total, bloop 0, pcmslave 0, dacs 1.
benoetigt diese EInstellung:

Code:
options qozap ports=9
 
Zuletzt bearbeitet:

jensdipo

Neuer User
Mitglied seit
12 Jul 2013
Beiträge
26
Punkte für Reaktionen
0
Punkte
0
Hab da noch ne Frage:
isdngw1*CLI> dahdi show channels
No such command 'dahdi show channels' (type 'core show help dahdi show' for other possible commands)
kann das sein das bei mir dahdi gar nicht geladne wird?

hab jetzt mal das chan_dahdi neugestartet und dann kommt:
ERROR[3932]: chan_dahdi.c:12325 mkintf: Unable to open channel 2: No such device or address

Dazu habe ich in der datei modules noch dahdi_echocan_mg2 eingetragen.
In der system.conf habe ich echocanceller=mg2,1-2 anstelle echocanceller=oslec,1-2
jetzt werden mir auch die channels im Asterisk angezeigt.
 
Zuletzt bearbeitet:

sparkie

Aktives Mitglied
Mitglied seit
13 Nov 2005
Beiträge
1,551
Punkte für Reaktionen
14
Punkte
38
welche Basis verwendest du im Moment? Nach meinen eigenen Erfahrungen die letzten 2 Tage (ich habe diverse Systeme hier neu aufgesetzt) wuerde ich dir bei deiner Karte zu wheezy + qozap raten. Damit duerfte es fuer dich am einfachsten sein. Am besten also folgende Vorgehensweise:
Code:
- Minimalkonfiguration wheezy aufsetzen
- File anlegen, Treiber blacklisten

vi /etc/modprobe.d/blklist_drivers.conf

# modules are explicitly loaded as of /etc/dahdi/modules, don't load by default
blacklist hfcpci
blacklist hfcsusb
blacklist hfcmulti
blacklist mISDN_dsp
blacklist mISDN_core
blacklist mISDN_dsp_oslec
blacklist wcb4xxp
blacklist zaphfc

- Pakete/Treiber installieren

apt-get build-dep dahdi-source
apt-get install dahdi-source
apt-get install asterisk-dahdi
m-a -t a-i dahdi

- qozap darueberinstallieren

wget http://www.junghanns.net/downloads/jnet-dahdi-drivers-1.0.14.tar.gz
tar xfv jnet-dahdi-drivers-1.0.14.tar.gz
cd jnet-dahdi-drivers-1.0.14
install.sh

- optional NT/TE mode konfigurieren (Beispiel qozap: S/T ports: 4 [ NT TE TE NT ])

options qozap ports=9

- reboot

- konfigurieren

dahdi_hardware -v
modprobe quozap
dahdi_hardware -v
dahdi_genconf -v
 
Zuletzt bearbeitet:

jensdipo

Neuer User
Mitglied seit
12 Jul 2013
Beiträge
26
Punkte für Reaktionen
0
Punkte
0
werde ich gleich mal testen und melde mich dann.
Sorry wenn ich dieses Wochende sehr kurz angebunden war aber die Arbeit hat gerufen.

du hast noch geschrieben:
- optional NT/TE mode konfigurieren (Beispiel qozap: S/T ports: 4 [ NT TE TE NT ])
options qozap ports=9
wo mache ich das denn?
bzw wenn ich das ganze ohne konfiguration durchziehe bekomme ich:
Code:
isdngw1*CLI> dahdi show channels
   Chan Extension  Context         Language   MOH Interpret        Blocked    State
 pseudo            default                    default                         In Service
isdngw1*CLI> dahdi show status
Description                              Alarms  IRQ    bpviol CRC    Fra Codi Options  LBO
quadBRI PCI ISDN Card 1 Span 1 [TE]      UNCONFI 0      0      0      CAS Unk           0 db (CSU)/0-133 feet (DSX-1)
quadBRI PCI ISDN Card 1 Span 2 [TE]      UNCONFI 0      0      0      CAS Unk           0 db (CSU)/0-133 feet (DSX-1)
quadBRI PCI ISDN Card 1 Span 3 [TE]      UNCONFI 0      0      0      CAS Unk           0 db (CSU)/0-133 feet (DSX-1)
quadBRI PCI ISDN Card 1 Span 4 [TE]      UNCONFI 0      0      0      CAS Unk           0 db (CSU)/0-133 feet (DSX-1)
isdngw1*CLI> dahdi show channels
   Chan Extension  Context         Language   MOH Interpret        Blocked    State
 pseudo            default                    default                         In Service
und lämpchen sind auf meiner karte auch noch nicht an!?
 

sparkie

Aktives Mitglied
Mitglied seit
13 Nov 2005
Beiträge
1,551
Punkte für Reaktionen
14
Punkte
38
wenn du nur TE ports brauchst dann musst du hier gar nichts weiter tun.
Ansonsten die Zeile (mit der richtigen Bitmaske natuerlich) einfach in irgendein File im /etc/modprobe.d/ Directory einbauen. Z.B. in das neue File von oben:
Code:
/etc/modprobe.d/blklist_drivers.conf
sieht doch schon sehr gut aus. Du musst jetzt dafuer sorgen, dass 'dahdi-channels.conf' vom asterisk angezogen wird.
Am einfachsten noch einen include anhaengen:
Code:
echo '#include dahdi-channels.conf' >> /etc/asterisk/chan_dahdi.conf
und asterisk neu starten bzw. rebooten. Dann sollte
Code:
asterisk -nr
*CLI> dahdi show channels
mehr anzeigen
 

jensdipo

Neuer User
Mitglied seit
12 Jul 2013
Beiträge
26
Punkte für Reaktionen
0
Punkte
0
zeigt auch mehr!
Code:
isdngw1*CLI> dahdi show channels
   Chan Extension  Context         Language   MOH Interpret        Blocked    State
 pseudo            default                    default                         In Service
      1            from-pstn                  default                         In Service
      2            from-pstn                  default                         In Service
      4            from-pstn                  default                         In Service
      5            from-pstn                  default                         In Service
      7            from-pstn                  default                         In Service
      8            from-pstn                  default                         In Service
     10            from-pstn                  default                         In Service
     11            from-pstn                  default                         In Service
allerdings gehen die led´s hinten immer noch nicht an oder ist das hierbei einfach so.
 

sparkie

Aktives Mitglied
Mitglied seit
13 Nov 2005
Beiträge
1,551
Punkte für Reaktionen
14
Punkte
38
perfekt!

der generische qozap kennt die LEDs deiner speziellen Karte nicht. Ist insofern normal.
 

jensdipo

Neuer User
Mitglied seit
12 Jul 2013
Beiträge
26
Punkte für Reaktionen
0
Punkte
0
es sieht auf jedenfall so aus als wenn alles funktioniert.
Gespräche kommen rein und gehen auch raus.
 

Zurzeit aktive Besucher

3CX PBX - GRATIS
Linux / Win / Cloud

Statistik des Forums

Themen
231,819
Beiträge
2,015,595
Mitglieder
348,867
Neuestes Mitglied
matt82