.titleBar { margin-bottom: 5px!important; }

Telekom SIP-Trunk auf Issabel 4 (elastix - freepbx -asterisk) einrichten

Dieses Thema im Forum "Telekom VoIP" wurde erstellt von abcona, 22 Dez. 2017.

  1. abcona

    abcona Neuer User

    Registriert seit:
    10 Dez. 2004
    Beiträge:
    36
    Zustimmungen:
    0
    Punkte für Erfolge:
    6
    #1 abcona, 22 Dez. 2017
    Zuletzt bearbeitet: 23 Dez. 2017
    Hallo Gemeinde,

    um Asterisk an eine Telekom SIP-Trunk Haupteitung zum fliegen zu kriegen, hat mich echt Nerven gekostet.
    Nur mit Hilfe von den Jungs von http://www.asterisk-berlin.de fliegt das ganze jetzt .

    Achtung:
    Wenn Ihr noch nicht so tief in Asterisk drinn seid, kauft euch dort support ein (sehr zu empfehlen !).
    Selten das Vergnügen gehabt mit so kompetenten Spezialisten reden zu dürfen.

    1TR 118 und SIP auf TCP, g722 und was weiss ich noch was die Telekom an Sonderlocken implementiert hat.

    Hab in meinem lokalen DNS-Server (BIND version 9.3) als dritten dns 217.5.100.185 eingetragen:
    ### snip named.conf ###
    Code:
    options {
       directory "/etc";
            pid-file "/var/run/named/named.pid";
       dump-file "/var/log/named_dump.db";
       statistics-file "/var/log/named.stats";
       listen-on port 53 { any; };
       listen-on-v6 { any; };
       notify no;
       forwarders {
           8.8.8.8;
           194.25.2.129;
                    217.5.100.185;
           };
       cleaning-interval 120;
       #statistics-interval 60;
       sortlist {
             { localhost; localnets; };
             { localnets; };
       };
    };
    
    ### snap ###
    Dann mal schauen, was da raus kommt:
    nslookup -querytype=SRV _sip._tcp.reg.sip-trunk.telekom.de
    Wenn es nicht gleich klappt, macht erst mal weiter mit der Hauptleitung.
    Gibt error meldungen, das Asterisk -rvv sip-trunk.telekom.de nicht findet, funzt aber trotzdem.

    Trunk einrichten:
    Code:
    Trunk Name: Telekom
    CID Options Allow Any CID
    bei match pattern hab ich X. eingetragen.
    
    Outgoing Settings
    Trunk Name -> telekom
    
    Peer Details:
    
    type=friend
    insecure=invite
    defaultuser=55YYYYYYYYYY
    usereqphone=yes
    transport=tcp
    videosupport=no
    session-timers=refuse
    secret=ZZZZZZZZ
    qualify=yes
    directmedia=no
    dtmfmode=rfc2833
    context=from-Telekom
    srvlookup=yes
    disallow=all
    allow=g722,alaw
    host=reg.sip-trunk.telekom.de
    fromdomain=sip-trunk.telekom.de
    
    Incomming Settings
    User Context -> telekom_in
    
    User Details:
    
    type=friend
    insecure=invite
    defaultuser=55YYYYYYYYYY
    usereqphone=yes
    transport=tcp
    videosupport=no
    session-timers=refuse
    secret=ZZZZZZZZ
    qualify=yes
    directmedia=no
    dtmfmode=rfc2833
    context=from-Telekom
    srvlookup=yes
    disallow=all
    allow=g722,alaw
    host=reg.sip-trunk.telekom.de
    fromdomain=sip-trunk.telekom.de
    
    Registration
    
    Register String
    
    tcp://+496XXXXXXXX@sip-trunk.telekom.de:ZZZZZZZZ:55YYYYYYYYYY@reg.sip-trunk.telekom.de:5060/+496XXXXXXXX~480
    
    #######
    Bei meinem Telekom Zugangsdatenbrief steht das so drinen :)
    Telefonie einrichten
    Registrierungsrufnummer +49XXXXXXXX
    Telefonie-Benutzername 55YYYYYYYYYY
    Telefonie-Passwort ZZZZZZZZ
    Outbound-Proxy reg.sip-trunk.telekom.de
    Registrar sip-trunk.telekom.de

    Nun folgendes in der /etc/asterisk/extensions_custom.conf unten eintragen.
    Code:
    [from-Telekom]
    exten => _[+0-9].,1,NOOP(${SIP_HEADER(P-Called-Party-ID)})
     same => n,Set(tmpcid=${CUT(SIP_HEADER(P-Called-Party-ID),:,2)})
     same => n,Set(BNUMBER=${CUT(tmpcid,@,1)})
     same => n,Set(CALLERID(num)=00${CALLERID(num):1})
     same => n,Set(CALLERID(name)=00${CALLERID(name):1})
     same => n,GoTo(ext-did-0002,${BNUMBER:7},1)
    
    #######
    Inbout Route

    Bei mir funzt nun die eingehende Wählverbindung (inbout Route) mit der Stammnummer+nebenstelle.
    Bsp: +49 für deutschland 69 für die Stadt 1234 ist die Stammnummer XX die Nebenstellen.

    DID nummer eingeben z.B . 1234XX
    und auf z.B. Extension XX legen.

    #######
    Outbound Route
    Route Name -> telekom-out
    Bei den Deal Patterns hab ich einfach in match pattern -> X. eingetragen

    Trunk Sequence for Matched Routes
    Telekom gewählt (weil ich den Trunk so deklariert habe s.o. Trunk Name: Telekom )

    Bestimmt habe ich jetzt noch einiges vergessen :)

    So müsste es aber schon mal prinzipiell (wie bei mir ) funktioieren.

    Gruss
    Angelo
     
  2. stoney

    stoney Moderator
    Forum-Mitarbeiter

    Registriert seit:
    7 Okt. 2015
    Beiträge:
    2,480
    Zustimmungen:
    119
    Punkte für Erfolge:
    63
    Ort:
    Bayern
    Es wäre schön, wenn Du mit BBCode schreiben würdest
    zB.
    [CODE]config...
    ....
    ... [/CODE]

    Dann lässt es sich angenehmer lesen und man sieht direkt die Settings und die Kommentare

    Siehe Hilfe > BBCodes

    Auch das ist sicherlich nicht schlecht mal gelesen zu haben
    IP Phone Forum Regeln
    Neu im IP-Phone-Forum?
     
  3. koyaanisqatsi

    koyaanisqatsi IPPF-Promi

    Registriert seit:
    24 Jan. 2013
    Beiträge:
    9,926
    Zustimmungen:
    55
    Punkte für Erfolge:
    48