.titleBar { margin-bottom: 5px!important; }

[Trunk #2929] Schönheitsfehler "Ein USB-Speicher konnte nicht eingebunden werden"

Dieses Thema im Forum "Freetz" wurde erstellt von cuma, 21 Dez. 2008.

  1. cuma

    cuma Aktives Mitglied

    Registriert seit:
    16 Dez. 2006
    Beiträge:
    2,735
    Zustimmungen:
    0
    Punkte für Erfolge:
    0
    #1 cuma, 21 Dez. 2008
    Zuletzt bearbeitet: 28 Mai 2010
    AVM prüft in der /usr/www/all/html/de/home/home.js ob die Anzahl der verfügbaren Partitionen gleich der eingebundenen ist. Falls nicht erscheint "Ein USB-Speicher konnte nicht eingebunden werden". Folglich wir die Fehlermeldung immer angezeigt, wenn eine nicht mountbare Partition existiert, wie zB eine für Swap.
    Anbei ein Patch um dies für die deutsch 7170 zu ändern, für die 7270 folgt später. Es muss unter "Patches" aktivert werden.
    Die Anzeige unter "USB-Geräteübersicht" wir nicht verändert.
    Vorteil hiervon ist auch, dass USB-Gerät auch wieder von der Hauptseite ausgeworfen werden können.

    UPDATE für 7270
     
  2. balou1974

    balou1974 Mitglied

    Registriert seit:
    8 März 2006
    Beiträge:
    202
    Zustimmungen:
    0
    Punkte für Erfolge:
    0
    @cuma: Danke für den Patch! Lässt sich denn damit auch das Problem lösen, dass Samba nicht startet?
     
  3. cuma

    cuma Aktives Mitglied

    Registriert seit:
    16 Dez. 2006
    Beiträge:
    2,735
    Zustimmungen:
    0
    Punkte für Erfolge:
    0
    Ich benutze den Freetz-Samba und habe keine Probleme. Vielleicht prüft AVM an einer anderen Stelle noch den mount-Status?
     
  4. matze1985

    matze1985 Aktives Mitglied

    Registriert seit:
    17 Feb. 2007
    Beiträge:
    1,537
    Zustimmungen:
    0
    Punkte für Erfolge:
    0
    @balou: Das liegt wahrscheinlich daran, dass avm den samba als Plugin ausgelagert hat und nicht nachgeladen wird, z.b. wegen dem Versionsstring von Freetz.
     
  5. cuma

    cuma Aktives Mitglied

    Registriert seit:
    16 Dez. 2006
    Beiträge:
    2,735
    Zustimmungen:
    0
    Punkte für Erfolge:
    0
    #5 cuma, 23 Dez. 2008
    Zuletzt bearbeitet: 28 Mai 2010
    Hier noch eine Version ohne menuconfig. Wie gehabt für 7170de und 7270
     
  6. balou1974

    balou1974 Mitglied

    Registriert seit:
    8 März 2006
    Beiträge:
    202
    Zustimmungen:
    0
    Punkte für Erfolge:
    0
    Der Versionsstring ist ja schon aus, dass ist es ja was mich wundert....
    (es wird nur die avm-versionsnr. angezeigt!)
     
  7. wavemaster01

    wavemaster01 Neuer User

    Registriert seit:
    21 März 2008
    Beiträge:
    45
    Zustimmungen:
    0
    Punkte für Erfolge:
    0
    Beruf:
    WIler
    Hallo,

    danke für den Patch. Habe das gleiche Problem und will es auch beheben. Nur kurz eine Frage, was meinst du mit "ohne menuconfig"? Kann ich die Datei ähnlich wie die Patches von the-construct einfach als Firmwareaktualisierung auf die Box laden oder muss ich sie irgendwie anders in mein freetz-image einbauen?

    thnx wavemaster01
     
  8. cuma

    cuma Aktives Mitglied

    Registriert seit:
    16 Dez. 2006
    Beiträge:
    2,735
    Zustimmungen:
    0
    Punkte für Erfolge:
    0
    Mit "ohne menuconfig" meinte ich, dass er automatisch angewendet wird und nicht noch extra aktivert werden muss. Ist mittlerweile so eingecheckt
     
  9. Herbie_2005

    Herbie_2005 Mitglied

    Registriert seit:
    31 März 2007
    Beiträge:
    289
    Zustimmungen:
    0
    Punkte für Erfolge:
    16
    Wunderbar

    Herzlichen Dank für das Engagement in diesem Bereich! Ich habe auch über längere Zeit mit dem Problem der nicht ordnungsgemäß eingebundenen Partitionen von Usb-Datenträgern gekämpft.

    Gerade im Zusammenhang mit der Auslagerung von Teilen der modifizierten Firmware (Freetz), etwa mit „Usb-Root”-, „External”- oder „Downloader”-Komponenten, trat das genannte Problem immer wieder auf.

    Erst jetzt läuft bei mir (siehe Signatur) die Sache wieder richtig rund :).
     
  10. m.koesters

    m.koesters Neuer User

    Registriert seit:
    28 Dez. 2008
    Beiträge:
    6
    Zustimmungen:
    0
    Punkte für Erfolge:
    0
    Fehler beim Einspielen:Hunk #1 FAILED at 70.

    Könnst ihr mir helfen?
    Bin Linux Beginner und hab's nach der Anleitung probiert.
    Hier meine Fehlermeldung:

    slightly@StinkyLinux:~$ cd freetz
    slightly@StinkyLinux:~/freetz$ cd freetz-stable
    slightly@StinkyLinux:~/freetz/freetz-stable$ svn up
    Revision 2950.

    slightly@StinkyLinux:~/freetz/freetz-stable$ patch -p0 < notmountable_3_7170_7270-no_menuconfig.patch
    patching file patches/7170/de/210-notmountable.patch
    patching file patches/7270/210-notmountable.patch
    patching file patches/cond/usbstorage_7170.patch
    Hunk #1 FAILED at 70.
    1 out of 1 hunk FAILED -- saving rejects to file patches/cond/usbstorage_7170.patch.rej

    Vielen Dank für Eure Hilfe.
    Gruß
    Martin
     
  11. matze1985

    matze1985 Aktives Mitglied

    Registriert seit:
    17 Feb. 2007
    Beiträge:
    1,537
    Zustimmungen:
    0
    Punkte für Erfolge:
    0
    der Patch war gegen den Trunk und wurde hiermit auch in den Trunk aufgenommen.

    Für den stable-branch müsste er erst angepasst werden.
     
  12. m.koesters

    m.koesters Neuer User

    Registriert seit:
    28 Dez. 2008
    Beiträge:
    6
    Zustimmungen:
    0
    Punkte für Erfolge:
    0
    Hallo,

    bedeutet dass, dass der Patch noch nicht in den Stable-Branch eingebaut werden kann?
    Vielleicht kannst du mir das als Linux-Beginner etwas verständlicher erklären?
    Danke für deine Info's

    Mfg.
    M. Kösters
     
  13. Silent-Tears

    Silent-Tears IPPF-Promi

    Registriert seit:
    3 Aug. 2007
    Beiträge:
    7,456
    Zustimmungen:
    0
    Punkte für Erfolge:
    0
    Ort:
    BI
    Er ist im stable-branch (noch) nicht vorhanden. Entweder trunk, oder abwarten.