.titleBar { margin-bottom: 5px!important; }

u-boot auf Horst Box Pro

Dieses Thema im Forum "D-Link" wurde erstellt von davorin, 24 Nov. 2008.

  1. davorin

    davorin Neuer User

    Registriert seit:
    5 Jan. 2006
    Beiträge:
    14
    Zustimmungen:
    0
    Punkte für Erfolge:
    0
    Hatte ein bisschen Zeit und den u-boot Source Code modifiziert für Horst Box Pro...

    Zum Test natürlich wird er zuerst nur über Redboot gestartet (o;

    Was noch zu debuggen ist...u-boot übergibt nicht korrekt die machine ID an den Linux Kernel...also benutzte ich einen hardcoded machine ID in arch/arm/boot/compressed/head.S (o;
     

    Anhänge:

  2. davorin

    davorin Neuer User

    Registriert seit:
    5 Jan. 2006
    Beiträge:
    14
    Zustimmungen:
    0
    Punkte für Erfolge:
    0
    Kann ja mal passieren, dass man das Flash zerschiesst (o;

    Dafür gibt es ja JTAG und das urjtag Projekt...und läuft auch unter OSX mit einem selbstgebasteltem Altera USB Blaster...
     

    Anhänge:

    • jtag.png
      jtag.png
      Dateigröße:
      85.6 KB
      Aufrufe:
      33
  3. hehol

    hehol Mitglied

    Registriert seit:
    22 Feb. 2005
    Beiträge:
    458
    Zustimmungen:
    0
    Punkte für Erfolge:
    16
    Ort:
    Dortmund
    Hallo davorin,

    kannst Du mit urjtag auch den Flash-Speicher lesen und schreiben? Das hat bei meinen Versuchen nie funktioniert.

    Gruß
    Henning
     
  4. davorin

    davorin Neuer User

    Registriert seit:
    5 Jan. 2006
    Beiträge:
    14
    Zustimmungen:
    0
    Punkte für Erfolge:
    0
    Auslesen ja....

    Bin gerade am Testen von "Redboot" wiederherstellen..dauert eine Ewigkeit auch mit USB (o;
     
  5. davorin

    davorin Neuer User

    Registriert seit:
    5 Jan. 2006
    Beiträge:
    14
    Zustimmungen:
    0
    Punkte für Erfolge:
    0
    #5 davorin, 28 Nov. 2008
    Zuletzt bearbeitet: 28 Nov. 2008
    Also Redboot wollte nicht...also hab ich mal ein Standart u-boot.bin für IXDPG425 genommen....einwandfrei programmiert mit urjtag-0.9.

    Dann gleich ein richtiges gemacht und per ymodem raufgeladen und neu geflashed in u-boot...
     

    Anhänge: