.titleBar { margin-bottom: 5px!important; }

[Gelöst] Voicemail einrichten

Dieses Thema im Forum "Asterisk Allgemein" wurde erstellt von Ben_is_lol, 27 März 2012.

  1. Ben_is_lol

    Ben_is_lol Neuer User

    Registriert seit:
    1 Feb. 2012
    Beiträge:
    14
    Zustimmungen:
    0
    Punkte für Erfolge:
    0
    #1 Ben_is_lol, 27 März 2012
    Zuletzt bearbeitet: 10 Apr. 2012
    Hallo liebe Community,

    ich kenne mich in der Asterisk Szene nicht so gut aus.
    Nichts desto trotz muss ich das früher oder später beherrschen, im Zuge dessen plagt mich gerade die Einrichtung der Voicemail.

    Nach folgendem Artikel habe ich begonnen diese einzurichten:

    http://www.lilalinux.net/e-trolley/page_8678/index.html

    Habe die Anleitung schritt für Schritt befolgt, jedoch meldet sich weder die Voicemail noch kann ich mir erklären warum nicht.

    Folgenden Code habe ich in den Entsprechenden Config Dateien hinterlegt:

    Sip.conf:
    Zum erstellen eines Test Telefons und zum erstellen des Voicemail Users.

    PHP:
    [91]
    type=friend
    host
    =dynamic
    callderid
    ="Anrufbeantworter"
    secret=wbpr
    mailbox
    =91
    language
    =de
    subscribemwi
    =yes
    callgroup
    =1
    pickupgroup
    =1
    subscribecontext
    =sip-internal
    useclientcode
    =yes
    canreinvite
    =yes
    call
    -limit=10

    [90]
    type=friend
    host
    =dynamic
    callderid
    ="Test" <90>
    secret=wbpr
    mailbox
    =91
    language
    =de
    subscribemwi
    =yes
    callgroup
    =1
    pickupgroup
    =1
    subscribecontext
    =sip-internal
    useclientcode
    =yes
    canreinvite
    =yes
    call
    -limit=10
    Extensions.conf:

    PHP:
    ;voicemail
    exten 
    => voicemail,1,VoiceMailMain(${CALLERID(num)},s)
    exten 91,1,Wait(5)
    exten 91,2,Answer()
    exten 91,3,VoiceMail(Anrufbeantworter@default)
    exten a,1,VoiceMailMain(Anrufbeantworter@default)
    Voicemail.conf:

    PHP:
    [default]
    Define maximum number of messages per folder for a particular context.
    ;
    maxmsg=50

    ;1234 => 4242,Example Mailbox,root@localhost
    ;4200 => 9855,Mark Spencer,markster@linux-support.net,mypager@digium.com,attach=no|serveremail=myaddy@digium.com|tz=central|maxmsg=10
    ;4300 => 3456,Ben Rigas,ben@american-computer.net
    ;4310 => -5432,Sales,sales@marko.net
    ;4069 => 6522,Matt Brooks,matt@marko.net,,|tz=central|attach=yes|saycid=yes|dialout=fromvm|callback=fromvm|review=yes|operator=yes|envelope=yes|sayduration=$
    ;
    4073 => 1099,Bianca Paige,bianca@biancapaige.com,,delete=1
    ;4110 => 3443,Rob Flynn,rflynn@blueridge.net
    ;4235 => 1234,Jim Holmes,jim@astricon.ips,,Tz=european
    91 
    => firma,Anrufbeantworter,email@email.de
    Verwendete Telefone sind Snom 370.

    Hoffe ihr könnt da licht ins dunkle bringen.
     
  2. rentier-s

    rentier-s Guest

    Das passt nicht zusammen:

    Code:
    exten = 91,3,VoiceMail([COLOR="#FF0000"]Anrufbeantworter[/COLOR]@default)
    Code:
    [COLOR="#FF0000"]91[/COLOR] => firma,Anrufbeantworter,email@email.de
    Bei der Fehlersuche ist das CLI eine große Hilfe ;-)
    asterisk -rv (je mehr v, umso verbose)
     
  3. Ben_is_lol

    Ben_is_lol Neuer User

    Registriert seit:
    1 Feb. 2012
    Beiträge:
    14
    Zustimmungen:
    0
    Punkte für Erfolge:
    0
    Danke schon einmal für die Antwort, habe "Anrufbeantworter" gegen die 91 ausgetauscht.
    Wenn ich jetz einen Anruf tätige egal ob auf der 90 oder 91, es klingelt laut cli immer nur ganz normal.
     
  4. rentier-s

    rentier-s Guest

    Offensichtlich verheimlichst Du uns etwas. Mit Deinem obigen Dialplan kann es maximal 5 Sekunden klingeln, danach müsste irgendwas passieren (Voicemail oder Fehler).

    Hast Du noch weitere Contexte, wo die 91 drin vor kommt?

    Btw., hier gibt's eine schöne Einführung.
     
  5. Ben_is_lol

    Ben_is_lol Neuer User

    Registriert seit:
    1 Feb. 2012
    Beiträge:
    14
    Zustimmungen:
    0
    Punkte für Erfolge:
    0
    #5 Ben_is_lol, 27 März 2012
    Zuletzt von einem Moderator bearbeitet: 28 März 2012
    Wenn dann nicht absichtlich;).

    Also noch nebenbei, wenn ich die 91 wird der Anruf zu unserer Zentralen annahmestelle (Sekräteriat) weitergeleitet.
    Bei der 90 klingelt es einfach nur auf dem Test Telefon mit folgendem CLI logging:

    Code:
     -- Accepting overlap call from 'Anrufernummer' to 'Testgerät Nummer' on channel 0/28, span 1
        -- Starting simple switch on 'Zap/28-1'
        -- Executing [Testgerät Nummer@zap-external:1] Macro("Zap/28-1", "call-in|s-with-backup|SIP/|90|30|wk|SIP/|10||wk") in new stack
        -- Executing [s@macro-call-in:1] SIPAddHeader("Zap/28-1", ""Alert-Info: <http://www.wbpr>;info=alert-external;x-line-id=0"") in new stack
        -- Executing [s@macro-call-in:2] LDAPget("Zap/28-1", "CALLERID(name)=cidname") in new stack
        -- LDAPget: varname=CALLERID(name), config-section=cidname
        -- Executing [s@macro-call-in:3] Goto("Zap/28-1", "s|105") in new stack
        -- Goto (macro-call-in,s,105)
        -- Executing [s@macro-call-in:105] Set("Zap/28-1", "CALLERID(num)=Anrufernummer") in new stack
        -- Executing [s@macro-call-in:106] Goto("Zap/28-1", "s-with-backup|1") in new stack
        -- Goto (macro-call-in,s-with-backup,1)
        -- Executing [s-with-backup@macro-call-in:1] Dial("Zap/28-1", "SIP/90|30|wk") in new stack
        -- Called 90
        -- SIP/90-00933b90 is ringing
        -- SIP/90-00933b90 is ringing
        -- SIP/90-00933b90 is ringing
        -- SIP/90-00933b90 is ringing
        -- SIP/90-00933b90 is ringing
        -- SIP/90-00933b90 is ringing
    
    usw. bis der Anruf nach 15 Sekunden zur Zentrale weitergeleitet wird.

    Anrufernummer: Meine Handynummer
    Test Gerät: Die Stammnummer mit durchwahl

    Das stimmt, dass eigentlich nach 5 Sekunden die Voicemail rangehen sollte.
    Tut sie bloß leider nich:confused::confused::confused:, da liegt das prob.

    Die 91 und 90 kommt sonst nirgends in der Extensions.conf vor.
     
  6. rentier-s

    rentier-s Guest

    Bitte beschränke Dich bei Zitaten auf das notwendige/sinnvolle, keine Fullquotes!

    Das sieht ganz danach aus, als wäre der Dialplan das Werk eines GUI, oder zumindest anderweitig vorgefertigt. Da bekommst Du Dein Voicemail so nicht untergebracht. Entweder fängst Du mit den Grundlagen an und erstellst Dir zum Verständnis erst mal einen eigenen Dialplan, oder Du fragst dort nach wo Du den Dialplan her hast ob Voicemail schon irgendwie vorgesehen ist. Daran jetzt planlos rumbasteln bringt nichts.
     
  7. Ben_is_lol

    Ben_is_lol Neuer User

    Registriert seit:
    1 Feb. 2012
    Beiträge:
    14
    Zustimmungen:
    0
    Punkte für Erfolge:
    0
    Okay danke schomal, fange gerade mit dem erstellen eines eigenen Asterisk an.
     
  8. Ben_is_lol

    Ben_is_lol Neuer User

    Registriert seit:
    1 Feb. 2012
    Beiträge:
    14
    Zustimmungen:
    0
    Punkte für Erfolge:
    0
    Okay also habe mich in das TUT reingelesen und bis jetz auch alles verstanden.
    Bin bei Punkt 2.5.1(http://www.das-asterisk-buch.de/minimale-telefonanlage.html), habe auf einer Virtuellen Maschine auch einen Asterisk aufgesetzt.
    Habe mir zwei Snoms die Funktionalitäten die bis jetz erstellt wurden auch umgesetzt, inklusive Anrufbeantworter.

    Jetz habe ich versucht dies auf unserem Aktuellem Asterisk umzusetzten jedoch bereitet mir das einrichten Kopfzerbrechen.
    Im Tutorial gibt es die Nummer 2999 die sowohl beim Tutorial als auch bei meiner VM als AB dient.
    Ich kann diesen auch anrufen, Nachrichten abfragen und und und.
    Vielleicht kannst du mir da nochmal weiterhelfen.
    Meine Frage ist, wie kommt eigentlich die extension 2999 zu stande? wenn ich die gleichen Parameter auf dem Live Asterisk übernehme kann ich nichtmal den AB anwählen?
    ist die 2999 als default AB schon so eingestellt?
    Unser Live Asterisk läuft übrigens mit V. 1.4 und meine VM mit V. 1.8
     
  9. rentier-s

    rentier-s Guest

    Es gibt doch ausdrücklich die Zeile
    Code:
    exten => [COLOR="#FF0000"]2999[/COLOR],1,VoiceMailMain(${CALLERID(num)},s)
    Oder verstehe ich grad Dein Problem nicht? :gruebel:

    In der 1.8 gibt es ein paar Funktionen, die es in 1.4 noch nicht gab. Aber das stellst Du spätestens fest, wenn Du eine entsprechende Fehlermeldung auf dem CLI bekommst.
     
  10. Ben_is_lol

    Ben_is_lol Neuer User

    Registriert seit:
    1 Feb. 2012
    Beiträge:
    14
    Zustimmungen:
    0
    Punkte für Erfolge:
    0
    #10 Ben_is_lol, 2 Apr. 2012
    Zuletzt von einem Moderator bearbeitet: 2 Apr. 2012
    Genau mit dieser Zeile geht es ja auf meinem Testserver.
    Die Frage ist ob die 2999 eine fixe Nummer für die Voicemail ist oder ob ich diese Variable wählen kann.

    Leider klappt es auch mit dieser Zeile auf unserem Live Asterisk nicht.....geh da langsam vor die Breschen weil ich nicht weiter weis....
     
  11. rentier-s

    rentier-s Guest

    Du kannst auch eine beliebige exten dafür verwenden, die sich nicht mit Deinem restlichen Dialplan überschneidet.

    Hast Du die Zeile in einen context gesetzt, der auch durchlaufen wird? Was passiert auf dem CLI bei einem Fehlversuch?
     
  12. Ben_is_lol

    Ben_is_lol Neuer User

    Registriert seit:
    1 Feb. 2012
    Beiträge:
    14
    Zustimmungen:
    0
    Punkte für Erfolge:
    0
    Hab ich mir schon gedacht das ich die exten variabel benennen kann.
    Jop die exten liegt in einem Context, dieser wird sogar als erstes durchlaufen (habe aber auch schon in anderen contexten test gemacht).
    Die CLI sagt leider gar nichts, die einzige aussage die er gibt ist das ein anruf reinkommt und es klingelt.
    Die Voicemail wird nicht erwähnt, desweiteren kann ich die Voicemail (2999) auch nicht anrufen (besetzt Zeichen, no such host: 91).
    Es scheint so als wenn für den Server gar keine Voicemail existiert, obwohl der eintrag in der Voicemail.conf vorhanden ist.
     
  13. rentier-s

    rentier-s Guest

    Es scheint mir eher so, als wolltest Du in einen komplexen Dialplan irgendwo was rein basteln. Damit ein Anruf überhaupt auf die Voicemail weitergeleitet wird, müssen Voraussetzungen im Dial-Befehl gegeben sein (insbesondere angemessener Timeout).

    Wenn die 2999 nicht wie erwartet ausgeführt wird heißt das, dass diese Nummer bereits irgendwo vorher durch eine andere exten abgearbeitet wird.
     
  14. Ben_is_lol

    Ben_is_lol Neuer User

    Registriert seit:
    1 Feb. 2012
    Beiträge:
    14
    Zustimmungen:
    0
    Punkte für Erfolge:
    0
    #14 Ben_is_lol, 3 Apr. 2012
    Zuletzt von einem Moderator bearbeitet: 3 Apr. 2012
    Das ist wohl war!
    Bin quasi reingeschmissen worden in den Asterisk und versuche mich jetzt durchzufrimeln.

    Kann ich irgendwie prüfen ob z.B. die 2999 irgendwo vorher abgefangen/abgefragt wird?
     
  15. rentier-s

    rentier-s Guest

    Code:
    dialplan show 2999@
    Du zitierst wohl sehr gerne, oder? Etwas zu gerne vielleicht. :rolleyes:
     
  16. Ben_is_lol

    Ben_is_lol Neuer User

    Registriert seit:
    1 Feb. 2012
    Beiträge:
    14
    Zustimmungen:
    0
    Punkte für Erfolge:
    0
    :cool: gewöhnt man sich schnell in Auto Foren an;).

    Wenn ich den Dial abfrage (habe die 2999 gegen die 91 getauscht, die 91 passt besser zur algemeinen Nummernvergabe unseres Asterisk) sagt er mir:

    Code:
    [ Context 'sip-internal' created by 'pbx_config' ]
      '_ZX' =>          1. SIPAddHeader("Alert-Info: <http://www.domain>;info=alert-internal;x-line-id=0") [pbx_config]
                        2. Dial(SIP/${EXTEN})                         [pbx_config]
                        3. Busy()                                     [pbx_config]
    call*CLI>
    [ Context 'zap-external' created by 'pbx_config' ]
      '91' =>           1. VoiceMailMain(${CALLERID(num)}|s)          [pbx_config]
    call*CLI>
    [ Included context 'zap-external' created by 'pbx_config' ]
      '91' =>           1. VoiceMailMain(${CALLERID(num)}|s)          [pbx_config]
    call*CLI>
    [ Included context 'sip-internal' created by 'pbx_config' ]
      '_ZX' =>          1. SIPAddHeader("Alert-Info: <http://www.domain>;info=alert-internal;x-line-id=0") [pbx_config]
                        2. Dial(SIP/${EXTEN})                         [pbx_config]
                        3. Busy()                                     [pbx_config]
    call*CLI>
      Ignore pattern => '9'                                           [pbx_ael]
      Ignore pattern => '9'                                           [pbx_ael]
      Ignore pattern => '9'                                           [pbx_ael]
      Ignore pattern => '9'                                           [pbx_ael]
      Ignore pattern => '9'                                           [pbx_ael]
      Ignore pattern => '9'                                           [pbx_ael]
      Alt. Switch =>    'DUNDi/e164'                                  [pbx_ael]
    Scheint also so das die exten im entsprechendem context "sip-internal" gefunden wird, bleibt also nur die Frage warum diese nicht ausgeführt wird.

    Folgende Info zum ablauf der Contexte (von oben nach unten):
    include => zap-external
    include => zap-internal
    include => zap-internal-door
    include => misdn-external
    include => misdn-internal
    include => sip-internal
    include => parkedcalls
     
  17. rentier-s

    rentier-s Guest

    Hm, das müsste eigentlich funktionieren. Setz die exten=>91,... probehalber mal direkt vor die exten=>_ZX,... im sip-internal.
     
  18. Ben_is_lol

    Ben_is_lol Neuer User

    Registriert seit:
    1 Feb. 2012
    Beiträge:
    14
    Zustimmungen:
    0
    Punkte für Erfolge:
    0
    #18 Ben_is_lol, 4 Apr. 2012
    Zuletzt bearbeitet: 4 Apr. 2012
    Code:
    [ Context 'sip-internal' created by 'pbx_config' ]
      '91' =>            1. VoiceMailMain(${CALLERID(num)}|s)          [pbx_config]
      '_ZX' =>          1. SIPAddHeader("Alert-Info: <http://www.domain>;info=alert-internal;x-line-id=0") [pbx_config]
                           2. Dial(SIP/${EXTEN})                                [pbx_config]
                           3. Busy()                                                 [pbx_config]
    
    [ Included context 'sip-internal' created by 'pbx_config' ]
      '91' =>            1. VoiceMailMain(${CALLERID(num)}|s)          [pbx_config]
      '_ZX' =>          1. SIPAddHeader("Alert-Info: <http://www.domain>;info=alert-internal;x-line-id=0") [pbx_config]
                           2. Dial(SIP/${EXTEN})                                [pbx_config]
                           3. Busy()                                                 [pbx_config]
    
    Okay also geht leider auch nicht, CLI gibt wie immer nur ringing aus.
    Der nochmalige CLI abruf "dialplan show 91@" ergab nun folgendes.

    Aber was jetzt geht ist der Anrufbeantworter :kasper::kasper:, dieser kann schon angewählt werden unter der 91.
    Sagt auch das keine neuen Nachrichten verfügbar sind.
     
  19. rentier-s

    rentier-s Guest

    Was hast Du erwartet? Die exten für VoiceMailMain hat noch nichts mit ankommenden Anrufen zu tun.

    Jetzt musst Du wie bereits erwähnt beim Dial ein Timeout setzen, und direkt als nächste Priorität hinter dem Dial Deine exten=>...,Voicemail() einfügen, genau wie hier beschrieben.

    Solange das Telefon klingelt, wirst Du auf dem CLI übrigens auch nichts von wegen Voicemail sehen, der Befehl wird ja erst ausgeführt nachdem das Dial abgeschlossen ist.
     
  20. Ben_is_lol

    Ben_is_lol Neuer User

    Registriert seit:
    1 Feb. 2012
    Beiträge:
    14
    Zustimmungen:
    0
    Punkte für Erfolge:
    0
    [sip-internal]
    exten => 62,1,Dial(SIP/62,5)
    exten => 62,2,VoiceMail(62,u)
    exten => 91,1,VoiceMailMain(${CALLERID(num)},s)

    So sieht der Dial jetz in der extensions.conf aus, leider geht die Voicemail einfach nicht ran...:mad: es ist zum Mäuse melken.

    exten => 62 ist auch unter den hints in der extensions.conf vermerkt, könnte dies etwas damit zu tun haben?