Zoiper App als IP-Telefon an der Fritz!Box 7390 anmelden

tooloo

Neuer User
Mitglied seit
16 Dez 2016
Beiträge
26
Punkte für Reaktionen
1
Punkte
3
Ich habe mal eine kleine Kurzanleitung geschrieben:

ZoiperApp als IP-Telefon an Fritz!Box anmelden:

- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -
Diese Methode funktioniert im Heimnetzwerk & über Internet (hier aber nur über VPN)

Fritz!Box:
Neues IP Telefon anlegen.
Man erhält einen Namen und ein Passwort (selbst gewählt)

ZoiperApp:
Neuen Account anlegen => Manual configuration => SIP account

Account name: beliebig z.B.: Fritz!Box
Domain: fritz.box (oder IP der Fritz!Box)
User name: der Name
Passwort: das Passwort
Celler ID: beliebig (wird bei internen Gesprächen beim Angerufenen angezeigt)

Dann im Account der ZoiperApp noch diese Einstellungen vornehmen:
Network Settings > Transports: von UDP auf TCP setzen
Network Settings > Enable STUN ausschalten

- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -

Diese Methode funktioniert im Heimnetzwerk & über Internet (auch ohne VPN)
Dank an @koyaanisqatsi für diese Methode.


1. Fritz!Box mit My FRITZ-Konto für den Internetzugriff vorbereiten (HTTPS aktivieren) bei: Internet / MyFRITZ!-Konto
Wenn alles Ok ist steht unter Internet / Online-Monitor / MyFritz! die Internetadresse der FritzBox: https://xxxx.myfritz.net


2. IP-Telefon in der Fritz!Box anlegen (Benutzernamen und Passwort merken)
Dieses IP-Telefon noch einmal bearbeiten und Anmeldung aus dem Internet erlauben aktivieren (bei Anmeldedaten)


3. Neuen Account in der ZoiPer App anlegen: Settings > Accounts > [+] > Yes > Manual configuration > SIP account


SIP OPTIONS
Account name: < beliebig z.B. 'Fritz!Box' >
Domain: xxxx.myfritz.net:5060 (ohne 'https://', :5060 anfügen)
User name: Benutzernamen
Password: Passwort
Caller ID: < beliebig z.B. 'iPhone' >


ADVANCED SETTINGS
Auth Username: < frei lassen>
Use Outbound Proxy: ON
Outbound Proxy: xxxx.myfritz.net (ohne 'https://')




ADDITIONAL SETTINGS > Network Settings
Transports TCP


Enable STUN: ON


Jetzt kann der Account registriert werden. ( 'zurück' > REGISTER)


Settings > Incoming Calls > Force background & Wi-Fi Keep Alive aktivieren
(Das stellt sicher, dass man auch erreichbar ist wenn ZoiPer im Hintergrund ist oder sich das Gerät in Standby befindet)

- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -


getestet mit iOS 6 & iOS 8.
Klappt so ganz gut. Das einzige was noch zu bemängeln ist: die Ein- und Ausgabe auf dem iOS device (Bei mir jeweils ein iPod Touch) ist relativ leise.
Wenn da jemand einen Tip hätte, wäre ich dankbar.

 
Zuletzt bearbeitet:
  • Like
Reaktionen: koyaanisqatsi

tokelau

Neuer User
Mitglied seit
17 Nov 2004
Beiträge
53
Punkte für Reaktionen
0
Punkte
6
Hallo, bei host bzw. domain gehört hinter den registrar ":5060". Dersekbe Name, allerdings jetzt ohne ":5060" ist dann unter outbound proxy einzutragen. Dann habe ich selber beim STUN den auf nutze Voreinstellungen gesetzt, dies als Voraussetzung dafür, dass zoiper die Box über Internet und nicht nur lokales WLAN erreichen kann. Allerdings bedarf es dann der IV4-Adresse, die in der GUI der Box mit https://...:Port-Nummer erscheint. Die Box selber muss so eingerichtet werden, dass sie über das Internet tatsächlich erreichbar ist. Dann kannst Du alle Deine in der Box definierten Nummern samt internen Nummern nutzen. Zumindest für Android gibt es sogar eine weitere App, mit der Box sich steuern lässt, z.B. vordefinierte Unrufumleitungen ein/aus etc. etc. Dann ist es schon so, als sitze man im Auto oder im Hotel vor der heimischen Box und deren Telefone.
 

tooloo

Neuer User
Mitglied seit
16 Dez 2016
Beiträge
26
Punkte für Reaktionen
1
Punkte
3
Das hört sich interessant an.
Ich mache den Fernzugang über Internet mit VPN.
Funktioniert das nach deiner Beschreibung ohne VPN?

- - - Aktualisiert - - -

Ich hoffe, ich habe dich richtig verstanden.
Domain: https://xxxxxxxxxxx.myfritz.net:5060 (Stand bei Fritzbox/Online-Monitor/MyFritz! und ist grün)
Use Outbound Proxy ist eingeschaltet.
Outbound Proxy: https://xxxxxxxxxxx.myfritz.net
Auth Username: >freigelassen>
Enable STUN ist eingeschaltet

Mit diesen Einstellungen lässt sich der Account leider nicht registrieren. Es gibt auch keine Fehlermeldung.
 

koyaanisqatsi

IPPF-Urgestein
Mitglied seit
24 Jan 2013
Beiträge
12,192
Punkte für Reaktionen
291
Punkte
83
Moin

Post #1 zeigt die Einstellungen für lokale Anmeldung und für VPN.
...da ja VPN ins lokale Netzwerk führt.
Wichtig: Kein STUN aktivieren

@tooloo: VoIP ist SIP/RTP, entferne also: "https://"
Abgesehen davon müsste der SIP-Registrar (620-629) für eine direkte Registrierung übers Internet in der Fritz!Box "scharfgeschaltet" werden.
Das ist nicht empfehlenswert und für VPN nicht nötig.
Bitte freunde dich (mehr?) mit der VPN Methode an (VPN: dort benötigst du deine myfritz.net Adresse).
...dass klappt dann auch über das CGN des Mobilfunkinternets (SIM-Karte) und ist auch übers fremde WLAN-Internet sicherer (VPN-Verschlüsselung).
 
Zuletzt bearbeitet:

tooloo

Neuer User
Mitglied seit
16 Dez 2016
Beiträge
26
Punkte für Reaktionen
1
Punkte
3
VPN habe ich eingerichtet und die Methode aus meinem ersten Post funktioniert im lokalen Netzwerk und auch aus der Ferne.

Wenn man sich in einem sicheren Netzwerk befindet, kann es aber auch sinnvoll sein, eine Methode ohne VPN zur Verfügung zu haben, da VPN (nach meiner Erfahrung) mal unvermittelt rausspringen kann und man dann nicht mehr erreichbar ist.

Ich habe "https://" rausgenommen und jetzt sieht es so aus:
Domain: xxxxxxxxxxx.myfritz.net:5060 (Stand bei Fritzbox/Online-Monitor/MyFritz! und ist grün)
Use Outbound Proxy ist eingeschaltet.
Outbound Proxy: xxxxxxxxxxx.myfritz.net
Auth Username: >freigelassen>
Enable STUN ist eingeschaltet

Beim Versuch zu registrieren bekomme ich jetzt "(404) NOT FOUND"
Das liegt wahrscheinlich hier dran:
Abgesehen davon müss der SIP-Registrar (620-629) für eine direkte Registrierung übers Internet in der Fritz!Box "scharfgeschaltet" werden.
Was muss ich da machen?

Entschuldige bitte meine Fragen, aber die ganze Materie ist noch völlig neu für mich und ich muss noch viel lernen...
 

koyaanisqatsi

IPPF-Urgestein
Mitglied seit
24 Jan 2013
Beiträge
12,192
Punkte für Reaktionen
291
Punkte
83
Für eine direkte Registrierung übers Internet benötigst du....
Screenshot_2016-12-22-10-34-15.png
...mit "supersicheren" Passwort.
 

tooloo

Neuer User
Mitglied seit
16 Dez 2016
Beiträge
26
Punkte für Reaktionen
1
Punkte
3
Jetzt klappt's! :p
Ausgehende Telefonate funktionieren! Auch interne Kurzwahlen.

Aber ich kann damit nicht angerufen werden. :(
Auf der Fritzbox scheint alles richtig zu sein. Denn mit der Methode aus meinem ersten Post klingelt mein iPod wenn ich angerufen werde…
Muss ich bei der ZoiperApp noch was berücksichtigen? (Die beiden Optionen bei 'Settings/Incoming Calls' sind aktiviert)

- - - Aktualisiert - - -

Kommando zurück.
Es funktioniert alles, ich kann auch angerufen werden. (Mein Fehler!)

@koyaanisqatsi
Vielen Dank für Deine Tips. Ich habe wieder was gelernt. :D

- - - Aktualisiert - - -

Habe meinen ersten Post editiert, damit der Nächste, der danach sucht, es leichter hat.
 

tokelau

Neuer User
Mitglied seit
17 Nov 2004
Beiträge
53
Punkte für Reaktionen
0
Punkte
6
das mit dem STUN deaktiviert halten hängt eben davon ab, auf welchem Weg Zoiper ins Internet geht. Verwende ich mobiles Internet, d.h. das Handy ist selbst das Modem, dann kann STUN deaktiviert bleiben. Verwende ich WLAN im Hotel oder Shopping-Center, dann braucht es für die Weiterleitung eben schlicht und einfach STUN, sonst kommt der Verbindungsaufbau nicht zustande. Ich benötigte auch einige Wochen Prübelei, bis ich das auf Umwegen herausfand. Korrekt ist dann wieder, dass die FB direkt aus dem Internet erreichbar sein muss, ob über myfritz.net oder einen Dynamic DNS-Dienst, spielte in meinem Fall keine Rolle. Ich verwende allerdings der Einfachheit halber myfritz.net. Wie ich schon schrieb, kann man in der Box die externe myfritz.net-Adresse nachsehen, die dann im Zoiper verwendet werden muss. Selbstverständlich muss im Telefonieabschnitt der Box unter IP-Telefone das Mobiltelefon auch noch eingerichtet sein. Dann funktioniert das Mobiltelefon via Internet wie ein direkt angeschlossenes DECT-Telefon. Korrekt ist dann wieder, dass bei direkter Nutzung via WLAN (also lokal zu Hause) STUN eher zu deaktivieren ist,
 

thedude83

Neuer User
Mitglied seit
7 Jun 2010
Beiträge
4
Punkte für Reaktionen
0
Punkte
1
Hallo

meine Fritzbox ist leider nicht direkt im Internet, aber ich kann Ports auf sie weiter-/umleiten. VPN Verbindung zu FB bekomme ich so hin, und kann mit Zoiper dann auch telefonieren. Ich würde mich aber gerne auch ohne VPN anmelden. Ich habe jetzt TCP Port 5061 extern (5060 wird von den Telekom Speedport Routern selbst verwendet und kann nicht freigegeben werden, 5061 auch so in Zoiper als Registrar eingestellt) auf 5060 an der FB weitergeleitet, aber das funktioniert noch nicht.

Welchen Port sollte ich denn auf welchen Port weiterleiten, um den Outbound Proxy Zugriff auf die FB zu bewerkstelligen? Oder noch irgendwelche anderen Ports?

Danke, Thomas
 

koyaanisqatsi

IPPF-Urgestein
Mitglied seit
24 Jan 2013
Beiträge
12,192
Punkte für Reaktionen
291
Punkte
83
Der SIP (udp/tcp) Port 5061 ist (eigentlich) für SIPS (TLS) reserviert.
Benutze stattdessen mal: (udp/tcp) 5070
 

thedude83

Neuer User
Mitglied seit
7 Jun 2010
Beiträge
4
Punkte für Reaktionen
0
Punkte
1
Also Anmeldung bekomme ich schonmal hin: Registrar fritz.box oder IP-Adresse im lokalen Netz, als Outbound Proxy DDNS-Name:5071, wobei Port 5071 auf die 5060 der FB weitergeleitet wird.

Ich kann Nummern wählen, dann klingelt die Gegenstelle, und wenn ich selbst auf der FB angerufen werde klingelt Zoiper auch.

Aber dann höre ich nix, die Gegenstelle auch nichts. Ich denke es müssen noch weitere Ports für das Audio freigegeben werden, aber welche?

Danke, Thomas
 

Comshira

Neuer User
Mitglied seit
27 Sep 2006
Beiträge
163
Punkte für Reaktionen
2
Punkte
18
Hallo,
ich hatte die letzten Tage ewig rumprobiert, um herauszufinden, warum ich trotz der oben genannten Einstellungen für ohne VPN einfach keine Anrufe auf dem externen Zoiper-Android in einem fremden WLAN signalisiert bekomme und der Anrufer auch keinen Rufton hört. Nun habe ich die Registration-Einstellungen von Zoiper für TCP auf 600s gesetzt anstatt 900s und damit scheint es zu gehen. STUN nutze ich hingegen nicht (kostet das nicht extrem viel Akku, so wie auch UDP statt TCP).

Man kann ja in Zoiper in den Kontoeinstellungen unter Netzwerk-Einstellungen die Registration expiry time setzen und Keep alive einschalten. Kommt die Fritzbox nicht damit klar, wenn man mehr als 600s einstellt oder wie muss man das verstehen?

Danke.

Ergänzung:
Gerade scheine ich die Lösung gefunden zu haben: Wenn ich bei Host zum dyndns-Namen noch das ":5060" dazumache, klappt es plötzlich - zumindest bei den letzten Tests jetzt. Ich bin noch nicht 100% sicher.

Trotzdem noch die Frage: Man verbindet ja möglichst keine SIP-Server mit UDP, jedenfalls nicht von mobilen Geräten, weil das aufgrund der kurzen Portrefreshs zu stark am Akku saugt. Aber habe ich dasselbe Problem nicht auch bei der Nutzung von TCP, wenn parallel STUN aktiviert ist?
 
Zuletzt bearbeitet:

smartie

Mitglied
Mitglied seit
30 Mrz 2005
Beiträge
425
Punkte für Reaktionen
5
Punkte
18
Hallo zusammen,
ich hatte Zoiper schon länger im Einsatz... seit kurzem funktioniert es bei mir aber nicht mehr, ich bekomme immer die Fehlermeldung "Not Found (404)". Ich habe mir dann mal die Settings in der FB angeschaut, dort war komischerweise der Haken bei "Anmeldung aus dem Internet" weg. Um den wieder zu setzen, musste ich aber den Benutzernamen (war vorher standard 620) ändern, war ja kein Problem.

Den Benutzernamen habe ich für die Anmeldung dann auch in Zoiper eingetragen, trotzdem die gleiche Fehlermeldung... Manchmal auch "Request Timeout (408)" Hat noch jemand eine Idee?

Ich möchte Zoiper eigentlich nur als "Backup", falls ich mal kein VPN aufbauen kann/will, denn dann kann man ja auch Fritz!Fon (oder Hometalk) verwenden, d.h. es geht mir nur um die "externe" Variante.
 

stoney

Moderator
Teammitglied
Mitglied seit
7 Okt 2015
Beiträge
5,468
Punkte für Reaktionen
421
Punkte
83
Wie viele Zeichen hat denn der Benutzer jetzt? 8 ?

Teste doch mal mit
Benutzer: 12345678
Kennwort: 87654321
 

smartie

Mitglied
Mitglied seit
30 Mrz 2005
Beiträge
425
Punkte für Reaktionen
5
Punkte
18
Vollzitat entfernt by stoney
Nein es sind 6 Zeichen... konkret, Buchstaben... Meinst Du wirklich es hat mit dem Namen zu tun? Na ich kann das bei Gelegenheit noch mal testen..
 

stoney

Moderator
Teammitglied
Mitglied seit
7 Okt 2015
Beiträge
5,468
Punkte für Reaktionen
421
Punkte
83
Um welche HW und FW geht es Dir denn eig.?

Welche FW Version war es zuvor?
 

Manne44

Neuer User
Mitglied seit
30 Mai 2014
Beiträge
55
Punkte für Reaktionen
0
Punkte
6
Hallo, ich habe mal einige dumme Fragen, weil ich eigentlich keine Ahnung habe.
Was will ich? Mit dem Smartphone über die Fritzbox über meine Festnetznummer telefonieren und Gespräche empfangen, egal ob ich im heimischen Wlan oder im Vodafone-Mobilnetz unterwegs bin.
Ich habe mir VPN auf dem Smartphone erstellt, in einem AVM-Video sollte das auch die MyFritzApp 2 automatisch machen, ging aber nie, so dass ich das "händisch" eingetragen habe. Klappt, VPN ist da.
Dann Zoiper heruntergeladen und konfiguriert, so wie im Anfang dieses Threads beschrieben. Geht auch, aber ich kann mir nicht vorstellen, dass ich mit Host 192.168.178.1:5060 auch vom Mobilfunknetz meine FB 7490 erreiche. Wie kann ich denn überprüfen, ob da die Verbindung wirklich über VPN durchgeführt wird?
Wenn ich die zweite Methode verwende, also als Host xxxx.myfritz.net:5060 eintrage, dann kommt immer
"Anmeldung fehrlgeschlagen (Transport failure: no transports left to try (503))".
Kann mir da mal jemand helft oder sagen wo ich da was finde?
Also ich habe ein Samsung S9+ mit Android 8.0 und FB7490, nur so zur Info. Und Zoiper sieht auch ganz anders aus als in allen Beschreibungen, die ich bisher gesehen habe.
Gruß
Manne44
 

stoney

Moderator
Teammitglied
Mitglied seit
7 Okt 2015
Beiträge
5,468
Punkte für Reaktionen
421
Punkte
83
Wenn ich die zweite Methode verwende, also als Host xxxx.myfritz.net:5060 eintrage, dann kommt immer
"Anmeldung fehl....
Anmeldung aus dem Internet ist erlaubt wie in #6 gezeigt, ebenso hat der Benutzer und dessen KW min. 8 Zeichen?
 

Manne44

Neuer User
Mitglied seit
30 Mai 2014
Beiträge
55
Punkte für Reaktionen
0
Punkte
6
Vielen Dank, aber beim Kennwort werden kleinere als 8 Zeichen nicht mehr akzeptiert. Es sind sowohl beim Kennwort als auch beim Benutzernamen mehr oder gleich 8 Zeichen. Das kann nicht der Grund sein.
Wenn ich mich außerhalb des eigenen Wlan befinde, dann erfolgt bei der Methode 1 zwar auch ein Ruf, aber mit unverständlicher, abgehackter Sprache. Ratlos.
 
3CX

Neueste Beiträge

Statistik des Forums

Themen
234,931
Beiträge
2,053,436
Mitglieder
355,254
Neuestes Mitglied
fascha13