[Problem] 7240 -inet per lan1 - vpnc - iptables - Verbindung für angeschlossene Geräten?

yxt

Neuer User
Mitglied seit
12 Mrz 2012
Beiträge
5
Punkte für Reaktionen
0
Punkte
0
Firmware-Version 73.04.88freetz-1.2_rc2

Hi @ll,

ich mache heut schon den ganzen Tag rum (zieht sich wenn die fritz-linux-vm auf einem ein-kern-atom läuft ;-) ), aber komm nicht weiter :(

EDIT: hängt mit inet per lan1 zusammen, habe die Beschreibung mal angepasst.

Hänge ich die box direkt an dsl steht die Verbindung direkt für alle Geräte zur Verfügung.

Nutzt die fb eine bestehende Internetverbindung per lan1 funktioniert es nicht mehr

vpnc startet ohne Fehler, VPN Verbindung funktioniert auf der box, bekomme es aber nicht hin die Verbindung auch den angeschlossenen Rechnern zur Verfügung zu stellen.
Die box leitet alles per lan1 statt tun0 weiter. Der komplette traffic soll aber über vpn laufen.


iptables startet auch ohne fehler, habe aber keine Ahnung wie ich es konfigurieren muss.

das hier oft gelesene
Code:
iptables -A FORWARD -o tun0 -j ACCEPT
iptables -A FORWARD -i tun0 -j ACCEPT
iptables -t nat -A POSTROUTING -o tun0 -j MASQUERADE
funktioniert leider nicht.

Jemand eine Idee?


Der nächste Punkt wäre dann ein auto-reconnect wenn die Verbindung nach 12h beendet wird?
 
Zuletzt bearbeitet:

Suchiman

Mitglied
Mitglied seit
8 Apr 2011
Beiträge
320
Punkte für Reaktionen
0
Punkte
0
Du hast zwar vielleicht iptables drauf, die AVM firewall selbst kann man aber nicht abschalten, dort musst du ebenfalls Port forwarding aktivieren. Mit iptables entsteht ein fieses doppelt gemoppelt
 

yxt

Neuer User
Mitglied seit
12 Mrz 2012
Beiträge
5
Punkte für Reaktionen
0
Punkte
0
thx für deine Antwort Suchiman.

EDIT: liegt an inet per lan1 --> Anfangspost editiert
 
Zuletzt bearbeitet: