.titleBar { margin-bottom: 5px!important; }

Authentifizierung an Freigaben immer wieder notwendig

Dieses Thema im Forum "IP-TV" wurde erstellt von x-hugo-hugo, 16 Feb. 2009.

  1. x-hugo-hugo

    x-hugo-hugo Neuer User

    Registriert seit:
    10 Feb. 2006
    Beiträge:
    103
    Zustimmungen:
    0
    Punkte für Erfolge:
    0
    Hallo,


    ich verwende als zentrales Share für meine Mediensammlung einen 2003-er Server.

    Auf der IP1101 ist der aktuelle SOT-Client installiert. Das Mapping der der Freigaben erfolgt wie vorgesehen in der startup-Datei.

    Die IP1101 fährt ohne Felermeldung hoch. Die Freigaben werden gemappt und auch im Fileexplorer angezeigt. Sobald ich allerdings eine Freigabe öffnen möchte, erscheint der Authentifizierungsbildschirm. Wenn ich hier nochmals meine Anmeldeinfos eingebe, klappt auch der Zugriff - allerdings nur für ca. 5-10 Minuten... Dann erscheint der Dialog erneut und ich muss wieder Username und Passwort eingeben. Das Spielchen läßt sich beliebig lange im 5-10 Minuten Takt fortführen :(

    Die Windows-eigene Firewall habe ich deaktiviert.

    Die anderen Tips aus dem Wiki haben mich auch nicht weiter gebracht.

    Als Benutzername verwende ich das Administrator Account des Servers nebst Passwort.

    Hat jemand eine Idee, wie sich das Problem lösen läßt?
     
  2. angryjack

    angryjack Aktives Mitglied

    Registriert seit:
    20 Okt. 2007
    Beiträge:
    1,646
    Zustimmungen:
    0
    Punkte für Erfolge:
    0
    scheinbar hast du und User "hwei" ein ähnliches oder sogar das gleiche Problem. Hier

    Leider hat er uns keine Rückmeldung gegeben, ob er das Problem lösen konnte oder nicht. Vielleicht schickst du ihm man ne PN.

    Falls du rausbekommst woran es liegt, dann wäre es schön wenn du dies mitteilen würdest damit wir künftig nicht wieder bei Null anfangen ;)

    Gruß
    angryjack
     
  3. x-hugo-hugo

    x-hugo-hugo Neuer User

    Registriert seit:
    10 Feb. 2006
    Beiträge:
    103
    Zustimmungen:
    0
    Punkte für Erfolge:
    0
    Den Thread hatte ich wohl übersehen...

    Auf jeden Fall bin ich über Umwege zum Ziel gekommen. Der Hinweis von Gismotro auf "NetworkKeepAlive=1" hat dazu geführt, dass der SOT Client den Anmeldebildschrim schon unmittelbar nach dem Start angezeigt hat - also wenn die Übersicht mit den eigenen Buttons und dem SOT-Hintergrundbild erscheint.

    In jedem Fall recht komisch. So was hatte ich noch nicht...

    Habe dann als Alternative das Mapping über die Sot.ini vorgenommen und in der Startup.cmd auskommentiert.

    Jetzt funktioniert alles wieder.

    Vielleicht liegt das an meiner etwas unkonventionellen Art den SOT-Client auf einer zweiten CF installiert zu haben (Hard Disk2)...
     
  4. Joe_57

    Joe_57 IPPF-Promi

    Registriert seit:
    5 März 2006
    Beiträge:
    4,859
    Zustimmungen:
    40
    Punkte für Erfolge:
    48
    Hallo x-hugo-hugo,

    ich habe eine ähnliche Konfiguration wie deine (keine 2 CF-Karten, sondern eine mit 2 Partitionen).

    Wie hast du denn den Parameter in der sot.ini nun endgültig gesetzt? :noidea:

    NetworkKeepAlive=1 oder auf
    NetworkKeepAlive=0 ?
    Joe
     
  5. x-hugo-hugo

    x-hugo-hugo Neuer User

    Registriert seit:
    10 Feb. 2006
    Beiträge:
    103
    Zustimmungen:
    0
    Punkte für Erfolge:
    0
    Hi Joe, Du warst schneller mit Deiner Antwort als ich meinen Beitrag editieren konnte: Es funktioniert doch nicht...

    Unabhängig davon, wie der Parameter gesetzt ist.

    Auf meinem Server sehe ich im Eventlog das Ereignis mit dem Eintrag 538. Das bedeutet, dass der User sich abgemeldet hat. So richtig nachvollziehen kann ich das nicht.

    Hast Du das selbe Problem?
     
  6. angryjack

    angryjack Aktives Mitglied

    Registriert seit:
    20 Okt. 2007
    Beiträge:
    1,646
    Zustimmungen:
    0
    Punkte für Erfolge:
    0
    Vielleicht ist es sinnvoll mit Wireshark mal aufzuzeichnen was da an Netzwerkkommunikation zwischen Box und Server passiert.

    WS installieren und dann unter "Capture" den Netzwerkadapter auswählen. Unter "Capture Filter" "host IP_der_Box" eingeben. Dann Box hochfahren und wenn sie hochgefahren ist das Capture starten.

    Ist der Reconnect gemacht, dann Aufzeichnung anhalten, das letzte TCP-Paket markieren, rechte Maustaste und "Follow TCP-Stream" auswählen. Dann sollte die bidirektionale Kommunikation der Box angezeigt werden.

    angryjack
     
  7. x-hugo-hugo

    x-hugo-hugo Neuer User

    Registriert seit:
    10 Feb. 2006
    Beiträge:
    103
    Zustimmungen:
    0
    Punkte für Erfolge:
    0
    was meinst Du mit "ist der Reconnect gemacht"?

    Bzw. wann soll ich die Aufzeichnung anhalten? Wenn ich darüber nachdenke, müßte ich die Aufzeichnung doch dann stoppen, wenn die Wiedergabe abbricht und ich das Authentifizierungsfenster angezeigt bekomme. Richtig?

    Das habe ich schon mal gemacht. Allerdings war das Ergebnis recht unauffällig (zumindest für mich)...

    Nur kurz zur Info für alle, die es interessiert: Wenn ich mit meinem Client (anderer PC) auf den Server zugreife, hatte ich manchmal die Fehlermeldung erhalten, dass nicht genügend Serverspeicher vorhanden ist. Habe dann über den Registryeintrag "IRPStackSize" das Problem behoben. Das Problem mit der IP1101 ist damit aber immer noch nicht gefixt.
     
  8. angryjack

    angryjack Aktives Mitglied

    Registriert seit:
    20 Okt. 2007
    Beiträge:
    1,646
    Zustimmungen:
    0
    Punkte für Erfolge:
    0
    Ja, genau wenn das Authentifizierungsfenster wieder kommt kannst du die Aufzeichnung anhalten.

    Du kannst ja dann den kompletten WS-Trace mal posten, vielleicht sieht man ja was.

    Übrigens, hast du statische IP's vergeben oder dynamisch über DHCP ? Falls du DHCP eigestellt hast, wäre ja mal interessant ob sich das Problem auch bei festen Adressen einstellt oder nicht.

    Gruß
    angryjack
     
  9. x-hugo-hugo

    x-hugo-hugo Neuer User

    Registriert seit:
    10 Feb. 2006
    Beiträge:
    103
    Zustimmungen:
    0
    Punkte für Erfolge:
    0
    Ok. Das mache ich mal morgen, wenn ich zu Hause bin und poste den Trace.

    IP-Adressen verwende ich soweit möglich in fester Form. Die IP1101 bezieht Ihre IP-Adressse per DHCP von der 7270. In der 7270 Konfig habe ich vorgegeben, dass die IP1101 immer die selbe IP-Adresse erhalten soll.
     
  10. angryjack

    angryjack Aktives Mitglied

    Registriert seit:
    20 Okt. 2007
    Beiträge:
    1,646
    Zustimmungen:
    0
    Punkte für Erfolge:
    0
    #10 angryjack, 20 Feb. 2009
    Zuletzt bearbeitet: 20 Feb. 2009
    Ich glaube das dein Problem definitiv mit der DHCP Adressvergabe zu tun hat. Warum vergibt du denn nicht feste Adressen ? Hast du sooo viele Rechner am laufen das dies Sinn machen würde ?

    Auch dein anderes Problem mit dem Ablauf der Leasetime weist meines Erachtens eindeutig auf den DHCP hin.

    Ändere das doch und du bist deine Sorgen bestimmt los ;)

    angryjack
     
  11. autothorsten

    autothorsten Neuer User

    Registriert seit:
    16 Sep. 2007
    Beiträge:
    17
    Zustimmungen:
    0
    Punkte für Erfolge:
    0
    Hallo,

    ich hatte auch das Problem mit der ständigen neu Anmeldung.

    Die Lösung war folgende.

    Ich habe die Netzwerkpfade aus der Startup auskommentiert (mit :).

    Ich habe nur noch die Netzwerkpfade in der SOT.ini.

    Ich habe eine Feste IP Adresse vergeben.

    Gruß

    autothorsten
     
  12. suedharzer

    suedharzer Mitglied

    Registriert seit:
    25 Okt. 2006
    Beiträge:
    442
    Zustimmungen:
    0
    Punkte für Erfolge:
    0
    Ort:
    Bayern
    So genau kann man das leider nicht sagen.

    Ich habe von Anfang an, die Freigaben in der startup stehen,
    habe feste IP's und noch nie diese Probleme gehabt.
    Außer wenn ich, während die Box lief, den PC (XPhome SP3) mit den Freigaben
    runter gefahren oder neu gebooted habe - dann fragt die Box wieder nach.
     
  13. x-hugo-hugo

    x-hugo-hugo Neuer User

    Registriert seit:
    10 Feb. 2006
    Beiträge:
    103
    Zustimmungen:
    0
    Punkte für Erfolge:
    0
    So, hier des Rätsels Lösung:

    Um eindeutig zu regeln, welches Endgerät in meinem Netz, welche IP-Adresse bekommt, hatte ich am DHCP Server der 7270 die entsprechenden Haken gesetzt. Den Haken bei der IP1101 rausgenommen und das Problem ist weg. Erklären kann ich das nicht, aber ich denke, dass sich die IP1101 und der DHCP Server der Fritzbox nicht richtig vertragen...

    @angryjack: richtig. Habe zu viele Kisten am laufen... In jedem Fall VIELEN Dank für den Tip mit DHCP :groesste:

    @autohorsten: das Mapping der Freigaben von der startup.cmd in die sot.ini zu verlegen, brachte keinen Erfolg.
     
  14. Abyss

    Abyss Neuer User

    Registriert seit:
    23 März 2009
    Beiträge:
    1
    Zustimmungen:
    0
    Punkte für Erfolge:
    0
    Des Rätzels Lösung -Teil 2-

    Hallo zusammen,
    erst mal vielen Dank für die Unterstützung des SOT-Clients hier im Forum.

    Da meine Ausgangssitutation fast die gleiche wie der von x-hugo-hugo war, hatte ich logischerweise auch die gleichen Probleme wie x-hugo-hugo.:eek:

    Jedenfalls war das Abschalten der Option "Diesem Netzwerkgerät immer die gleiche IP-Adresse zuweisen." auf der FritzBox nur eine Linderung, nicht die Lösung. Sobald das innerhalb des SOT-Clients z.B. das SOT-Portal gestartet und beendet wurde und auf SOT-Client-Oberfläche zurückgekehrt wurde, war er wieder da, der böse Authentifizierungsdialog.

    Erst ein kompletter Verzicht auf DHCP bzw. das Einstellen einer fester IP-Adresse auf der IP1101PC brachte die ganze Sache sauber zum laufen.
    Ob nun die Shares in der SOT.ini oder per startup.cmd gemappt werden, macht meiner Erfahrung nach keinen Unterschied.

    Um sicher zu sein, dass der Share nicht seitens des Servers getrennt wird, sollte man unter W2k3-Server oder unter Windows 2000 Prof. noch die lokalen Sicherheitsrichtlinien anpassen (der Timeout steht per Default auf 15min). Eine Einstellung die über die tägliche Online-Zeit der IP1101PC hinausgeht, bzw. eine 0 für keinen Timeout bringt einen auf die sichere Seite.

    Ich hoffe, dass ich als Newbie jetzt nicht geschlachtet werde, weil ich mich getraut habe x-hugo-hugo zu widersprechen.
     
  15. x-hugo-hugo

    x-hugo-hugo Neuer User

    Registriert seit:
    10 Feb. 2006
    Beiträge:
    103
    Zustimmungen:
    0
    Punkte für Erfolge:
    0
    Erstmal ein herzliches Willkommen im Forum!!!


    Wir schlachten hier niemanden :beerdigu:

    Und erst recht keine :newbie:s