[HowTo] Cisco 8941 an Fritzbox 7390 & 7490

LaUs3r

Neuer User
Mitglied seit
13 Okt 2015
Beiträge
22
Punkte für Reaktionen
1
Punkte
3
Hallo zusammen,

nach etlichen Stunden an Fehlersuche in der Config meines Cisco 8941-Telefons, Wireshark-Logs, Fritzbox-Downgrades und Internet-Recherche habe ich schlußendlich ein stabiles und vor allem funktionierendes VoIP-System am Laufen.

Die Lösung und Stolpersteine möchte ich euch nicht vorenthalten.
Begonnen hat im Grunde alles mit dem Upgrade der Fritbox und der Erhöhung der Komplexitätsanforderungen an Username und Password mit Version 6.60 und dann 6.83.
Vor dem Upgrade auf 6.60 hat alles wunderbar funktioniert, da ich die vorgegebenen Usernamen wie z.B. 620, 621, etc. verwendet habe.
Bei dem Upgrade auf 6.60 konnte ich mir noch behelfen, indem ich eine alte Sicherung der FB eingespielt habe und auf die bereits existierenden Geräte die neuen Komplexitätsanforderungen nicht angewendet wurden. Somit hat zunächst alles gepasst und ich habe gar nicht mitbekommen, dass sich die Anforderungen geändert haben.
Bei Version 6.83 wurde dann alles anders und ich war gezwungen die Config meines Cisco-Telefons anzupassen. Cross-Checks mit anderen Softphones an der FB habe ich natürlich gemacht und hier hat auch alles auf Anhieb funktioniert.

Demzufolge habe ich Username und Password geändert, die Cisco-Config angepasst und alles sollte passen - war aber nicht so.
Das Cisco-Phone konnte sich nicht mehr registrieren bzw. registrierte sich dann irgendwann sporadisch, aber beim Anrufen ertönte immer ein Besetztzeichen.

Die Lösung: in meinem Fall super simple. In der Cisco-Config muss der <name> = <authname> = FB-Username sein. Ich hatte bis dato immer nur sichergestellt, dass der <authname> = FB-Username ist :-/
Mit FB-Username ist der Benutzername bei den Anmeldedaten des Telefoniegerätes in der FB gemeint

Deshalb waren die Wireshark-Logs für mich auch nicht plausible, da ich einen 404-Not found-Error bekommen habe.

Durch Zufall habe ich nun die Lösung gefunden. Nachdem ich auch im Netz keinerlei Config für ein Cisco 8941 gefunden habe, hier nun meine Config.

Zunächstunächst die aktuellen Eckdaten des Systems:
- Phone: Cisco 8941, cmterm-894x-sip.9-4-2SR3-1
- Fritzbox 7390 & 7490, FRITZ!OS 6.83
- Asterisk 1.8.8.2, DHCP (ISC-DHCPD) und TFTP (aTFTPD) auf einem Raspberry PI

Und hier die Config - ich wollte eigentlich den kompletten TFTP-Ordner hochladen, aber die Cisco-Firmware ist zu groß.
Hier zumindest ein Link auf einen Hoster und untenstehenden die Files als Code, sowie die Configs in der ZIP ohne Firmware
https://www.sendspace.com/file/4u9y1a

SEP+MAC.cnf.xml
Code:
<?xml version="1.0" encoding="UTF-8"?>
<device>
    <deviceProtocol>SIP</deviceProtocol>
    <sshUserId>admin</sshUserId> <!-- Benutzer-->
    <sshPassword>GEHEIM</sshPassword> <!-- Passwort-->
    <devicePool>
        <dateTimeSetting>
            <name>W.Europe</name>
            <dateTemplate>D.M.Y</dateTemplate>
            <timeZone>W. Europe Standard/Daylight Time</timeZone>
            <ntps>
                <ntp>
                    <name>192.168.0.1</name>                 <!-- NTP-Server-->
                    <ntpMode>Unicast</ntpMode>
                </ntp>
            </ntps>
        </dateTimeSetting>
        <callManagerGroup>
            <members>
                <member priority="0">
                    <callManager>
                        <processNodeName>192.168.0.1</processNodeName> <!-- IP Adresse Fritzbox-->
                        <ports>
                            <ethernetPhonePort>2000</ethernetPhonePort>                         
                            <sipPort>5060</sipPort>
                            <securedSipPort>5061</securedSipPort>
                        </ports>
                    </callManager>
                </member>
            </members>
        </callManagerGroup>
    </devicePool>
    <sipProfile>
        <sipProxies>
            <registerWithProxy>true</registerWithProxy>
        </sipProxies>
        <transportLayerProtocol>4</transportLayerProtocol>
        <sipCallFeatures>
         <cnfJoinEnabled>true</cnfJoinEnabled>
         <callForwardURI>x--serviceuri-cfwdall</callForwardURI>
         <callPickupURI>x-cisco-serviceuri-pickup</callPickupURI>
         <callPickupListURI>x-cisco-serviceuri-opickup</callPickupListURI>
         <callPickupGroupURI>x-cisco-serviceuri-gpickup</callPickupGroupURI>
         <meetMeServiceURI>x-cisco-serviceuri-meetme</meetMeServiceURI>
         <abbreviatedDialURI>x-cisco-serviceuri-abbrdial</abbreviatedDialURI>
         <rfc2543Hold>false</rfc2543Hold>
         <callHoldRingback>2</callHoldRingback>
         <localCfwdEnable>true</localCfwdEnable>
         <semiAttendedTransfer>true</semiAttendedTransfer>
         <anonymousCallBlock>2</anonymousCallBlock>
         <callerIdBlocking>2</callerIdBlocking>
         <dndControl>0</dndControl>
         <remoteCcEnable>true</remoteCcEnable>
        </sipCallFeatures>
        <sipStack>
         <sipInviteRetx>6</sipInviteRetx>
         <sipRetx>10</sipRetx>
         <timerInviteExpires>180</timerInviteExpires>
         <timerRegisterExpires>3600</timerRegisterExpires>
         <timerRegisterDelta>5</timerRegisterDelta>
         <timerKeepAliveExpires>120</timerKeepAliveExpires>
         <timerSubscribeExpires>120</timerSubscribeExpires>
         <timerSubscribeDelta>5</timerSubscribeDelta>
         <timerT1>500</timerT1>
         <timerT2>4000</timerT2>
         <maxRedirects>70</maxRedirects>
         <remotePartyID>false</remotePartyID>
         <userInfo>None</userInfo>
      </sipStack>
      <autoAnswerTimer>1</autoAnswerTimer>
      <autoAnswerAltBehavior>false</autoAnswerAltBehavior>
      <autoAnswerOverride>true</autoAnswerOverride>
      <transferOnhookEnabled>false</transferOnhookEnabled>
      <enableVad>false</enableVad>
      <preferredCodec>g729a</preferredCodec>
      <dtmfAvtPayload>101</dtmfAvtPayload>
      <dtmfDbLevel>3</dtmfDbLevel>
      <dtmfOutofBand>avt</dtmfOutofBand>
      <alwaysUsePrimeLine>false</alwaysUsePrimeLine>
      <alwaysUsePrimeLineVoiceMail>false</alwaysUsePrimeLineVoiceMail>
      <kpml>3</kpml>
    <phoneLabel>OG</phoneLabel>
    <stutterMsgWaiting>2</stutterMsgWaiting>
    <silentPeriodBetweenCallWaitingBursts>10</silentPeriodBetweenCallWaitingBursts>
      <disableLocalSpeedDialConfig>false</disableLocalSpeedDialConfig>
      <startMediaPort>16384</startMediaPort>
      <stopMediaPort>32766</stopMediaPort>
        <sipLines>
            <line button="1" lineIndex="1">                 <!-- SIP Account -->
                <featureID>9</featureID>
                   <featureLabel>Hell's Kitchen</featureLabel> <!-- Name der oben im Display steht-->
                   <proxy>USECALLMANAGER</proxy>                   
                <port>5060</port>
 
        <!-- ### WICHTIG: der <name> UND <authName> muessen dem username in der Fritzbox entsprechen ### -->
            
        <name>Hell's Kitchen</name>          <!-- Name der im Telefon angezeigt wird, auf der Taste-->
        <authName>Hell's Kitchen</authName> <!-- erstelle Telefonnummer der Box-->
                <authPassword>GEHEIM</authPassword>    
            
        <messageWaitingLampPolicy>4</messageWaitingLampPolicy>    <!-- FB AB auf Brieftaste -->
                <messagesNumber>**600</messagesNumber>         
        <ringSettingIdle>4</ringSettingIdle>             <!-- Wichtig fuer Anklopfen -->
        <ringSettingActive>5</ringSettingActive>
        </line>
        <line button="2">                         <!-- Kurzwahl 2-->
        <featureID>21</featureID>
        <featureLabel>Küchen Ferkel</featureLabel>
        <speedDialNumber>**610</speedDialNumber>
        </line>    
        <line button="3">                         <!-- Kurzwahl 3-->
        <featureID>21</featureID>
        <featureLabel>Büro Ferkel</featureLabel>
        <speedDialNumber>**611</speedDialNumber>
        </line>           
        <line  button="4">                           <!-- Kurzwahl 4 Nicht stören-->
        <featureID>130</featureID>
        <featureLabel>Nicht stören</featureLabel>
        <helpID>369</helpID>
        </line>
        </sipLines>
        <dialTemplate>dialplan.xml</dialTemplate>             <!-- Dialplan, einfach mal googeln -->
    </sipProfile>
<userLocale>
    <name>en_US</name>
    <langCode>en</langCode>
</userLocale>
    <networkLocale>Germany</networkLocale>
<networkLocaleInfo>
    <name>Germany</name>
</networkLocaleInfo>
    <vendorConfig>
        <displayOnWhenIncomingCall>1</displayOnWhenIncomingCall>
        <displayIdleTimeout>00:45</displayIdleTimeout>
        <daysDisplayNotActive> ,</daysDisplayNotActive>                <!-- Display immer an -->
        <displayOnTime>00:00</displayOnTime>
        <displayOnDuration>00:00</displayOnDuration>
        <settingsAccess>1</settingsAccess>
        <webAccess>0</webAccess>                     <!-- Web Zugriff erlaubt -->
    </vendorConfig>
    <phoneServices>
        <provisioning>2</provisioning>
        <phoneService  type="1" category="0">                 <!-- verpasster Anrufe -->
            <name>Missed Calls</name>
            <url>Application:Cisco/MissedCalls</url>
            <vendor></vendor>
            <version></version>
        </phoneService>
        <phoneService  type="2" category="0">                 <!-- zum nutzen der Brieftaste -->
        <name>Voicemail</name>
        <url>Application:Cisco/Voicemail</url>
        <vendor></vendor>
        <version></version>
    </phoneService>
    <phoneService  type="1" category="0">                 <!-- empfangener Anrufe -->
            <name>Received Calls</name>
            <url>Application:Cisco/ReceivedCalls</url>
            <vendor></vendor>
            <version></version>
        </phoneService>
    <phoneService  type="1" category="0">                 <!-- getaetigte Anrufe -->
            <name>Placed Calls</name>
            <url>Application:Cisco/PlacedCalls</url>
            <vendor></vendor>
            <version></version>
        </phoneService>
 
    </phoneServices>
    <addOnModules>
        <addOnModule  uuid="" idx="1">
            <deviceType>CKEM</deviceType>
            <deviceLine>36</deviceLine>
            <loadInformation></loadInformation>
            <phoneTemplateId></phoneTemplateId>
        </addOnModule>
    </addOnModules>
    <commonConfig>                             <!-- USB, Bluetooth, WLAN(9971) -->
        <usb1>1</usb1>
        <usb2>1</usb2>
        <ciscoCamera>1</ciscoCamera>
        <usbClasses>0,1,2</usbClasses>
        <sdio>1</sdio>
        <bluetooth>1</bluetooth>
        <wifi>1</wifi>
        <bluetoothProfile>0,1</bluetoothProfile>
        <joinAndDirectTransferPolicy>0</joinAndDirectTransferPolicy>
    </commonConfig>
    <featurePolicyFile>DefaultFP.xml</featurePolicyFile>         <!-- steuert Funktionen, zB Wahlwiederholung -->
    <loadInformation>SIP894x.9-4-2SR3-1</loadInformation>              <!-- FW Version, durch die für das jeweilige Grät zu erstezen -->
</device>

XMLDefault.cnf.xml
Code:
<?xml version="1.0" encoding="utf-8" ?>
<Default>
    <callManagerGroup>
    <members>
        <member priority="0">
            <callManager>
                <ports>
                    <ethernetPhonePort>2000</ethernetPhonePort>
                </ports>
                <processNodeName>192.168.0.1</processNodeName>
            </callManager>
        </member>
    </members>
    </callManagerGroup>
    <loadInformation model="Cisco IP Phone 8941">SIP894x.9-4-2SR3-1</loadInformation>
</Default>

dialplan.xml
Code:
<DIALTEMPLATE>
    <TEMPLATE MATCH="*" Timeout="5" />
</DIALTEMPLATE>

Ringlist.xml
Code:
<CiscoIPPhoneRingList>
    <Ring>
        <DisplayName>CTU</DisplayName>
        <FileName>ctu.raw</FileName>
    </Ring>
</CiscoIPPhoneRingList>

DistinctiveRingList.xml
Code:
<CiscoIPPhoneRingList>
    <Ring>
        <DisplayName>CTU</DisplayName>
        <FileName>ctu.raw</FileName>
    </Ring>
</CiscoIPPhoneRingList>


DefaultFP.xml
Code:
<?xml version="1.0" encoding="utf-8"?>
<featurePolicy name="Default Policy">
    <versionStamp>0000000000</versionStamp>
    <featureDef name="ForwardAll">
        <id>1</id>
        <enable>false</enable>
    </featureDef>
    <featureDef name="Park">
        <id>2</id>
        <enable>false</enable>
    </featureDef>
    <featureDef name="iDivert">
        <id>3</id>
        <enable>false</enable>
    </featureDef>
    <featureDef name="ConfList">
        <id>4</id>
        <enable>false</enable>
    </featureDef>
    <featureDef name="SpeedDial">
        <id>5</id>
        <enable>true</enable>
    </featureDef>
    <featureDef name="Callback">
        <id>6</id>
        <enable>false</enable>
    </featureDef>
    <featureDef name="Redial">
        <id>7</id>
        <enable>true</enable>
    </featureDef>
    <featureDef name="Barge">
        <id>8</id>
        <enable>false</enable>
    </featureDef>
</featurePolicy>

Zum Thema Hintergrundbilder und Klingeltöne findet man etliches im Netz.
Die Grob-Config:
Die Hintergrundbilder kommen in das Verzeichnis: \TFTP\Desktops\640x480x24
Die Locale-Settings sind im Verzeichnis: \TFTP\en_us
Der Klingelton muss im Root-Verzeichnis sein, also \TFTP

Greetz
 

Anhänge

  • tftp.zip
    1.5 MB · Aufrufe: 73
Zuletzt bearbeitet:

djhans

Neuer User
Mitglied seit
19 Nov 2012
Beiträge
168
Punkte für Reaktionen
0
Punkte
16
Hallo
Was genau ist mit FB-Username gemeint? Der Benutzername in der IP-Phone Konfiguration, oder der generelle FB-Benutzer?
Christian
 
Zuletzt bearbeitet:

bt43a

Mitglied
Mitglied seit
5 Feb 2011
Beiträge
210
Punkte für Reaktionen
2
Punkte
18
Irgendwie kommen mir die Kommentare in der XML bekannt vor :D

Schöne Zusammenfassung *daumenhoch*
 
  • Like
Reaktionen: LaUs3r

LaUs3r

Neuer User
Mitglied seit
13 Okt 2015
Beiträge
22
Punkte für Reaktionen
1
Punkte
3
Hallo
Was genau ist mit FB-Username gemeint? Der Benutzername in der IP-Phone Konfiguration, oder der generelle FB-Benutzer?
Christian

Es ist der Benutzername der IP-Phone-Config in der FB gemeint.
In meinem Beispiel also "Hell's Kitchen"

v6c57qk5.jpg
 

klsa

Neuer User
Mitglied seit
7 Aug 2017
Beiträge
2
Punkte für Reaktionen
0
Punkte
1
Hallo
Bei mir läuft alles nur ein bischen und nicht richtig:(:(
Anlage:
Fritzbox 7490
Cisco 8941
Server Zyxel NAS326

Telefonieren ankommend und gehend funktioniert
intregierter AB der Fritzbox funktioniert: läst sich ein und ausschalten und Nachrichten abhören, aber neue Nachrichten werden nicht gemeldet.

Telefonbuch der FB fuktioniert nicht wird nicht übertragen

aber bei ankommenden Anrufen wird wenn der anrufer im Telefonbuch gespeichert ist auf dem Display angezeigt

Wo und wie und womit muß man das auslesen und anzeigen des Telefonbuchs und der anderen möglichen Fähigkeiten des cisco Tel. einbinden
 

AlexDietz82

Neuer User
Mitglied seit
22 Jun 2018
Beiträge
9
Punkte für Reaktionen
2
Punkte
3
Hallo,
bei der Anmeldung an die Fritzbox läuft wohl was schief.
Wird zwar irgendwie verbunden, aber ich bekomme kein Freizeichen, und klingeln tut es bei Anruf auch nicht.

HAb schon gegoogelt, aber finde keine Antwort.
LG
Alex
Fast vergessen
Cisco CP 8961
mit sip8961.9-0-4 (Wegen NTP)
und FB 7490
mit aktuellster FW
 
Zuletzt bearbeitet:

LaUs3r

Neuer User
Mitglied seit
13 Okt 2015
Beiträge
22
Punkte für Reaktionen
1
Punkte
3
[Edit Novize: Überflüssiges Fullquote des Beitrags direkt darüber gelöscht - siehe Forumsregeln]

Hallo Alex,

mit dieser Fehlerbeschreibung wirst Du wenige User dazu animieren können Dir wirklich fundiert zu helfen. Sorry, aber ein paar mehr konkrete und aussagefähige Infos sollten es schon sein:
- was heißt denn "wird irgendwie verbunden?" --> was sagt die Asterisk-Konsole? Registriert sich der Client oder nicht? (sip show peers)
- wie sehen Deine Config-Files aus?
- wie ist Dein grundsätzliches Setup? (wer macht den tftp? welche Asterisk-Version?)
- welche detaillierten Schritte zur Fehleranalyse hast Du durchgeführt und mit welchem Ergebnis?
-etc.
 
Zuletzt bearbeitet von einem Moderator:

AlexDietz82

Neuer User
Mitglied seit
22 Jun 2018
Beiträge
9
Punkte für Reaktionen
2
Punkte
3
Asterisk nutze ich derzeit noch garnicht.
Irgendwie verbunden soll heißen, dass im Display nicht mehr steht dass das Telefon nicht verbunden sei.

XML:
<?xml version="1.0" encoding="UTF-8"?>
<device>
    <deviceProtocol>SIP</deviceProtocol>
    <sshUserId>.....</sshUserId> <!-- Benutzer-->
    <sshPassword>.......</sshPassword> <!-- Passwort-->
    <devicePool>
        <dateTimeSetting>
            <name>W.Europe</name>
            <dateTemplate>D.M.Y</dateTemplate>
            <timeZone>W. Europe Standard/Daylight Time</timeZone>
            <ntps>
                <ntp>
                    <name>192.168.1.10</name>                 <!-- NTP-Server-->
                    <ntpMode>unicast</ntpMode>
                </ntp>
            </ntps>
        </dateTimeSetting>
        <callManagerGroup>
            <members>
                <member priority="0">
                    <callManager>
                        <processNodeName>fritz.box</processNodeName> <!-- IP Adresse Fritzbox-->
                        <ports>
                            <ethernetPhonePort>2000</ethernetPhonePort>                        
                            <sipPort>5060</sipPort>
                            <securedSipPort>5061</securedSipPort>
                        </ports>
                    </callManager>
                </member>
            </members>
        </callManagerGroup>
    </devicePool>
    <sipProfile>
        <sipProxies>
            <registerWithProxy>false</registerWithProxy>
        </sipProxies>
        <transportLayerProtocol>2</transportLayerProtocol>
        <sipCallFeatures>
         <cnfJoinEnabled>true</cnfJoinEnabled>
         <callForwardURI>x--serviceuri-cfwdall</callForwardURI>
         <callPickupURI>x-cisco-serviceuri-pickup</callPickupURI>
         <callPickupListURI>x-cisco-serviceuri-opickup</callPickupListURI>
         <callPickupGroupURI>x-cisco-serviceuri-gpickup</callPickupGroupURI>
         <meetMeServiceURI>x-cisco-serviceuri-meetme</meetMeServiceURI>
         <abbreviatedDialURI>x-cisco-serviceuri-abbrdial</abbreviatedDialURI>
         <rfc2543Hold>false</rfc2543Hold>
         <callHoldRingback>2</callHoldRingback>
         <localCfwdEnable>true</localCfwdEnable>
         <semiAttendedTransfer>true</semiAttendedTransfer>
         <anonymousCallBlock>2</anonymousCallBlock>
         <callerIdBlocking>2</callerIdBlocking>
         <dndControl>0</dndControl>
         <remoteCcEnable>true</remoteCcEnable>
        </sipCallFeatures>
        <sipStack>
         <sipInviteRetx>6</sipInviteRetx>
         <sipRetx>10</sipRetx>
         <timerInviteExpires>180</timerInviteExpires>
         <timerRegisterExpires>3600</timerRegisterExpires>
         <timerRegisterDelta>5</timerRegisterDelta>
         <timerKeepAliveExpires>120</timerKeepAliveExpires>
         <timerSubscribeExpires>120</timerSubscribeExpires>
         <timerSubscribeDelta>5</timerSubscribeDelta>
         <timerT1>500</timerT1>
         <timerT2>4000</timerT2>
         <maxRedirects>70</maxRedirects>
         <remotePartyID>false</remotePartyID>
         <userInfo>None</userInfo>
      </sipStack>
      <autoAnswerTimer>1</autoAnswerTimer>
      <autoAnswerAltBehavior>false</autoAnswerAltBehavior>
      <autoAnswerOverride>true</autoAnswerOverride>
      <transferOnhookEnabled>false</transferOnhookEnabled>
      <enableVad>false</enableVad>
      <preferredCodec>g729a</preferredCodec>
      <dtmfAvtPayload>101</dtmfAvtPayload>
      <dtmfDbLevel>3</dtmfDbLevel>
      <dtmfOutofBand>avt</dtmfOutofBand>
      <alwaysUsePrimeLine>false</alwaysUsePrimeLine>
      <alwaysUsePrimeLineVoiceMail>false</alwaysUsePrimeLineVoiceMail>
      <kpml>3</kpml>
    <phoneLabel>.....</phoneLabel>
    <stutterMsgWaiting>2</stutterMsgWaiting>
    <silentPeriodBetweenCallWaitingBursts>10</silentPeriodBetweenCallWaitingBursts>
      <disableLocalSpeedDialConfig>false</disableLocalSpeedDialConfig>
      <startMediaPort>16384</startMediaPort>
      <stopMediaPort>32766</stopMediaPort>
        <sipLines>
            <line button="1" lineIndex="1">                 <!-- SIP Account -->
                <featureID>9</featureID>
                   <featureLabel>......</featureLabel> <!-- Name der oben im Display steht-->
                   <proxy>USECALLMANAGER</proxy>                  
                <port>5060</port>

        <!-- ### WICHTIG: der <name> UND <authName> muessen dem username in der Fritzbox entsprechen ### -->
           
        <name>......</name>          <!-- Name der im Telefon angezeigt wird, auf der Taste-->
        <authName>........</authName> <!-- erstelle Telefonnummer der Box-->
                <authPassword>.........</authPassword>  
        <messageWaitingLampPolicy>4</messageWaitingLampPolicy>    <!-- FB AB auf Brieftaste -->
                <messagesNumber>**600</messagesNumber>        
        <ringSettingIdle>4</ringSettingIdle>             <!-- Wichtig fuer Anklopfen -->
        <ringSettingActive>5</ringSettingActive>
        </line>
            <line button="2" lineIndex="2">                 <!-- SIP Account -->
                <featureID>9</featureID>
                   <featureLabel>......</featureLabel> <!-- Name der oben im Display steht-->
                   <proxy>........</proxy>                  
     
        <name>........</name>          <!-- Name der im Telefon angezeigt wird, auf der Taste-->
        <authName>........</authName> <!-- erstelle Telefonnummer der Box-->
                <authPassword>.........</authPassword>  
        <messageWaitingLampPolicy>4</messageWaitingLampPolicy>    <!-- FB AB auf Brieftaste -->
                <messagesNumber>**600</messagesNumber>        
        <ringSettingIdle>4</ringSettingIdle>             <!-- Wichtig fuer Anklopfen -->
        <ringSettingActive>5</ringSettingActive>
        </line>
        <line button="4">                         <!-- Kurzwahl 4-->
        <featureID>21</featureID>
        <featureLabel>Ma</featureLabel>
        <speedDialNumber>**1</speedDialNumber>
        </line>
                </sipLines>
        <dialTemplate>dialplan.xml</dialTemplate>             <!-- Dialplan, einfach mal googeln -->
    </sipProfile>
<userLocale>
    <name>de_DE</name>
    <langCode>de</langCode>
</userLocale>
    <networkLocale>Germany</networkLocale>
<networkLocaleInfo>
    <name>Germany</name>
</networkLocaleInfo>
    <vendorConfig>
        <displayOnWhenIncomingCall>1</displayOnWhenIncomingCall>
        <displayIdleTimeout>00:45</displayIdleTimeout>
        <daysDisplayNotActive> ,</daysDisplayNotActive>                <!-- Display immer an -->
        <displayOnTime>00:00</displayOnTime>
        <displayOnDuration>00:00</displayOnDuration>
        <settingsAccess>1</settingsAccess>
        <webAccess>0</webAccess>                     <!-- Web Zugriff erlaubt -->
    </vendorConfig>
    <phoneServices>
        <provisioning>2</provisioning>
        <phoneService  type="1" category="0">                 <!-- verpasster Anrufe -->
            <name>Missed Calls</name>
            <url>Application:Cisco/MissedCalls</url>
            <vendor></vendor>
            <version></version>
        </phoneService>
        <phoneService  type="2" category="0">                 <!-- zum nutzen der Brieftaste -->
        <name>Voicemail</name>
        <url>Application:Cisco/Voicemail</url>
        <vendor></vendor>
        <version></version>
    </phoneService>
    <phoneService  type="1" category="0">                 <!-- empfangener Anrufe -->
            <name>Received Calls</name>
            <url>Application:Cisco/ReceivedCalls</url>
            <vendor></vendor>
            <version></version>
        </phoneService>
    <phoneService  type="1" category="0">                 <!-- getaetigte Anrufe -->
            <name>Placed Calls</name>
            <url>Application:Cisco/PlacedCalls</url>
            <vendor></vendor>
            <version></version>
        </phoneService>
    </phoneServices>
    <addOnModules>
        <addOnModule  uuid="" idx="1">
            <deviceType>CKEM</deviceType>
            <deviceLine>36</deviceLine>
            <loadInformation></loadInformation>
            <phoneTemplateId></phoneTemplateId>
        </addOnModule>
    </addOnModules>
    <commonConfig>                             <!-- USB, Bluetooth, WLAN(9971) -->
        <usb1>1</usb1>
        <usb2>1</usb2>
        <ciscoCamera>1</ciscoCamera>
        <usbClasses>0,1,2</usbClasses>
        <sdio>1</sdio>
        <bluetooth>1</bluetooth>
        <wifi>1</wifi>
        <bluetoothProfile>0,1</bluetoothProfile>
        <joinAndDirectTransferPolicy>0</joinAndDirectTransferPolicy>
    </commonConfig>
    <featurePolicyFile>DefaultFP.xml</featurePolicyFile>         <!-- steuert Funktionen, zB Wahlwiederholung -->
    <loadInformation>sip8961.9-0-4</loadInformation>              <!-- FW Version, durch die für das jeweilige Grät zu erstezen -->
</device>

LG
Alex
 
Zuletzt bearbeitet:

LaUs3r

Neuer User
Mitglied seit
13 Okt 2015
Beiträge
22
Punkte für Reaktionen
1
Punkte
3
Hi Alex, gib mal bitte die Namen in der XML an und schwärze nur die Passwörter.
Ich würde auch mal die direkte IP der Fritzbox eintragen und nicht "fritz.box".
Du könntest auch mal einen Trace an der Fritzbox mitschneiden und posten: http://fritz.box/html/capture.html


Warum nimmst Du nicht die Fritzbox als NTP oder ist die 192.168.1.10.die Fritzbox? Wobei das hier nachrangig ist.
 
Zuletzt bearbeitet:

Loewe81

Neuer User
Mitglied seit
7 Jan 2009
Beiträge
167
Punkte für Reaktionen
0
Punkte
16
Hallo zusammen,
seit 7 Jahren endlich mal wieder ein Beitrag hier in diesem wundervollen Forum.
Auch bei uns hat nun ein Cisco IP-Phone (8961) Einzug gehalten und ich kämpfe auch noch mit ein paar kleinen Problemchen.
  • Als Datum wird 01.01.1982 angezeigt und auch die Uhrzeit stimmt nicht:
    • Ich habe sowohl die IP der Fritzbox (auf der natürlich die Option NTP im Netzwerk zur Verfügung stellen aktiviert ist), als auch direkt einen DNS-Namen () probiert.
    • Die entsprechende XML-Config lautet:
    • XML:
      <dateTimeSetting>    <dateTemplate>D.M.YY</dateTemplate>
          <timeZone>Central Europe Standard/Daylight Time</timeZone>
          <ntps>
              <ntp>
                  <name>192.168.0.1</name> <!-- IP des NTP-Servers. Hier die Fritzbox -->
                  <ntpMode>Unicast</ntpMode>
              </ntp>
          </ntps>
      </dateTimeSetting>
  • Ich bekomme die fünf rechte Schnellwahltasten nicht belegt:
    • Taste 6 ist mit einem Telefonhörer-Symbol belegt, diese entspricht der "neuer Anruf"-Funktion
    • Taste 7 ist mit einem "Verlauf"-Symbol belegt, diese entspricht der Anrufprotokoll-Funktion
    • Taste 8-10 sind leer und können scheinbar trotz entsprechender Einträge im XML-Code nicht belegt werden
  • Die Anbindung/Integration des Fritzbox-Telefonbuchs funktioniert noch nicht
    • Ich nutze hier das fritzco-1.2 Script
    • Es kommt immer nur die Meldung "Keine Telefonbücher vorhanden", auch nach drücken der "Aktualisieren"-Taste
    • Die Verzeichnisse haben eigentlich die entsprechenden Berechtigungen
    • Nach Aktivierung der Logs sehe ich folgenden Fehler: "directory.php: execute: refresh > ERROR: HTTP-CODE n/a => http://192.168.0.1/login_sid.lua"
    • Ich werde dieses Problem wohl am besten im entsprechenden Thread hier im Forum versuchen zu klären.
    • UPDATE: habe den Fehler gefunden und bereits hier beschrieben.
Und dann hätte ich noch ein paar allgemeine Verständnis-Fragen:
  • Warum müssen die Credentials für das Fritzbox-IP-Phone als "Line" auf einer Schnellwahltaste konfiguriert werden? Ich hätte jetzt erwartet, dass das irgendwie als "versteckte" Einstellung im XML-Code hinterlegt wird. Somit geht eine Schnellwahltaste verloren oder welche Funktion soll das haben?
  • Das o.g. Verlaufs-Protokoll hätte ich gerne auf einer der Softkeys, aber wenn ich das richtig sehe, können hier nur vordefinierte Funktionen aktiviert werden?
  • Gibt es eine Möglichkeit die verschiedenen "Einträge" auf dem AB in einer Liste wie an einem Fritzfon anzuzeigen?
So, das soll es für den Anfang erstmal gewesen sein. Wenn ihr weitere Einstellungen oder Details braucht, sagt mir bitte Bescheid.
Vielen lieben Dank!

Ciao Stefan :)
 
Zuletzt bearbeitet:

LaUs3r

Neuer User
Mitglied seit
13 Okt 2015
Beiträge
22
Punkte für Reaktionen
1
Punkte
3
Hallo zusammen,
seit 7 Jahren endlich mal wieder ein Beitrag hier in diesem wundervollen Forum.
Auch bei uns hat nun ein Cisco IP-Phone (8961) Einzug gehalten und ich kämpfe auch noch mit ein paar kleinen Problemchen.
  • Als Datum wird 01.01.1982 angezeigt und auch die Uhrzeit stimmt nicht:
    • Ich habe sowohl die IP der Fritzbox (auf der natürlich die Option NTP im Netzwerk zur Verfügung stellen aktiviert ist), als auch direkt einen DNS-Namen () probiert.
    • Die entsprechende XML-Config lautet:
    • XML:
      <dateTimeSetting>    <dateTemplate>D.M.YY</dateTemplate>
          <timeZone>Central Europe Standard/Daylight Time</timeZone>
          <ntps>
              <ntp>
                  <name>192.168.0.1</name> <!-- IP des NTP-Servers. Hier die Fritzbox -->
                  <ntpMode>Unicast</ntpMode>
              </ntp>
          </ntps>
      </dateTimeSetting>
  • Ich bekomme die fünf rechte Schnellwahltasten nicht belegt:
    • Taste 6 ist mit einem Telefonhörer-Symbol belegt, diese entspricht der "neuer Anruf"-Funktion
    • Taste 7 ist mit einem "Verlauf"-Symbol belegt, diese entspricht der Anrufprotokoll-Funktion
    • Taste 8-10 sind leer und können scheinbar trotz entsprechender Einträge im XML-Code nicht belegt werden
  • Die Anbindung/Integration des Fritzbox-Telefonbuchs funktioniert noch nicht
    • Ich nutze hier das fritzco-1.2 Script
    • Es kommt immer nur die Meldung "Keine Telefonbücher vorhanden", auch nach drücken der "Aktualisieren"-Taste
    • Die Verzeichnisse haben eigentlich die entsprechenden Berechtigungen
    • Nach Aktivierung der Logs sehe ich folgenden Fehler: "directory.php: execute: refresh > ERROR: HTTP-CODE n/a => http://192.168.0.1/login_sid.lua"
    • Ich werde dieses Problem wohl am besten im entsprechenden Thread hier im Forum versuchen zu klären.
    • UPDATE: habe den Fehler gefunden und bereits hier beschrieben.
Und dann hätte ich noch ein paar allgemeine Verständnis-Fragen:
  • Warum müssen die Credentials für das Fritzbox-IP-Phone als "Line" auf einer Schnellwahltaste konfiguriert werden? Ich hätte jetzt erwartet, dass das irgendwie als "versteckte" Einstellung im XML-Code hinterlegt wird. Somit geht eine Schnellwahltaste verloren oder welche Funktion soll das haben?
  • Das o.g. Verlaufs-Protokoll hätte ich gerne auf einer der Softkeys, aber wenn ich das richtig sehe, können hier nur vordefinierte Funktionen aktiviert werden?
  • Gibt es eine Möglichkeit die verschiedenen "Einträge" auf dem AB in einer Liste wie an einem Fritzfon anzuzeigen?
So, das soll es für den Anfang erstmal gewesen sein. Wenn ihr weitere Einstellungen oder Details braucht, sagt mir bitte Bescheid.
Vielen lieben Dank!

Ciao Stefan :)

Hi Stefan,

ich hab das 8941 und ggf. ist die Config hier etwas unterschiedlich. Ich hab Dir nochmal meine "Runing config" auf meinen 2 IP-Phones kopiert:

Code:
      <dateTimeSetting>
            <name>W.Europe</name>
            <dateTemplate>D.M.Y</dateTemplate>
            <timeZone>W. Europe Standard/Daylight Time</timeZone>
            <ntps>
                <ntp>
                    <name>192.168.0.1</name>                 <!-- NTP-Server-->
                    <ntpMode>Unicast</ntpMode>
                </ntp>
            </ntps>
        </dateTimeSetting>

Ansonsten bleibt mir nur etwas Rätselraten, warum die Uhrzeit nicht aktualisiert wird (hast Du eine Firewall, die ggf. den Traffic block? Hast Du mal Wireshark angeworfen, um zu sehen, ob an dem Port was NTP-technisches ankommt?)

Das ist leider schon alles was ich beitragen kann. Die Schnellwahltasten habe ich nicht belegt und die Einbindung des Telefonbuchs habe ich ebenfalls nicht vorgenommen. Sry.

vg
Sascha
 

Loewe81

Neuer User
Mitglied seit
7 Jan 2009
Beiträge
167
Punkte für Reaktionen
0
Punkte
16
Also NTP-Pakete sehe ich beim Sniffern, alle 60 Sekunden zwischen dem Phone und der FB.
Ich bin jetzt nicht der NTP-Protokoll Experte, aber es sieht so aus, als ob das Phone die Antwort nicht korrekt verarbeitet???
Hier mal zwei Screenshots vom NTP-Request:
NTP-Request.jpg
und von der NTP-Response:
NTP-Response.jpg
[Edit Novize: Riesenbilder gemäß der Forumsregeln auf Vorschau verkleinert]
Danke!

UPDATE: Laut einem Cisco Forumsbeitrag scheint das leider normal zu sein:
Symptom:
8961, 9951, and 9971 phones will not use the phone NTP reference as configured for getting their time.
Conditions:
Firmware versions 9.1(1) and later will not synchronize their time with an external NTP server. The ability to use an NTP reference for time has been turned off on 89XX and 99XX phones.
Allerdings wohl mit einer Firmware 9.0.x zu fixen. Auf der Cisco-Seite lässt sich allerdings nur noch die 9.0.4 herunterladen. Soweit ja erstmal genau richtig. Aber warum auch immer werden die Dateien nicht per TFTP übertragen. Er ließt die .loads-Datei, aber zieht sich dann leider nicht die darin referenzierten anderen Dateien:
Read request for file <SEP5067AEE18AF0.cnf.xml>. Mode octet [15/04 01:04:17.841]
Using local port 65172 [15/04 01:04:17.841]
<SEP5067AEE18AF0.cnf.xml>: sent 16 blks, 8152 bytes in 0 s. 0 blk resent [15/04 01:04:17.873]
Connection received from 192.168.0.20 on port 49152 [15/04 01:04:20.917]
Read request for file </g4-tones.xml>. Mode octet [15/04 01:04:20.918]
File <g4-tones.xml> : error 2 in system call CreateFile Das System kann die angegebene Datei nicht finden. [15/04 01:04:20.918]
Connection received from 192.168.0.20 on port 49152 [15/04 01:04:21.435]
Read request for file <dialplan.xml>. Mode octet [15/04 01:04:21.436]
Using local port 57020 [15/04 01:04:21.436]
<dialplan.xml>: sent 1 blk, 71 bytes in 0 s. 0 blk resent [15/04 01:04:21.442]
Connection received from 192.168.0.20 on port 49152 [15/04 01:04:24.364]
Read request for file <sip8961.9-0-4.loads>. Mode octet [15/04 01:04:24.364]
Using local port 57021 [15/04 01:04:24.365]
<sip8961.9-0-4.loads>: sent 3 blks, 1248 bytes in 0 s. 0 blk resent [15/04 01:04:24.374]
Hat hier jemand eine Idee an was das liegt und/oder wie man das beheben/umgehen kann? Eine andere Version habe ich leider zum Testen nicht zur Verfügung. Oder kennt hier noch jemand andere Quellen?

Ciao Stefan :)
 
Zuletzt bearbeitet von einem Moderator:

sonyKatze

Aktives Mitglied
Mitglied seit
6 Aug 2009
Beiträge
2,747
Punkte für Reaktionen
245
Punkte
63
Einwurf: Ohne jetzt irgendwie Ahnung vom Thema zu haben, hilft wegen NTP der zweite Artikel aus diesem Post?
 

Loewe81

Neuer User
Mitglied seit
7 Jan 2009
Beiträge
167
Punkte für Reaktionen
0
Punkte
16
Hi sonyKatze,
Danke für den Hinweis, aber die Links zu Heise bringen einem recht wenig, wenn man dort kein Abo hat.
Ich vermute aber mal, dass es sich auf diesen Seiten um die allgemeine Umsetzung/Einrichtung der diversen Themen handelt.
Dieses technische Wissen ist hier aber nicht das Problem. Wie ich in meinem letzten Post geschrieben habe, scheine ich ein "ungünstiges" Modell erwischt zu haben, bei dem die NTP-Funktionalität per se deaktiviert ist. Als einziger Workaround scheint ein downgrade auf eine ältere Version. Diese konnte ich mir zwar besorgen (konkret die 9.0.4), aber warum auch immer wird diese nicht mittels TFTP-Server gezogen. Kann es vielleicht sein, dass die Cisco Phones generell keinen downgrade "mögen" und man das irgendwie exlizit "forcen" muss? Oder kennt sich hier sonst noch jemand mit dem Thema Installation von SIP-Images aus?
Das downgrade-Problem wird auch explizit hier diskutiert, daher können wir das Thema hier gerne beenden und uns auf die übrigen Fragen konzentrieren.
Danke!

Ciao Stefan :)
 
Zuletzt bearbeitet:

Loewe81

Neuer User
Mitglied seit
7 Jan 2009
Beiträge
167
Punkte für Reaktionen
0
Punkte
16
Das mit den 5 Tasten auf der rechten Seite des Displays hat sich erledigt, da dies KEINE Line-Keys, sondern Session-Keys sind. Das muss ich mir mal näher anschauen bzw. etwas rumspielen.
 

Loewe81

Neuer User
Mitglied seit
7 Jan 2009
Beiträge
167
Punkte für Reaktionen
0
Punkte
16
Das NTP-Problem wollte ich nun statisch mit setzen des korrekten Datums/Uhrzeit über die SSH-Console machen.
In den Debug-Modus komme ich auch rein. Dort gibt es den "date"-Befehl mit dem ich die aktuelle Zeit anzeigen und (angeblich) setzen kann. Aber egal welche Form von "date"-Befehl ich eingebe, es wird mir immer nur die derzeit eingestellte (falsche) Uhrzeit angezeigt.
date
Print or set the system date and time
DEBUG> date -s '2021-04-27 00:16:00'
Fri Jan 8 13:19:44 UTC 1982
DEBUG> date %Y
Fri Jan 8 13:24:01 UTC 1982
DEBUG> date +"%Y"
Fri Jan 8 13:24:54 UTC 1982
DEBUG>
Weiß hier zufällig jemand, wie ich die Uhrzeit manuell geändert bekomme?
EDIT: So wie es aussieht erlaubt Cisco aus Sicherheitsgründen nur noch den "DEBUG"-Modus. Und kann es sein, dass der "date"-Befehl nur anzeigt und nicht wie fälschlicherweise in der Hilfe angegeben auch ändern kann? Sprich die Uhrzeit kann man gar nicht manuell ändern???
Danke!

Ciao Stefan :)
 
Zuletzt bearbeitet:

Erhalten Sie 3CX für 1 Jahr kostenlos!

Gehostet, in Ihrer privaten Cloud oder on-Premise! Ganz ohne Haken. Geben Sie Ihren Namen und Ihre E-Mail an und los geht´s:

3CX
Für diese E-Mail-Adresse besteht bereits ein 3CX-Konto. Sie werden zum Kundenportal weitergeleitet, wo Sie sich anmelden oder Ihr Passwort zurücksetzen können, falls Sie dieses vergessen haben.
oder via

IPPF im Überblick

Neueste Beiträge

Website-Sponsoren


Kontaktieren Sie uns bei Interesse