[Problem] Eingabefeld Weiterleitung Fax fehlt

Lauser71

Mitglied
Mitglied seit
2 Aug 2009
Beiträge
323
Punkte für Reaktionen
0
Punkte
0
Hallo,
ich habe die Tage einige Speedport Router mit der aktuellen Freetz Software Devel 8595 ausgestattet. Hierbei sind mir zwei "Fehler" ?!? aufgefallen.
Betrifft mehrere Modelle u.a. SP W701 und W900

1. Das Eingabefeld für Weiterleitung des intergrierten Fax fehlt
2. die user.filter kann nicht geöffnet werden (Error opening File)

Kann sich das bitte jemand aus dem Team anschauen und fixen falls es ein Fehler ist.
Danke
 
Zuletzt bearbeitet:

olistudent

IPPF-Urgestein
Mitglied seit
19 Okt 2004
Beiträge
14,779
Punkte für Reaktionen
10
Punkte
38
Moin.

Zu 1.) Hier müsstest du die zugrunde liegende html-Datei mit der aus dem original Image der 7170 vergleichen. Wahrscheinlich wird durch die Patches zuviel entfernt...
Zu 2.) Kannst du mal ein Screenshot von deinen Privoxy Einstellungen posten? Oder den Inhalt der privoxy.cfg

Gruß
Oliver
 

Lauser71

Mitglied
Mitglied seit
2 Aug 2009
Beiträge
323
Punkte für Reaktionen
0
Punkte
0
Hallo olistudent,
vielen Dank für die schnelle Antwort.
Zu 1. Nein denke nicht das zuviel durch Patches entfernt wurde. Siehe Anlage config.txt
Zu 2. Wie gewünscht der Screenshot von privoxy.cfg
Falls ich einen Fehler gemacht habe, bitte auch Info welchen.
Danke
Viele Grüße
 

olistudent

IPPF-Urgestein
Mitglied seit
19 Okt 2004
Beiträge
14,779
Punkte für Reaktionen
10
Punkte
38
Ich meinte nicht die durch dich ausgewählten Patches, sondern die die bei der Alien Variante automatisch benutzt werden.

Gruß
Oliver
 

Lauser71

Mitglied
Mitglied seit
2 Aug 2009
Beiträge
323
Punkte für Reaktionen
0
Punkte
0
Hallo olistudent,
deine Frage bezüglich der Alienvers. Patches kann ich dir leider so nicht beantworten da hier mein Wissen nicht tief und weit genug reicht.
Wegen des Fehlers Error open bei der Datei user.filter habe ich eine neue Datei erstellt und siehe da es hat funktioniert.
 

olistudent

IPPF-Urgestein
Mitglied seit
19 Okt 2004
Beiträge
14,779
Punkte für Reaktionen
10
Punkte
38
Schau doch mal bitte mir Firebug oder ähnlichem wie der HTML-Quelltext an der Stelle aussieht. Da ich grad keine 7170 zur Hand habe weiß ich nicht wonach ich suchen soll.

Gruß
Oliver
 

Lauser71

Mitglied
Mitglied seit
2 Aug 2009
Beiträge
323
Punkte für Reaktionen
0
Punkte
0
Hallo olistudent,
Quelltext schaut bei mir an dieser Stelle so aus

!DOCTYPE html PUBLIC "-//W3C//DTD XHTML 1.0 Frameset//EN" "http://www.w3.org/TR/xhtml1/DTD/xhtml1-frameset.dtd">
<html>
<head>
<title>FRITZ!Box</title>
<meta http-equiv="Content-Type" content="text/html; charset=utf-8">
<meta http-equiv="expires" content="0">
<link rel="shortcut icon" type="image/x-icon" href="/favicon.ico" />
<script type="text/javascript">
var g_HelpWin = null;
</script>
</head>
<frameset id="frame_set" rows="*">
<frame src="/logincheck.lua" id="frame_content" scrolling="auto" frameborder="0" />
</frameset>
<noframes>
</html>
 

MaxMuster

IPPF-Promi
Mitglied seit
1 Feb 2005
Beiträge
6,932
Punkte für Reaktionen
1
Punkte
36
Du hast nur den Teil ohne den eigentlichen Frame erwischt, das hilft nicht so richtig...
Du müsstest das z.B. im Firefox so machen: Auf der Seite daneben per "Rechts-Kilck" wählen:
Aktueller Frame -> Frame-Quelltext anzeigen .

Da sollte dann in etwa sowas stehen (suche nach e-mail-adresse):
Code:
<td id="Dataspalte">
<div align=center>
<div id="content">
<div class="backtitelkonfig"><div class="rundrt"><div class="rundlt"><div class="ecklb"><div class="eckrb"><div class="foretitel">
Einstellungen für den Faxempfang
</div></div></div></div></div></div>
<div class="backdialog"><div class="ecklm"><div class="eckrm"><div class="ecklb"><div class="eckrb"><div class="foredialog">
<p class="mb10">Geben Sie an, welche Kennung dem Versender des Faxes übermittelt werden soll.</p>

<p class="mb5 pLeft25">
<label for="uiViewFaxKennung">Fax-Kennung</label>&nbsp;
<input type="text" class="ml25 Eingabefeld" size="20" maxlength="20" style="width:200px;" id="uiViewFaxKennung" />
</p>
<p class="mb10 mt20">Empfangene Faxe können per E-Mail weitergeleitet und/oder auf einem USB-Speicher gespeichert werden.</p>
<div class="ml25">
<p class="mb5">
<input type="checkbox" id="uiViewActivMail" />&nbsp;
<label for="uiViewActivMail">per E-Mail weiterleiten</label>
</p>
[B][I]<p class="mb10 pLeft25" id="uiShowMailAdr" style="display: none;">
<label for="uiViewAdr">an die E-Mail-Adresse</label>&nbsp;
<input id="uiViewAdr" type="text" size="40" class="Eingabefeld" />

</p>[/I][/B]
<p class="mb10 pLeft25" id="uiShowErrorMail" style="display: none;">
<span id="uiSpanMailError">E-Mail Versand nicht möglich, da "Push Service" deaktiviert ist. Wenn Sie empfangene Faxe per Mail weiterleiten möchten, müssen Sie den "Push Service" aktivieren.</span>
</p>
<p class="mb5">
</p>
</div>
</div></div></div></div></div></div>
<div class="backdialog"><div class="ecklm"><div class="eckrm"><div class="rundrb"><div class="rundlb"><div class="forebuttons">
<input type="button" onclick="uiDoBack()" value="< Zurück" class="Pushbutton" id="uiBtnBack">
<input type="button" onclick="uiDoOk()" value="Weiter >" class="Pushbuttonfett " id="uiBtnOK">&nbsp;&nbsp;
<input type="button" onclick="uiDoCancel()" value="Abbrechen" class="Pushbutton" id="uiBtnCancel">
</div></div></div></div></div></div>

</div>

</div>
<div class="clear_float"></div>
<div style="position:relative; top:-5px;">
<div class="page_left_bottom"></div>
<div class="page_right_bottom"></div>
<div class="page_back_bottom" style="">
<div id="MainPagebottom">
</div>
</div>
</div>
</td>
Ist von einem "älteren" W701-Build (29.04.87freetz-devel-7753)
 
Zuletzt bearbeitet:

Lauser71

Mitglied
Mitglied seit
2 Aug 2009
Beiträge
323
Punkte für Reaktionen
0
Punkte
0
Hallo MaxMuster,
vielen Dank für den Hinweis, mehr ist nicht da.
Vorgehensweise wie von Dir beschrieben.
<!DOCTYPE HTML PUBLIC "-//W3C//DTD HTML 4.01 Transitional//EN" "http://www.w3.org/TR/html4/loose.dtd">
<html>

Nachtrag:
Kann dir gern das aktuelle Image zukommen lassen.
 
Zuletzt bearbeitet:

Lauser71

Mitglied
Mitglied seit
2 Aug 2009
Beiträge
323
Punkte für Reaktionen
0
Punkte
0
Hallo MaxMuster, hallo RalfFriedl,
ich kann nicht weiter runter scrollen.
Selbst wenn ich den Quelltext in IE anzeigen lasse kommt nichts anderes heraus als beim Posting um 19:44 Uhr.
:confused::confused:
VG
 

MaxMuster

IPPF-Promi
Mitglied seit
1 Feb 2005
Beiträge
6,932
Punkte für Reaktionen
1
Punkte
36
Im IE8 getestet (neben das Feld geklickt; mit rechter Maustaste "Quellcode anzeigen" gewählt):
Oben die zwei Zeilen, dann über 150 leere Zeilen und ab Zeile 158 geht es dann mit "<head>" los...
 

Lauser71

Mitglied
Mitglied seit
2 Aug 2009
Beiträge
323
Punkte für Reaktionen
0
Punkte
0
Im IE8 getestet...
Hallo MaxMuster,
ab hier keinen IE 8 sondern nur IE 6 mit installiert welcher allerdings nur für die Programmiersoftware benutzt wird. Update nicht möglich wegen einer älteren Programmiersoftware aus der Automatisierung. :(

Nachtrag:
Kann gerne das Image irgendwo hochladen, damit es sich jemand anschauen kann.
 
Zuletzt bearbeitet:

MaxMuster

IPPF-Promi
Mitglied seit
1 Feb 2005
Beiträge
6,932
Punkte für Reaktionen
1
Punkte
36
Dann mach doch auf der Box bitte mal ein "cat /var/html/html/de/fon_config/fon_config_3fxi.html", da sollte das drinstehen.
Bei mir:
Code:
[email protected]:/var/mod/root# cat  /var/html/html/de/fon_config/fon_config_3fxi.html 
<div id="content">
<div class="backtitelkonfig"><div class="rundrt"><div class="rundlt"><div class="ecklb"><div class="eckrb"><div class="foretitel">
{?8604:4706?}
</div></div></div></div></div></div>
<div class="backdialog"><div class="ecklm"><div class="eckrm"><div class="ecklb"><div class="eckrb"><div class="foredialog">
<p class="mb10">{?8604:7491?}</p>
<p class="mb5 pLeft25">
<label for="uiViewFaxKennung">{?8604:3631?}</label>&nbsp;
<input type="text" class="ml25 Eingabefeld" size="20" maxlength="20" style="width:200px;" id="uiViewFaxKennung" />
</p>
<p class="mb10 mt20">{?8604:7785?}</p>
<div class="ml25">
<p class="mb5">
<input type="checkbox" id="uiViewActivMail" />&nbsp;
<label for="uiViewActivMail">{?8604:3014?}</label>
</p>
<p class="mb10 pLeft25" id="uiShowMailAdr" style="display: none;">
<label for="uiViewAdr">{?8604:5100?}</label>&nbsp;
[B]<input id="uiViewAdr" type="text" size="40" class="Eingabefeld" />[/B]
</p>
<p class="mb10 pLeft25" id="uiShowErrorMail" style="display: none;">
<span id="uiSpanMailError">{?8604:7383?}</span>
</p>
<p class="mb5">
</p>
</div>
</div></div></div></div></div></div>
<? include ../html/de/fon_config/rbb_backokcancel.html ?>
</div>
[email protected]:/var/mod/root#
 

Lauser71

Mitglied
Mitglied seit
2 Aug 2009
Beiträge
323
Punkte für Reaktionen
0
Punkte
0
Hallo MaxMuster,
habe ich wie gewünscht ausgeführt. siehe Anlage
Hoffe es hilft und ich habe es richtig ausgeführt
Danke
 

MaxMuster

IPPF-Promi
Mitglied seit
1 Feb 2005
Beiträge
6,932
Punkte für Reaktionen
1
Punkte
36
Sieht nach meinem Dafürhalten so aus, wie bei mir.
Der "interessante" Part ist auch bei dir drin:
Code:
<input id="uiViewAdr" type="text" size="40" class="Eingabefeld" />
und da der zugehörige "Label" ({?8604:5100?} = "an die E-Mail-Adresse") angezeigt wird, bin ich fast geneigt, auf ein lokales Problem mit dem Browser zu tippen. Oder du hast JS ausgeschaltet oder sowas??

Könntest du das mal mit einem anderen Browser testen, eventuell von einem anderem PC?
 

Lauser71

Mitglied
Mitglied seit
2 Aug 2009
Beiträge
323
Punkte für Reaktionen
0
Punkte
0
Hallo MaxMuster,
Javascript ist aktiviert. Sollten dann nicht andere Eingabefelder ebenfalls mit betroffen sein ?
In der älteren Image Version war es meines Wissens ja noch vorhanden.
Werde es mit einer Linux Live CD und einem blanken Windows nochmal probieren.

Nachtrag:
Bilder von verschiedenen Systemen eingefügt
 
Zuletzt bearbeitet:

Lauser71

Mitglied
Mitglied seit
2 Aug 2009
Beiträge
323
Punkte für Reaktionen
0
Punkte
0
... angezeigt wird, bin ich fast geneigt, auf ein lokales Problem mit dem Browser zu tippen. Oder du hast JS ausgeschaltet oder sowas??
Hallo MaxMuster,
ich habe noch etwas weiter probiert. Dabei ist mir einiges aufgefallen. siehe Anhang
Vielleicht doch kein lokales Problem ;)

Internes Fax einrichten => Box für Email Weiterleitung vorhanden.
Internes Fax fertig eingerichtet => Box für Email Weiterleitung nicht mehr vorhanden.
 

MaxMuster

IPPF-Promi
Mitglied seit
1 Feb 2005
Beiträge
6,932
Punkte für Reaktionen
1
Punkte
36
Ach so, ich hatte immer nur das "Einrichten" versucht.

Bis du denn sicher, dass das ohne Freetz anders wäre? Also auf einer unmodifizierten 7170?

Ich lese das im JS so, als "soll das so":
Code:
function uiToggleShowMail(CtrlIdCheckBox, CtrlIdMailAdr, display_form)
{
jslSetEnabled(CtrlIdMailAdr, jslGetChecked(CtrlIdCheckBox) && display_form);
if (jslGetChecked(CtrlIdCheckBox) && display_form [B][I]&& !isMailerConfigured()[/I][/B])
{
jslDisplay("uiViewMailFrom",true);
OnViewMailFrom();
}
else
{
jslDisplay("uiViewMailFrom",false);
}
}
Nur, wenn der Mailer nicht konfiguriert ist (also bei der Einrichtung da nichts konfiguriert wurde), wird das Feld angezeigt.
Das kann ich natürlich mangels USB beim 701-er nicht testen, ob es angezeigt würde, weil ich hier nur die E-Mail-Option habe....
 

Zurzeit aktive Besucher

3CX

Neueste Beiträge

Statistik des Forums

Themen
235,892
Beiträge
2,067,345
Mitglieder
356,881
Neuestes Mitglied
LTH-doc