[Frage] FRITZ!Box 7490 - VoIP Traffic mit DSCP Codepoint EF

[Arnold]

Neuer User
Mitglied seit
6 Dez 2010
Beiträge
33
Punkte für Reaktionen
0
Punkte
0
Hallo zusammen,

ich würde gerne meine FB 7490 (FW 6.20) dazu bewegen, ausgehenden VoIP-Traffic im IP-Header mit dem DSCP Codepoint EF (Decimal 46, ToS Hex 0xb8) zu taggen. QoS Standardprogramm für VoIP-Traffic im LAN eigentlich. Sie steht im LAN, nutzt Internet als IP-Client (über einen LANCOM Router) und ist reine Telefonanlage für VoIP und ein paar DECT Telefone.

Bisher tagged die FB ausgehende RTP-Pakete Richtung VoIP-Telefon AF12 (Decimal 12, ToS Hex 0x30), Richtung Router garnicht. In der Vergangenheit gab es doch mal die Option "Sprachpakete kennzeichnen" (Type of Service) mit der man so etwas machen konnte, aber die finde ich nicht mehr.

Was ist mit dieser Option passiert? Gibt es vielleicht noch eine andere Möglichkeit so etwas einzustellen (gefunden habe ich nur etwas zum VLAN Tagging von VoIP Traffic)?

Danke vorab!
 
Zuletzt bearbeitet:

eisbaerin

IPPF-Promi
Mitglied seit
29 Sep 2009
Beiträge
7,906
Punkte für Reaktionen
367
Punkte
83

[Arnold]

Neuer User
Mitglied seit
6 Dez 2010
Beiträge
33
Punkte für Reaktionen
0
Punkte
0
Du kannst in der voip.cfg die Werte setzen:
Vielen Dank für den Tip! Mit

Code:
[COLOR=#3E3E3E][I]sip_prio = 26;[/I][/COLOR]
[COLOR=#3E3E3E][I]rtp_prio = 46;[/I][/COLOR]
[COLOR=#3E3E3E][I]rtcp_prio = 46;[/I][/COLOR]
läuft die Priorisierung über Switches und Router hinweg ohne Problem.

Fragt man sich, warum man diese nützliche Einstellung in der Weboberfläche versteckt, aber sei's drum.
 
Zuletzt bearbeitet:

[Arnold]

Neuer User
Mitglied seit
6 Dez 2010
Beiträge
33
Punkte für Reaktionen
0
Punkte
0
Nachtrag: Mittels Wireshark habe ich festgestellt, dass die FB nun RTP in Richtung Internet korrekt mit DSCP 46 (EF) tagt. In Richtung VoIP Telefon im LAN schickt sie allerdings weiterhin DSCP 48 (CoS Class 6 Selector). Das landet in der Standard Konfiguration der meisten Switches nicht in der höchsten Queue. In dem bei mir an der FB verwendeten Cisco SG-300 etwa landet das in Queue 3 statt 4.

Das finde ich erstaunlich, um so mehr, als dass die FB von beiden Teilnehmern (VoIP Telefon im LAN und Gegenstelle im Internet) korrekt mit DSCP 46 (EF) getagte Pakete erhält. Möglicherweise stecke ich in der QoS Thematik noch nicht tief genug drin, aber was könnte der Sinn dieser Vorgehensweise sein? Oder ist das schlicht ein Fehler, den man AVM melden sollte?
 
Zuletzt bearbeitet:

sonyKatze

Aktives Mitglied
Mitglied seit
6 Aug 2009
Beiträge
1,446
Punkte für Reaktionen
125
Punkte
63
Leider muss ich den Thread aus der Versenkung holen, weil ich dasselbe Problem sechs Jahre später immer noch habe – inzwischen mit FRITZ!OS 07.20:
FRITZ!Box [tagged] RTP-Pakete Richtung VoIP-Telefon [mit] AF12
In Richtung VoIP-Telefon im LAN schickt [eine FRITZ!Box] weiterhin DSCP 48 (CoS Class 6 Selector).
Ich vermute Du meinst in beiden Fällen nicht AF12 sondern CS6. Das müsste eigentlich in der schnellsten Warteschlange landen. Aber ja, laut RFC 4594 ist EF also 46 für RTP angebracht. Ansonsten kann ich Deine Beobachtungen bestätigen:
  • Der SIP-Client der FRITZ!Box schickt an meinen VoIP/SIP-Anbieter die RTP-Pakete mit dem, was ich bei rtp_prio eingestellt habe. Folglich hält der SIP-Client sich an den Wert von rtp_prio. Gut.
  • Der SIP-Registrar fritz.box schickt an seine IP-Telefone die RTP-Pakete laut Wireshark immer mit 0xc0. Folglich ignoriert der SIP-Registrar den Wert von rtp_prio. Schlecht.
Hattest Du damals ein Ticket bei AVM aufgemacht und hast Du die Ticket-ID noch? Ich würde mich nämlich gerne dran hängen.
  • Beide – also sowohl SIP-Client als auch SIP-Registrar – halten sich an sip_prio. Gut. Aber nur bei UDP. Bei TCP ignoriert die FRITZ!Box sip_prio. Schlecht. Dazu habe ich bei AVM das Ticket 3581282 aufgemacht.
Das war die FRITZ!Box als SIP-Client bzw. SIP-Registrar (egal ob Router oder im Modus IP-Client). Aber mir fiel noch ein weiteres, ganz anderes Szenario auf, bei dem ich überhaupt kein SIP in der FRITZ!Box nutze:
  • Wenn die FRITZ!Box den Router spielt und ich eine Port-Freigabe (oder Exposed-Host) nutze, dann löscht AVM die Bits für DiffServ in IPv4 sowohl eingehend als auch abgehend.
Beispiel: Ich habe einen Digium Asterisk mit dem Channel-Driver chan_sip. In dessen Konfigurationsdatei sip.conf habe ich im Bereich general den Parameter tos_audio=ef. In der FRITZ!Box ist eine Port-Freigabe auf Port 5060 zu diesem Digium Asterisk eingerichtet. In der FRITZ!Box ist kein Telefonie-Anbieter hinterlegt. Beim Digium Asterisk kommt als Traffic-Class nur Null an. Und das obwohl die FRITZ!Box eine Traffic-Class erhielt. Der Digium Asterisk schickt seine RTP-Pakete schön mit EF. Die FRITZ!Box verlassen diese Pakete mit der Traffic-Class Null. Gibt es dazu bereits einen Thread im IP-Phone-Forum (oder sonst wo)? Dazu habe ich bei AVM das Ticket 3581232 aufgemacht. Wegen diesem Verhalten musste ich meine FRITZ!Box sogar erstmal ausmustern. Heul.