Fritzbox 5491 SFP module compatibility

nop90

Neuer User
Mitglied seit
29 Okt 2020
Beiträge
4
Punkte für Reaktionen
0
Punkte
1
Hello, first of all sorry for writing in English but seeing as this is a forum for Fritzboxes I thought I'd give it a try.
Recently I moved from a DSL connection to a fiber one (GPON). My ISP supplied me with a Fritzbox 5491 which I would like to replace with a PC running pfSense. I would like to have a direct connection into the PC (without going into the Fritzbox first).

I saw that Fritzbox 5491 uses an SFP module (Cigtech G-95SP) to connect and bought two SFP+ NICs.
First NIC is a Mellanox MCX311A-XCAT which doesn't detect the module at all. I think that's because it's not compatible with non SFP+ modules.
The second NIC is a Chelsio T520-CR which prints "transciever module error" when I plug the module in.
As there is not much documentation of the module itself I'm not sure why this doesn't work. Maybe the NIC doesn't support SGMII interface?

Prior to this I didn't have any experience with SFP so I don't know which SFP modules and interfaces are compatible. I only see this brand of SFP modules is compatible with this brand of interfaces...
I saw some people used media converters, switches and routers with this SFP module and they all worked.
if you have any idea why above NICs don't work please share your thoughts.
 

KunterBunter

IPPF-Urgestein
Mitglied seit
12 Okt 2005
Beiträge
28,347
Punkte für Reaktionen
974
Punkte
113
It doesn't sound as if you have entered serial number, MAC, Vendor ID, Version and Equipment ID in order to fake the SFP to your original module.
 

nop90

Neuer User
Mitglied seit
29 Okt 2020
Beiträge
4
Punkte für Reaktionen
0
Punkte
1
I think that would be the next step after the NIC recognizes the module.
The way Fritzbox 5491 does it is it pings 192.168.47.1 (IP of the SFP module) and after it gets a response it sends commands to 192.168.47.1:8888. One of those commands sets the serial.
But I can't even ping the module as there is no link established. I also tried turning auto negotiation off and setting advertise speed to 1000baseT/Full on the NIC but that didn't make a difference.
 

eisbaerin

IPPF-Urgestein
Mitglied seit
29 Sep 2009
Beiträge
11,377
Punkte für Reaktionen
1,058
Punkte
113

nop90

Neuer User
Mitglied seit
29 Okt 2020
Beiträge
4
Punkte für Reaktionen
0
Punkte
1
Yes that is true for standard SFP modules.
Cigtech G-95SP acts as an GPON ONT and is running its own OS and has its own IP.
It's also using some ground pins for different functions. In the documentation they are marked as BOOT4, 1PPS and BOOT0 but no further documentation is provided.
The module works with other switches and media converters so maybe those pins aren't that important?

I think I'd need to make modifications to the NICs driver to make this work or somehow force it into thinking that a link is established.
I need to make some more research into why the NIC gives me a "transciever module error". There are some more driver debug log files in /sys/kernel/debug/cxgb4 I'll need to check.
Also after a minute or two after plugging in the module I see activity light on the NIC blink twice but no link gets established.
 

eisbaerin

IPPF-Urgestein
Mitglied seit
29 Sep 2009
Beiträge
11,377
Punkte für Reaktionen
1,058
Punkte
113

nop90

Neuer User
Mitglied seit
29 Okt 2020
Beiträge
4
Punkte für Reaktionen
0
Punkte
1
Recently I got some time to revisit this project and managed to get a link.
The problem was that the transceiver's OS wasn't fully booted, so the NIC couldn't read any data from it.
Waiting some time before initializing the kernel module (cxgb4) of Chelsio T520-CR I managed to get a link. Setting the routes and the IP to 192.168.47.2 I could ping and send commands to the GPON ONT transceiver (on IP 192.168.47.1).
I haven't tested this with the Mellanox MCX311A-XCAT NIC, but I have a suspicion it won't work because of other reasons.

Sorry for reviving this old thread, hopefully it can help somebody in the future.
 

Neueste Beiträge

Statistik des Forums

Themen
241,486
Beiträge
2,164,923
Mitglieder
366,003
Neuestes Mitglied
VoBoss
Holen Sie sich 3CX - völlig kostenlos!
Verbinden Sie Ihr Team und Ihre Kunden Telefonie Livechat Videokonferenzen

Gehostet oder selbst-verwaltet. Für bis zu 10 Nutzer dauerhaft kostenlos. Keine Kreditkartendetails erforderlich. Ohne Risiko testen.

3CX
Für diese E-Mail-Adresse besteht bereits ein 3CX-Konto. Sie werden zum Kundenportal weitergeleitet, wo Sie sich anmelden oder Ihr Passwort zurücksetzen können, falls Sie dieses vergessen haben.