Fritzbox hinter Vodafone-Kabelrouter (Bridge Mode) - automatisch neu verbinden nach Lease-Ablauf?

telefonicus

Aktives Mitglied
Mitglied seit
14 Okt 2005
Beiträge
923
Punkte für Reaktionen
0
Punkte
16
Hallo,
Ich habe seit ca. 3 Wochen einen Kabelanschluss. In einem Kabeldeutschland-Forum hat vor ein paar Jahren jemand geschrieben:

Der DNS-Server generiert zufällig Lease Times und Die Lease-Time beträgt durchschnittlich 2 Stunden. Deshalb solle man die LeaseTime per RENEW erneuern.

Tatsächlich hatte ich Verbindungsabbrüche nach jeweils etwa einer Woche.

Wie geht das mit dem Renew / Auto-Renew? Warum erneuert die Fritzbox die Verbindung nicht von selbst, so wie beim DSL-Anschluss?

Ich könnte eine Schaltuhr einsetzen, fände das aber ausgesprochen doof.

Muss ich eigentlich beides resetten, Kabelrouter und Fritzbox oder nur eins von beiden?

lg
Telonius
 
Zuletzt bearbeitet:

telefonicus

Aktives Mitglied
Mitglied seit
14 Okt 2005
Beiträge
923
Punkte für Reaktionen
0
Punkte
16
...zu kompliziert?

falsches Forum?
 

sonyKatze

Mitglied
Mitglied seit
6 Aug 2009
Beiträge
559
Punkte für Reaktionen
33
Punkte
28
Falsche Herangehensweise. Du hast ein Symptom und hast Dir irgendeine Ursache er-googlt (die auch noch falsch ist; Leases vergibt nicht der DNS- sondern wenn überhaupt der DHCP-Server). Eine FRITZ!Box ist inzwischen so gut, dass solch ein Fehler quasi ausgeschlossen ist.
  1. Kabelanschluss: Von wem, in welchem Bundesland?
  2. FRITZ!Box: Welches Modell, welche Version des FRITZ!OS?
  3. Verbindungsabbruch: Wie äußert sich das, wie merkst Du das?
  4. Wenn Du so einen Abbruch hast, deutet die Übersicht bzw. die Statusmeldungen auf der Web-Oberfläche unter fritz.box auf irgendwas hin?
 

telefonicus

Aktives Mitglied
Mitglied seit
14 Okt 2005
Beiträge
923
Punkte für Reaktionen
0
Punkte
16
Ich weiß, das mit dem DNS ist Käse, und das mit den 2 Stunden stimmt auch nicht (mehr). Aber das Stichwort RENEW hat mich interessiert, deshalb habe ich danach gefragt. Zu deinen Fragen:

1) Vodafon-Kabeldeutschland, Nordwestdeutschland

2) FRITZ!Box Fon WLAN 7390 FRITZ!OS: 06.86

3) Surfen und Telefonieren ging nicht mehr, Fritzbox meldet "kein Internet" Ob die DSL-Lampe aus war oder geblinkt hat, erinnere ich mich nicht mehr. Ich wolte gerade einen Linux-Paketupdate machen (Downloads aus vielen verteilten Quellen), der immer langsamer wurde und zweimal wegen Zeitüberschreitung abbrach. Danach konnte ich noch einmal google.de und vodafone.de pingen, dann ging auch das nicht mehr, und die Statusmeldung auf der Web-Oberfläche lautete

4) ...nicht verbunden - Ereignismeldung: 30.10.19 18:01:27 Internetverbindung wurde getrennt.

Dann habe ich den Kabelrouter neu gestartet und beim Hochfahren hat dieser offenbar kurz eine lokale IP vergeben:

30.10.19 18:00:15 Internetverbindung wurde erfolgreich hergestellt. IP-Adresse: 192.168.0.4, DNS-Server: 192.168.0.1 und 192.168.0.1, Gateway: 192.168.0.1

Danach war er aber wieder im Bridge Mode. Ich habe dann (glaub ich) die Fritzbox nicht neu gestartet sondern nur neu verbunden:

30.10.19 18:02:00 Internetverbindung wurde erfolgreich hergestellt. IP-Adresse: 77.20.231.41, DNS-Server: 88.134.228.161 und 88.134.228.225, Gateway: 77.20.231.254

1572863198397.png

Der DHCP-Hostname ist nicht von mir eingetragen sondern die AVM-Vorgabe (die ich nicht verwendet habe). Was drin stand, als ich die ausgefüllte Seite abgeschickt habe, weiß ich nicht mehr, wahrscheinlich gar nichts.

1572872322606.png
(aktuelle IPs gekürzt)

1572873110072.png

Wenn ich bei meiner 7390 auf die Meldung "Internetverbindung wurde erfolgreich erneuert" klicke, erhalte ich nur eine nichtssagende Antwort. Aber gugeln hilft:

FRITZ!Box mit Kabelmodem meldet alle 12 Stunden "Internetverbindung wurde erfolgreich erneuert"
Beim Betrieb mit einem Kabelmodem scheint die Internetverbindung von der FRITZ!Box regelmäßig getrennt zu werden. In den Ereignissen der FRITZ!Box wird alle 12 Stunden entweder die Meldung "Internetverbindung wurde erfolgreich erneuert" oder "Internetverbindung wurde erfolgreich hergestellt" angezeigt.
Internetverbindung wird von FRITZ!Box nicht getrennt

Da die vom Kabelanbieter zugewiesenen IP-Adressen eine zeitlich begrenzte Gültigkeit haben, wird die Gültigkeit (DHCP Lease-Time) von der FRITZ!Box regelmäßig "verlängert". Jede Verlängerung wird im Ereignisprotokoll der FRITZ!Box protokolliert. Die Internetverbindung wird dabei von der FRITZ!Box nicht getrennt.
(aus der AVM-Wissensdatenbank für die Fritz!Box 7270)

Damit ist die Frage nach dem Umgang der Fritzbox mit der mysteriösen Lease-Time Policy von Voda/KD vorerst geklärt. Ich muss (und kann) keine "Trennung um der Zwangstrennung zuvor zu kommen" einstellen, weil AVM das stillschweigend 2 x täglich für mich macht.

Im Log sehe ich immer dieselbe IP - heißt das, dass die Verbindung nicht durch Voda getrennt wurde, weil die Lease Time jetzt nicht mehr ablaufen kann da sie seitens der Fritzbox durch ein "Renew" verlängert wurde? Ich bin ja mal gespannt, ob das länger als eine Woche so weiter geht...

lg
Telonius
 
Zuletzt bearbeitet:

sonyKatze

Mitglied
Mitglied seit
6 Aug 2009
Beiträge
559
Punkte für Reaktionen
33
Punkte
28
Ich muss (und kann) keine "Trennung um der Zwangstrennung zuvor zu kommen" einstellen, weil AVM das stillschweigend 2 x täglich für mich macht.
Jein. Bei DHCP bekommst Du eine IP zugewiesen. Für eine gewisse Zeit. Wenn der IP-Client (hier FRITZ!Box) noch da ist, verlängert er diesen Pachtvertrag (Englisch: Lease) kurz vor dem Ablauf.
[…] immer langsamer […] abbrach. Danach konnte ich noch einmal google.de und vodafone.de pingen, dann …
Solche Symptome kann ich mir nicht erklären. Vielleicht kommt noch jemand mit mehr Erfahrung im Breitband-Kabel vorbei. Hört sich für mich eher nach einem Hardware-Fehler an. Daher und um auch diese Bastel zu beenden: Was spricht gegen eine FRITZ!Box Cable?
 

telefonicus

Aktives Mitglied
Mitglied seit
14 Okt 2005
Beiträge
923
Punkte für Reaktionen
0
Punkte
16
Eine mögliche Erklärung, die mir einfällt: um die fragliche Zeit startete auf Sky die Übertragung eines Fußballspiels von einiger regionaler Bedeutung. Ich kann nicht gut abschätzen wie viele Fußballfans in unserer Straße wohnen, aber es gibt wohl ein halbes Dutzend Sky-Kneipen in meiner Nachbarschaft...

Ob die alle am Voda-Internet hängen?

Was spricht gegen eine FRITZ!Box Cable?
...dass ich keine habe :)
 

iqjet

Mitglied
Mitglied seit
16 Jul 2006
Beiträge
708
Punkte für Reaktionen
0
Punkte
16
Bei Kabel gibt es keine Zwangstrennung. Meine WAN IP bleibt mir für Monate erhalten.
Sieht teilweise so aus als ob die Verbindungen zum Modem kurz weggeht.
Hast du Im VF Kundencenter den Bridge Mode eingeschaltet? Wenn nicht, doppel NAT und ich denke das ist bei dir der Fall. (Linux Distro update)
Hast du Dual Stack? Ich sehe keine IPv6.

Wenn du wieistmeineip.de oder browserleaks.com aufrufst, bekommst du eine IPv6?
Ich habe am Modem eine pfSense hängen und dann die FB. Aber nicht mehr lange. Wenn ich die DECT IP Telefone gekauft habe, fliegt die 7390 raus. Bei mir läuft alles reibungslos.

sonyKatze schrieb:
Was spricht gegen eine FRITZ!Box Cable?
...dass ich keine habe :)

@telefonicus: Da gibt es bessere Lösungen als eine AVM Box. Tue es nicht :cool:
 

telefonicus

Aktives Mitglied
Mitglied seit
14 Okt 2005
Beiträge
923
Punkte für Reaktionen
0
Punkte
16
Ähm sorry, ich weiß nicht ob das so klar rüber gekommen ist: ich benutze die Vodafone Box im Bridge Mode, also als reines Modem. Die Fritzbox hängt mit dem LAN1 Port quasi direkt am Internet. Und nein @iqjet, bislang kommt meine heimische IT-Infrastruktur noch ohne IPV6 aus.

Jetzt, da ich davon ausgehen kann, dass sich die Fritzbox nach einer Kabelstörung (irgendwann?) neu verbindet, kann ich ja getrost in Urlaub fahren, oder? ;-)

Nochmals meine Frage vom Anfang: ist es sinnvoll Modem und/oder Fritzbox regelmäßig per Schaltuhr zu resetten? Nach der oben beschriebenen Kabelstörung war die Voda-Box irgendwie tot. Ok, ich habe nicht lange gewartet sondern nach ein paar Minuten einfach resettet.

ps
ich habe gerade mal für 1 Minute die Fritzbox vom Modem getrennt und die Online Monitor Seite beobachtet. Die Trennung kriegt die Fritzbox ziemlich schnell mit, für die Wiederverbindung benötigt sie ca 20-30 Sekunden. Also die Fritzbox braucht glaub ich keinen Sicherheits-Reset. Aber dem Kabelrouter werde ich eine Schaltuhr spendieren.

1572994106744.png
Bild geschrumpft by stoney
 
Zuletzt bearbeitet von einem Moderator:

iqjet

Mitglied
Mitglied seit
16 Jul 2006
Beiträge
708
Punkte für Reaktionen
0
Punkte
16
Reset per Schaltuhr: Ein schlichtes Nein reicht dir hoffentlich

...zu kompliziert?
Nein, falls man sich helfen lässt.

Ich hatte dir Fragen in Post #7 gestellt, welche nonchalant ignoriert wurden.
Deinen 2ten Post habe ich aufmerksam gelesen, speziell der "Download wird immer langsamer bis er abricht" und "ping google.de und vodafone.de" gehen nicht.

Letzter Versuch
Merksatz: Bridge Mode FB nicht gleich Bridge Mode VF Kundencenter
Ich kaue dir sogar die VF Website "Bridge Mode" vor:

Und die Einstellung muß so aussehen:

Code:
VF Bridge Mode einstellen
Im Bridge Mode werden die Daten transparent an das Endgerät weitergeleitet wie z.B. bei einem einfachen Kabelmodem. Die Aktivierung des Bridge Mode sollte nur von Experten mit Netzwerkkenntnissen vorgenommen werden.
Bridge Mode: eingeschaltet
Machst du diese Einstellung nicht, bekommst du ein doppeltes NAT, dein Modem und deine FB naten. Durch dein erfolgloses ping "google.de" und dein einhergehender Verbindungsverlust "Linux update" ist ein doppeles NAT die mutmaßliche Ursache.

Und nein @@iqjet, bislang kommt meine heimische IT-Infrastruktur noch ohne IPV6 aus.
WAN IPv6: Hust...Hier denke ich, irrst du dich erneut. Jeder VF Kabel Kunde bekommt per default einen Dual Stack (lite?) und damit IPv6 zugewiesen.

Im Normaltarif wirst du für die Umstellung auf pure IPv4 was zahlen müßen, aber da bin ich mir nicht sicher. Ich habe (2013) für die Umstellung nichts bezahlt, da ich einen Business Tarif habe.

VF Kundencenter Hilfe Eingabe -> "IPv6"
Code:
Deine Eingabe: Ich will mehr Infos zu IPv6
Hierzu können wir Dir lediglich noch einmal dieselbe Information anbieten:
Betreibst Du Dein System über IPv4, meld Dich bitte bei unseren Kollegen von der Technik. Frag dort bitte, ob Dir mit Dual Stack geholfen werden kann. Unten siehst Du, wie Du uns erreichst.

Ich will mehr Infos zu IPv6
Prüfe auf IPv6 Adresse das nochmal bei browserleaks.com

Falls du diese Einstellungen "VF Bridge Mode" auf "Ein" gestellt hast, kannst du
das Thema Schaltuhr vergessen und in Urlaub fahren.
Wie bist du nur auf die Idee mit der Schaltuhr gekommen? o_O
Man lernt nie aus.
 
Zuletzt bearbeitet:

telefonicus

Aktives Mitglied
Mitglied seit
14 Okt 2005
Beiträge
923
Punkte für Reaktionen
0
Punkte
16
Statt hier den Schlaumeier zu machen setz lieber mal die Lesebrille auf. Der Thread-Titel lautet doch:

Fritzbox hinter Vodafone-Kabelrouter (Bridge Mode)...

Und warum willst du mir unbedingt IPv6 aufs Auge drücken? Ich habe keins bestellt und auch keins bekommen.

--

Statt hier den Schlaumeier zu machen setz lieber mal die Lesebrille auf. Der Thread-Titel lautet:

Fritzbox hinter Vodafone-Kabelrouter (Bridge Mode)...

Glaube mir, ich weiß was Bridge Mode ist und was NAT.

Und warum willst du mir unbedingt IPv6 aufs Auge drücken? Ich habe keins bestellt und auch keins bekommen.
 
Zuletzt bearbeitet von einem Moderator:

iqjet

Mitglied
Mitglied seit
16 Jul 2006
Beiträge
708
Punkte für Reaktionen
0
Punkte
16
Na dann ist dir nicht zu helfen.
Wie der Thread-Titel lautet ist mir klar, nochmals du hast mutmaßlich keinen Bridge Mode seitens VF.

Viel Spaß mit der Eieruhr
 

telefonicus

Aktives Mitglied
Mitglied seit
14 Okt 2005
Beiträge
923
Punkte für Reaktionen
0
Punkte
16
3 Tage gut gegangen...

Heute zeigte die Fritzbox Rotlicht.

09.11.19 14:26:14 Internetverbindung ist fehlgeschlagen: Fehlergrund: 2 (DHCPv4 no answer on DISCOVER)
09.11.19 14:19:54 Internetverbindung wurde getrennt.
09.11.19 14:19:54 Internetverbindung ist fehlgeschlagen: Fehlergrund: 1 (DHCPv4 lease timed out)
09.11.19 07:34:54 Internetverbindung wurde erfolgreich erneuert.

Fritz-Reset hat nichts genützt - das "Kabelmodem" war ausgestiegen. Also muss ich das doch regelmäßig per Schaltuhr resetten.

Als ich die Schaltuhr programmieren wollte, musste ich feststellen, dass die kürzeste Aus-Schaltzeit eine halbe Stunde ist :-(

Ich brauche also was anderes...
 
Zuletzt bearbeitet:

sonyKatze

Mitglied
Mitglied seit
6 Aug 2009
Beiträge
559
Punkte für Reaktionen
33
Punkte
28
Den Einwand von iqjet kannst Du widerlegen, indem Du einen Paket-Mitschnitt laufen lässt. Dort in der App Wireshark filterst Du dann nach „bootp“. Von der Ebene Ethernet gib uns bitte nur die „Src“. Das ist eine MAC. Folglich brauchen wir nur das was vor der Klammer steht.

Ich befürchte wie iqjet, dass Du im falschen Modus bist. Ja, ich hoffe das! Wenn nämlich nicht, wüsste ich keinen anderen Trick, als Dein Kabel-Modem austauschen zu lassen. Und wenn es dann immer noch passiert, Deinen Kabel-Anbieter aufzufordern seine Komponente auf der anderen Seite auszutauschen. Weil er das anfangs ignorieren und sich das ewig hinziehen wird, empfehle ich Dir in dieser Zeit auf eine FRITZ!Box Cable auszuweichen. Aber bleibe bitte weiter an dem Austausch dran, weil das auch Bewohner in Deiner Umgebung betrifft … aber, aber soweit sind wir (noch lange) noch nicht. Poste bitte mal jenen Teil der MAC.
 
Zuletzt bearbeitet:

PeterPawn

IPPF-Urgestein
Mitglied seit
10 Mai 2006
Beiträge
12,316
Punkte für Reaktionen
803
Punkte
113
Ich brauche also was anderes...
Als Blitzangebot gäbe es gerade den 2er-Pack "Gosund SP111" für 19,19 EUR beim großen Fluß.

Da kann man (mittels "tuya-convert") mit irgendeinem Linux-System (das einen WLAN-Adapter hat) in 5 Minuten ein Tasmota-Image draufbraten - ohne jedes Schrauben. In meinen Augen ist das derzeit der sinnvollste smarte Steckdosen-Adapter - inkl. Verbrauchsmessung, trägt seitwärts kaum auf (wenn man mehrere nebeneinander in einer Mehrfach-Steckdosenleiste betreiben will) und wird von Tasmota "out of the box" unterstützt mit dem Module 45 (BlitzWolf SHP). Einfacher geht es auch für Laien kaum noch ...

Dann kann man diese Steckdose in das WLAN der FRITZ!Box einbinden und ganz einfach per HTTP-Request steuern - das alles für < 10 EUR und mit etwas (allerdings sehr geringem) eigenem Aufwand.

Vor allem dann, wenn man als "special interests" noch einen RasPi angegeben hat ... da hat man die notwendige Hardware für "tuya-convert" ja auch bereits (bzw. eine mögliche).

------------------------------------------------------------------------------------------------

Laß Dich hinsichtlich der Frage "Bridge-Mode oder nicht" nicht verrückt machen ... die Zuweisung der öffenlichen IPv4-Adresse an die FRITZ!Box in #4 zeigt, daß das Modem zumindest zu diesem Zeitpunkt im richtigen Modus war. Dieser Modus wird über die Vodafone-Webseite konfiguriert, da das Modem beim Start eine Konfiguration von Kabelanbieter übermittelt bekommt. Das hast Du offenbar korrekt eingetragen bei Vodafone.

Die (zwischenzeitliche) Zuweisung einer privaten IP-Adresse ist vermutlich darauf zurückzuführen, daß das Modem zu diesem Zeitpunkt noch keine Konfiguration vom Provider erhalten hatte (hier kann "Strom weg" und "Neustart" schon einen Unterschied machen, wenn das Sagemcom-Gerät dann erst wieder auf die Suche nach Kanalzuordnungen geht bei einem "Kaltstart") ... der lokale Zugriff funktioniert dann natürlich trotzdem schon (inkl. DHCP-Server im Sagemcom-Router), damit man diesen Router auch irgendwie konfigurieren kann, wenn keine DOCSIS-Verbindung zustande kommt und keine Konfiguration vom KNB übermittelt wird.

Wenn sich das Sagemcom-Modem (was ja eigentlich auch ein Router ist) tatsächlich reproduzierbar aufhängen sollte, wäre wohl wirklich ein Austausch angesagt - nur sollte man das dann auch passend belegen können, indem man die Zeitpunkte dieser Aussetzer protokolliert.

Selbst wenn Du ein Problem in der 7390 mit dem DHCP-Client auf dem WAN-Interface haben solltest, bringt Dir der vorgeschlagene Paketmitschnitt auch nur dann etwas, wenn Du wenigstens grob voraussagen kannst, wann das Erneuern der DHCP-Lease ansteht ... kein Mensch kann sinnvoll seinem Edge-Router über mehrere Tage per Paketmitschnitt auf die Finger sehen (und das dann auch noch auswerten lassen), wenn er nicht extrem wenig Internet-Traffic verursacht - die FRITZ!Box schneidet dann nämlich alles mit, was auf dem entsprechenden Interface übertragen wird und kennt keine Filter, die bereits die aufzuzeichnenden Daten aussieben würden.

Um tatsächlich zu protokollieren, ob und wann der Sagemcom-Router (im Bridge-Mode) regelmäßig aussteigt, würde ich ein periodisches "ping" zu einer Internet-Adresse auf irgendeinem anderen Gerät im LAN laufen lassen (notfalls auch auf der 7390 selbst, was dann aber selbstmodifizierte Firmware erfordert - die einem andererseits aber auch bei der Automatisierung der "Fehlerbehandlung" helfen kann) und erst einmal ermitteln, ob die Abbrüche tatsächlich immer dann auftreten, wenn ein "renew" für die DHCP-Lease ansteht oder ob das eher unregelmäßig geschieht. Hier steht mal etwas von einer Woche und mal von 3 Tagen (bis zum "nichts geht mehr") - dazwischen sollte es schon einige Erneuerungen der DHCP-Lease gegegen haben, wenn die Lease-Time tatsächlich im Stundenbereich liegt. Die Internetverbindung (bzw. das Modem) kann natürlich auch zu einem Zeitpunkt "sterben", wo keine Erneuerung der Lease ansteht - dann kriegt die FRITZ!Box selbst den Abbruch gar nicht mit, es sei denn, sie hat noch andere Aufgaben (z.B. als SIP-Client), die davon dann ebenfalls betroffen sind.

Wobei Du noch probieren könntest, bei den Anschlußeinstellungen den dritten Punkt (externes Modem) auszuwählen ... der zweite Punkt ist mehr oder weniger ein Zwitter, bei dem auf LAN1 als WAN-Anschluß umgestellt wird und trotzdem noch ein paar "Voreinstellungen" hinsichtlich DHCP u.ä. getroffen werden. Das hat die Box m.E. von den "HomeBoxen" bei Vodafone (angefangen bei der HomeBox 1, die ja eine 7270 war) geerbt, damit die Einstellungen für die Kunden nicht so kompliziert aussahen - man muß (bzw. kann) bei der dritten Option dann halt die WAN-Seite der Box noch etwas genauer konfigurieren, was beim zweiten Punkt (aber wechselnd in den FRITZ!OS-Versionen) weiter "versteckt" wurde. Auch auf die SIP-Konfiguration hat(te) diese Auswahl Auswirkungen ... wobei die 06.8x inzwischen wieder so lange her ist, daß ich die exakten Unterschiede nicht mehr auf dem Schirm habe.

------------------------------------------------------------------------------------------------

Gäbe es bei routermiete.de noch die 6490 (oder irgendein anderes Cable-Modell) zur Miete, würde ich Dir auch dazu raten, das Gespann aus FAST5460 und 7390 durch eine Cable-Box zu ersetzen (zumindest befristet und als "Teststellung") ... für jemanden, der nicht längerfristig in einer Wohnung oder einem Haus mit einem Cable-Anschluß wohnt oder auch mal den Anbieter wechseln möchte (weil bei ihm gut ausgebaut ist und es Alternativen gibt), macht die Anschaffung einer Cable-FRITZ!Box jedenfalls nur begrenzten Sinn in wirtschaftlicher Hinsicht.

Bis sich so eine Anschaffung dann amortisiert hat (verglichen mit einem Miet- oder Leihgerät), vergeht einiges an Zeit und wenn man nicht gerade FRITZ!Box-Enthusiast ist und immer das Neueste haben will (was ich bei einer 7390 jetzt mal nicht unterstelle), dann rechnet man eher mit dem spitzen Bleistift nach und so ein Router ist kein Gerät, was man täglich in die Hand nimmt (wie ein Smartphone) und wo einem die Unterschiede in den Modellen tatsächlich jeden Tag ins Auge springen und zum Nachdenken führen, ob man nicht endlich mal einen neuen Router bräuchte.

Insofern ist ein "generischer Router" hinter einem DOCSIS-"Modem" gar keine sooo schlechte Lösung, wenn man auf die Vorteile verzichten kann (und will), die sich aus der Integration beider Geräte in einem ergeben (u.a. kriegt die 7390 so eben keine Information, wann der KNB das Modem konfiguriert hat - bei einem einzelnen Gerät besteht dieses Problem nicht). Es läßt einem zumindest auch in der Zukunft die Wahl, weil man seinen liebgewonnenen Router mit einer anderen Technologie weiterhin verwenden kann.
 
  • Like
Reaktionen: telefonicus

telefonicus

Aktives Mitglied
Mitglied seit
14 Okt 2005
Beiträge
923
Punkte für Reaktionen
0
Punkte
16
Hallo @PeterPawn,
danke für deine ausführliche Antwort! Ich war grade am Schreiben, muss jetzt grad mal weg, antworte heute Abend.

_____________________________________________________________________________________
Hab mir gerade das Wireshark-Paket installiert.

Ethernet II, Src: Avm_54:7b:78 (24:65:11:54:7b:78)
Ethernet II, Src: IntelCor_1d:fd:74 (00:24:d7:1d:fd:74)

Beantwortet das deine MAC-Frage @sonyKatze ?

Ein "bootp" habe ich nicht gefunden. Wie lange muss ich loggen, während die Fritzbox was genau machen soll?
 
Zuletzt bearbeitet:

sonyKatze

Mitglied
Mitglied seit
6 Aug 2009
Beiträge
559
Punkte für Reaktionen
33
Punkte
28
der vorgeschlagene Paketmitschnitt
Ich vergaß zu erwähnen, dass das Modem vorher kurz stromlos gemacht werden muss. Danach müsste die FRITZ!Box merken, dass sie Ethernet verloren hat und erneut eine DHCP-Abfrage machen, also bootp greifen.
 

PeterPawn

IPPF-Urgestein
Mitglied seit
10 Mai 2006
Beiträge
12,316
Punkte für Reaktionen
803
Punkte
113
Vielleicht verstehe ich dann den Sinn dieses Mitschnitts auch nicht so ganz ... was soll er am Ende beweisen?

Wenn das Modem (genauer: der Sagemcom-Router FAST5460) neu gestartet wird, initialisiert es sich zunächst mal im "normalen Router-Modus". Das heißt, hier kriegt (nachdem Ethernet im LAN bereit ist und das Teil hat per se erst mal kein WLAN (das ist eine freizuschaltende Option), sollte also per LAN verbunden sein mit der FRITZ!Box) JEDER Client, der in diesem Zustand einen DHCP-Request auslöst, erst einmal eine IP-Adresse aus dem konfigurierten LAN-Segment für den Router-Modus des Sagemcom-Gerätes angeboten.

Erst nach der Verbindungsaufnahme mit dem CMTS kriegt das Sagemcom-Gerät die passende Konfigurationsdatei und schaltet sich in den Bridge-Modus (das "config"-File kriegt es vom CMTS bei JEDEM Start) - von diesem Zeitpunkt an bringt dann der erste DHCP-Request auch für den betreffenden Client eine öffentliche IP-Adresse, weil der Request nun tatsächlich an das CMTS (und damit in das Netz des KNB) weitergereicht wird. Die FRITZ!Box würde von diesem Zeitpunkt nur dann etwas mitbekommen, wenn der Sagemcom-Router bei bzw. nach der Umkonfiguration für den Bridge-Mode seine LAN-seitigen Ports neu initialisiert und es für die FRITZ!Box dann so aussähe, als wäre kurzzeitig das Kabel gezogen worden (also auch nur, wenn zwischen Modem und Box keine andere aktive Komponente mehr ist).

Daß beides per se erst einmal richtig konfiguriert ist, zeigen die Ergebnisse in #4 ... bleibt also die Frage übrig, warum in (offenbar eher unregelmäßigen Abständen) das Sagemcom-Gerät als CM die Daten nicht mehr korrekt weiterleitet. Das Fehlschlagen des DHCP-RENEW-Requests ist ja offensichtlich (zumindest ist das bis zum Beweis des Gegenteils erst einmal die plausibelste Annahme) eher Symptom als Ursache der Fehlfunktion - nur dann, wenn alle anderen Aktivitäten (von denen man hier im Thread noch nichts weiter gelesen hat) genau bis zu diesem Versuch der Erneuerung der Lease weiterhin funktionieren, rückt das DHCP-Protokoll "in den Fokus der Ermittlungen" und die Frage, ob dieses Erneuern die Ursache ist, erlangt entsprechende Relevanz.

Normalerweise funktioniert der DHCP-Client in der FRITZ!Box einwandfrei und beachtet auch alle übermittelten Timer. Da er bereits nach ca. der Hälfte der Lease-Time (die konkreten Werte legt allerdings der Provider, hier also Vodafone, fest) versucht, die Lease zu verlängern (der sogenannte T1-Timer) und hier die Kommunikation mit dem DHCP-Server auch per Unicast erfolgt, deutet die Nachricht in #12 sogar darauf hin, daß das Problem schon deutlich zuvor aufgetreten sein muß.

Denn nach 7/8 der Lease-Time (so zumindest die Empfehlung im Standard - das ist dann der T2-Timer) beginnt der Client dann erneut (weil er auf seine Verlängerungsversuche keine Antwort erhalten hat, ansonsten startete die Lease-Time ja bereits da neu), mittels Broadcast-Paketen nach einem anderen DHCP-Server zu suchen. Selbst wenn er darauf immer noch keine Antwort erhält, hat er trotzdem für das verbliebene Achtel der Zeit (also eigentlich für "lease time - T2", weil man die Anteile auch in der Zuweisung (DHCP-OFFER/DHCP-ACK) vorgeben kann) weiterhin das Recht, die einmal zugewiesene Adresse zu benutzen ... d.h. auch, so ein fehlgeschlagener Versuch der Erneuerung nach T2-Ablauf führt nicht sofort dazu (jedenfalls solange die Differenz zwischen Lease-Time und T2 einigermaßen groß ist), daß deshalb keine Internet-Kommunikation mehr möglich ist. Wenn also die Box in #12 ein "DHCPv4 lease timed out" konstatiert, hat sie schon eine Weile zuvor keine Antworten mehr erhalten ... vermutlich war da das CM bereits ausgestiegen.

Daher verstehe ich hier (zumindest bei diesem Fehlerbild) auch nicht so ganz, was der Paketmitschnitt an Informationen erbringen soll ... außer ggf. die exakten Werte für die Timer aus dem DHCP-ACK-Paket. Die kann man aber auch ermitteln, indem man einfach irgendeinen Linux-Host (und nach Signatur hat der Fragesteller hier ja mehrere, außerdem wollte er ein Linux-System aktualisieren in #4) an den Sagemcom-Router hängt (also an das "CM") und sich mittels eines DHCP-Clients (z.B. dhclient) die Einzelheiten einer solchen Lease ansieht.
Ich weiß nicht, ob das bei Vodafone auch parallel für zwei Clients funktioniert ... der Provider kann im CM auch konfigurieren, wieviele IP-Adressen die Clients hinter dem CM im Bridge-Mode verwenden dürfen.
Das dürfte einfacher sein (vom Triggern bis zur Auswertung), als in einem Packet-Dump nach den DHCP-Paketen zu suchen.
 
Zuletzt bearbeitet:
  • Like
Reaktionen: telefonicus

telefonicus

Aktives Mitglied
Mitglied seit
14 Okt 2005
Beiträge
923
Punkte für Reaktionen
0
Punkte
16
Als Blitzangebot gäbe es gerade den 2er-Pack "Gosund SP111" für 19,19 EUR beim großen Fluß.

Da kann man (mittels "tuya-convert") mit irgendeinem Linux-System (das einen WLAN-Adapter hat) in 5 Minuten ein Tasmota-Image draufbraten - ohne jedes Schrauben.
Yepp, hab ich auch schon auf dem Zettel. Vor mir liegt eine Sonoff 20 Wifi und wartet auf Tasmota. Einen USB-TTL Converter hatte ich mir auch schon zugelegt, weil ich den Tuya-WiFi-Hack noch nicht kannte. Vielleicht erfahre ich beim Studium der Quellen auch, warum ich einen Raspi dafür brauche. Meine Raspis haben hier alle einen festen Job, aber kurzfristig könnte ich schon mal einen entbehren :)

Laß Dich hinsichtlich der Frage "Bridge-Mode oder nicht" nicht verrückt machen ... die Zuweisung der öffenlichen IPv4-Adresse an die FRITZ!Box in #4 zeigt, daß das Modem zumindest zu diesem Zeitpunkt im richtigen Modus war. Dieser Modus wird über die Vodafone-Webseite konfiguriert, da das Modem beim Start eine Konfiguration von Kabelanbieter übermittelt bekommt. Das hast Du offenbar korrekt eingetragen bei Vodafone.

Die (zwischenzeitliche) Zuweisung einer privaten IP-Adresse ist vermutlich darauf zurückzuführen, daß das Modem zu diesem Zeitpunkt noch keine Konfiguration vom Provider erhalten hatte (hier kann "Strom weg" und "Neustart" schon einen Unterschied machen, wenn das Sagemcom-Gerät dann erst wieder auf die Suche nach Kanalzuordnungen geht bei einem "Kaltstart") ... der lokale Zugriff funktioniert dann natürlich trotzdem schon (inkl. DHCP-Server im Sagemcom-Router), damit man diesen Router auch irgendwie konfigurieren kann, wenn keine DOCSIS-Verbindung zustande kommt und keine Konfiguration vom KNB übermittelt wird.

Wenn sich das Sagemcom-Modem (was ja eigentlich auch ein Router ist) tatsächlich reproduzierbar aufhängen sollte, wäre wohl wirklich ein Austausch angesagt - nur sollte man das dann auch passend belegen können, indem man die Zeitpunkte dieser Aussetzer protokolliert.

Selbst wenn Du ein Problem in der 7390 mit dem DHCP-Client auf dem WAN-Interface haben solltest, bringt Dir der vorgeschlagene Paketmitschnitt auch nur dann etwas, wenn Du wenigstens grob voraussagen kannst, wann das Erneuern der DHCP-Lease ansteht ... kein Mensch kann sinnvoll seinem Edge-Router über mehrere Tage per Paketmitschnitt auf die Finger sehen (und das dann auch noch auswerten lassen), wenn er nicht extrem wenig Internet-Traffic verursacht - die FRITZ!Box schneidet dann nämlich alles mit, was auf dem entsprechenden Interface übertragen wird und kennt keine Filter, die bereits die aufzuzeichnenden Daten aussieben würden.

Um tatsächlich zu protokollieren, ob und wann der Sagemcom-Router (im Bridge-Mode) regelmäßig aussteigt, würde ich ein periodisches "ping" zu einer Internet-Adresse auf irgendeinem anderen Gerät im LAN laufen lassen (notfalls auch auf der 7390 selbst, was dann aber selbstmodifizierte Firmware erfordert - die einem andererseits aber auch bei der Automatisierung der "Fehlerbehandlung" helfen kann) und erst einmal ermitteln, ob die Abbrüche tatsächlich immer dann auftreten, wenn ein "renew" für die DHCP-Lease ansteht oder ob das eher unregelmäßig geschieht. Hier steht mal etwas von einer Woche und mal von 3 Tagen (bis zum "nichts geht mehr") - dazwischen sollte es schon einige Erneuerungen der DHCP-Lease gegegen haben, wenn die Lease-Time tatsächlich im Stundenbereich liegt.
Ja, s. dritter Screenshot in Post #4. In Post #4 habe ich auch die Erklärung von AVM zum 12-stündlichen Renew gepostet (blauer Text).
Wobei Du noch probieren könntest, bei den Anschlußeinstellungen den dritten Punkt (externes Modem) auszuwählen
Hatte ich schon mal, ich glaube, ich hab so ziemlich alles durchprobiert, mit der 7390 und mit einer 7412.

Insofern ist ein "generischer Router" hinter einem DOCSIS-"Modem" gar keine sooo schlechte Lösung
Ja, und dabei will ich auch erst mal bleiben. Zumal ich öfter mal andere Router testen muss.

Bevor ich in Urlaub fahre, muss eine Reset-Lösung her, notfalls mit meiner fehlgekauften Halbestunden-Schaltuhr. Zwischen 4:00 und 4:30 brauche ich meist kein Internet. Aber lieber wäre mir, meine Sonoff hätte schon den Tuya-Hack.

Danke @PeterPawn für deine Einschätzungen, ich sehe das im Großen und Ganzen genau so.

lg
Telonius
 

iqjet

Mitglied
Mitglied seit
16 Jul 2006
Beiträge
708
Punkte für Reaktionen
0
Punkte
16
@Peter Pan
Eine sehr gute Erklärung für Lease und Renew.
Sehr gut das du ihm einen Weg aufgezeigt hast wie man eine Eieruhr mit Linux bastelt.
Ich will hoffen das der TO zum großen Fluss schwimmt, den 2er Pack kauft, und so sein Problem löst.

Ich bin der Meinung das der TO einen Konfigfehler aufweißt. Der TO gibt auch auf Nachfragen keine Infos.
Auch ist unklar ob das Modem aussteigt oder die FB. Vielleicht verursachen die Unmenge an States die FB oder den VF Router zu einem reset.
Post4: Interessant ist das die Telefonie nicht funktioniert hat. Hat der TO VoC oder Voip? Ich mutmaße VoC.

Zur Info:
Ich bekomme, nachdem die pfSense neu startet, einen Request auf Port 67 von meinem VF Router. Die pfSense bekommt eine WAN IP zugewiesen mit einer Lease Time, sorry die genaue Zeit habe ich vergessen, um die 26xx sek.
Nach 20h bekam ich keinen einzigen DHCP Request auf meiner pfSense WAN Schnittstelle. Ziehe ich das WAN Ethernetkabel ab beginnt das Spiel von vorne. Der TO sollte auch Port 546 und 547 im Auge behalten.
 

NDiIPP

Aktives Mitglied
Mitglied seit
13 Apr 2017
Beiträge
2,178
Punkte für Reaktionen
343
Punkte
83
Vielleicht erfahre ich beim Studium der Quellen auch, warum ich einen Raspi dafür brauche.
Brauchst du dafür nicht. Ist nur ein mögliches Gerät.

---

Edit:
Sehr gut das du ihm einen Weg aufgezeigt hast wie man eine Eieruhr mit Linux bastelt.
Ich will hoffen das der TO zum großen Fluss schwimmt, den 2er Pack kauft, und so sein Problem löst.
Ich habe (dank des Hinweises von @PeterPawn) die Gelegenheit wahrgenommen und bestellt. Aber nicht um daraus Eieruhren zu basteln oder Modem/Router damit zu schalten, sondern für ganz andere Zwecke (u.a. für eine Zirkulationspumpe, zur elektrischen Verbrauchsmessung oder auch für die Ansteuerung eines Herrnhuter Stern). Für eine Eieruhr gibt es sicherlich geeignetere Geräte.

Ich bin der Meinung das der TO einen Konfigfehler aufweißt. Der TO gibt auch auf Nachfragen keine Infos.
Ich bin ja eher der Meinung (trotz defekten Displays meiner Glaskugel), das verwendete DOCSIS-Modem legt unregelmäßig Reboots hin. Vielleicht ja aufgrund eines Defektes. Für einen evtl. "Konfigfehler des TO" ist imo eher ein Psychotherapeut zuständig...
 
Zuletzt bearbeitet:

3CX PBX - GRATIS
Linux / Win / Cloud

Statistik des Forums

Themen
233,292
Beiträge
2,032,454
Mitglieder
351,825
Neuestes Mitglied
Holstentor