.titleBar { margin-bottom: 5px!important; }

[gelöst] Asterisk Fehlermeldung "Unable to lookup host ..."

Dieses Thema im Forum "Asterisk Allgemein" wurde erstellt von beowulf, 13 Jan. 2007.

  1. beowulf

    beowulf Neuer User

    Registriert seit:
    28 Mai 2004
    Beiträge:
    161
    Zustimmungen:
    0
    Punkte für Erfolge:
    16
    Ort:
    Singapore & Vienna
    #1 beowulf, 13 Jan. 2007
    Zuletzt bearbeitet: 19 Feb. 2007
    Hi!

    Ich bin neu im Verwenden von Asterisk und habe Asterisk 1.2.9.1 auf einer OpenBSD-Box laufen. Mit betateilchens Anleitung habe ich auch die Sipgate und SipPhone Accounts erfolgreich eingerichtet.

    Bei einem Account aber spießt es sich. Eingehende Anrufe werden gar nicht erst signalisiert und in der Asterisk Konsole kommt folgender Fehler:

    WARNING[13688]: chan_sip.c:3527 process_sdp: Unable to lookup host in c= line, 'IN IP4 213.185.164.123213.185.164.123'

    Googlen hat mir nicht weitergeholfen und so probiere ich es mal hier. Vielleicht kann mir jemand weiterhelfen.

    Danke!

    Niki
     
  2. kombjuder

    kombjuder IPPF-Promi

    Registriert seit:
    2 Nov. 2004
    Beiträge:
    3,086
    Zustimmungen:
    0
    Punkte für Erfolge:
    0
    Ort:
    Weil am Rhein

    Da steht doch der Fehler. Du hast anscheinend einen fehlerhaften Eintrag in deiner sip.conf. Das sind zwei IP-Adressen am Stück. Also mal den Eintrag anschauen.
     
  3. beowulf

    beowulf Neuer User

    Registriert seit:
    28 Mai 2004
    Beiträge:
    161
    Zustimmungen:
    0
    Punkte für Erfolge:
    16
    Ort:
    Singapore & Vienna
    Die Syntax meiner sip.conf-Einträge orientiert sich an der in dem "Kurs: Wir konfigurieren uns einen Asterisk" beschriebenen. Für Sipgate funktioniert das auch; für diesen anderen Provider nicht.

    Und nein, ich habe die IP dieses Providers *nicht* nebeneinander geschrieben. Aber bitte, guck' hier.

    ---sip.conf---
    ; MobileCall
    register => 123456:blabla@sip001.mitacs.com/123456

    ; SIP out
    [123456]
    type=peer
    username=123456
    secret=blabla
    host=sip001.mitacs.com
    fromdomain=sip001.mitacs.com
    insecure=very
    canreinvite=no
    nat=yes
    disallow=all
    allow=ulaw

    ; SIP in
    [MobileCall_in]
    type=peer
    fromdomain=sip001.mitacs.com
    host=sip001.mitacs.com
    disallow=all
    allow=ulaw
    allow=ilbc
    allow=gsm
    context=ankommend
    ---END---

    Also, wenn jeman einen Fehler sieht, bitte sagen. Vier Augen sehen mehr als 2.

    Danke!

    Niki
     
  4. kombjuder

    kombjuder IPPF-Promi

    Registriert seit:
    2 Nov. 2004
    Beiträge:
    3,086
    Zustimmungen:
    0
    Punkte für Erfolge:
    0
    Ort:
    Weil am Rhein
    Was sagt denn ein ping sip001.mitacs.com?

    Kommt dort die richtige ip-Adresse? Wenn ja schau mal unter /var/log/asterisk/messages was asterisk beim start an Fehlermeldungen bringt. Zumindest zu mitacs sollte er was sagen.
     
  5. HobbyStern

    HobbyStern Aktives Mitglied

    Registriert seit:
    5 Dez. 2005
    Beiträge:
    1,837
    Zustimmungen:
    0
    Punkte für Erfolge:
    36
    Beruf:
    vorhanden
    Ort:
    Ruhrgebiet
    Hey Ihr Zwei,

    die erste IP gehört zu dem mitacs-Server.

    Quelle (ping)

    Code:
    Ping srv9.mitacs.com [213.185.164.123]
    
    Die zweite ist aktiv, der Nummernbereich gehört zur Telecom Austria, ist aber nicht direkt zuzuordnen.

    Quelle : (whois)

    Code:
    inetnum:        213.185.160.0 - 213.185.191.255
    org:            ORG-CTAG1-RIPE
    netname:        AT-COLT-20010906
    descr:          PROVIDER
    descr:          COLT Telecom Austria GmbH
    country:        AT
    admin-c:        WK1840-RIPE
    admin-c:        NEIL1-RIPE
    tech-c:         JG10028-RIPE
    status:         ALLOCATED PA
    mnt-by:         RIPE-NCC-HM-MNT
    mnt-lower:      AS12878-MNT
    mnt-routes:     AS12878-MNT
    source:         RIPE # Filtered
    
    Könnte die zweite der Telecom Austria, Deine eigene sein ?

    Kannst Du andere IP Adressen sauber ansprechen ? Ist es ggf. kein Asterisk Problem ?

    Grüsse, Stefan
     
  6. beowulf

    beowulf Neuer User

    Registriert seit:
    28 Mai 2004
    Beiträge:
    161
    Zustimmungen:
    0
    Punkte für Erfolge:
    16
    Ort:
    Singapore & Vienna
    So ist es!

    Beide IPs, die Asterisk in der Konsole auswirft, sind die 213.185.164.123. Interessant ist, daß ein Reverse DNS auf die IP nicht funktioniert.

    Ja, ich kann alle anderen IPs sauber ansprechen. Provider wie Sipgate funktionieren problemlos.

    Ich werde mir mal die Logs genau vornehmen.

    Niki
     
  7. HobbyStern

    HobbyStern Aktives Mitglied

    Registriert seit:
    5 Dez. 2005
    Beiträge:
    1,837
    Zustimmungen:
    0
    Punkte für Erfolge:
    36
    Beruf:
    vorhanden
    Ort:
    Ruhrgebiet
    Mach doch mal einen SIP Debug wenn er sich registriert, also "sip debug" und ein "sip reload", dann weisst wenigstens was er dann macht, jedoch immer noch nicht "warum" ;)

    Grüsse, Stefan
     
  8. beowulf

    beowulf Neuer User

    Registriert seit:
    28 Mai 2004
    Beiträge:
    161
    Zustimmungen:
    0
    Punkte für Erfolge:
    16
    Ort:
    Singapore & Vienna
    Tja, das SIP Debug hat leider nix gebracht. Die Fehlermeldung ist immer die gleiche und wird nicht aussagekräftiger.

    Kann man dem Asterisk beibringen, keinen Reverse-DNS-Lookup zu machen?

    Niki
     
  9. merlion

    merlion Mitglied

    Registriert seit:
    22 Aug. 2004
    Beiträge:
    202
    Zustimmungen:
    0
    Punkte für Erfolge:
    0
  10. beowulf

    beowulf Neuer User

    Registriert seit:
    28 Mai 2004
    Beiträge:
    161
    Zustimmungen:
    0
    Punkte für Erfolge:
    16
    Ort:
    Singapore & Vienna
    Hi!

    Danke für die Links. Ich habe mit dem serverlookup=yes herumgespielt, einmal "yes", einmal "no". Das Ergebnis ist immer das gleiche. Eingehende Anrufe werden nicht siganilisiert; ausgehende Anrufe gehen hingegen problemlos.

    Ich poste mal meine sip.conf und extensions.conf Einträge für den fraglichen Provider, ebenso ein Debug Log vom Asterisk.

    Hier meine sip.conf
    Code:
    [general]
    disallow=all
    allow=ulaw
    allow=alaw
    allow=ulaw
    allow=g729
    allow=gsm
    allow=slinear
    ;qualify=no
    context=default
    bindport=5060
    bindaddr=0.0.0.0
    srvlookup=yes
    localnet=192.168.0.0/255.255.255.0
    
    
    ; --------------------------------------------------------------------
    ;
    ; Connection Data for SIP providers
    ;
    
    ; MobileCall
    register => 43720755555:XXXXX@sip001.mitacs.com/43720755555
    
    ; ---
    ; SIP out
    [43720755555]
    type=peer
    username=43720755555
    fromuser=43720755555
    secret=XXXXX
    host=sip001.mitacs.com
    fromdomain=sip001.mitacs.com
    insecure=very
    nat=yes
    qualify=yes
    
    
    ; ---
    ; SIP in
    [Mitacs_in]
    type=peer
    fromdomain=sip001.mitacs.com
    host=sip001.mitacs.com
    nat=yes
    context=ankommend
    
    
    ; --------------------------------------------------------------------
    ;
    ; Connection Data for SIP clients
    ;
    
    [39]
    callerid=Phone 3 <39>
    host=dynamic
    domain=192.168.0.82
    user=39
    secret=100
    type=friend
    mailbox=39
    nat=yes
    canreinvite=no
    qualify=yes
    
    Hier meine extensions.conf
    Code:
    [general]
    static=yes
    writeprotect=no
    
    ; --------------------------------------------------------------------
    ; Es hat sich als gute Praxis erwiesen, die Inhalte der Datei
    ; extensions.conf modular aufzubauen. Diese Praxis wollen
    ; wir auch hier anwenden
    ;
    
    [lokal]
    ; Erreichbarkeit der Nebenstellen 30-39
    ; untereinander herstellen
    
    exten => _3X,1,NoCDR()
    exten => _3X,n,Dial,SIP/${EXTEN}|55|Ttr
    
    ; SIP Provider
    [Mitacs_out]
    exten => _X.,1,SetCallerId,SIPID
    exten => _X.,2,Dial(SIP/${EXTEN}@43720755555,45,trg)
    exten => _X.,3,Hangup
    
    ; --------------------------------------------------------------------
    ;
    ; hier kommt der default-Context, in dem alle Geraete in der
    ; Grundkonfiguration erstmal laufen.
    ; Alle Geraete koennen sich gegenseitig anrufen
    
    [default]
    include => lokal
    include => Mitacs_out
    
    
    [ankommend]
    exten => 43720755555,1,Dial,SIP/39|39|r
    
    Und schließlich noch das log-file mit dem debug-level aktiviert.

    Es scheint so, als käme der Anruf auch beim Asterisk an, aber dann passiert etwas, weshalb der Anruf nicht signalisiert wird. Ich bin mir nicht mehr sicher, ob das mit dem "Unable to lookup host" etwas zu tun hat. Ich hoffe, jemand hier kennt sich besser aus und kann mir weiterhelfen.

    Code:
    Feb  9 20:07:06 VERBOSE[27979] logger.c: 
    <-- SIP read from 213.185.164.123:5060: 
    
    Feb  9 20:07:06 VERBOSE[27979] logger.c: --- (0 headers 0 lines)Feb  9 20:07:06 VERBOSE[27979] logger.c: --- (0 headers 0 lines) Nat keepalive Feb  9 20:07:06 VERBOSE[27979] logger.c: --- (0 headers 0 lines) Nat keepalive ---
    Feb  9 20:07:08 NOTICE[27979] manager.c: Unable to open management configuration manager.conf.  Call management disabled.
    Feb  9 20:07:08 NOTICE[27979] cdr.c: CDR simple logging enabled.
    Feb  9 20:07:08 NOTICE[27979] indications.c: Removed default indication country 'us'
    Feb  9 20:07:08 WARNING[27979] pbx_ael.c: Unable to open '/etc/asterisk/extensions.ael': No such file or directory
    Feb  9 20:07:08 WARNING[27979] pbx.c: Requested contexts didn't get merged
    Feb  9 20:07:08 ERROR[27979] pbx_dundi.c: Unable to load config dundi.conf
    Feb  9 20:07:08 NOTICE[27979] chan_agent.c: No agent configuration found -- agent support disabled
    Feb  9 20:07:08 ERROR[27979] chan_iax2.c: Unable to load config iax.conf
    Feb  9 20:07:08 WARNING[27979] chan_iax2.c: Error opening firmware directory '/usr/local/share/asterisk/firmware/iax': No such file or directory
    Feb  9 20:07:08 NOTICE[27979] iax2-provision.c: No IAX provisioning configuration found, IAX provisioning disabled.
    Feb  9 20:07:08 NOTICE[27979] chan_skinny.c: Unable to load config skinny.conf, Skinny disabled
    Feb  9 20:07:08 NOTICE[27979] app_enumlookup.c: No ENUM Config file, using defaults
    Feb  9 20:07:08 NOTICE[27979] app_queue.c: No call queueing config file (queues.conf), so no call queues
    Feb  9 20:07:08 WARNING[27979] cdr_custom.c: Failed to reload configuration file.
    Feb  9 20:07:08 NOTICE[27979] chan_mgcp.c: Unable to load config mgcp.conf, MGCP disabled
    Feb  9 20:07:09 VERBOSE[27979] logger.c: 12 headers, 0 lines
    Feb  9 20:07:09 VERBOSE[27979] logger.c: Reliably Transmitting (NAT) to 213.185.164.123:5060:
    OPTIONS sip:sip001.mitacs.com SIP/2.0
    Via: SIP/2.0/UDP 192.168.0.2:5060;branch=z9hG4bK7410f22e;rport
    From: "asterisk" <sip:asterisk@192.168.0.2>;tag=as0883770e
    To: <sip:sip001.mitacs.com>
    Contact: <sip:asterisk@192.168.0.2>
    Call-ID: 4847e54b117bab2828be404103db59e6@192.168.0.2
    CSeq: 102 OPTIONS
    User-Agent: Asterisk PBX
    Max-Forwards: 70
    Date: Fri, 09 Feb 2007 19:07:09 GMT
    Allow: INVITE, ACK, CANCEL, OPTIONS, BYE, REFER, SUBSCRIBE, NOTIFY
    Content-Length: 0
    
    
    ---
    Feb  9 20:07:09 VERBOSE[27979] logger.c: 
    <-- SIP read from 213.185.164.123:5060: 
    SIP/2.0 404 Not Found
    Via: SIP/2.0/UDP 192.168.0.2:5060;branch=z9hG4bK7410f22e;rport=5060;received=85.125.152.162
    From: "asterisk" <sip:asterisk@192.168.0.2>;tag=as0883770e
    To: <sip:sip001.mitacs.com>;tag=d4eccf8b83660ff28578f976e0340e46.176c
    Call-ID: 4847e54b117bab2828be404103db59e6@192.168.0.2
    CSeq: 102 OPTIONS
    Server: Sip EXpress router (0.9.6 (i386/linux))
    Content-Length: 0
    Warning: 392 213.185.164.123:5060 "Noisy feedback tells:  pid=12189 req_src_ip=85.125.152.162 req_src_port=5060 in_uri=sip:sip001.mitacs.com out_uri=sip:sip001.mitacs.com via_cnt==1"
    
    
    Feb  9 20:07:09 VERBOSE[27979] logger.c: --- (9 headers 0 lines)Feb  9 20:07:09 VERBOSE[27979] logger.c: --- (9 headers 0 lines)---
    Feb  9 20:07:09 VERBOSE[27979] logger.c: Destroying call '4847e54b117bab2828be404103db59e6@192.168.0.2'
    Feb  9 20:07:09 NOTICE[27979] chan_sip.c:    -- Re-registration for  43720755555@sip001.mitacs.com
    Feb  9 20:07:09 VERBOSE[27979] logger.c: REGISTER 12 headers, 0 lines
    Feb  9 20:07:09 VERBOSE[27979] logger.c: Reliably Transmitting (no NAT) to 213.185.164.123:5060:
    REGISTER sip:sip001.mitacs.com SIP/2.0
    Via: SIP/2.0/UDP 192.168.0.2:5060;branch=z9hG4bK14ef08fe;rport
    From: <sip:43720755555@sip001.mitacs.com>;tag=as4eb9b679
    To: <sip:43720755555@sip001.mitacs.com>
    Call-ID: 0c7451d45c6d9f7d58f32e7255ddb2c3@192.168.0.2
    CSeq: 102 REGISTER
    User-Agent: Asterisk PBX
    Max-Forwards: 70
    Expires: 120
    Contact: <sip:43720755555@192.168.0.2>
    Event: registration
    Content-Length: 0
    
    
    ---
    Feb  9 20:07:09 VERBOSE[27979] logger.c: 
    <-- SIP read from 213.185.164.123:5060: 
    SIP/2.0 401 Unauthorized
    Via: SIP/2.0/UDP 192.168.0.2:5060;branch=z9hG4bK14ef08fe;rport=5060;received=85.125.152.162
    From: <sip:43720755555@sip001.mitacs.com>;tag=as4eb9b679
    To: <sip:43720755555@sip001.mitacs.com>;tag=d4eccf8b83660ff28578f976e0340e46.69c9
    Call-ID: 0c7451d45c6d9f7d58f32e7255ddb2c3@192.168.0.2
    CSeq: 102 REGISTER
    WWW-Authenticate: Digest realm="sip001.mitacs.com", nonce="45ccc77592a36df8592d5236be2a0009315fd596"
    Server: Sip EXpress router (0.9.6 (i386/linux))
    Content-Length: 0
    Warning: 392 213.185.164.123:5060 "Noisy feedback tells:  pid=12190 req_src_ip=85.125.152.162 req_src_port=5060 in_uri=sip:sip001.mitacs.com out_uri=sip:sip001.mitacs.com via_cnt==1"
    
    
    Feb  9 20:07:09 VERBOSE[27979] logger.c: --- (10 headers 0 lines)Feb  9 20:07:09 VERBOSE[27979] logger.c: --- (10 headers 0 lines)---
    Feb  9 20:07:09 VERBOSE[27979] logger.c: Responding to challenge, registration to domain/host name sip001.mitacs.com
    Feb  9 20:07:09 VERBOSE[27979] logger.c: REGISTER 13 headers, 0 lines
    Feb  9 20:07:09 VERBOSE[27979] logger.c: Reliably Transmitting (no NAT) to 213.185.164.123:5060:
    REGISTER sip:sip001.mitacs.com SIP/2.0
    Via: SIP/2.0/UDP 192.168.0.2:5060;branch=z9hG4bK63f949cb;rport
    From: <sip:43720755555@sip001.mitacs.com>;tag=as4b68076c
    To: <sip:43720755555@sip001.mitacs.com>
    Call-ID: 0c7451d45c6d9f7d58f32e7255ddb2c3@192.168.0.2
    CSeq: 103 REGISTER
    User-Agent: Asterisk PBX
    Max-Forwards: 70
    Authorization: Digest username="43720755555", realm="sip001.mitacs.com", algorithm=MD5, uri="sip:sip001.mitacs.com", nonce="45ccc77592a36df8592d5236be2a0009315fd596", response="712a286ea565da465b965a71a670323b", opaque=""
    Expires: 120
    Contact: <sip:43720755555@192.168.0.2>
    Event: registration
    Content-Length: 0
    
    
    ---
    Feb  9 20:07:09 VERBOSE[27979] logger.c: 
    <-- SIP read from 213.185.164.123:5060: 
    SIP/2.0 200 OK
    Via: SIP/2.0/UDP 192.168.0.2:5060;branch=z9hG4bK63f949cb;rport=5060;received=85.125.152.162
    From: <sip:43720755555@sip001.mitacs.com>;tag=as4b68076c
    To: <sip:43720755555@sip001.mitacs.com>;tag=d4eccf8b83660ff28578f976e0340e46.456f
    Call-ID: 0c7451d45c6d9f7d58f32e7255ddb2c3@192.168.0.2
    CSeq: 103 REGISTER
    Contact: <sip:43720755555@85.125.152.162:5064>;expires=3572, <sip:43720755555@85.125.152.162:5060>;expires=120;received="sip:85.125.152.162:5060"
    Server: Sip EXpress router (0.9.6 (i386/linux))
    Content-Length: 0
    Warning: 392 213.185.164.123:5060 "Noisy feedback tells:  pid=12190 req_src_ip=85.125.152.162 req_src_port=5060 in_uri=sip:sip001.mitacs.com out_uri=sip:sip001.mitacs.com via_cnt==1"
    
    
    Feb  9 20:07:09 VERBOSE[27979] logger.c: --- (10 headers 0 lines)Feb  9 20:07:09 VERBOSE[27979] logger.c: --- (10 headers 0 lines)---
    Feb  9 20:07:09 VERBOSE[27979] logger.c: Scheduling destruction of call '0c7451d45c6d9f7d58f32e7255ddb2c3@192.168.0.2' in 32000 ms
    Feb  9 20:07:09 NOTICE[27979] chan_sip.c: Outbound Registration: Expiry for sip001.mitacs.com is 120 sec (Scheduling reregistration in 105 s)
    Feb  9 20:07:26 VERBOSE[27979] logger.c: 
    <-- SIP read from 213.185.164.123:5060: 
    INVITE sip:43720755555@85.125.152.162:5060 SIP/2.0
    Record-Route: <sip:213.185.164.123;ftag=as4217aa4d;lr>
    Via: SIP/2.0/UDP 213.185.164.123;branch=z9hG4bK70a3.0dcf83b3.1
    Via: SIP/2.0/UDP 213.185.164.125:5060;branch=z9hG4bK5fcb6276;rport=5060
    From: "011112222" <sip:011112222@213.185.164.125>;tag=as4217aa4d
    To: <sip:43720755555@sip001.mitacs.com>
    Contact: <sip:011112222@213.185.164.125>
    Call-ID: 0cfba8cf00f68a23538851a52e2faf17@213.185.164.125
    CSeq: 102 INVITE
    User-Agent: Asterisk PBX
    Max-Forwards: 16
    Date: Fri, 09 Feb 2007 19:07:26 GMT
    Allow: INVITE, ACK, CANCEL, OPTIONS, BYE, REFER, SUBSCRIBE, NOTIFY
    Content-Type: application/sdp
    Content-Length: 554
    P-hint: request forced to rtp proxy
    
    v=0
    o=root 16463 16463 IN IP4 213.185.164.125
    s=session
    c=IN IP4 213.185.164.123213.185.164.123
    t=0 0
    m=audio 5231252312 RTP/AVP 10 18 97 3 4 0 8 111 5 7 110 101
    a=rtpmap:10 L16/8000
    a=rtpmap:18 G729/8000
    a=fmtp:18 annexb=no
    a=rtpmap:97 iLBC/8000
    a=rtpmap:3 GSFeb  9 20:07:26 VERBOSE[27979] logger.c: --- (16 headers 23 lines)Feb  9 20:07:26 VERBOSE[27979] logger.c: --- (16 headers 23 lines)---
    Feb  9 20:07:26 VERBOSE[27979] logger.c: Using INVITE request as basis request - 0cfba8cf00f68a23538851a52e2faf17@213.185.164.125
    Feb  9 20:07:26 VERBOSE[27979] logger.c: Sending to 213.185.164.123 : 5060 (non-NAT)
    Feb  9 20:07:26 VERBOSE[27979] logger.c: Found peer 'Mitacs_in'
    Feb  9 20:07:26 WARNING[27979] chan_sip.c: Unable to lookup host in c= line, 'IN IP4 213.185.164.123213.185.164.123'
    Feb  9 20:07:26 VERBOSE[27979] logger.c: Transmitting (NAT) to 213.185.164.123:5060:
    SIP/2.0 488 Not acceptable here
    Via: SIP/2.0/UDP 213.185.164.123;branch=z9hG4bK70a3.0dcf83b3.1;received=213.185.164.123
    Via: SIP/2.0/UDP 213.185.164.125:5060;branch=z9hG4bK5fcb6276;rport=5060
    From: "011112222" <sip:011112222@213.185.164.125>;tag=as4217aa4d
    To: <sip:43720755555@sip001.mitacs.com>;tag=as0f54a05d
    Call-ID: 0cfba8cf00f68a23538851a52e2faf17@213.185.164.125
    CSeq: 102 INVITE
    User-Agent: Asterisk PBX
    Allow: INVITE, ACK, CANCEL, OPTIONS, BYE, REFER, SUBSCRIBE, NOTIFY
    Contact: <sip:43720755555@192.168.0.2>
    Content-Length: 0
    
    
    ---
    Feb  9 20:07:26 VERBOSE[27979] logger.c: Destroying call '0cfba8cf00f68a23538851a52e2faf17@213.185.164.125'
    Feb  9 20:07:26 VERBOSE[27979] logger.c: 
    <-- SIP read from 213.185.164.123:5060: 
    ACK sip:43720755555@85.125.152.162:5060 SIP/2.0
    Via: SIP/2.0/UDP 213.185.164.123;branch=z9hG4bK70a3.0dcf83b3.1
    From: "011112222" <sip:011112222@213.185.164.125>;tag=as4217aa4d
    Call-ID: 0cfba8cf00f68a23538851a52e2faf17@213.185.164.125
    To: <sip:43720755555@sip001.mitacs.com>;tag=as0f54a05d
    CSeq: 102 ACK
    User-Agent: Sip EXpress router(0.9.6 (i386/linux))
    Content-Length: 0
    
    
    Feb  9 20:07:26 VERBOSE[27979] logger.c: --- (8 headers 0 lines)Feb  9 20:07:26 VERBOSE[27979] logger.c: --- (8 headers 0 lines)---
    Feb  9 20:07:26 VERBOSE[27979] logger.c: Destroying call '0cfba8cf00f68a23538851a52e2faf17@213.185.164.125'
    Feb  9 20:07:27 VERBOSE[27979] logger.c: Destroying call '660cc9ef36d2fcfc47d2af854c0d71da@192.168.0.2'
    Feb  9 20:07:37 VERBOSE[27979] logger.c: 
    <-- SIP read from 213.185.164.123:5060: 
    
    Feb  9 20:07:37 VERBOSE[27979] logger.c: --- (0 headers 0 lines)Feb  9 20:07:37 VERBOSE[27979] logger.c: --- (0 headers 0 lines) Nat keepalive Feb  9 20:07:37 VERBOSE[27979] logger.c: --- (0 headers 0 lines) Nat keepalive ---
    Feb  9 20:07:41 VERBOSE[27979] logger.c: Destroying call '0c7451d45c6d9f7d58f32e7255ddb2c3@192.168.0.2'
    
    Danke!

    Niki
     
  11. HobbyStern

    HobbyStern Aktives Mitglied

    Registriert seit:
    5 Dez. 2005
    Beiträge:
    1,837
    Zustimmungen:
    0
    Punkte für Erfolge:
    36
    Beruf:
    vorhanden
    Ort:
    Ruhrgebiet
    Versuch doch mal den bindport auszuklammern, das ist auf die schnelle das erste was ich gesehen habe - bei dem dt. provider 1&1 ist dies immer wieder ein Fallstrick gewesen....allerdings dort in verbindung mit dem registrieren.

    Etwas was nichts damit zu tun haben sollte - ulaw ist die amerikanische version des 711er , disallow diesen mal (steht auch zweimal drin), alaw ist immer gut und gsm kannst du nehmen wenn du ein wenig auf deine bandbreite achten musst. aber das ist hier nicht wirklich problemrelevant.

    Irgendwie steig ich durch Dein Problem nicht durch - hast Du einen SSH Zugang zu Deinem Asterisk ?

    Grüsse, Stefan (sorry, Starkbier macht dusselig)
     
  12. merlion

    merlion Mitglied

    Registriert seit:
    22 Aug. 2004
    Beiträge:
    202
    Zustimmungen:
    0
    Punkte für Erfolge:
    0
    mir fiel auf ;

    Feb 9 20:07:09 VERBOSE[27979] logger.c:
    <-- SIP read from 213.185.164.123:5060:
    SIP/2.0 401 Unauthorized !!!!!!

    Passwort ??

    Gucke mal mit sip show register ob deine Anschlüsse registriert sind.


    Ich habe eine Vermutung. Du hast den Asterisk 1.4 installiert ?

    nimm mal den 1.2.14. Der läuft mit der Konfiguration die im Kurs erklärt wird.

    Im 1.4 er must du die Datei /etc/asterisk/extensions.ael als extensions.conf nehmen. Hier ändert sich aber die Syntax. Es soll aber einfacher werden.

    Ich habe auch Probleme gehabt mit der neusten version.


    Dann

    Feb 9 20:07:09 VERBOSE[27979] logger.c:
    <-- SIP read from 213.185.164.123:5060:
    SIP/2.0 404 Not Found
    Via: SIP/2.0/UDP 192.168.0.2:5060;branch=z9hG4bK7410f22e;rport=5060;received=85.125.152.162
    From: "asterisk" <sip:asterisk@192.168.0.2>;tag=as0883770e
    To: <sip:sip001.mitacs.com>;tag=d4eccf8b83660ff28578f976e0340e46.176c
    Call-ID: 4847e54b117bab2828be404103db59e6@192.168.0.2
    CSeq: 102 OPTIONS
    Server: Sip EXpress router (0.9.6 (i386/linux))
    Content-Length: 0

    wie ich sehe ist dein Asterisk lokal wegen der lokalen IP 192.168.0.2. Und er versucht sich an einem SER zu verbinden?? Wem gehört der ? Dir ?

    Welche Ports haste du auf deine MAschine weitergeleitet ?

    Das mit der doppelten IP schnall ich leider auch nicht
     
  13. beowulf

    beowulf Neuer User

    Registriert seit:
    28 Mai 2004
    Beiträge:
    161
    Zustimmungen:
    0
    Punkte für Erfolge:
    16
    Ort:
    Singapore & Vienna
    #13 beowulf, 10 Feb. 2007
    Zuletzt bearbeitet: 10 Feb. 2007
    Sind registriert. Ich habe auch das richtige Paßwort eingegeben. Denn ausgehende Telephonate kann ich ja machen.

    hrodulf*CLI> sip show peers
    Name/username Host Dyn Nat ACL Port Status
    39/39 192.168.0.1 D N 45388 OK (1 ms)
    Mitacs_in 213.185.164.123 N 5060 Unmonitored
    43720755555/43720755555 213.185.164.123 N 5060 OK (28 ms)
    5 sip peers [5 online , 0 offline]


    Nope! Asterisk 1.2.9.1, weil der in den OpenBSD Packerln und Ports drinnen ist.

    Nein, der SER gehört mir nicht. Ich habe das auch gesehen und denke, er gehört dem Provider.

    Ports: 5060 und 5004.

    Niki
     
  14. merlion

    merlion Mitglied

    Registriert seit:
    22 Aug. 2004
    Beiträge:
    202
    Zustimmungen:
    0
    Punkte für Erfolge:
    0
    du hast ne PM
     
  15. HobbyStern

    HobbyStern Aktives Mitglied

    Registriert seit:
    5 Dez. 2005
    Beiträge:
    1,837
    Zustimmungen:
    0
    Punkte für Erfolge:
    36
    Beruf:
    vorhanden
    Ort:
    Ruhrgebiet
    Wenn es noch nicht gelöst ist würde ich dann die Frage stellen :

    - Wie bist Du bisher überhaupt vorgegangen ? (Sources und dann make oder per Paket?)

    - Wie hast Du OpenBSD bzgl seiner FW konfiguriert ?


    Grüsse, Stefan
     
  16. beowulf

    beowulf Neuer User

    Registriert seit:
    28 Mai 2004
    Beiträge:
    161
    Zustimmungen:
    0
    Punkte für Erfolge:
    16
    Ort:
    Singapore & Vienna
    Nein, Problem besteht noch. Ich habe das Paket installiert. Auf OpenBSD habe ich die FW nicht aktiviert, da ich hinter einem Router bin.

    Niki
     
  17. HobbyStern

    HobbyStern Aktives Mitglied

    Registriert seit:
    5 Dez. 2005
    Beiträge:
    1,837
    Zustimmungen:
    0
    Punkte für Erfolge:
    36
    Beruf:
    vorhanden
    Ort:
    Ruhrgebiet
    Wenn Du nicht mehr weiter kommen solltest und einen SSH Zugang hast (und ein wenig Vertrauen) dann schreib mir kurz eine PM, dann schauen wir mal gemeinsam..

    Grüsse, Stefan
     
  18. beowulf

    beowulf Neuer User

    Registriert seit:
    28 Mai 2004
    Beiträge:
    161
    Zustimmungen:
    0
    Punkte für Erfolge:
    16
    Ort:
    Singapore & Vienna
    Hi!

    Also, es gibt Teilerfolgsmeldungen. Nachdem in dem [general]-Teil der sip.conf ein "externip=meineIP" gesetzt habe, ging der Provider Mitacs. Auch Sipgate.AT geht, aber Sipgate.DE geht nicht. Sipgate.DE geht nur, wenn ich "externip=meineIP" lösche oder auskommentiere; dann funktionieren aber Mitacs und Sipgate.AT nicht.

    Und wie bringe ich diese beiden Ansprüche nun unter einen Hut? Hat jeman 'ne Idee?

    Danke!

    Niki
     
  19. HobbyStern

    HobbyStern Aktives Mitglied

    Registriert seit:
    5 Dez. 2005
    Beiträge:
    1,837
    Zustimmungen:
    0
    Punkte für Erfolge:
    36
    Beruf:
    vorhanden
    Ort:
    Ruhrgebiet
    Mit einem kleinen "Note"-Hinweis sollte es gehen, ich sende Dir mal hier meine sipgate.de Einstellungen (sind etwas antik, aber sollten immernoch funktionieren) :

    zuerst aber [GENERAL]
    Code:
    externhost=someone.dyndns.org
    localnet=10.0.0.0/255.255.255.0
    
    Code:
    ; [SipgateNUMMER]
    ; username=USERNUMMER
    ; secret=SECRET
    ; host=sipgate.de
    ; fromuser=USERNUMMER
    ; fromdomain=sipgate.de
    ; nat=yes
    ; insecure=very
    ; type=peer
    ; qualify=no 
    ; context=voip_eingehend
    
    Wie Du sehen kannst habe ich für *alle* Provider diese Einstellungen gesetzt und habe Asterisk mitgeteilt in welchem Bereich mein eigenes Netz liegt, also im Bereich 10.0.0.x , so habe ich es damals aus voip-info.org erlesen...

    Siehe dazu hier :

    Hoffe geholfen zu haben.

    Grüsse, Stefan
     
  20. beowulf

    beowulf Neuer User

    Registriert seit:
    28 Mai 2004
    Beiträge:
    161
    Zustimmungen:
    0
    Punkte für Erfolge:
    16
    Ort:
    Singapore & Vienna
    Hi!

    Ich poste mal die entsprechenden Teile meiner sip.conf

    Der [GENERAL]-Teil

    Code:
    [general]
    disallow=all
    allow=ulaw
    allow=alaw
    allow=ulaw
    allow=g729
    allow=gsm
    allow=slinear
    context=default
    bindport=5060
    bindaddr=0.0.0.0
    localnet=192.168.0.0/255.255.255.0
    externip=blabla.dynalias.org
    srvlookup=yes
    
    Ich habe localnet wohl gesetzt, nur eben externip statt externhost.

    Und der Rest meiner sip.conf für die Provider sieht so aus:

    Code:
    ; Mitacs
    
    [43720555555]
    type=peer
    username=43720555555
    fromuser=43720555555
    secret=XXX
    host=sip001.mitacs.com
    fromdomain=sip001.mitacs.com
    insecure=very
    nat=yes
    qualify=yes
    
    [Mitacs_in]
    type=peer
    fromdomain=sip001.mitacs.com
    host=sip001.mitacs.com
    context=ankommend
    
    
    ; Sipgate_DE
    
    [4355555]
    type=peer
    username=4355555
    fromuser=4355555
    secret=XXX
    host=sipgate.de
    fromdomain=sipgate.de
    insecure=very
    qualify=yes
    
    [Sipgate_de_in]
    type=peer
    fromdomain=sipgate.de
    host=sipgate.de
    context=ankommend
    
    
    ; Sipgate_AT
    
    [1555555]
    type=peer
    username=1555555
    fromuser=1555555
    secret=XXX
    host=sipgate.at
    fromdomain=sipgate.at
    insecure=very
    qualify=yes
    
    [Sipgate_at_in]
    type=peer
    fromdomain=sipgate.at
    host=sipgate.at
    context=ankommend
    
    Bei der Gelegenheit ... was ist der Unterschied zwischen type=peer und type=friend [Bei FWD habe ich gelesen, daß type=friend vorgeschlagen wird.]?

    Danke,

    Niki