Iphone VPN zugriff auf Fritzbox aber nicht weiter!!

audiopro

Aktives Mitglied
Mitglied seit
14 Nov 2006
Beiträge
1,346
Punkte für Reaktionen
0
Punkte
36
Versuch's mal mit 255.255.255.255 ;)
 

Fritzbox

Mitglied
Mitglied seit
3 Sep 2004
Beiträge
281
Punkte für Reaktionen
0
Punkte
16
Nach der von Dir vorgeschlagenen Änderung das gleiche Problem. "VPN Server antwortet nicht"
 

audiopro

Aktives Mitglied
Mitglied seit
14 Nov 2006
Beiträge
1,346
Punkte für Reaktionen
0
Punkte
36
Ich habe in der accesslist den Eintrag: permit ip any 192.168.100.201 255.255.255.255. Damit funktioniert es bei mir einwandfrei. Evtl. postest Du mal Deine cfg-Datei (Benutzernamen und PW vorher unkenntlich machen).
 

sonja1956

Neuer User
Mitglied seit
10 Jun 2005
Beiträge
39
Punkte für Reaktionen
0
Punkte
0
mache es wie bei AVM beschrieben damit geht es bei mir super auch über VPN .Bin in Sardinien
 

marzen

Neuer User
Mitglied seit
31 Mrz 2006
Beiträge
93
Punkte für Reaktionen
0
Punkte
0
Hallo Fritzbox,

so kann das natürlich nicht gehen...

Anstatt

accesslist = "permit ip any 192.168.178.0 255.255.255.0";
musst du

Code:
 accesslist = "permit ip any <Host-IP> 255.255.255.255";
eintragen, wobei <Host-IP> der IP entsprechen muss, die du im Programm "Fritz Fernzugang einrichten" vergeben hast.

Gruß
marzen
 
Zuletzt bearbeitet:

Fritzbox

Mitglied
Mitglied seit
3 Sep 2004
Beiträge
281
Punkte für Reaktionen
0
Punkte
16
[Edit frank_m24: Mehrere Beiträge zusammengefasst. Man kann seine Beiträge auch editieren.]
@ audiopro hier mal meine funktionierende cfg mit der ich auf die FB komme aber nicht ins Internet

[Edit frank_m24: Bitte benutzt CODE Tags für solche Ausgaben.]
Code:
vpncfg {
        connections {
                enabled = yes;
                conn_type = conntype_user;
                name = "remote_fb";
                always_renew = no;
                reject_not_encrypted = no;
                dont_filter_netbios = yes;
                localip = 0.0.0.0;
                local_virtualip = 0.0.0.0;
                remoteip = 0.0.0.0;
                remote_virtualip = 192.168.178.201;
                remoteid {
                        key_id = "meine vpn id";
                }
                mode = phase1_mode_aggressive;
                phase1ss = "all/all/all";
                keytype = connkeytype_pre_shared;
                key = "mein passwort";
                cert_do_server_auth = no;
                use_nat_t = yes;
                use_xauth = yes;
                xauth {
                        valid = yes;
                        username = "mein username";
                        passwd = "mein passwort";
                }
                use_cfgmode = no;
                phase2localid {
                        ipnet {
                                ipaddr = 0.0.0.0;
                                mask = 0.0.0.0;
                        }
                }
                phase2remoteid {
                        ipaddr = 192.168.178.201;
                }
                phase2ss = "esp-all-all/ah-none/comp-all/no-pfs";
                accesslist = 
                             "permit ip 192.168.178.0 255.255.255.0 192.168.178.201 255.255.255.255";
        }
        ike_forward_rules = "udp 0.0.0.0:500 0.0.0.0:500", 
                            "udp 0.0.0.0:4500 0.0.0.0:4500";
}


// EOF

**** END OF FILE ****
Wenn ich nun den Eintrag wie auch immer in der Zeile access list ändere klappt der Zugriff vie VPN nicht mehr.
z.B.
accesslist = "permit ip any 192.168.178.0 255.255.255.0";
oder
accesslist = "permit ip any 192.168.178.1 255.255.255.255";
[Beitrag 2:]
@sonja
Mit den Angaben von AVM klappte der Zugriff auf die FB, aber keine Verbind ung zum Internet. Dieser Effekt wurde aber hier im Forum auch schon bestätigt.
 

audiopro

Aktives Mitglied
Mitglied seit
14 Nov 2006
Beiträge
1,346
Punkte für Reaktionen
0
Punkte
36
Lt. Deiner Konfig müsste der accesslist-Eintrag dann aber "permit ip any 192.168.178.201 255.255.255.255" lauten. Teste das mal bitte.
 

sonja1956

Neuer User
Mitglied seit
10 Jun 2005
Beiträge
39
Punkte für Reaktionen
0
Punkte
0
Und warum komme ich dann mit der Konfig von AVM über VPN auch ins Internet,kann es ja sehen, wenn ich meineip.de eingebe und das vom Iphon und vom Lappi
 

audiopro

Aktives Mitglied
Mitglied seit
14 Nov 2006
Beiträge
1,346
Punkte für Reaktionen
0
Punkte
36
Es gibt immer wieder Fälle, bei denen es Probleme mit den AVM-Vorgaben gibt. Der Eintrag accesslist regelt, wie und was das iPhone aus dem VPN Netz machen darf. Hier unterscheidet sich der Eintrag von den von AVM vorgegebenen Werten. Wird der Wert auf das IP Netz im Heimnetz (wie von AVM vorgeschlagen) beschränkt, so kann das iPhone nur in das Heimnetzwerk, jedoch nicht über den VPN Tunnel, die Fritz!Box in die weite Welt. Es wird also das Routing aus dem VPN Netz über die Fritz!Box unterbunden. Mit dem Eintrag permit ip any … wird dem iPhone der Zugang gestattet.
 

marzen

Neuer User
Mitglied seit
31 Mrz 2006
Beiträge
93
Punkte für Reaktionen
0
Punkte
0
@Fritzbox:
Bitte deine Accessliste so konfigurieren, wie schon von mir allgemein erklärt und von audiopro anhand deiner Konfig. Dann gehts auch.

Einträge wie
Code:
accesslist =
"permit ip 192.168.178.0 255.255.255.0 192.168.178.201 255.255.255.255";
sind der Grund, dass du nicht ins Internet kommst über VPN, denn damit erlaubst du dem Host 192.168.178.201 nur, bis ins Netz 192.168.178.0 zu kommen und nicht weiter.

Einträge wie
Code:
accesslist =
"permit ip any 192.168.178.0 255.255.255.0";
oder
Code:
accesslist =
"permit ip any 192.168.178.1 255.255.255.255";
können nicht funzen.

@sonja1956: Antwort: Du hast ja auch alles richtig gemacht ;-)

Gruß
marzen
 

Fritzbox

Mitglied
Mitglied seit
3 Sep 2004
Beiträge
281
Punkte für Reaktionen
0
Punkte
16
@audiopro
Genau das war es, nun komme ich auch ins Internet. Vielen Dank für Deinen Tipp.
 

ahmedahmed

Neuer User
Mitglied seit
25 Apr 2009
Beiträge
75
Punkte für Reaktionen
0
Punkte
0
Iphone 4s IOS5 VoIP [ok] aber kein Internet Verbindung?!

Hallo leute ich hab mir ein Iphone 4s zugelegt. Wie auch bei meiner alten N85 wollte ich natürlich VoIP mit VPN nutzen.
Was ich diesmal möchte, das ich auch ins Internet gehen kann, wenn mein Iphone VPN hat. (habe keine lust jedemal VPN ein und auszuschalten).

Hier sind die einstellungen

HTML:
vpncfg {
        connections {
                enabled = yes;
                conn_type = conntype_user;
                name = "dd";
                always_renew = no;
                reject_not_encrypted = no;
                dont_filter_netbios = yes;
                localip = 0.0.0.0;
                local_virtualip = 0.0.0.0;
                remoteip = 0.0.0.0;
                remote_virtualip = 192.168.178.201;
                remoteid {
                        key_id = "dd";
                }
                mode = phase1_mode_aggressive;
                phase1ss = "all/all/all";
                keytype = connkeytype_pre_shared;
                key = "dd";
                cert_do_server_auth = no;
                use_nat_t = yes;
                use_xauth = yes;
                xauth {
                        valid = yes;
                        username = "dd";
                        passwd = "dd";
                }
                use_cfgmode = no;
                phase2localid {
                        ipnet {
                                ipaddr = 0.0.0.0;
                                mask = 0.0.0.0;
                        }
                }
                phase2remoteid {
                        ipaddr = 192.168.178.201;
                }
                phase2ss = "esp-all-all/ah-none/comp-all/no-pfs";
                accesslist = 
                             "permit ip 0.0.0.0 0.0.0.0 192.168.178.201 255.255.255.255";
        }
        ike_forward_rules = "udp 0.0.0.0:500 0.0.0.0:500", 
                            "udp 0.0.0.0:4500 0.0.0.0:4500";
}
Ich hab wirklich sämtliche Posts hier im Forum durchgelesen. fast jede accesslist beispielen ausprobiert, aber es klappt irgendwie nicht :(... bitte um Hilfe.. danke..
 

J-B

Neuer User
Mitglied seit
5 Sep 2007
Beiträge
16
Punkte für Reaktionen
0
Punkte
0
Gibt es hier mittlerweile eine Lösung, damit man mit dem iPhone via VPN ins Internet kommt?
 

openstagefreak

Mitglied
Mitglied seit
14 Nov 2009
Beiträge
515
Punkte für Reaktionen
0
Punkte
0
Ja, bei mir geht das schon lange, mittlerweile behält das iPhone sogar das Passwort, nur weiß ich nicht mehr was ich genau gemacht habe das es geht.
 

J-B

Neuer User
Mitglied seit
5 Sep 2007
Beiträge
16
Punkte für Reaktionen
0
Punkte
0
[Edit Novize: Unsinniges Fullquote vom Beitrag direkt davor gelöscht - siehe Foren-Regeln]
Sehr hilfreich :rolleyes:
 

openstagefreak

Mitglied
Mitglied seit
14 Nov 2009
Beiträge
515
Punkte für Reaktionen
0
Punkte
0
Du wolltest wissen ob es eine Lösung gibt oder? Darauf hast du eine Antwort bekommen :p
 

J-B

Neuer User
Mitglied seit
5 Sep 2007
Beiträge
16
Punkte für Reaktionen
0
Punkte
0
[Edit Novize: Unsinniges Fullquote vom Beitrag direkt davor gelöscht - siehe Foren-Regeln]

Dann denk bitte noch ein bisschen nach, damit ich nicht dumm sterbe bis zum 21.12 :D
 

theNeo

Neuer User
Mitglied seit
1 Jul 2006
Beiträge
24
Punkte für Reaktionen
0
Punkte
0
Benutze die Anleitung von AVM. Hat bei mir funktioniert ;)
 

HabNeFritzbox

IPPF-Urgestein
Teammitglied
Mitglied seit
12 Dez 2017
Beiträge
15,235
Punkte für Reaktionen
205
Punkte
63
Es geht schon seid Jahren, mit dem iPhone via VPN zu surfen im gesamten Netz, musste man nur in der Konfig manuell eine Zeile hinzufügen.

Das mit dem PW speichern, ging durch einer bestimmten FB FW, frag aber bitte nicht ab welcher Version. Ich hatte einfach ein simples Passwort benutzt mit 2-3 Zeichen. Verbindung ist ja schon durch den Shared Key schon ausreichend geschützt.
 

J-B

Neuer User
Mitglied seit
5 Sep 2007
Beiträge
16
Punkte für Reaktionen
0
Punkte
0
Ich hab es wie in der Anleitung gemacht. Komme auch wunderbar ins Netzwerk nur nicht mit dem iphone ins Internet.
 

Zurzeit aktive Besucher

3CX PBX - GRATIS
Linux / Win / Cloud

Statistik des Forums

Themen
232,901
Beiträge
2,027,916
Mitglieder
351,033
Neuestes Mitglied
thburkhart