.titleBar { margin-bottom: 5px!important; }

Kein NAS mehr nach Freetz Installation

Dieses Thema im Forum "Freetz" wurde erstellt von fischkopp82, 8 Aug. 2010.

  1. olistudent

    olistudent IPPF-Urgestein

    Registriert seit:
    19 Okt. 2004
    Beiträge:
    14,761
    Zustimmungen:
    5
    Punkte für Erfolge:
    38
    Beruf:
    Softwareentwickler
    Ort:
    Kaiserslautern
    Ich check das libfreetz Update aus dem Ticket heute oder morgen ein. Dann können wir nochmal schauen, ob es so besser ist.

    Gruß
    Oliver
     
  2. gismotro

    gismotro Mitglied

    Registriert seit:
    5 Sep. 2007
    Beiträge:
    254
    Zustimmungen:
    16
    Punkte für Erfolge:
    18
    oder so, dann warte ich noch mit meinem Test.
     
  3. linuzer

    linuzer Neuer User

    Registriert seit:
    22 Juni 2007
    Beiträge:
    54
    Zustimmungen:
    0
    Punkte für Erfolge:
    6
    Ich weiss, dass der Thread zwar schon ein halbes Jahr alt ist, aber gibt es dazu eigentlich inzwischen eine Lösung? Ich habe nämlich das gleiche Problem...

    Gruß,
    linuzer
     
  4. JohnDoe42

    JohnDoe42 Aktives Mitglied

    Registriert seit:
    17 März 2009
    Beiträge:
    1,403
    Zustimmungen:
    0
    Punkte für Erfolge:
    36
    Nur kurz am Rande:

    Ich habe dieses Problemchen auch .... wie hier beschrieben.
    Grüße,

    JD.
     
  5. spi900

    spi900 Neuer User

    Registriert seit:
    20 Dez. 2007
    Beiträge:
    7
    Zustimmungen:
    0
    Punkte für Erfolge:
    1
    #45 spi900, 1 Okt. 2018
    Zuletzt von einem Moderator bearbeitet: 1 Okt. 2018
    Ich habe vor wenigen Tagen ein 7.01 Image für eine 7490 gebaut. Freetz Samba ist deaktiviert, weil mir das AVM-eigene Samba reicht. Doch nach einem Reboot der 7490 läuft der AVM-eigene Samba nicht - das entspricht dem bisher geschriebenen Verhalten.

    Ich habe mir mit einem Aufruf von /bin/inetdsamba in der rc.custom in Freetz geholfen. Damit startet am Ende des Bootprozesses der AVM-eigene Samba wieder. Zur Sicherheit läuft bei mir noch alle 5 Minuten ein cron-Job zur Überprüfung, ob Samba noch läuft. Bisher hatte sich der aber noch nicht verabschiedet.

    ### Zusammenführung Doppelpost by stoney ###

    Ich habe noch gesehen, dass der AVM-eigene ftpd auch nicht läuft. Verwende nun folgende beiden Aufrufe in rc.custom und crontab:
    /bin/inetdctl enable ftpd
    /bin/inetdctl enable smbd
     
  6. f666

    f666 Mitglied

    Registriert seit:
    6 Apr. 2016
    Beiträge:
    217
    Zustimmungen:
    26
    Punkte für Erfolge:
    28
    Könntet ihr bitte probieren, ob der Patch im Ticket 2908 euer Problem behebt?
     
  7. spi900

    spi900 Neuer User

    Registriert seit:
    20 Dez. 2007
    Beiträge:
    7
    Zustimmungen:
    0
    Punkte für Erfolge:
    1
    Wenn ich das recht sehe, sind das lokale Änderungen in den Skripten, d. h. ich muss nicht das Image neu bauen, wenn ich die Änderungen z.B. direkt in der /etc/init.d/rc.smbd eintrage?
     
  8. spi900

    spi900 Neuer User

    Registriert seit:
    20 Dez. 2007
    Beiträge:
    7
    Zustimmungen:
    0
    Punkte für Erfolge:
    1
    ah, Denkfehler, read-only Filesystem.

    Muss ich neu kompilieren oder kann ich anderen Trick anwenden, damit die Änderungen das Booten überleben?
     
  9. f666

    f666 Mitglied

    Registriert seit:
    6 Apr. 2016
    Beiträge:
    217
    Zustimmungen:
    26
    Punkte für Erfolge:
    28
    Du wirst um ein neues Image nicht herumkommen.
     
  10. spi900

    spi900 Neuer User

    Registriert seit:
    20 Dez. 2007
    Beiträge:
    7
    Zustimmungen:
    0
    Punkte für Erfolge:
    1
    Compiler läuft schon... Test aber erst am Abend.
     
  11. Shirocco88

    Shirocco88 Mitglied

    Registriert seit:
    4 Jan. 2016
    Beiträge:
    729
    Zustimmungen:
    48
    Punkte für Erfolge:
    28
    wie überprüfst Du, ob Samba läuft ?
    der Dienst Samba wird doch nur "On-Demand per Inetd gestartet";
    wie sieht der Cron-Job aus, der prüft, ob Samba läuft ?
     
  12. spi900

    spi900 Neuer User

    Registriert seit:
    20 Dez. 2007
    Beiträge:
    7
    Zustimmungen:
    0
    Punkte für Erfolge:
    1
    Ok, missverständlich ausgedrückt. Bei wird beim Start inetd nicht gestartet. Mit
    /bin/inetdctl enable ftpd
    /bin/inetdctl enable smbd
    in der rc.custom starte ich am Ende des Bootprozesses inetd und aktiviere ftpd und smbd.
    Da ich nicht weiß, ob das nur ein Problem beim Booten ist oder später im Betrieb der inetd sich verabschiedet, habe ich in die crontab den gleichen Aufruf aufgenommen. Die sieht dann bei mir so aus (alle 5 Min neu starten, falls beendet):
    */5 * * * * /bin/inetdctl enable smbd
    */5 * * * * /bin/inetdctl enable ftpd
     
  13. spi900

    spi900 Neuer User

    Registriert seit:
    20 Dez. 2007
    Beiträge:
    7
    Zustimmungen:
    0
    Punkte für Erfolge:
    1
    Der Patch behebt das Problem, dass der AVM-eigene smb nicht startet. Ich brauche meinen Workaround in der rc.custom damit nicht mehr.

    Fließt der Patch in freetz-stable-2.0 ein?
     
  14. NDiIPP

    NDiIPP Aktives Mitglied

    Registriert seit:
    13 Apr. 2017
    Beiträge:
    980
    Zustimmungen:
    146
    Punkte für Erfolge:
    43
    o_O Wozu? Freetz 2.0 unterstützt ja nicht einmal ansatzweise die neueren FRITZ!OS-Versionen 6.x oder 7.0x.
     
  15. spi900

    spi900 Neuer User

    Registriert seit:
    20 Dez. 2007
    Beiträge:
    7
    Zustimmungen:
    0
    Punkte für Erfolge:
    1
    Stimmt. Ist eine alte Leiche bei mir, so heißt mein altes Verzeichnis. Fließt denn der Patch in freetz-devel ein?
     
  16. f666

    f666 Mitglied

    Registriert seit:
    6 Apr. 2016
    Beiträge:
    217
    Zustimmungen:
    26
    Punkte für Erfolge:
    28
    Das liegt nicht in meiner Macht. Bisher steht ja noch nicht einmal das Konzept, wie das Problem gelöst werden soll.
    Ich habe das Ticket mit einem Link auf deine Beiträge ergänzt.