OpenVPN-Paket

radislav

Aktives Mitglied
Mitglied seit
15 Mrz 2008
Beiträge
950
Punkte für Reaktionen
0
Punkte
16
vielen dank für die hilfe! den ersten satz verstehe ich leider nicht, der fehler kommt aber nicht mehr. nach den änderungen (dev und dev-node) sehe ich nun folgendes:
Code:
/var/media/data/noBackup # ./openvpn_2.2.1_mipsel_static --config /var/media/data/noBackup/openvpn.conf --auth-nocache
[...]
Tue Jul 26 19:35:03 2011 TUN/TAP device tap0 opened
Tue Jul 26 19:35:03 2011 NOTE: unable to redirect default gateway -- Cannot read current default gateway from system
Tue Jul 26 19:35:03 2011 Initialization Sequence Completed
es scheint alles zu funktionieren, aber die internetanbindung geht nach wie vor nicht über vpn. ist die "NOTE" von oben doch wichtig? oder liegt es an etwas anderem?

hier ist für alle fälle meine routig tabelle:
Code:
~ # route
Kernel IP routing table
Destination     Gateway         Genmask         Flags Metric Ref    Use Iface
192.168.180.1   *               255.255.255.255 UH    2      0        0 dsl
192.168.180.2   *               255.255.255.255 UH    2      0        0 dsl
default         xxx.xxx.xxx.1   255.255.255.0   UG    0      0        0 tap0
192.168.178.0   *               255.255.255.0   U     0      0        0 lan
192.168.179.0   *               255.255.255.0   U     0      0        0 guest
xxx.xxx.xxx.0   *               255.255.255.0   U     0      0        0 tap0
188.194.32.0    *               255.255.248.0   U     2      0        0 dsl
169.254.0.0     *               255.255.0.0     U     0      0        0 lan
default         *               0.0.0.0         U     0      0        0 dsl
 

MaxMuster

IPPF-Promi
Mitglied seit
1 Feb 2005
Beiträge
6,932
Punkte für Reaktionen
1
Punkte
36
Du hast Recht, dieser "Note" ist entscheidend. OpenVPN kommt nicht damit klar, wie AVM das Defaultgateway setzt, um die Defaultroute zu ändern muss aber sicher gestellt werden, dass die Verbindung vom CLient zum Server über das "alte" Defaultgateway (und damit durch das Internet) geht und nicht versucht wird, das VPN durch das VPN aufzubauen.
Damit OpenVPN das doch hinbekommt, musst du das Defaultgateway auf der Box vor der Verbindung "abändern" oder diese Option "nachbauen" mit einem up- und down-Skript.

Das findest du z.B. hier...
 

radislav

Aktives Mitglied
Mitglied seit
15 Mrz 2008
Beiträge
950
Punkte für Reaktionen
0
Punkte
16
leider funktioniert bei mir beides nicht.
1. vor der Verbindung "abändern":
Code:
# route del default 2> /dev/null
# route add default gw 169.254.2.1 dev dsl 
route: SIOCADDRT: Network is unreachable
2. diese Option "nachbauen":
Code:
 # route add openvpn.server.ip dev dsl
 # route add -net 0.0.0.0/1 dev tap0
 # route add -net 128.0.0.0/1 dev tap0
so, nun ist hier schluss: es funktionieren keine verbindungen nach außen mehr.
die neue routing tabelle:
Code:
# route
Kernel IP routing table
Destination     Gateway         Genmask         Flags Metric Ref    Use Iface
192.168.180.1   *               255.255.255.255 UH    2      0        0 dsl
openvpn.server.ip  *               255.255.255.255 UH    0      0        0 dsl
192.168.180.2   *               255.255.255.255 UH    2      0        0 dsl
188.194.34.68   *               255.255.255.255 UH    0      0        0 dsl
default         xxx.xxx.xxx.1   255.255.255.0   UG    0      0        0 tap0
192.168.178.0   *               255.255.255.0   U     0      0        0 lan
192.168.179.0   *               255.255.255.0   U     0      0        0 guest
xxx.xxx.xxx.0   *               255.255.255.0   U     0      0        0 tap0
188.194.32.0    *               255.255.248.0   U     2      0        0 dsl
169.254.0.0     *               255.255.0.0     U     0      0        0 lan
default         *               128.0.0.0       U     0      0        0 tap0
128.0.0.0       *               128.0.0.0       U     0      0        0 tap0
default         *               0.0.0.0         U     0      0        0 dsl
es ist zum verzweifeln...
 

MaxMuster

IPPF-Promi
Mitglied seit
1 Feb 2005
Beiträge
6,932
Punkte für Reaktionen
1
Punkte
36
Nur so als Hinweis: Du hast aber auch "openvpn.server.ip" durch die IP deines VPN-Servers ersetzt, das war nur ein Platzhalter ;-)
 

radislav

Aktives Mitglied
Mitglied seit
15 Mrz 2008
Beiträge
950
Punkte für Reaktionen
0
Punkte
16
na klar! da muss natürlich die richtige vierzahlige IP stehen, ich möchte diese bloß nicht veröffentlichen ;) genau so wie xxx in der routing tabelle
 

MaxMuster

IPPF-Promi
Mitglied seit
1 Feb 2005
Beiträge
6,932
Punkte für Reaktionen
1
Punkte
36
o.k. ;)
Du kannst aber (siehe auch die "endlose" Diskussion dazu in dem anderen genannten Thread) so nur von der Box aus alles erreichen, sofern nicht der Server dein LAN kennt und zu deinem VPN-Client routet. Das müsste der Server-Admin dort einstellen.
Hast du da keinen Einfluss drauf, dann brauchst du NAT (und iptables). Lies dann (sofern das nicht alles schon für dich klar ist) den anderen Thread, der scheint fast identisch zu deinem Anliegen zu sein...

Jörg

PS: Ich bin jetzt weg...
 

grobi2000

Neuer User
Mitglied seit
4 Mai 2006
Beiträge
48
Punkte für Reaktionen
0
Punkte
6
Hallo!

es ist zwar schon ne Weile her das ich mich mit OpenVPN beschäftigt habe.
Haben zwei Fritzboxen (7390 Server und 7240 Client) am laufen und ich meine mich zu erinnern das wenn man eine CA.CRT nutzt braucht man auch die zum Client passende CRT und KEY Datei.
Oder?

Bei mir sieht die Client Conf so aus:

# OpenVPN v2.0.5 config:
#
# Grunds�tzliches (Was soll der CLIENT nutzen)
port 1194
proto udp
dev tap
# Client-Einstellungen
tls-client
ns-cert-type server
remote IP 1194
# Authentifizierung und Verschl�sselung
ca /var/tmp/ca.crt
cert /var/tmp/client01.crt
key /var/tmp/client01.key
auth SHA1
cipher AES-256-CBC
# Sonstiges
route 192.168.5.0 255.255.255.0 10.0.0.1
comp-lzo
pull


Gruß
 

radislav

Aktives Mitglied
Mitglied seit
15 Mrz 2008
Beiträge
950
Punkte für Reaktionen
0
Punkte
16
@MaxMuster:
ich habe auf den server wirklich keinen einfluss (will ich auch nicht). das tolle ist ja, dass es in debian auf dem pc funktioniert.

@grobi2000:
was macht denn die zeile "route 192.168.5.0 255.255.255.0 10.0.0.1" ganau. wer ist bei dir im netz 192.168.5.x und im 10.0.0.x?
 

MaxMuster

IPPF-Promi
Mitglied seit
1 Feb 2005
Beiträge
6,932
Punkte für Reaktionen
1
Punkte
36
das tolle ist ja, dass es in debian auf dem pc funktioniert.
... genauso, wie auf der Box, aber das willst du ja nicht ;-)
Der Unterscheid ist, für die Box reicht es eben nicht, wenn nur die Box auf die Gegenseite kommt (wie es mit dem PC ist, auch bei dem kommt nur der PC in das VPN). Hier möchtest du, denke ich, nicht mit der Box, sondern Geräten "dahinter" durch das VPN, und dazu muss die Gegenstelle (der VPN-Server) über dein Netz bescheid wissen, sonst kann er es nicht "zurückschicken". So kennt er aber nur die VPN-IP des Clients, also musst du dein LAN hinter dieser Box "verstecken" (per NAT).
 

radislav

Aktives Mitglied
Mitglied seit
15 Mrz 2008
Beiträge
950
Punkte für Reaktionen
0
Punkte
16
ja, so ist es! mir ist aber noch nicht klar, was da zu tun ist. wonach muss ich denn stichwortmäßig suchen? ich habe bis jetzt nach "openvpn tutorial" gesucht. es gibt ja viele im netz, ich habe aber das problem, das richtige daraus zu filtern.
 

MaxMuster

IPPF-Promi
Mitglied seit
1 Feb 2005
Beiträge
6,932
Punkte für Reaktionen
1
Punkte
36
Deshalb der Verweis auf diesen anderen Thread, da habe ich versucht, das alles auseinander zu dröseln (wann man NAT braucht, wofür und auch wie es geht...)

Jörg
 

grobi2000

Neuer User
Mitglied seit
4 Mai 2006
Beiträge
48
Punkte für Reaktionen
0
Punkte
6
@grobi2000
was macht denn die zeile "route 192.168.5.0 255.255.255.0 10.0.0.1" ganau. wer ist bei dir im netz 192.168.5.x und im 10.0.0.x?
Hi!

Die Zeile Schickt alle Anfragen an Rechner im IP Bereich 192.168.5.0 an den VPN Client 10.0.0.1 der sich in diesem befindet.

10.0.0.1 ist mein Server im IP Bereich 192.168.5.0 und 10.0.0.2 ist mein Client im IP Bereich 192.168.0.0

Ich weiß nur nicht ob dir das wirklich helfen kann...... !?
 

sualc1812

Neuer User
Mitglied seit
11 Mai 2007
Beiträge
21
Punkte für Reaktionen
0
Punkte
0
Hallo zusammen,

ich habe zwar die Suchfunktion des Forums kräftig bemüht, kam aber leider nicht weiter mit meinem Problem:

Ich möchte gerne durch einen Firmenproxy hindurch per OpenVPN auf meine Fritzbox 7170 und von dort in mein Heim-LAN und auf das Internet greifen.
Der Verbindungsaufbau klappt wunderbar und ich kann alles innerhalb meines Heim-LANs erreichen einschliesslich der Box.
Nur die Zugriffe auf das Internet (HTTP, IMAP etc.) werden leider nicht über VPN geleitet. Ich vermute eine falsche/fehlende Routing-Einstellung.

Auf der Box läuft OpenVPN mit folgender Einstellung:
http://www.bartetzko-net.de/freetz/ovpn1.jpg
[Edit frank_m24: Bild vom externen Hoster in Link umgewandelt, siehe auch hier.]

Meine Client-Config sieht so aus:
client
pull
dev tap
dev-node OpenVPN
proto tcp
remote xxx.selfhost.de 443
resolv-retry infinite
nobind
persist-key
persist-tun
http-proxy firmenproxy 8080
ca ca.crt
cert client_xp.crt
key client_xp.key
ns-cert-type server
tls-auth static.key 1
cipher AES-128-CBC
comp-lzo
verb 3

Was muß ich ändern, damit der Zugriff über VPN auch ins Internet klappt ?
 

MaxMuster

IPPF-Promi
Mitglied seit
1 Feb 2005
Beiträge
6,932
Punkte für Reaktionen
1
Punkte
36
Ich formuliere es mal als Frage: von welcher deiner gewählten Optionen erwartest du, dass sie “jedes Pakete des Clients umleitet“ durch das VPN hindurch?
 

sualc1812

Neuer User
Mitglied seit
11 Mai 2007
Beiträge
21
Punkte für Reaktionen
0
Punkte
0
Die Frage ist natürlich berechtigt.
Erwarten würde ich das vom Haken "Jedes Paket des Clients umleiten"

Wenn ich den allerdings setze, dann schmiert mir mein Client beim Hochlaufen sehr schnell wieder ab mit der Meldung "Re-Connecting to xxx-Net has failed".
Hier ist das Protokoll:

Code:
Thu Aug 11 09:55:50 2011 OpenVPN 2.2.1 Win32-MSVC++ [SSL] [LZO2] built on Jul  1 2011
Thu Aug 11 09:55:50 2011 NOTE: OpenVPN 2.1 requires '--script-security 2' or higher to call user-defined scripts or executables
Thu Aug 11 09:55:50 2011 Control Channel Authentication: using 'static.key' as a OpenVPN static key file
Thu Aug 11 09:55:50 2011 Outgoing Control Channel Authentication: Using 160 bit message hash 'SHA1' for HMAC authentication
Thu Aug 11 09:55:50 2011 Incoming Control Channel Authentication: Using 160 bit message hash 'SHA1' for HMAC authentication
Thu Aug 11 09:55:50 2011 LZO compression initialized
Thu Aug 11 09:55:50 2011 Control Channel MTU parms [ L:1592 D:168 EF:68 EB:0 ET:0 EL:0 ]
Thu Aug 11 09:55:50 2011 Socket Buffers: R=[8192->8192] S=[8192->8192]
Thu Aug 11 09:55:51 2011 Data Channel MTU parms [ L:1592 D:1450 EF:60 EB:135 ET:32 EL:0 AF:3/1 ]
Thu Aug 11 09:55:51 2011 Local Options hash (VER=V4): '29f6c8b2'
Thu Aug 11 09:55:51 2011 Expected Remote Options hash (VER=V4): '3d4363c6'
Thu Aug 11 09:55:51 2011 Attempting to establish TCP connection with 127.0.0.1:8080
Thu Aug 11 09:55:53 2011 TCP connection established with 127.0.0.1:8080
Thu Aug 11 09:55:53 2011 Send to HTTP proxy: 'CONNECT xxx.selfhost.de:443 HTTP/1.0'
Thu Aug 11 09:55:54 2011 HTTP proxy returned: 'HTTP/1.1 200 Connection established'
Thu Aug 11 09:55:56 2011 TCPv4_CLIENT link local: [undef]
Thu Aug 11 09:55:56 2011 TCPv4_CLIENT link remote: 127.0.0.1:8080
Thu Aug 11 09:55:56 2011 TLS: Initial packet from 127.0.0.1:8080, sid=dfec1fb0 2a214318
Thu Aug 11 09:55:57 2011 VERIFY OK: depth=1, /C=DE/ST=./L=xxx/O=./OU=./CN=xxx.selfhost.de/name=./emailAddress=xxx
Thu Aug 11 09:55:57 2011 VERIFY OK: nsCertType=SERVER
Thu Aug 11 09:55:57 2011 VERIFY OK: depth=0, /C=DE/ST=./L=xxx/O=./OU=./CN=server/name=./emailAddress=xxx
Thu Aug 11 09:55:59 2011 Data Channel Encrypt: Cipher 'AES-128-CBC' initialized with 128 bit key
Thu Aug 11 09:55:59 2011 Data Channel Encrypt: Using 160 bit message hash 'SHA1' for HMAC authentication
Thu Aug 11 09:55:59 2011 Data Channel Decrypt: Cipher 'AES-128-CBC' initialized with 128 bit key
Thu Aug 11 09:55:59 2011 Data Channel Decrypt: Using 160 bit message hash 'SHA1' for HMAC authentication
Thu Aug 11 09:55:59 2011 Control Channel: TLSv1, cipher TLSv1/SSLv3 DHE-RSA-AES256-SHA, 1024 bit RSA
Thu Aug 11 09:55:59 2011 [server] Peer Connection Initiated with 127.0.0.1:8080
Thu Aug 11 09:56:01 2011 SENT CONTROL [server]: 'PUSH_REQUEST' (status=1)
Thu Aug 11 09:56:01 2011 PUSH: Received control message: 'PUSH_REPLY,route-gateway 192.168.200.1,route 192.168.178.0 255.255.255.0,route 192.168.200.1,redirect-gateway,ping 10,ping-restart 120,ifconfig 192.168.200.100 255.255.255.0'
Thu Aug 11 09:56:01 2011 OPTIONS IMPORT: timers and/or timeouts modified
Thu Aug 11 09:56:01 2011 OPTIONS IMPORT: --ifconfig/up options modified
Thu Aug 11 09:56:01 2011 OPTIONS IMPORT: route options modified
Thu Aug 11 09:56:01 2011 OPTIONS IMPORT: route-related options modified
Thu Aug 11 09:56:01 2011 ROUTE default_gateway=141.73.30.254
Thu Aug 11 09:56:01 2011 TAP-WIN32 device [OpenVPN] opened: \\.\Global\{18F2E960-6CEF-432F-AEC9-12E0A0D5B69C}.tap
Thu Aug 11 09:56:01 2011 TAP-Win32 Driver Version 9.8 
Thu Aug 11 09:56:01 2011 TAP-Win32 MTU=1500
Thu Aug 11 09:56:01 2011 Notified TAP-Win32 driver to set a DHCP IP/netmask of 192.168.200.100/255.255.255.0 on interface {18F2E960-6CEF-432F-AEC9-12E0A0D5B69C} [DHCP-serv: 192.168.200.0, lease-time: 31536000]
Thu Aug 11 09:56:01 2011 Successful ARP Flush on interface [65542] {18F2E960-6CEF-432F-AEC9-12E0A0D5B69C}
Thu Aug 11 09:56:06 2011 TEST ROUTES: 3/3 succeeded len=2 ret=1 a=0 u/d=up
Thu Aug 11 09:56:06 2011 C:\WINDOWS\system32\route.exe ADD 127.0.0.1 MASK 255.255.255.255 141.73.30.254
Thu Aug 11 09:56:06 2011 ROUTE: route addition failed using CreateIpForwardEntry: Falscher Parameter.   [status=87 if_index=4]
Thu Aug 11 09:56:06 2011 Route addition via IPAPI failed [adaptive]
Thu Aug 11 09:56:06 2011 Route addition fallback to route.exe
Thu Aug 11 09:56:06 2011 openvpn_execve: CreateProcess C:\WINDOWS\system32\route.exe failed: Das System kann den angegebenen Pfad nicht finden.   (errno=3)
Thu Aug 11 09:56:06 2011 ERROR: Windows route add command failed [adaptive]: external program did not execute -- returned error code -1
Thu Aug 11 09:56:06 2011 C:\WINDOWS\system32\route.exe DELETE 0.0.0.0 MASK 0.0.0.0 141.73.30.254
Thu Aug 11 09:56:06 2011 Route deletion via IPAPI succeeded [adaptive]
Thu Aug 11 09:56:06 2011 C:\WINDOWS\system32\route.exe ADD 0.0.0.0 MASK 0.0.0.0 192.168.200.1
Thu Aug 11 09:56:06 2011 Route addition via IPAPI succeeded [adaptive]
Thu Aug 11 09:56:06 2011 C:\WINDOWS\system32\route.exe ADD 192.168.178.0 MASK 255.255.255.0 192.168.200.1
Thu Aug 11 09:56:06 2011 Route addition via IPAPI succeeded [adaptive]
Thu Aug 11 09:56:06 2011 WARNING: potential route subnet conflict between local LAN [192.168.200.0/255.255.255.0] and remote VPN [192.168.200.1/255.255.255.255]
Thu Aug 11 09:56:06 2011 OpenVPN ROUTE: omitted no-op route: 192.168.200.1/255.255.255.255 -> 192.168.200.1
Thu Aug 11 09:56:06 2011 Initialization Sequence Completed
Thu Aug 11 09:56:42 2011 Connection reset, restarting [0]
Thu Aug 11 09:56:42 2011 TCP/UDP: Closing socket
Thu Aug 11 09:56:42 2011 SIGUSR1[soft,connection-reset] received, process restarting
Thu Aug 11 09:56:42 2011 Restart pause, 5 second(s)
Thu Aug 11 09:56:47 2011 NOTE: OpenVPN 2.1 requires '--script-security 2' or higher to call user-defined scripts or executables
Thu Aug 11 09:56:47 2011 Re-using SSL/TLS context
Thu Aug 11 09:56:47 2011 LZO compression initialized
Thu Aug 11 09:56:47 2011 Control Channel MTU parms [ L:1592 D:168 EF:68 EB:0 ET:0 EL:0 ]
Thu Aug 11 09:56:47 2011 Socket Buffers: R=[8192->8192] S=[8192->8192]
Thu Aug 11 09:56:47 2011 Data Channel MTU parms [ L:1592 D:1450 EF:60 EB:135 ET:32 EL:0 AF:3/1 ]
Thu Aug 11 09:56:47 2011 Local Options hash (VER=V4): '29f6c8b2'
Thu Aug 11 09:56:47 2011 Expected Remote Options hash (VER=V4): '3d4363c6'
Thu Aug 11 09:56:47 2011 Attempting to establish TCP connection with 127.0.0.1:8080
Thu Aug 11 09:56:47 2011 TCP connection established with 127.0.0.1:8080
Thu Aug 11 09:56:47 2011 Send to HTTP proxy: 'CONNECT clausbartetzko.selfhost.de:443 HTTP/1.0'
Thu Aug 11 09:56:52 2011 recv_line: TCP port read timeout expired
Thu Aug 11 09:56:52 2011 TCP/UDP: Closing socket
Thu Aug 11 09:56:52 2011 C:\WINDOWS\system32\route.exe DELETE 192.168.178.0 MASK 255.255.255.0 192.168.200.1
Thu Aug 11 09:56:52 2011 Route deletion via IPAPI succeeded [adaptive]
Thu Aug 11 09:56:52 2011 C:\WINDOWS\system32\route.exe DELETE 127.0.0.1 MASK 255.255.255.255 141.73.30.254
Thu Aug 11 09:56:52 2011 ROUTE: route deletion failed using DeleteIpForwardEntry: Falscher Parameter.  
Thu Aug 11 09:56:52 2011 Route deletion via IPAPI failed [adaptive]
Thu Aug 11 09:56:52 2011 Route deletion fallback to route.exe
Thu Aug 11 09:56:52 2011 openvpn_execve: CreateProcess C:\WINDOWS\system32\route.exe failed: Das System kann den angegebenen Pfad nicht finden.   (errno=3)
Thu Aug 11 09:56:52 2011 ERROR: Windows route delete command failed [adaptive]: external program did not execute -- returned error code -1
Thu Aug 11 09:56:52 2011 C:\WINDOWS\system32\route.exe DELETE 0.0.0.0 MASK 0.0.0.0 192.168.200.1
Thu Aug 11 09:56:52 2011 Route deletion via IPAPI succeeded [adaptive]
Thu Aug 11 09:56:52 2011 C:\WINDOWS\system32\route.exe ADD 0.0.0.0 MASK 0.0.0.0 141.73.30.254
Thu Aug 11 09:56:52 2011 Route addition via IPAPI succeeded [adaptive]
Thu Aug 11 09:56:52 2011 Closing TUN/TAP interface
Thu Aug 11 09:56:52 2011 SIGTERM[soft,init_instance] received, process exiting
 
Zuletzt bearbeitet:

MaxMuster

IPPF-Promi
Mitglied seit
1 Feb 2005
Beiträge
6,932
Punkte für Reaktionen
1
Punkte
36
Das Problem ist, dass du dich nicht mit dem Server verbindest, sondern "mit dir selbst sprichst" (TCP connection established with 127.0.0.1:8080), vermutlich versuchst du das durch eine SSH Verbindung?
Damit klappt das Umleiten der Defaultroute nicht, denn deren erster Schritt ist, die Verbindung zum VPN-Server von der neuen Default-Route auszunehmen, dazu muss aber die "echte" IP bekannt sein, mit der eigenen IP 127.0.0.1 klappt das nicht...

Du must also "von Hand" eine Hoste-Route zum Proxy erhalten...

Zudem: nimm noch oben den Namen oben raus, z.B. aus den Zertifikaten und aus der Zeile:
Thu Aug 11 09:55:53 2011 Send to HTTP proxy: 'CONNECT XXXXX:443 HTTP/1.0'
 
Zuletzt bearbeitet:

sualc1812

Neuer User
Mitglied seit
11 Mai 2007
Beiträge
21
Punkte für Reaktionen
0
Punkte
0
127.0.0.1:8080 ist die Adresse meines lokalen Proxies, der auf den Firmenproxy verweist.

Habe den mal rausgenommen und greife nun direkt über den Firmenproxy (xxx.254.160.21:81).

Ergebins: Der VPN Client schmiert zwar nicht mehr ab, aber mein Windows wird immer langsamer bis sich nach ca. 1 Minute der Explorer verabschiedet.

Hier das Client-Logfile:
Code:
Thu Aug 11 14:57:00 2011 OpenVPN 2.2.1 Win32-MSVC++ [SSL] [LZO2] built on Jul  1 2011
Thu Aug 11 14:57:00 2011 NOTE: OpenVPN 2.1 requires '--script-security 2' or higher to call user-defined scripts or executables
Thu Aug 11 14:57:00 2011 Control Channel Authentication: using 'static.key' as a OpenVPN static key file
Thu Aug 11 14:57:00 2011 Outgoing Control Channel Authentication: Using 160 bit message hash 'SHA1' for HMAC authentication
Thu Aug 11 14:57:00 2011 Incoming Control Channel Authentication: Using 160 bit message hash 'SHA1' for HMAC authentication
Thu Aug 11 14:57:00 2011 LZO compression initialized
Thu Aug 11 14:57:00 2011 Control Channel MTU parms [ L:1592 D:168 EF:68 EB:0 ET:0 EL:0 ]
Thu Aug 11 14:57:00 2011 Socket Buffers: R=[8192->8192] S=[8192->8192]
Thu Aug 11 14:57:00 2011 Data Channel MTU parms [ L:1592 D:1450 EF:60 EB:135 ET:32 EL:0 AF:3/1 ]
Thu Aug 11 14:57:00 2011 Local Options hash (VER=V4): '29f6c8b2'
Thu Aug 11 14:57:00 2011 Expected Remote Options hash (VER=V4): '3d4363c6'
Thu Aug 11 14:57:00 2011 Attempting to establish TCP connection with xxx.254.160.21:81
Thu Aug 11 14:57:00 2011 TCP connection established with xxx.254.160.21:81
Thu Aug 11 14:57:00 2011 Send to HTTP proxy: 'CONNECT xxx.selfhost.de:443 HTTP/1.0'
Thu Aug 11 14:57:01 2011 HTTP proxy returned: 'HTTP/1.1 200 Connection established'
Thu Aug 11 14:57:03 2011 TCPv4_CLIENT link local: [undef]
Thu Aug 11 14:57:03 2011 TCPv4_CLIENT link remote: xxx.254.160.21:81
Thu Aug 11 14:57:03 2011 TLS: Initial packet from xxx.254.160.21:81, sid=5e7a98e7 bfceed14
Thu Aug 11 14:57:04 2011 VERIFY OK: depth=1, /C=DE/ST=./L=xxx/O=./OU=./CN=xxx.selfhost.de/name=./emailAddress=xxx
Thu Aug 11 14:57:04 2011 VERIFY OK: nsCertType=SERVER
Thu Aug 11 14:57:04 2011 VERIFY OK: depth=0, /C=DE/ST=./L=xxx/O=./OU=./CN=server/name=./emailAddress=xxx
Thu Aug 11 14:57:06 2011 Data Channel Encrypt: Cipher 'AES-128-CBC' initialized with 128 bit key
Thu Aug 11 14:57:06 2011 Data Channel Encrypt: Using 160 bit message hash 'SHA1' for HMAC authentication
Thu Aug 11 14:57:06 2011 Data Channel Decrypt: Cipher 'AES-128-CBC' initialized with 128 bit key
Thu Aug 11 14:57:06 2011 Data Channel Decrypt: Using 160 bit message hash 'SHA1' for HMAC authentication
Thu Aug 11 14:57:06 2011 Control Channel: TLSv1, cipher TLSv1/SSLv3 DHE-RSA-AES256-SHA, 1024 bit RSA
Thu Aug 11 14:57:06 2011 [server] Peer Connection Initiated with 146.254.160.21:81
Thu Aug 11 14:57:08 2011 SENT CONTROL [server]: 'PUSH_REQUEST' (status=1)
Thu Aug 11 14:57:09 2011 PUSH: Received control message: 'PUSH_REPLY,route-gateway 192.168.200.1,route 192.168.178.0 255.255.255.0,route 192.168.200.1,redirect-gateway,ping 10,ping-restart 120,ifconfig 192.168.200.100 255.255.255.0'
Thu Aug 11 14:57:09 2011 OPTIONS IMPORT: timers and/or timeouts modified
Thu Aug 11 14:57:09 2011 OPTIONS IMPORT: --ifconfig/up options modified
Thu Aug 11 14:57:09 2011 OPTIONS IMPORT: route options modified
Thu Aug 11 14:57:09 2011 OPTIONS IMPORT: route-related options modified
Thu Aug 11 14:57:09 2011 ROUTE default_gateway=141.73.30.254
Thu Aug 11 14:57:09 2011 TAP-WIN32 device [OpenVPN] opened: \\.\Global\{18F2E960-6CEF-432F-AEC9-12E0A0D5B69C}.tap
Thu Aug 11 14:57:09 2011 TAP-Win32 Driver Version 9.8 
Thu Aug 11 14:57:09 2011 TAP-Win32 MTU=1500
Thu Aug 11 14:57:09 2011 Notified TAP-Win32 driver to set a DHCP IP/netmask of 192.168.200.100/255.255.255.0 on interface {18F2E960-6CEF-432F-AEC9-12E0A0D5B69C} [DHCP-serv: 192.168.200.0, lease-time: 31536000]
Thu Aug 11 14:57:09 2011 Successful ARP Flush on interface [5] {18F2E960-6CEF-432F-AEC9-12E0A0D5B69C}
Thu Aug 11 14:57:14 2011 TEST ROUTES: 3/3 succeeded len=2 ret=1 a=0 u/d=up
Thu Aug 11 14:57:14 2011 C:\WINDOWS\system32\route.exe ADD 146.254.160.21 MASK 255.255.255.255 141.73.30.254
Thu Aug 11 14:57:14 2011 Route addition via IPAPI succeeded [adaptive]
Thu Aug 11 14:57:14 2011 C:\WINDOWS\system32\route.exe DELETE 0.0.0.0 MASK 0.0.0.0 141.73.30.254
Thu Aug 11 14:57:14 2011 Route deletion via IPAPI succeeded [adaptive]
Thu Aug 11 14:57:14 2011 C:\WINDOWS\system32\route.exe ADD 0.0.0.0 MASK 0.0.0.0 192.168.200.1
Thu Aug 11 14:57:14 2011 Route addition via IPAPI succeeded [adaptive]
Thu Aug 11 14:57:14 2011 C:\WINDOWS\system32\route.exe ADD 192.168.178.0 MASK 255.255.255.0 192.168.200.1
Thu Aug 11 14:57:14 2011 Route addition via IPAPI succeeded [adaptive]
Thu Aug 11 14:57:14 2011 WARNING: potential route subnet conflict between local LAN [192.168.200.0/255.255.255.0] and remote VPN [192.168.200.1/255.255.255.255]
Thu Aug 11 14:57:14 2011 OpenVPN ROUTE: omitted no-op route: 192.168.200.1/255.255.255.255 -> 192.168.200.1
Thu Aug 11 14:57:14 2011 Initialization Sequence Completed
Was bedeuted die Warning in der 3. letzten Zeile ?
 

MaxMuster

IPPF-Promi
Mitglied seit
1 Feb 2005
Beiträge
6,932
Punkte für Reaktionen
1
Punkte
36
Die Warnung kannst du ignorieren. Zur Sicherheit kommt von der FB immer eine Route zum Default-Gateway, es gibt aber (wie bei dir) Situationen, wo diese Route überflüssig ist. Dann kommt diese Warnung.

Du musst bedenken, dass du so wirklich alles durch den Tunnel schiebst, evtl. auch Verbindungen zu irgendwelchen Shares usw., die dann nicht mehr erreichbar sind. Was zieht denn dann die Last (Taskmanager oder so)?

Geht denn generell jetzt der ganze Verkehr wie gewünscht komplett durch den Tunnel? Was hat es mit dem lokalen Proxy auf sich, wofür ist der?
 

sualc1812

Neuer User
Mitglied seit
11 Mai 2007
Beiträge
21
Punkte für Reaktionen
0
Punkte
0
Habe mir nun statt der TAP eine TUN Verbindung eingerichtet und im VPN-Client einfach ein "redirect-gateway" gesetzt.
Jetzt funktioniert alles so, wie ich mir das vorgestellt hatte.

Vielen Dank nochmals für die Unterstützung !
 

wengi

Mitglied
Mitglied seit
3 Okt 2006
Beiträge
339
Punkte für Reaktionen
1
Punkte
18
Hallo allerseits,

ich hätte da mal einen Feature Request.

OpenVPN listet in der /var/log/openvpn.log die verbundenen Clients.
Könnte man diese auswerten und im Webinterface von Freetz anzeigen?
Unter dem OpenVPN Menü vielleicht eine neue Seite "Status", auf der die verbundenen Clients gelistet werden.

Ich bin gerne bereit zu helfen, bin allerdings nicht wirklich fit ...

Danke
wengi

EDIT:
Alternativ könnte man das auch unterhalb des Status Menüs machen.
 

3CX PBX - GRATIS
Linux / Win / Cloud

Statistik des Forums

Themen
232,863
Beiträge
2,027,488
Mitglieder
350,971
Neuestes Mitglied
Bieka2003