.titleBar { margin-bottom: 5px!important; }

[PROBLEM] 360 + Asterisk: SNOM erzeugt bei einem Anruf keinen Klingelton

Dieses Thema im Forum "snom" wurde erstellt von cervi, 14 Sep. 2006.

  1. cervi

    cervi Neuer User

    Registriert seit:
    12 Apr. 2006
    Beiträge:
    30
    Zustimmungen:
    0
    Punkte für Erfolge:
    0
    Wähle ich mit meinem Snom über Asterisk eine Nebenstelle an, so bekomme ich kein Klingelton. Laut tcpdump bekommt das Snom aber sehr wohl ein "SIP/2.0 180 Ringing" zugeschickt. Das Problem lässt sich nur lösen, wenn ich in Asterisk VOR dem Dial() ein Answer() hinzufüge. Muss ich am snom oder am Asterisk was ändern?
     
  2. HobbyStern

    HobbyStern Aktives Mitglied

    Registriert seit:
    5 Dez. 2005
    Beiträge:
    1,837
    Zustimmungen:
    0
    Punkte für Erfolge:
    36
    Beruf:
    vorhanden
    Ort:
    Ruhrgebiet
    #2 HobbyStern, 18 Sep. 2006
    Zuletzt bearbeitet: 19 Sep. 2006
    Mal andersherum gedacht - könnte es ggf am Klingelton liegen, selbiges ist mir aufgefallen als ich eigens erstelle Töne eingespielt habe - wenigstens im Bastelstadium reagierte Das Snom bei grösseren Files **überhaupt** nicht auf den Anruf, nach einigen Sekunden (je nach kb des Files) sprang das Snom an und trällerte fröhlich, manchmal hatte ich aber schon vorher aufgelegt :)

    EDIT : Sorry, hatte das Problem falsch aufgefasst - diese "Hilfe" ist keine Hilfe !

    Grüsse, Stefan
     
  3. cervi

    cervi Neuer User

    Registriert seit:
    12 Apr. 2006
    Beiträge:
    30
    Zustimmungen:
    0
    Punkte für Erfolge:
    0
    Es geht um den Ton, den ein Anrufer hört wenn es beim Angerufenen klingelt. Freizeichen?

    Ich habe nun über Asterisk ein 2. SNOM angerufen - mit dem gehts ohne Answer(). Die andere problematische Extension ist mit IAX zu einem anderen Asterisk verbunden.

    Der Unterschiede beim sniffen: Bei der IAX-Extension antwortet mir Asterisk mit einem "183 Session Progress" und dann erst mit einem "180 Ringing". Wähle ich das 2. SNOM an, dann kommt nur ein "180 Ringing" und ich höre das Freizeichen.
     
  4. geistio

    geistio Neuer User

    Registriert seit:
    20 Okt. 2007
    Beiträge:
    52
    Zustimmungen:
    0
    Punkte für Erfolge:
    0
    Hallo cervi!
    Habe genau dasselbe Problem wie du... Hast du es denn irgendwie lösen können?
    (Snom320 v7.1.30)
     
  5. cervi

    cervi Neuer User

    Registriert seit:
    12 Apr. 2006
    Beiträge:
    30
    Zustimmungen:
    0
    Punkte für Erfolge:
    0
    Bei mir tuts jetzt. Weiss nimmer genau was es war
    Versuchs mal mit
    progressinband=no
    in der sip.conf
     
  6. pemer

    pemer Neuer User

    Registriert seit:
    20 Juni 2008
    Beiträge:
    43
    Zustimmungen:
    0
    Punkte für Erfolge:
    0
    ich habe auch dieses Problem und glaube das der progressinband nichts zur sache tut. Könnt ihr eure sip.conf posten ??
     
  7. cervi

    cervi Neuer User

    Registriert seit:
    12 Apr. 2006
    Beiträge:
    30
    Zustimmungen:
    0
    Punkte für Erfolge:
    0
    Code:
    [general]
    context=incoming
    tos=lowdelay
    srvlookup=yes
    rtptimeout=60
    rtpholdtimeout=300
    allow=all
    allow=alaw
    language=de
    dtmfmode=auto
    fromdomain=example.com
    videosupport=yes               ; Turn on support for SIP video
    progressinband=no
    notifyringing=yes
    useclientcode=yes
    ; test fuer sipsak
    notifymimetype=application/simple-message-summary
    
    callevents=yes
    
    nat=yes
    externip=134.x.x.x
    canreinvite=no
    localnet=10.0.0.0/255.0.0.0