.titleBar { margin-bottom: 5px!important; }

[Problem] VPN Anmeldung an Fritzbox 7390von Symsung Galaxy Tab 2 O.K. aber kein Tunnel

Dieses Thema im Forum "FRITZ!Box Fon: Modifikationen" wurde erstellt von Genesis100, 10 Juni 2013.

  1. Genesis100

    Genesis100 Neuer User

    Registriert seit:
    6 März 2011
    Beiträge:
    62
    Zustimmungen:
    0
    Punkte für Erfolge:
    6
    Hallo,
    ich habe seit längerer Zeit eine VPN Verbindung zu Fritzbox mit meinem HP Laptop. Mit diesem gerät funktioniert die VPN Verbindung mit meiner Fritzbox 7390 einwandfrei.
    Nun will ich mich mit meinem neuen Galaxy Tab 2 (WiFi kein GSM) (android 4.0.3) anmelden. Dazu habe ich mich wie in der Anleitung von AVM beschrieben verhalten. Leider habe ich das Problem, das die VPN-Verbindung hergestellt wird, es können aber keine Daten ausgetauscht werden. (Screen VPN verbunden: Sitzung: android, Dauer: xx:xx:xx, gesendet: -, empfangen: -)
    In der Fritzbox wurde unter VPN folgendes Angezeigt:
    Adresse im Internet: IP des WLAN-Routers, von dem ich mich angemeldet habe
    lokales Netz 0.0.0.0 und entferntes Netz war die IP-Adresse des Tab2.

    Meine Fritz.cfg:

    /*
    * C:\Users\Otto_7\AppData\Roaming\AVM\FRITZ!Fernzugang\dyndns_org\fritzbox_ dyndns_org.cfg
    * Thu Jun 06 18:06:40 2013
    */

    vpncfg {
    connections {
    enabled = yes;
    conn_type = conntype_user;
    name = " SamsungTab2";
    always_renew = no;
    reject_not_encrypted = no;
    dont_filter_netbios = yes;
    localip = 0.0.0.0;
    local_virtualip = 0.0.0.0;
    remoteip = 0.0.0.0;
    remote_virtualip = 192.168.178.201;
    remoteid {
    key_id = "SamsungTab2";
    }
    mode = phase1_mode_aggressive;
    phase1ss = "all/all/all";
    keytype = connkeytype_pre_shared;
    key = "123456";
    cert_do_server_auth = no;
    use_nat_t = yes;
    use_xauth = yes;
    xauth {
    valid = yes;
    username = " SamsungTab2";
    passwd = "passwort";
    }
    use_cfgmode = yes;
    phase2localid {
    ipnet {
    ipaddr = 0.0.0.0;
    mask = 0.0.0.0;
    }
    }
    phase2remoteid {
    ipaddr = 192.168.178.201;
    }
    phase2ss = "esp-all-all/ah-none/comp-all/no-pfs";
    accesslist =
    "permit ip 192.168.178.0 255.255.255.0 192.168.178.201 255.255.255.255",
    "permit ip any 192.168.178.201 255.255.255.255";
    }
    ike_forward_rules = "udp 0.0.0.0:500 0.0.0.0:500",
    "udp 0.0.0.0:4500 0.0.0.0:4500";
    }


    // EOF


    Woran ich noch schrauben muss ?

    Gruß
     
  2. Genesis100

    Genesis100 Neuer User

    Registriert seit:
    6 März 2011
    Beiträge:
    62
    Zustimmungen:
    0
    Punkte für Erfolge:
    6
    Hallo !!

    Ich habe es hingekriegt. Beim Eintragen von VPN Daten von Tab2 gibt es Option Erweitert, dort habe ich Route eingetragen 192.168.178.0/24 und unter DNS Server 192.168.178.1. Danach hat es sofort geklappt.

    Gruß
     
  3. emil70

    emil70 Neuer User

    Registriert seit:
    17 Okt. 2012
    Beiträge:
    44
    Zustimmungen:
    1
    Punkte für Erfolge:
    8
    Hallo

    Ich habe das selbe Problem. Fritzbox 7270v3 mit FRITZ!OS 05.22 und Galaxy Tab 2 (7 Zoll) Androidversion 4.1.2

    Das Tab2 verbindet sich und ist unter Freigaben-VPN auch zu sehe.
    Adresse im Internet wird angezeigt, bei lokales Netz steht 0.0.0.0 und bei entferntes Netz die IP die ich vergeben habe

    Leider komme ich dann aber mit dem Tab2 aber dann nicht mehr ins Internet. Das Tab2 ist Verbunden mit meinem Handy über Hotspot


    Auch wenn ich das eintrage, ändert sich nichts.

    Hat da Jemand noch eine Idee??
     
  4. Genesis100

    Genesis100 Neuer User

    Registriert seit:
    6 März 2011
    Beiträge:
    62
    Zustimmungen:
    0
    Punkte für Erfolge:
    6
    Welche Ip Adresse hast Du genommen? Wie sieht Deine fritz.cfg aus? Hast Du andere VPN schon auf Fritzbox?
     
  5. emil70

    emil70 Neuer User

    Registriert seit:
    17 Okt. 2012
    Beiträge:
    44
    Zustimmungen:
    1
    Punkte für Erfolge:
    8
    #5 emil70, 3 Aug. 2013
    Zuletzt von einem Moderator bearbeitet: 4 Aug. 2013
    Hi

    Ich haben den IP-Bereich geändert. Das Tab2 sollt die 7 am Ende bekommen. Habe es aber auch schon mit 201 am Ende probiert. Ich nutze ein Freetzimage wo auch open VPN drauf ist. aber nicht eingeschaltet

    Code:
    /*
     * C:\Users\Lappi\AppData\Roaming\AVM\FRITZ!Fernzugang\*****_dyndns_org\fritzbox_*****_dyndns_org.cfg
     * Mon Jul 29 19:52:51 2013
     */
    
    vpncfg {
            connections {
                    enabled = yes;
                    conn_type = conntype_user;
                    name = "Tablet";
                    always_renew = no;
                    reject_not_encrypted = no;
                    dont_filter_netbios = yes;
                    localip = 0.0.0.0;
                    local_virtualip = 0.0.0.0;
                    remoteip = 0.0.0.0;
                    remote_virtualip = 1xx.1xx.8.7;
                    remoteid {
                            key_id = "Tablet";
                    }
                    mode = phase1_mode_aggressive;
                    phase1ss = "all/all/all";
                    keytype = connkeytype_pre_shared;
                    key = "1c9+++++++++++++1e";
                    cert_do_server_auth = no;
                    use_nat_t = yes;
                    use_xauth = yes;
                    xauth {
                            valid = yes;
                            username = "Tablet";
                            passwd = "12345";
                    }
                    use_cfgmode = yes;
                    phase2localid {
                            ipnet {
                                    ipaddr = 0.0.0.0;
                                    mask = 0.0.0.0;
                            }
                    }
                    phase2remoteid {
                            ipaddr = 1xx.1xx.8.7;
                    }
                    phase2ss = "esp-all-all/ah-none/comp-all/no-pfs";
                    accesslist = 
                                 "permit ip 1xx.1xx.8.0 255.255.255.0 1xx.1xx.8.7 255.255.255.255", 
                                 "permit ip any 1xx.1xx.8.7 255.255.255.255";
            }
            ike_forward_rules = "udp 0.0.0.0:500 0.0.0.0:500", 
                                "udp 0.0.0.0:4500 0.0.0.0:4500";
    }
    
    
    // EOF
    
    Edit: VPN mit meinem Lappi in Verbindung Hotspot Handy geht ohne Probleme
     
  6. Genesis100

    Genesis100 Neuer User

    Registriert seit:
    6 März 2011
    Beiträge:
    62
    Zustimmungen:
    0
    Punkte für Erfolge:
    6
    Wenn Du open VPN nicht benutzt nimmt eine Freetz Image ohne open VPN , vieleicht fählt in der Image was. Hast Du schon eine Avm VPN Verbindung z.B. mit PC hinbekommen? (Damit kann man erkennen , ob deine Image o.k. ist)
     
  7. emil70

    emil70 Neuer User

    Registriert seit:
    17 Okt. 2012
    Beiträge:
    44
    Zustimmungen:
    1
    Punkte für Erfolge:
    8
    Verbindung mit Lappi klappt ohne Probleme. Komme dann auch ins Internet und auf mein eFritzbox mit der internen IP. Baue meine Freetzimage selber. Auch ohne open VPN geht es nicht mit dem Tab2.

    Steht den bei dir unter lokales Netz beim Tab dann die 192.168.178.0/24 bei dir oder 0.0.0.0. Beim Lappi steht es nämlich da. Natürlich mit meinen IP-Daten. Internet über Hotspot geht mit dem Tab. Sobald aber der Tunnel steht geht es nicht mehr. Nutze den Internetexplorer der Orginal drauf ist
     
  8. Genesis100

    Genesis100 Neuer User

    Registriert seit:
    6 März 2011
    Beiträge:
    62
    Zustimmungen:
    0
    Punkte für Erfolge:
    6
    Mit dem 0.0.0.0 ist o.k. es ist anders als mit dem Laptop. Ich hatte gerade gesehen, dass Du IP Adresse 192.168.178.7 genommen hast.Das ist aber falsch. Sie muss außerhalb IP Bereiches deiner Fritzbox sein. Wenn der Bereich z.B. 192.168.178.1-192.168.178.200 so ist, muss Deine IP größer 200 sein und darf nicht gleich wie die z.B. von dem Laptop
     
  9. emil70

    emil70 Neuer User

    Registriert seit:
    17 Okt. 2012
    Beiträge:
    44
    Zustimmungen:
    1
    Punkte für Erfolge:
    8
    So ich habe VPN noch mal komplett neu aufgesetzt. Lappi-IP am Ende 201. Tab2 am Ende 202. Es bleibt aber das Gleiche.
    Tab2 mit Hotspot am Handy verbunden. Komme ins Internet. VPN-Verbindung klappt auch. Internet-IP wird angezeigt,genauso wie die Lokale-IP. Sobald der VPN-Tunnel steht komm eich aber nicht mehr ins Internet mit dem Tab2. Wenn ich die VPN-Verbindung trenne, wird trotzdem noch die Verbindung an der Fritzbox angezeigt. Momentan habe ich keine Ahnung wo ran es liegt. Werde vllt mal recovern und nur die orginale Firmeware drauf machen zum testen. Ausser es hat noch jemand ein eIdee