.titleBar { margin-bottom: 5px!important; }

7270 54.04.97-13286: fz-trunk 2936:AVM Plugin's werden nicht nachgeladen

Dieses Thema im Forum "Freetz" wurde erstellt von rolsch, 29 Dez. 2008.

  1. rolsch

    rolsch Neuer User

    Registriert seit:
    28 Okt. 2004
    Beiträge:
    177
    Zustimmungen:
    0
    Punkte für Erfolge:
    0
    - 7270 mit 54.04.97-13286
    - fz-trunk 2936
    - build mit labor phone
    - Freetz version-/dev-string ist nicht aktiviert

    Scheinbar gibt es Probleme mit den nachladen der AVM Plugins.

    Code:
    / # Dec 28 23:50:52 ctlmgr[551]: ctlmgr: plugin_install()
    Dec 28 23:50:52 ctlmgr[551]: ctlmgr: plugin_installer: plugin not found yet. further installation needed!
    Dec 28 23:50:52 ctlmgr[6351]: ctlmgr: plugin_intaller: starting "/sbin/start_plugin.sh ext_mount"
    /sbin/start_plugin.sh[6351]: Plugins awaited: ntfs mini samba
    /sbin/start_plugin.sh[6351]: External get & install
    script url="http://boxplugin.avm.de./cgi-bin/boxplugin?name=FRITZ!Box+Fon+WLAN+7270&revision=13286&version=54.04.97&subversion=-13286&hw=139&OEM=avm"
    2008-12-28 23:50:52 httpsdl: CSession::Connect enter
    2008-12-28 23:50:52 httpsdl: dns: boxplugin.avm.de: query
    2008-12-28 23:52:12 httpsdl: dns: boxplugin.avm.de: timeout after 3 retries
    not found
    Error 6
    /sbin/start_plugin.sh[6351]: Could not resolve Plugin-URL ''
    Dec 28 23:52:14 ctlmgr[551]: ctlmgr: plugin_installer: plugin not found yet. further installation needed!
    
     
  2. itzy

    itzy Neuer User

    Registriert seit:
    25 Nov. 2006
    Beiträge:
    150
    Zustimmungen:
    0
    Punkte für Erfolge:
    0
    Code:
    ping boxplugin.avm.de
    
    Pinging boxplugin.avm.de [212.42.244.73] with 32 bytes of data:
    
    Request timed out.
    Reply from 212.42.244.73: bytes=32 time=66ms TTL=53
    Reply from 212.42.244.73: bytes=32 time=59ms TTL=53
    Reply from 212.42.244.73: bytes=32 time=63ms TTL=53
    
    Ping statistics for 212.42.244.73:
        Packets: Sent = 4, Received = 3, Lost = 1 (25% loss),
    Approximate round trip times in milli-seconds:
        Minimum = 59ms, Maximum = 66ms, Average = 62ms
    Jetzt sollte er wieder da sein...
     
  3. frank_m24

    frank_m24 IPPF-Urgestein

    Registriert seit:
    20 Aug. 2005
    Beiträge:
    17,571
    Zustimmungen:
    1
    Punkte für Erfolge:
    36
    Ort:
    Niederrhein
    Hallo,

    hmm, kein Problem hier. Grad eben noch ne neue Phone Labor mit Freetz (r2937) gebaut, auch um dem Time Problem auf die Spur zu kommen.

    Ich kann im Syslog den Aufruf der Plugins sehen, z.B.
    Code:
    Dec 28 22:29:55 fritz user.info tr069fwupdate[1118]: exec_shellcmd httpsdl -O - "http://boxplugin.avm.de/boxplugin/122/54.04.97/13286.-13286.avm.plugin/plugins.update" 2>/var/dl_err | /usr/www/cgi-bin/firmwarecfg stream |tee "/var/tmp/plugins.update" |  tar xvf - ret
    Dec 28 22:29:55 fritz user.info tr069fwupdate[1118]: Get_stream_error total=1157120 ret=0 sigcrc=0a38be77006704ce3997e3cb4f7439d1
    Dec 28 22:29:56 fritz user.err ctlmgr[520]: ctlmgr: plugin_installer: plugin directory found: plugin-samba
    Dec 28 22:29:56 fritz user.err ctlmgr[520]: ctlmgr: plugin_installer: plugin found in flash. no further installation needed.
    in dl_err steht:
    Code:
    2000-01-01 01:01:55 httpsdl: CSession::Connect enter
    2000-01-01 01:01:55 httpsdl: dns: boxplugin.avm.de: query
    2000-01-01 01:01:55 httpsdl: dns: boxplugin.avm.de: 212.42.244.73 ttl=13895 from 192.168.180.1.
    2000-01-01 01:01:55 httpsdl: DNS: new best 192.168.180.1:53
    2000-01-01 01:01:55 httpsdl: CSession::ConnectNow TCP connect to ip=0xd42af449 Port=80
    2000-01-01 01:01:55 httpsdl: CSession::connected
    2000-01-01 01:01:56 httpsdl: DownloadStream Start
    2008-12-28 22:29:54 httpsdl: DownloadStream End g_fp_out=0x2acf31dc total=1157120
    2008-12-28 22:29:54 httpsdl: Download Ended
    2008-12-28 22:29:54 httpsdl: CSession::disconnected reason=0
    2008-12-28 22:29:54 httpsdl: DownloadStream End g_fp_out=(nil) total=1157120
    
    Und mount zeigt mir dann an:
    Code:
    /var/mod/root # mount
    rootfs on / type rootfs (rw)
    /dev/root on / type squashfs (ro)
    dev on /dev type tmpfs (rw,nosuid)
    proc on /proc type proc (rw,nosuid,nodev,noexec)
    tmpfs on /var type tmpfs (rw)
    sysfs on /sys type sysfs (rw,nosuid,nodev,noexec)
    usbfs on /proc/bus/usb type usbfs (rw)
    /dev/loop0 on /var/plugin-mediasrv type squashfs (ro)
    /dev/loop1 on /var/plugin-mini type squashfs (ro)
    /dev/loop2 on /var/plugin-ntfs type squashfs (ro)
    /dev/loop3 on /var/plugin-samba type squashfs (ro)
    
    Sieht für mich aus, als ob 4 Plugins gemountet sind.
     
  4. itzy

    itzy Neuer User

    Registriert seit:
    25 Nov. 2006
    Beiträge:
    150
    Zustimmungen:
    0
    Punkte für Erfolge:
    0
    @frank_m24: wobei die Fbox bei dir auch nichts nachladen wollte.
    Um wirklich zu testen müsste man die plugins.update löschen/verschieben, um den Download zu erzwingen.
     
  5. rolsch

    rolsch Neuer User

    Registriert seit:
    28 Okt. 2004
    Beiträge:
    177
    Zustimmungen:
    0
    Punkte für Erfolge:
    0
    Hmm,
    die Box war nun über Nacht online - es wurden keine Plugins geladen.

    Die Box hängt hinter einem Router mit der Internetoption "Internetzugang über LAN 1" und erhält per statischen DHCP ihre zugewiesene IP.

    In der Telnetkonsole:
    - ping auf buxplugin.avm.de funktioniert, DNS daher ok
    - http://boxplugin.avm.de./cgi-bin/bo...ion=54.04.97&subversion=-13286&hw=139&OEM=avm
    liefert
    - http://boxplugin.avm.de/boxplugin/139/54.04.97/13286.-13286.avm.plugin
    - manueller download mittles wget und der zweiten URL funktioniert

    Hier nochmal der Konsolenoutput nach einem Neustart der 7270:
    Code:
    BusyBox v1.12.3 (2008-12-28 22:18:13 CET) built-in shell (ash)
    Enter 'help' for a list of built-in commands.
    
    ermittle die aktuelle TTY
    tty is "/dev/pts/0"
    Console Ausgaben auf dieses Terminal umgelenkt
    /var/mod/root # Dec 29 10:55:02 tr069discover[837]: discover_request to iface lan sent
    2008-12-29 10:55:23 httpsdl: dns: boxplugin.avm.de: timeout after 3 retries
    not found
    Error 6
    /sbin/start_plugin.sh[1143]: Could not resolve Plugin-URL ''
    Dec 29 10:55:25 ctlmgr[575]: ctlmgr: plugin_installer: plugin not found yet. further installation needed!
    Dec 29 10:55:31 ctlmgr[575]: ctlmgr: plugin_install()
    Dec 29 10:55:31 ctlmgr[575]: ctlmgr: plugin_installer: plugin not found yet. further installation needed!
    Dec 29 10:55:31 ctlmgr[1383]: ctlmgr: plugin_intaller: starting "/sbin/start_plugin.sh ext_mount"
    /sbin/start_plugin.sh[1383]: Plugins awaited: ntfs mini samba
    /sbin/start_plugin.sh[1383]: External get & install
    script url="http://boxplugin.avm.de./cgi-bin/boxplugin?name=FRITZ!Box+Fon+WLAN+7270&revision=13286&version=54.04.97&subversion=-13286&hw=139&OEM=avm"
    2008-12-29 10:55:31 httpsdl: CSession::Connect enter
    2008-12-29 10:55:31 httpsdl: dns: boxplugin.avm.de: query
    Dec 29 10:56:05 tr069discover[837]: discover_request to iface lan sent
    Dec 29 10:56:32 tr069discover[837]: discover_timeout_cb occured!, sig=0
    2008-12-29 10:56:51 httpsdl: dns: boxplugin.avm.de: timeout after 3 retries
    not found
    Error 6
    /sbin/start_plugin.sh[1383]: Could not resolve Plugin-URL ''
    Dec 29 10:56:53 ctlmgr[575]: ctlmgr: plugin_installer: plugin not found yet. further installation needed!
    Dec 29 10:57:05 ctlmgr[575]: ctlmgr: plugin_install()
    Dec 29 10:57:05 ctlmgr[575]: ctlmgr: plugin_installer: plugin not found yet. further installation needed!
    Dec 29 10:57:05 ctlmgr[1449]: ctlmgr: plugin_intaller: starting "/sbin/start_plugin.sh ext_mount"
    /sbin/start_plugin.sh[1449]: Plugins awaited: ntfs mini samba
    /sbin/start_plugin.sh[1449]: External get & install
    script url="http://boxplugin.avm.de./cgi-bin/boxplugin?name=FRITZ!Box+Fon+WLAN+7270&revision=13286&version=54.04.97&subversion=-13286&hw=139&OEM=avm"
    2008-12-29 10:57:05 httpsdl: CSession::Connect enter
    2008-12-29 10:57:05 httpsdl: dns: boxplugin.avm.de: query
    [00000004][pcmlink]error: trigger to late 8952656 usec (674E13 7D477B 7DBF02)
    2008-12-29 10:58:25 httpsdl: dns: boxplugin.avm.de: timeout after 3 retries
    not found
    Error 6
    /sbin/start_plugin.sh[1449]: Could not resolve Plugin-URL ''
    Dec 29 10:58:26 ctlmgr[575]: ctlmgr: plugin_installer: plugin not found yet. further installation needed!
    Dec 29 10:58:50 ctlmgr[575]: ctlmgr: plugin_install()
    Dec 29 10:58:50 ctlmgr[575]: ctlmgr: plugin_installer: plugin not found yet. further installation needed!
    Dec 29 10:58:50 ctlmgr[1503]: ctlmgr: plugin_intaller: starting "/sbin/start_plugin.sh ext_mount"
    /sbin/start_plugin.sh[1503]: Plugins awaited: ntfs mini samba
    /sbin/start_plugin.sh[1503]: External get & install
    script url="http://boxplugin.avm.de./cgi-bin/boxplugin?name=FRITZ!Box+Fon+WLAN+7270&revision=13286&version=54.04.97&subversion=-13286&hw=139&OEM=avm"
    2008-12-29 10:58:50 httpsdl: CSession::Connect enter
    2008-12-29 10:58:50 httpsdl: dns: boxplugin.avm.de: query
    
     
  6. rolsch

    rolsch Neuer User

    Registriert seit:
    28 Okt. 2004
    Beiträge:
    177
    Zustimmungen:
    0
    Punkte für Erfolge:
    0
    So,
    jetzt mal die org. AVM Firmware-Version 54.04.67 geflasht,
    auch hier werden die Plugins bei mir nicht nachgeladen!

    Code:
    BusyBox v1.8.2 (2008-08-19 14:56:32 CEST) built-in shell (ash)
    Enter 'help' for a list of built-in commands.
    
    ermittle die aktuelle TTY
    tty is "/dev/pts/0"
    Console Ausgaben auf dieses Terminal umgelenkt
    # /sbin/start_plugin.sh[962]: Plugins awaited: samba mini ntfs
    /sbin/start_plugin.sh[962]: External get & install
    script url="http://boxplugin.avm.de./cgi-bin/boxplugin?name=FRITZ!Box+Fon+WLAN+7270&revision=13053&version=54.04.67&subversion=&hw=139&OEM=avm"
    Dec 29 17:30:05 telefon[774]: set initial telefon time from linux time to 17:30 29.12 2008!
    not found
    Error 6
    /sbin/start_plugin.sh[962]: Could not resolve Plugin-URL ''
    /sbin/start_plugin.sh[977]: Plugins awaited: samba mini ntfs
    /sbin/start_plugin.sh[977]: External get & install
    script url="http://boxplugin.avm.de./cgi-bin/boxplugin?name=FRITZ!Box+Fon+WLAN+7270&revision=13053&version=54.04.67&subversion=&hw=139&OEM=avm"
    not found
    Error 6
    
    Scheint wohl doch an der Internetoption "Internetzugang über LAN 1" zu liegen,
    obwohl DNS-Auflösung und wget aus der Telnetkonsole funktioniert...?
     
  7. RalfFriedl

    RalfFriedl IPPF-Urgestein

    Registriert seit:
    22 Apr. 2007
    Beiträge:
    12,343
    Zustimmungen:
    0
    Punkte für Erfolge:
    0
    Bei mir kommt unter
    Code:
    http://boxplugin.avm.de./cgi-bin/boxplugin?name=FRITZ!Box+Fon+WLAN+7270&revision=13053&version=54.04.67&subversion=&hw=139&OEM=avm
    
    eine Datei mit dem Inhalt
    Code:
    URL="http://boxplugin.avm.de/boxplugin/139/54.04.67/13053..avm.plugin"
    
    Und unter der dort angegebenen URL kommt eine Datei mit ca. 1MB Größe, also vermutlich das Plugin.
     
  8. rolsch

    rolsch Neuer User

    Registriert seit:
    28 Okt. 2004
    Beiträge:
    177
    Zustimmungen:
    0
    Punkte für Erfolge:
    0
    Stimmt,
    habe ich ja oben auch beschrieben,
    DNS Auflösung und manuelles wget funktioniert auf/von der Box,
    nur die AVM-Mimik kann nichts runterladen und installieren... :(
     
  9. RalfFriedl

    RalfFriedl IPPF-Urgestein

    Registriert seit:
    22 Apr. 2007
    Beiträge:
    12,343
    Zustimmungen:
    0
    Punkte für Erfolge:
    0
    Wenn es mit original Firmware auch nicht funtioniert, dann ist es ein Fall für AVM.
     
  10. rolsch

    rolsch Neuer User

    Registriert seit:
    28 Okt. 2004
    Beiträge:
    177
    Zustimmungen:
    0
    Punkte für Erfolge:
    0
    7270: nachladen der AVM-Plugins: Internetoption "Internetzugang über LAN 1"

    Ok,
    dann die abschliessende Frage:

    Wer betreibt eine 7270 hinter einem Router mit der Internetoption "Internetzugang über LAN 1"?
    - geht bei euch dann das nachladen der AVM-Plugin's?
     
  11. olistudent

    olistudent IPPF-Urgestein

    Registriert seit:
    19 Okt. 2004
    Beiträge:
    14,756
    Zustimmungen:
    1
    Punkte für Erfolge:
    0
    Beruf:
    Softwareentwickler
    Ort:
    Kaiserslautern
    Bei mir hat das Nachladen mit 54.04.67 funktioniert (Inet über LAN1).

    MfG Oliver
     
  12. rolsch

    rolsch Neuer User

    Registriert seit:
    28 Okt. 2004
    Beiträge:
    177
    Zustimmungen:
    0
    Punkte für Erfolge:
    0
    Hallo Oliver,
    danke für deine Rückmeldung.

    Nun bin ich echt ratlos,
    denn ich habe nun über Recover eine "frische Box" aufgesetzt und auch hier werden die Plugins nicht nachgeladen.

    Nicht dass ich diese Plugins benötige,
    aber es stört mich, wenn diese Meldungen in der Konsole auftauchen...

    Habe nun wieder den aktuellen Trunk mit der 67er Firm geladen,
    um mit meinem DTMFBOX Vorhaben weiterzumachen.
     
  13. zirkon

    zirkon Aktives Mitglied

    Registriert seit:
    12 Aug. 2008
    Beiträge:
    906
    Zustimmungen:
    0
    Punkte für Erfolge:
    0
    #13 zirkon, 25 Jan. 2009
    Zuletzt bearbeitet: 25 Jan. 2009
    Ich kann das Problem nur bestätigen (LAN1); mit der aktuellen Labor-Version 54.04.97-13483 erhalte ich ähnliche Fehlermeldungen.

    Liegt es vllt. am TR069-Patch?
     
  14. Silent-Tears

    Silent-Tears IPPF-Promi

    Registriert seit:
    3 Aug. 2007
    Beiträge:
    7,456
    Zustimmungen:
    0
    Punkte für Erfolge:
    0
    Ort:
    BI
    Versikonstring entfernt?
     
  15. zirkon

    zirkon Aktives Mitglied

    Registriert seit:
    12 Aug. 2008
    Beiträge:
    906
    Zustimmungen:
    0
    Punkte für Erfolge:
    0
    Ja, wie rolsch auch.
     
  16. cando

    cando Aktives Mitglied

    Registriert seit:
    28 Nov. 2008
    Beiträge:
    1,080
    Zustimmungen:
    0
    Punkte für Erfolge:
    0
    aus "versehen" tr069 entfernt?

    obwohl die Plugins von der website geholt werden können sie ohne tr069 nicht automatisch installiert werden.

    also entweder versionsstring entfernen + tr069 drin lassen = plugins funktionieren

    oder darauf ganz verzichten / notfalls mit der firewall avm adresse + port für die interne box ip adresse 169.254.1.1 / 169.254.2.1 blocken, damit schon der download schief geht. dann gibt die box auf.

    vielleicht könnte man auch das start script patchen, damit sie gar nicht erst versucht die plugins zu holen, wenn tr069 abgewählt wird oder der versionsstring angehängt wird. wäre was für die entwickler...;)
     
  17. zirkon

    zirkon Aktives Mitglied

    Registriert seit:
    12 Aug. 2008
    Beiträge:
    906
    Zustimmungen:
    0
    Punkte für Erfolge:
    0
    Nein, schon absichtlich. Nur könnte der tr069 Patch dann auch noch erweitert werden, indem diese Abfragen gestoppt/entfernt werden. Aber das hast du ja bereits erwähnt! Sollte man vllt. mal in einem Ticket festhalten?
     
  18. cando

    cando Aktives Mitglied

    Registriert seit:
    28 Nov. 2008
    Beiträge:
    1,080
    Zustimmungen:
    0
    Punkte für Erfolge:
    0
    ich hatte es mal vor einiger zeit angeregt, hatte aber wohl keine prio, da es ja mit dem blocken funktioniert. die meisten lassen den tr069 eh drin wegen der fritz samba / mini.
     
  19. hermann72pb

    hermann72pb IPPF-Promi

    Registriert seit:
    6 Nov. 2005
    Beiträge:
    3,564
    Zustimmungen:
    0
    Punkte für Erfolge:
    36
    Ich habe so eine Frage am Rande: Hat jemand es eigentlich vollständig kapiert, was diese plugins an sich haben und wie sie funktionieren? Falls es bereits irgendwo ausführlich beschrieben, bitte darauf verlinken, ansonsten interessieren mich folgende Fragen:
    1. Wie werden die Dateien archiviert?
    2. Was ist die "Schaltzentrale" auf der Box? (Es wurde eine Datei erwähnt, die alle Pluginnamen enthält)
    3. Was hat es mit tr069 zu tun?
    4. Wann werden die plugins geladen? tr069 kann z.B. agieren schon bevor die DSL-Verbindung steht (bzw. es wird eine pseudo-Verbindung dafür aufgebaut)? Die Frage ziehlt sich Richtung Dienste starten.
    5. Wo landen die plugins? Im RAM?
    6. Wie werden sie gemounted? So ähnlich, wie "o -bind"-Methode?

    Und letzte Frage: Wo ist der Unterschied zum Downloader?

    MfG
     
  20. cando

    cando Aktives Mitglied

    Registriert seit:
    28 Nov. 2008
    Beiträge:
    1,080
    Zustimmungen:
    0
    Punkte für Erfolge:
    0
    -> Wieso sollten die archiviert werden?

    -> Die box basiert auf einem linux system, normale bootfunktionalität.
    -> Es wird eine fest verdrahtete datei auf einer avm url, die die boxversion + firmware nr. im pfad hat heruntergeladen und entweder im ram oder wenn ein usb medium angesteckt ist, dort gespeichert und ausgepackt. diese datei enthält auch ein shell script, dass dann die enthaltenen plugins in mit tr069install in den speicher lädt / an der box registriert. damit kann avm features dynamisch hinzufügen, auch wenn diese nicht in den flash der box passen (solande der RAM reicht).

    tr069install wird für die registrierung der plugins aus dem script aufgerufen. wenn der fehlt, geht es nicht.

    nach dem booten der box und dem verbindungsaufbau über dsl wird ein loop - timer aktiviert, der alle minute versucht avm zu erreichen und die plugins zu laden. wenn dsl funktioniert, avm aber nicht erreichbar ist, gibt er irgendwann auf. sind die erstmal auf der box, wird über den loop timer versucht, die plugins auszupacken und das enthaltene setup-script auszuführen. meldet das den vollzug, ist alles gut und die loop wird beendet, tritt ein fehler auf, wird der aufruf erneut in die loop geschrieben und eine minute später geht das spiel von vorne los...

    im endeffekt ja, wobei die gepackte datei entweder auf einem angeschlossenen usb massenspeicher oder in dem flüchtigen internen speicher der box gelagert werden.

    macht der tr069install

    der downloader ist ein freetz modul und hat mit der avm mimik meines wissens nach gar nichts zu tun.