[Anleitung]:Trixbox V2.0beta mit ISDN-Anbindung (HFC/Florz/bristuff/Fritz/chan_capi)

maxkr

Neuer User
Mitglied seit
16 Nov 2006
Beiträge
58
Punkte für Reaktionen
0
Punkte
6
Hallo charly_th,

die Bri-Bestandteile scheinen aber nicht bei der Junghanns-Version zu fehlen wie in der Anleitung (im Kapitel 1.5) beschrieben. Zumindest liefert mir asterisk -r folgendes:

Code:
Connected to Asterisk 1.2.13-BRIstuffed-0.3.0-PRE-1v

...warum sich mit der 1.2.9 zufrieden geben, wenn die 1.2.13 auch läuft!

Viele Grüße,
Max
 

charly_th

Neuer User
Mitglied seit
28 Okt 2005
Beiträge
2
Punkte für Reaktionen
0
Punkte
0
Hmm, bei mir laueft der 13er von Junghanns nicht, der 9er allerdings problemlos.

Ist aber nicht so wichtig, ich wollte nur darauf hinweisen woher der Fehler kommt, nach dem ich stundenland danch gesucht habe.
 

gregcgn

Neuer User
Mitglied seit
20 Nov 2006
Beiträge
7
Punkte für Reaktionen
0
Punkte
0
Hi!

Voweg: Ich bin relativ neu auf dem Gebiet und dementsprechend dumm könnten sich meine Fragen anhören. Ich habe eine Junghanns OctoBri installiert und bin nach dieser Anleitung hier vorgegangen.

Bis zum Schritt "Laden der Treiber" funktionierte auch noch alles prima.
Beim Booten des Rechners erhalte ich aber nun bei

zaphfc : No functioning hardware found in /proc/zaptel...
Dann wird der dummy geladen...

Beim start des Amportals erhalte ich ein "Asterisk dies with code 1."

Im Log:
Code:
Dec 11 11:29:31 WARNING[4078] pbx.c: Context 'default' tries includes nonexistent context 'ext-local'
Dec 11 11:29:31 WARNING[4078] pbx.c: Context 'from-did-direct' tries includes nonexistent context 'ext-findmefollow'
Dec 11 11:29:31 WARNING[4078] pbx.c: Context 'from-did-direct' tries includes nonexistent context 'ext-local'
Dec 11 11:29:31 WARNING[4078] pbx.c: Context 'from-pstn' tries includes nonexistent context 'from-pstn-custom'
Dec 11 11:29:31 WARNING[4078] pbx.c: Context 'from-pstn' tries includes nonexistent context 'ext-findmefollow'
Dec 11 11:29:31 WARNING[4078] pbx.c: Context 'from-pstn' tries includes nonexistent context 'ext-did-direct'
Dec 11 11:29:31 WARNING[4078] pbx.c: Context 'from-pstn' tries includes nonexistent context 'ext-did'
Dec 11 11:29:31 WARNING[4078] pbx.c: Context 'custom-meetme' tries includes nonexistent context 'ext-meetme'
Dec 11 11:29:31 WARNING[4078] pbx.c: Context 'from-internal-additional' tries includes nonexistent context 'from-internal-additional-custom'
Dec 11 11:29:31 VERBOSE[4078] logger.c:  [pbx_functions.so]Dec 11 11:29:31 VERBOSE[4078] logger.c:  [pbx_functions.so] => (Builtin dialplan functions)
Dec 11 11:29:31 VERBOSE[4078] logger.c:  [chan_skinny.so]Dec 11 11:29:31 VERBOSE[4078] logger.c:  [chan_skinny.so] => (Skinny Client Control Protocol (Skinny))
Dec 11 11:29:31 VERBOSE[4078] logger.c:  [chan_h323.so]Dec 11 11:29:31 VERBOSE[4078] logger.c:  [chan_h323.so] => (Objective Systems H323 Channel)
Dec 11 11:29:31 NOTICE[4078] src/chan_h323.c: Unable to load config ooh323.conf, OOH323 disabled
Dec 11 11:29:31 VERBOSE[4078] logger.c:  [chan_sip.so]Dec 11 11:29:31 VERBOSE[4078] logger.c:  [chan_sip.so] => (Session Initiation Protocol (SIP))
Dec 11 11:29:31 VERBOSE[4078] logger.c:  [skipping chan_oss.so]
Dec 11 11:29:31 VERBOSE[4078] logger.c:  [chan_mgcp.so]Dec 11 11:29:31 VERBOSE[4078] logger.c:  [chan_mgcp.so] => (Media Gateway Control Protocol (MGCP))
Dec 11 11:29:31 VERBOSE[4078] logger.c:  [chan_local.so]Dec 11 11:29:31 VERBOSE[4078] logger.c:  [chan_local.so] => (Local Proxy Channel)
Dec 11 11:29:31 VERBOSE[4078] logger.c:  [chan_features.so]Dec 11 11:29:31 VERBOSE[4078] logger.c:  [chan_features.so] => (Feature Proxy Channel)
Dec 11 11:29:31 VERBOSE[4078] logger.c:  [chan_agent.so]Dec 11 11:29:31 VERBOSE[4078] logger.c:  [chan_agent.so] => (Agent Proxy Channel)
Dec 11 11:29:31 VERBOSE[4078] logger.c:  [chan_phone.so]Dec 11 11:29:31 VERBOSE[4078] logger.c:  [chan_phone.so] => (Linux Telephony API Support)
Dec 11 11:29:31 VERBOSE[4078] logger.c:  [chan_iax2.so]Dec 11 11:29:31 VERBOSE[4078] logger.c:  [chan_iax2.so] => (Inter Asterisk eXchange (Ver 2))
Dec 11 11:29:31 VERBOSE[4078] logger.c:  [chan_zap.so]Dec 11 11:29:31 VERBOSE[4078] logger.c:  [chan_zap.so] => (Zapata Telephony w/PRI)
Dec 11 11:29:31 WARNING[4078] config.c: No '=' (equal sign) in line 5 of zapata.conf
Dec 11 11:29:31 ERROR[4078] chan_zap.c: Unknown signalling method 'bri_cpe_ptmp'
Dec 11 11:29:31 ERROR[4078] chan_zap.c: Signalling must be specified before any channels are.
Dec 11 11:29:31 WARNING[4078] loader.c: chan_zap.so: load_module failed, returning -1
Dec 11 11:29:31 WARNING[4078] loader.c: Loading module chan_zap.so failed!

Das bei der angepassten zapata.conf

Bei der Standard-zapata.conf kann ich Asterisk starten "Connected to Asterisk 1.2.13-BRIstuffed-0.3.0-PRE-1v currently running on asterisk1 (pid = 3106)"

[[email protected] ~]# cat /proc/zaptel/*

gibt aus:

Span 1: ZTDUMMY/1 "ZTDUMMY/1 1"

Meine Karte scheint nicht erkennt zu werden, richtig?
Was mache ich bloss falsch?

Gregor
 
Zuletzt bearbeitet:

maxkr

Neuer User
Mitglied seit
16 Nov 2006
Beiträge
58
Punkte für Reaktionen
0
Punkte
6
Hi gregcgn,

Voweg: Ich bin relativ neu auf dem Gebiet und dementsprechend dumm könnten sich meine Fragen anhören. Ich habe eine Junghanns OctoBri installiert und bin nach dieser Anleitung hier vorgegangen.

...ich auch ;)! Willkommen im Forum!

Ich habe leider keine OctoBri vermute aber mal, dass der Treiber entweder nicht passt von den einfachen HFC-Karten oder er irgendwie anders eingestellt werden muss. Den Florz-Patch brauchst du vermutlich auch nicht?!
Wie gesagt habe ich mich mit den Mehrport-Karten noch nicht auseinandergesetzt...

Viele Grüße,
Max
 

Pandos

Neuer User
Mitglied seit
18 Jan 2007
Beiträge
20
Punkte für Reaktionen
0
Punkte
0
Hallöchen,

auch ich plage mich jetzt schon seit 3 Tagen und Nächten mit Trixbox herum :(

Wenn ich nach der Anleitung gehe, dann sind beide HFC Karten aktiv, aber Asterisk ist tot :(

Fehler im Full-Log:
Unknown signalling method 'bri_cpe_ptmp'

Hilfe wäre sehr willkommen, damit ich auch mal weieder etwas Schlaf bekomme :rock:

Gruß

Sven
 

maxkr

Neuer User
Mitglied seit
16 Nov 2006
Beiträge
58
Punkte für Reaktionen
0
Punkte
6
Hallo Pandos,

hoffentlich konntest du dich in der Zwischenzeit erholen...

Scheint so als wäre beim compilieren was schief gegangen oder du hast nicht alles so durchgeführt wie beschrieben?! Liegt vermutlich an der (Version der chan_zap). Was sagt denn cat /proc/zaptel/*

Viele Grüße,
Max
 

Pandos

Neuer User
Mitglied seit
18 Jan 2007
Beiträge
20
Punkte für Reaktionen
0
Punkte
0
Hallöchen,

just in diesem Moment habe ich es geschafft :)

Bilanz: 4 Tage und Nächte Stress....

Lösung:
Bei der Version 2.0 einfach zweifach
trixbox-update.sh update ausführen und danach
install-ZAPHFC :rolleyes:

Danach ging alles von alleine :)

Vielleicht sollte man vorher lesen, dass die Anleitung fü die 2.0 Beta ist *ggg*

Nun kämpfe ich mich gerade durch die Diallisten, um Weiterleitungen, etc. zu konfigurieren.

Gruß

Sven
 

maxkr

Neuer User
Mitglied seit
16 Nov 2006
Beiträge
58
Punkte für Reaktionen
0
Punkte
6
Hallo Sven,

schön, wenn es jetzt funktioniert. Zum damaligen Zeitpunkt gab es nur die Beta. Schön wenn trixbox-update.sh alles richtig macht - das war leider damals nicht der Fall...

Viele Grüße,
Max
 

gdogg2003

Neuer User
Mitglied seit
23 Mrz 2006
Beiträge
48
Punkte für Reaktionen
0
Punkte
0
Hallo allerseits,
ich bin gerade mitten dabei Trixbox 2.0 mit der ISDN-Anbindung zu installieren und bin gerade bei dem Part mit dem Florz' Patch.

Irgendwie ist der Server nicht erreichbar, sodass ich die Datei nicht runterladen kann.

Hat vielleicht jemand von Euch folgende Datei:

zaphfc_0.3.0-PRE-1o_florz-12.diff.gz

Wäre echt super, wenn mir diese jemand zukommen lassen könnte, ansonsten kann ich jetzt erstmal nicht weiter machen...


Vielen Dank im Voraus

Gruß
gdogg2003


//EDIT

Habs schon gefunden
Falls Ihr die Datei auch sucht, findet Ihr diese unter:

http://www.shadow4.de/zaphfc_0.3.0-PRE-1o_florz-12.diff.gz
 
Zuletzt bearbeitet:

Pandos

Neuer User
Mitglied seit
18 Jan 2007
Beiträge
20
Punkte für Reaktionen
0
Punkte
0
Hallöchen,

gib mal folgendes in der Konsole ein:

install-ZAPHFC

Bei der Meldung: Overwrite file? y eingeben.

Dann sollte alles von selber gehen :)

Liebe Grüße

Sven
 

gdogg2003

Neuer User
Mitglied seit
23 Mrz 2006
Beiträge
48
Punkte für Reaktionen
0
Punkte
0
So, nachdem ich jetzt weiter machen konnte, wird meine HFC-Karte nun erkannt, bloß ist die irgendwie in dem Zustand "Unconfigured".

Außerdem lässt sich Asterisk nicht mehr starten.
Die Fehlermeldung dort:

Asterisk dies with code 1
 

Pandos

Neuer User
Mitglied seit
18 Jan 2007
Beiträge
20
Punkte für Reaktionen
0
Punkte
0
Dann schau mal in die Logdatei:
/var/log/asterisk/full

und schau mal , was es für eine Fehlermeldung gibt.
 

gdogg2003

Neuer User
Mitglied seit
23 Mrz 2006
Beiträge
48
Punkte für Reaktionen
0
Punkte
0
Dort wird diese Meldung angezeigt:

Code:
Unable to connect to remote asterisk (does /var/run/asterisk/asterisk.ctl exist?)
 

Pandos

Neuer User
Mitglied seit
18 Jan 2007
Beiträge
20
Punkte für Reaktionen
0
Punkte
0
Und ein wenig weiter oben?

Poste mal bitte die letzten 30 Zeilen...
 

gdogg2003

Neuer User
Mitglied seit
23 Mrz 2006
Beiträge
48
Punkte für Reaktionen
0
Punkte
0
ansonsten stehen da nur einträge über die hfc-karte, weil ich
Code:
install-ZAPHFC
ausgeführt hatte...
warscheinlich muss ich eh alles nochmal komplett neu machen
 

Pandos

Neuer User
Mitglied seit
18 Jan 2007
Beiträge
20
Punkte für Reaktionen
0
Punkte
0
Wäre denke ich das Beste...

Einfach wirklich nur folgendes machen:

1.Trixbox ISO installieren
2. install-ZAPHFC ausführen
3. Nach Abschluss der Installation fragt er Dich, welche Version Bristuff patchen soll.
Dort einfach 11 für "Quit! eingeben. Dann sollte alles laufen :)

Habe auch 4 Tage und Nächte gebraucht, bis ich das herausgefunden habe *ggg*

Niemals nicht trixbox-update.sh update ausführen!!!!!
Dies macht einen Downgrade von der 1.2.13 auf die 1.2.7 :(
 

gdogg2003

Neuer User
Mitglied seit
23 Mrz 2006
Beiträge
48
Punkte für Reaktionen
0
Punkte
0
wundert mich zwar, dass ich danach nur install-zaphfc ausführen muss, aber das wäre natürlich genial, wenn es so einfach geht :)

dann probiere ich mein glück mal

vielen dank erstmal für die hilfe :D
 

Pandos

Neuer User
Mitglied seit
18 Jan 2007
Beiträge
20
Punkte für Reaktionen
0
Punkte
0
Was meinst Du, wie ich mir in den Hintern gebissen habe, als ich das heruasgefunden habe...

Ich habe die ganze Zeit nach der Anleitung der Beta gearbeitet und bin immer irgendwo gescheitert :(

Aber so klappt das wunderbar und in 30 Minuten ist deine PBX fertig :)
 

gdogg2003

Neuer User
Mitglied seit
23 Mrz 2006
Beiträge
48
Punkte für Reaktionen
0
Punkte
0
mir fällt gerade der neue kernel ein...
muss ich den vor dem ausführen von install-zaphfc nicht updaten
wirklich nur diesen einen befehl ausführen?
und wie sieht es z.b. mit der zapata.conf mit der einrichtung der hfc-karte aus?
 

Pandos

Neuer User
Mitglied seit
18 Jan 2007
Beiträge
20
Punkte für Reaktionen
0
Punkte
0
Nein, DU musst nichts weiter machen.
Evtl. noch language nach nl setzen, aber das war es dann auch
 

Erhalten Sie 3CX für 1 Jahr kostenlos!

Gehostet, in Ihrer privaten Cloud oder on-Premise! Ganz ohne Haken. Geben Sie Ihren Namen und Ihre E-Mail an und los geht´s:

3CX
Für diese E-Mail-Adresse besteht bereits ein 3CX-Konto. Sie werden zum Kundenportal weitergeleitet, wo Sie sich anmelden oder Ihr Passwort zurücksetzen können, falls Sie dieses vergessen haben.
oder via