Buildumgebung: freetz-linux

schumi20091

Neuer User
Mitglied seit
19 Mai 2009
Beiträge
185
Punkte für Reaktionen
4
Punkte
18
Hallo Gismotro,
ich habe die Freetz-VM von Ubuntu 12.04 auf 14.04 upgedatet.
Hallo,
habe mir deine Version heruntergeladen.
Läuft auch, aber wenn ich in die Konsole "sudo passwd root" eingebe und dann ein Root Passwort eingebe, wird dieses nicht geändert.
Wie kann ich das Problem lösen?
 

koyaanisqatsi

IPPF-Urgestein
Mitglied seit
24 Jan 2013
Beiträge
12,510
Punkte für Reaktionen
323
Punkte
83
Moins

Zum Beispiel so...
Als freetz: sudo su -l root
Als root: passwd -a md5 root
 

schumi20091

Neuer User
Mitglied seit
19 Mai 2009
Beiträge
185
Punkte für Reaktionen
4
Punkte
18
Das Problem ist, ich möchte gerne wieder eine Verbindung mit WinSCP haben und da wird das Passwort nicht akzeptiert...

Auch wenn ich mich mit putty einloggen möchte als root wird das Passwort nicht angenommen...
 
Zuletzt bearbeitet:

PeterPawn

IPPF-Urgestein
Mitglied seit
10 Mai 2006
Beiträge
13,096
Punkte für Reaktionen
998
Punkte
113
Radio Jerewan/Eriwan antwortet da eigentlich: Im Prinzip ja, aber ... es ist eben eine Frage der Einstellung(en).
 

Riverhopper

Mitglied
Mitglied seit
29 Sep 2015
Beiträge
228
Punkte für Reaktionen
1
Punkte
18
Hallo schumi20091,
ich habe bei mir folgende Änderungen durchgeführt:

Code:
[email protected]:~$ sudo su -

[email protected]:~# grep root /etc/shadow
root:!:14470:0:99999:7:::

[email protected]:~# passwd root
Geben Sie ein neues UNIX-Passwort ein:
Geben Sie das neue UNIX-Passwort erneut ein:
passwd: password updated successfully

[email protected]:~# grep root /etc/shadow
root:$6$4DxvxjWASNIPSNIPSNIPSNIPSNIPSNIPSNIPSNIPSNIPSNIPSNIPSNIPSNIPSNIPSNIPSNIPSNIPSNIPSNIPSNIPAvdoiV0:16885:0:99999:7:::
[email protected]:~#


[email protected]:/etc/ssh# vi sshd_config
SNIP
#PermitRootLogin without-password
[COLOR=#0000ff]PermitRootLogin yes[/COLOR]
[email protected]:/etc/ssh# grep -i UsePAM sshd_config
[COLOR=#0000ff]UsePAM yes[/COLOR]
[email protected]:/etc/ssh# /etc/init.d/ssh stop
[email protected]:/etc/ssh# /etc/init.d/ssh start
oder 
reboot
Anschließend funktionierte Remote-SSH-Login.

Bitte testen, bei Problemen müssen wir ggf. einen Blick in PAM-Config werfen.

LG Riverhopper
 
Zuletzt bearbeitet:

Riverhopper

Mitglied
Mitglied seit
29 Sep 2015
Beiträge
228
Punkte für Reaktionen
1
Punkte
18
Zum Beispiel so...
Als freetz: sudo su -l root
Als root: passwd -a md5 root
Hallo koyaanisqatsi,
habe gerade nachgesehen, die Freetz-Linux-1.4.1 verwendet Encryption-Schema SHA512 und nicht MD5

Code:
[email protected]:~# grep -i sha /etc/pam.d/common-password
# The "sha512" option enables salted SHA512 passwords.  Without this option,
password        [success=1 default=ignore]      pam_unix.so obscure [COLOR=#0000ff]sha512[/COLOR]
[email protected]:~#

[email protected]:~# grep -i sha /etc/login.defs
#       which is, starting from shadow 4.0.12-1 in Debian, entirely the
# If set to SHA512, SHA512-based algorithm will be used for encrypting password
ENCRYPT_METHOD [COLOR=#0000ff]SHA512[/COLOR]
[email protected]:~#
d.h. als root ist der Befehl "passwd" zum setzen eines Passwords ausreichend.

LG Riverhopper
 

schumi20091

Neuer User
Mitglied seit
19 Mai 2009
Beiträge
185
Punkte für Reaktionen
4
Punkte
18
Hallo schumi20091,
ich habe bei mir folgende Änderungen durchgeführt:

Code:
[email protected]:~$ sudo su -

[email protected]:~# grep root /etc/shadow
root:!:14470:0:99999:7:::

[email protected]:~# passwd root
Geben Sie ein neues UNIX-Passwort ein:
Geben Sie das neue UNIX-Passwort erneut ein:
passwd: password updated successfully

[email protected]:~# grep root /etc/shadow
root:$6$4DxvxjWASNIPSNIPSNIPSNIPSNIPSNIPSNIPSNIPSNIPSNIPSNIPSNIPSNIPSNIPSNIPSNIPSNIPSNIPSNIPSNIPAvdoiV0:16885:0:99999:7:::
[email protected]:~#


[email protected]:/etc/ssh# vi sshd_config
SNIP
#PermitRootLogin without-password
[COLOR=#0000ff]PermitRootLogin yes[/COLOR]
[email protected]:/etc/ssh# grep -i UsePAM sshd_config
[COLOR=#0000ff]UsePAM yes[/COLOR]
[email protected]:/etc/ssh# /etc/init.d/ssh stop
[email protected]:/etc/ssh# /etc/init.d/ssh start
oder 
reboot
Anschließend funktionierte Remote-SSH-Login.

Bitte testen, bei Problemen müssen wir ggf. einen Blick in PAM-Config werfen.

LG Riverhopper
Danke für deine Antwort, aber ich komme bei diesem Schritt nicht weiter:
/etc/ssh# vi sshd_config

Dann kommt diese Meldung:
-su: /etc/ssh#: Datei oder Verzeichnis nicht gefunden

Woran liegt es?
 

thtomate12

IPPF-Promi
Mitglied seit
28 Okt 2010
Beiträge
5,165
Punkte für Reaktionen
6
Punkte
38
Das "/etc/ssh#" wurde nicht eingegeben, es ist die Ausgabe, die bei riverhopper bereits in der Konsole stand. Man gibt immer nur den Teil nach '#' oder '$' ein.
 

Riverhopper

Mitglied
Mitglied seit
29 Sep 2015
Beiträge
228
Punkte für Reaktionen
1
Punkte
18
Hallo schumi20091,
anbei die Befehlsequenzen zum Ändern von /etc/ssh/sshd_config:

Code:
Ausgangsstand:
[email protected]:~# grep PermitRootLogin /etc/ssh/sshd_config
PermitRootLogin without-password
[email protected]:~#

Änderungen per Editor durchführen:
[email protected]:~# vi /etc/ssh/sshd_config
SNIP
#PermitRootLogin without-password
PermitRootLogin yes
[email protected]:~#

Dateiinhalt nach Änderung:
[email protected]:~# grep PermitRootLogin /etc/ssh/sshd_config
#PermitRootLogin without-password
PermitRootLogin yes
[email protected]:~#
weitere Vorgehenswiese siehe #667

LG Riverhopper
 

schumi20091

Neuer User
Mitglied seit
19 Mai 2009
Beiträge
185
Punkte für Reaktionen
4
Punkte
18
Also ich bin jetzt etwas weiter, aber nachdem Befehl "vi /etc/ssh/sshd_config" kommt diese Ausgabe:
Code:
#PasswordAuthentication yes

# Kerberos options
#KerberosAuthentication no
#KerberosGetAFSToken no
#KerberosOrLocalPasswd yes
#KerberosTicketCleanup yes

# GSSAPI options
#GSSAPIAuthentication no
#GSSAPICleanupCredentials yes

X11Forwarding yes
X11DisplayOffset 10
PrintMotd no
PrintLastLog yes
TCPKeepAlive yes
#UseLogin no

#MaxStartups 10:30:60
#Banner /etc/issue.net

# Allow client to pass locale environment variables
Aber eigentlich sollte ja diese kommen:
Code:
SNIP[/FONT][FONT=arial]
#PermitRootLogin without-password
[COLOR=#0000ff]PermitRootLogin yes[/COLOR]
[email protected]:/etc/ssh# grep -i UsePAM sshd_config
[COLOR=#0000ff]UsePAM yes[/COLOR]
[email protected]:/etc/ssh# /etc/init.d/ssh stop
[email protected]:/etc/ssh# /etc/init.d/ssh start
oder 
reboot[/FONT]


Sprich ich finde jetzt nicht, wo ich die Änderung durchführen muss, da die Ausgabe ganz anders ist wie bei dir...
 

thtomate12

IPPF-Promi
Mitglied seit
28 Okt 2010
Beiträge
5,165
Punkte für Reaktionen
6
Punkte
38
Du bist nun in einem Editor in dem die genannten Zeilen geändert werden sollen. Falls dir vi Probleme macht, kannst du nano benutzen, navigiert wird mit den Pfeiltasten, verlassen mit Strg+X.
 

schumi20091

Neuer User
Mitglied seit
19 Mai 2009
Beiträge
185
Punkte für Reaktionen
4
Punkte
18
Jetzt hat es auch bei mir geklappt!!

Hier mal meine angepasste Anleitung:
Code:
sudo su -
(Passwort eingabe)
grep root /etc/shadow
passwd root
(Neues Root Passwort 2x Eingeben)
grep root /etc/shadow
grep PermitRootLogin /etc/ssh/sshd_config
nano /etc/ssh/sshd_config
Diese Zeile ändern:
# Authentication:
LoginGraceTime 120
[COLOR=#ff0000]#PermitRootLogin without-password
PermitRootLogin yes[/COLOR]
StrictModes yes
STRG+X und mit J und Enter bestätigen.

Nach der Änderung:
grep PermitRootLogin /etc/ssh/sshd_config
Und die Ausgabe sollte dann so aussehen:
#PermitRootLogin without-password
PermitRootLogin yes
 

andiling

IPPF-Promi
Mitglied seit
19 Jun 2013
Beiträge
5,975
Punkte für Reaktionen
1
Punkte
0
Ein
Code:
sudo nano /etc/ssh/sshd_config
reicht absolut aus um diese eine Einstellung zu ändern.

Besser: Zertifikat verwenden.
 

alecxs

Neuer User
Mitglied seit
22 Apr 2015
Beiträge
199
Punkte für Reaktionen
0
Punkte
16
Ich vote an dieser Stelle noch einmal für die Bereitstellung als ISO-Image Alternative, welche ich nach wie vor präferiere! Sollte es eventuell sogar möglich sein, die Freetz-Linux-1.4.1.ova bootfähig auf CD / Stick zu brennen?
 

andiling

IPPF-Promi
Mitglied seit
19 Jun 2013
Beiträge
5,975
Punkte für Reaktionen
1
Punkte
0
Falls Du an eine Live-CD o.Ä. denkst würde ich sagen, dass eine Buildumgebung denkbar schlecht dafür geeignet ist, da Du vergleichsweise viel Speicherplatz brauchst und somit immer eine zusätzliche (Linux-)Partition eingebunden werden muss (auch weil man nicht jedes Mal von vorne bauen will). Dann richte Dir eher ein Dualboot System ein und installiere Linux Deiner Wahl (z.B. Ubuntu 14.04 LTS). Die Abhängigkeiten (zu installierenden Pakete) stehen m.E. irgendwo auf der freetz Seite.
 

alecxs

Neuer User
Mitglied seit
22 Apr 2015
Beiträge
199
Punkte für Reaktionen
0
Punkte
16
Okay hast Recht auf CD macht es wenig Sinn, auf einem USB-Stick jedoch hat man dann eine portable Lösung. Ich biete ja selbst hier ein ISO-Image zum Download an. Man erstellt eine 2. Partition mit disk name "casper-rw" und ergänzt die syslinux.cfg mit "persistent".
Code:
append initrd=/casper/initrd.lz boot=casper persistent
Dann hat man ein Live-System mit genug Speicherplatz und muss auch nicht jedesmal von vorne bauen.

Bezüglich Konvertierung von OVA zu ISO hab ich leider nix brauchbares gefunden..
 

andiling

IPPF-Promi
Mitglied seit
19 Jun 2013
Beiträge
5,975
Punkte für Reaktionen
1
Punkte
0
Mit einer "Konvertierung" wird man da nicht viel weiter kommen... CDs/DVDs nutzen einen angepassten Bootloader (isolinux), ein ganz anderes Dateisystem (iso9660), kennen keine "Partitionen" (diese wären eben in Imagedateien zu packen), haben eine Autokonfiguration (casper) und sind eben ro (u.U. Nutzung von einem overlayfs im RAM). In Ubuntu kann man ja mit debootstrap ein System in einem Verzeichnis anlegen, dann geht man mit chroot rein, macht seine Anpassungen und packt das ganze in eine Datei und auf CD neben dem Bootloader/kernel. Alternativ kannst Du natürlich die ova als Basis für das neue root System nutzen und anpassen, ob das aber wirklich Zeit spart?
 
3CX

Statistik des Forums

Themen
235,567
Beiträge
2,062,640
Mitglieder
356,313
Neuestes Mitglied
Gerald52