[Problem] FreePBX: Hauptleitung einrichten und registrieren am Telekom Sip Trunk Pure

Panchon

Neuer User
Mitglied seit
1 Jul 2013
Beiträge
31
Punkte für Reaktionen
0
Punkte
6
Hallo allerseits,

ich versuche gerade, in einer FreePBX-Installation eine Hauptleitung für einen Sip Trunk Pure (Telekom) einzurichten, doch das klappt leider nicht und daher suche ich Hilfe.

Folgendes ist der Stand der Dinge:
- Zum Ausprobieren hab ich für meinem Raspberry 4b eine zweite SD-Karte mit aktuellem Raspbian und einer normalen Asterisk-Installation (apt-get intall Asterisk) vorbereitet. Über das veraltete SIP (sip.conf) habe ich den für diese Einrichtung richtigen Registrierungsstring zurechtgebastelt, d.h. ohne RasPBX und SIP bzw. mit reinem Asterisk und SIP kann ich die Registrierung am Telekom-Server erfolgreich durchführen. Weitere Einrichtugen (ausgehende/eingehende Anrufe) habe ich noch nicht durchgeführt.

- Beim Betrieb der zweiten und eigentlich gewollten SD-Karte mit aktuellem RasPBX (Asterisk 16.6.1 & FreePBX 15.0.16.22) und unter Verwendung von PJSIP komme ich immerhin soweit, daß auf der Asterisk-Konsole nach Eingabe von "pjsip show registration" folgendes ausgegeben wird:

55xxxxxxxxxx/sip:sip-trunk.telekom.de 55xxxxxxxxxx Rejected

Daraus schließe ich, daß ich den Telekomserver erreiche, aber fehlerhafte Anmeldedaten hinschicke.

- Nach Eingabe von "pjsip show endpoints" erhalte ich bezüglich der Telekom-Registrierung folgende Ausgabe

Endpoint: 55xxxxxxxxxx Not in use 0 of inf
OutAuth: 55xxxxxxxxxx/55xxxxxxxxxx
Aor: 55xxxxxxxxxx 0
Contact: 55xxxxxxxxxx/sip:[email protected] 51d07bb383 Avail 93.356
Transport: 0.0.0.0-tcp tcp 3 96 0.0.0.0:5060
Identify: 55xxxxxxxxxx/55xxxxxxxxxx
Match: 217.0.0.0/13

- Wenn ich die CLI eine Weile beobachte, erhalte ich abwechselnd folgende Ausgaben:

== Endpoint 55xxxxxxxxxx is now Unreachable
-- Contact 55xxxxxxxxxx/sip:[email protected]:5060 is now Unreachable. RTT: 0.000 msec
== Endpoint 55xxxxxxxxxx is now Reachable
-- Contact 55xxxxxxxxxx/sip:[email protected]:5060 is now Reachable. RTT: 62.740 msec

Hat jemand eine Idee, wo mein Fehler bei der Anmeldung stecken könnte?

Vielen Dank vorab
Franz






 

sonyKatze

Mitglied
Mitglied seit
6 Aug 2009
Beiträge
608
Punkte für Reaktionen
41
Punkte
28
über […] sip.conf) habe ich den für diese Einrichtung richtigen Registrierungsstring zurechtgebastelt
Niemand zwingt Dich (hoffentlich) PJSIP zu nutzen. Aber um eine sip.conf in eine pjsip.conf umzuwandeln, bietet das Asterisk-Team eine Anleitung inklusive Python-Skript. Wenn das nicht (richtig) klappt, würde ich an Deiner Stelle wenigstens das als Startpunkt nehmen und debuggen. Dann kannst Du die Änderungen an Asterisk zurückgeben.
 

Panchon

Neuer User
Mitglied seit
1 Jul 2013
Beiträge
31
Punkte für Reaktionen
0
Punkte
6
Danke. Konvertiert hab ich's gerade. Auf die Schnelle klappt die Registrierung nicht, wenn ich nur die erzeugte pjsip.conf verwende, aber sie könnte ein guter Anhaltspunkt zum Weitermachen sein. Da hast du recht. Ich probier's und melde micht, wie's weiter geht.

Franz
 

3CX PBX - GRATIS
Linux / Win / Cloud

Statistik des Forums

Themen
233,709
Beiträge
2,037,396
Mitglieder
352,586
Neuestes Mitglied
Hightower199