wifi0 and wifi1 not created on FRITZ.Box_7490.en-de-es-it-fr-pl.113.07.12

frater

Mitglied
Mitglied seit
23 Nov 2008
Beiträge
443
Punkte für Reaktionen
3
Punkte
18
I upgraded and tested several 7490's and 7590's with the latest firmwares.
A few 7590's were running fine for several months, so I decided this week to make all 7490's and 7590's the same firmware.
After having flashed 5x 7590's and 42 7490's I started to get complaints regarding the WiFi.

It turns out I deployed an upgrade from hell...

Although the 7590's are running fine, the 7490's get no working WiFi.
Clients are able to connect, but they get no IP addresses.

I checked the interfaces and noticed that the interfaces "wifi0" and "wifi1" are not created.
1 of the 7490's I flashed with the original AVM firmware (same version out of my ~/dl/fw folder) and that one started working....
It would be a big problem if I would lose Freetz on those boxes...

Because many are using WAPs I got this feedback very late.

What are the commands to create the interfaces wifi0 and wifi1 ???

In the distant past I had similar problems with WiFi which turned out to be some wrong assumptions on Freetz part that worked fine for the German box, but not for the International box.
 

NDiIPP

Aktives Mitglied
Mitglied seit
13 Apr 2017
Beiträge
2,500
Punkte für Reaktionen
416
Punkte
83
This problem with Freetz at the VR9 models (e.g. 7490, 3490, 7430, ...) is known for a long time:
https://github.com/Freetz/freetz/issues/87

And the solution workaround is right there (the second post):
https://github.com/Freetz/freetz/issues/87#issuecomment-466666822

Or here in the forum the following topics:
...

---

Edit:
In the distant past I had similar problems with WiFi which turned out to be some wrong assumptions on Freetz part that worked fine for the German box, but not for the International box.
The german Firmware-Versions of the VR9 models (since FRITZ! OS 7) are also affected. The (triggering) difference is probably dnsmasq and not the international/german Firmware-Version.
 
Zuletzt bearbeitet:

frater

Mitglied
Mitglied seit
23 Nov 2008
Beiträge
443
Punkte für Reaktionen
3
Punkte
18
You are a life saver!!!
Thanks for the quick reaction. I took action immediately after I read your post an hour ago...

I had to run that command on all 42 boxes, so I'm a bit late in thanking you.

BTW... In 7590 it's wifi0 and wifi1. I used that as a reference, but it is indeed wlan on a 7490
 
Zuletzt bearbeitet:

3CX PBX - GRATIS
Linux / Win / Cloud

Statistik des Forums

Themen
234,033
Beiträge
2,041,865
Mitglieder
353,347
Neuestes Mitglied
menten-gmbh