.titleBar { margin-bottom: 5px!important; }

[HowTo] FBFW Annex A AVME FW 8.04.49 Downgrade to 8.04.34 AVM or other lower AVME

Dieses Thema im Forum "FRITZ!Box tot? Recover, Firmware Up-/ Downgrade" wurde erstellt von adrians, 14 Okt. 2011.

  1. adrians

    adrians Neuer User

    Registriert seit:
    15 Jan. 2008
    Beiträge:
    20
    Zustimmungen:
    0
    Punkte für Erfolge:
    0
    Hi!

    I would appreciate some help on this matter. The issue I have is that I have to use the Fritz with a cable modem and when I set the configuration on Internet access via LAN with PPPoE on reboot I cannot connect wireless or USB or whatsoever...

    I tried to load fritz_as_avm_newer.tar and on reboot tried to recover the 8.04.34... doesnt work because it says incompatible hardware.

    I entered with ftp adam2 (telent doesnt work) and also change annex A into annex B with SETENV, same result using recovery 8.0.34.

    I changed kernel SETENV into annex=B... same result. After 4 hours playing with it, dont know what to do anymore. Please help me!
     
  2. imagomundi

    imagomundi IPPF-Promi

    Registriert seit:
    27 Okt. 2006
    Beiträge:
    3,684
    Zustimmungen:
    2
    Punkte für Erfolge:
    38
    Ort:
    Santiago de Chile
    #2 imagomundi, 14 Okt. 2011
    Zuletzt bearbeitet: 14 Okt. 2011
    1. Welcome, adrians

    2. In brief: you must change "firmware_version" from "avme" to "avm" and run (do not allow the box to reboot before BOTH steps are done!!) German RECOVER 08.04.34. [POST=1323573]Here[/POST] you find (unfortunately in German only) how this can be done using ftp.
    The alternative method is to use "ruKernelTool" from "skyteddy". Search for it in this forum. Many users say this is the easier way for beginners and I would agree on this even if personally I do always use ftp.
     
  3. informerex

    informerex IPPF-Urgestein

    Registriert seit:
    20 Apr. 2005
    Beiträge:
    16,998
    Zustimmungen:
    32
    Punkte für Erfolge:
    48
  4. adrians

    adrians Neuer User

    Registriert seit:
    15 Jan. 2008
    Beiträge:
    20
    Zustimmungen:
    0
    Punkte für Erfolge:
    0
    Thanks for your help! As it didnt work over ftp adam2, I tried the ruKernelTool. It doesnt work either. I can put the "old" Annex A AVME firmware back but not the AVM 04.34. I will copy the log here
     
  5. adrians

    adrians Neuer User

    Registriert seit:
    15 Jan. 2008
    Beiträge:
    20
    Zustimmungen:
    0
    Punkte für Erfolge:
    0
    Bootvorgang anhalten:

    Adam2-IP-Adresse setzen... erfolgreich
    Warten auf die Box... Box anpingen... Host ist da.
    FTP-Verbindung zum Stoppen aufbauen... überprüfen... verbunden

    Box-Informationen:
    ProductID: Fritz_Box_WLAN_AnnexA
    HWRevision: 66
    annex: A
    autoload: yes
    bootloaderVersion: 1.309
    bootserport: tty0
    cpufrequency: 150000000
    firmware_info: 08.04.49
    firmware_version: avme
    firstfreeaddress: 0x946C0D14
    flashsize: 0x00400000
    kernel_args: annex=A
    maca: 00:04:0E:9F:A1:FC
    macb: 00:04:0E:9F:A1:FD
    macdsl: 00:04:0E:9F:A1:FF
    macwlan: 00:04:0E:9F:A1:FE
    memsize: 0x02000000
    modetty0: 38400,n,8,1,hw
    modetty1: 38400,n,8,1,hw
    mtd0: 0x90000000,0x90000000
    mtd1: 0x90010000,0x903C0000
    mtd2: 0x90000000,0x90010000
    mtd3: 0x903C0000,0x903E0000
    mtd4: 0x903E0000,0x90400000
    my_ipaddress: 192.168.178.1
    req_fullrate_freq: 125000000
    SerialNumber: 0000000000000000
    sysfrequency: 125000000
    urlader-version: 1309
    usb_board_mac: 00:04:0E:9F:A2:00
    usb_device_id: 0x4201
    usb_manufacturer_name: AVM
    usb_revision_id: 0x0100
    usb_rndis_mac: 00:04:0E:9F:A2:01
    wlan_key: 3283975625696

    Flash-/Speichergrößen:
    Flashsize: 4.194.304 Bytes (4.096 kb, 4 MB)
    Memsize: 33.554.432 Bytes (32.768 kb, 32 MB)
    mtd0: 0 Bytes
    mtd1: 3.866.624 Bytes (3.776 kb, 3,7 MB)
    mtd2: 65.536 Bytes (64 kb, 0,1 MB)
    mtd3: 131.072 Bytes (128 kb, 0,1 MB)
    mtd4: 131.072 Bytes (128 kb, 0,1 MB)

    ProductID: Fritz_Box_WLAN_AnnexA
    HW-Revision: 66 => FRITZ!Box Fon WLAN (Annex A)


    6) Firmware-Transfer, clear mtd3+4, Einstellungen vornehmen:


    A c h t u n g:

    Bitte etwas Geduld! Die Datenübertragung dauert!
    Nicht ausstecken und auch nicht unterbrechen!


    Keinen Eintrag in der Speed-Datenbank gefunden! Angenommene Default-Werte:
    Übertragungsrate: 30.000 Bytes/sec
    Kernel-Übertragung: 126 Sekunden
    Clear MTD3: 30 Sekunden
    Clear MTD4: 30 Sekunden
    Settings+Neustart: 3 Sekunden
    Gesamtzeit: 189 Sekunden

    Kernel- und mtd1-Größenüberprüfung:
    kernel.image-Größe: 3.768.072 Bytes (3.679,8 kb, 3,6 MB)
    mtd1-Größe: 3.866.624 Bytes (3.776 kb, 3,7 MB)
    freier Platz danach in mtd1: 98.552 Bytes (96,2 kb, 0,1 MB)

    kernel_aus_fritz.box_fon_wlan.08.04.34.image übertragen... überprüfen... erfolgreich!
    Gebrauchte Zeit: 78 Sekunden
    Bytes pro Sekunde: 48.286,9

    mtd3 löschen... überprüfen... erfolgreich!
    Gebrauchte Zeit: 18.2 Sekunden

    mtd4 löschen... überprüfen... erfolgreich!
    Gebrauchte Zeit: 18.5 Sekunden

    Einstellungen übertragen und Box rebooten... überprüfen... erfolgreich!



    ********** F e r t i g **********
     
  6. adrians

    adrians Neuer User

    Registriert seit:
    15 Jan. 2008
    Beiträge:
    20
    Zustimmungen:
    0
    Punkte für Erfolge:
    0
    This was the image I tried to put:
    3) Überprüfung:

    Ist ein Neustart notwendig? - Nein => [ok]

    Ist MediaSensing abgeschaltet? - Ja => [ok]

    Ist das kernel.image vorhanden? - Ja => [ok]

    Firmware: fritz.box_fon_wlan.08.04.34.image
    Kernel: kernel_aus_fritz.box_fon_wlan.08.04.34.image
    Kernelgröße: 3.768.072 Bytes (3.679,8 kb, 3,6 MB)
    md5-Hash vom Kernel: 0xdd0acf0d4a446ced89997f9bb6b804f8
    sha1-Hash vom Kernel: 0xae8339606f7887a4a0a2ea04db37dca0c823932a
    Firmware-Version: 08.04.34
    Branding: avm
    Annex: B
    Clear MTD 3+4: Ja
    Neue Adam2-IP-Adresse: 192.168.178.1
    WLAN-Key:
    Soll jetzt gestartet werden? - Ja
     
  7. adrians

    adrians Neuer User

    Registriert seit:
    15 Jan. 2008
    Beiträge:
    20
    Zustimmungen:
    0
    Punkte für Erfolge:
    0
    Where is the problem? The box gets stuck in booting or loading kernel somewhere. I can always put the 04.49 AVME image and it works. Should I try to change with adam2 the HW-Revision? Is 66 for Annex A and 64 for Annex B?
     
  8. imagomundi

    imagomundi IPPF-Promi

    Registriert seit:
    27 Okt. 2006
    Beiträge:
    3,684
    Zustimmungen:
    2
    Punkte für Erfolge:
    38
    Ort:
    Santiago de Chile
    #8 imagomundi, 14 Okt. 2011
    Zuletzt bearbeitet: 14 Okt. 2011
    Have a look [THREAD=169769]here[/THREAD]: Annex A = 66 -- Annex B = 61

    Fear you might have to do things "manually" using ftp as suggested in #2.

    ftp commands

    quote SETENV HWRevision 61
    quote SETENV firmware_version avm
    quote SETENV firmware_info 08.04.34
    quote SETENV annex B
    quote SETENV kernel_args A

    close ftp "bye" now run IMMEDIATELY (do not allow the box to reboot, do not plug off even if you are asked to do so) German recover 04.34
     
  9. skyteddy

    skyteddy IPPF-Promi

    Registriert seit:
    26 Mai 2005
    Beiträge:
    5,830
    Zustimmungen:
    5
    Punkte für Erfolge:
    38
    Ort:
    Bayern
    What should this do? You want to set the Annex? And if yes, why A and not B as the line before?

    happy computing
    R@iner
     
  10. adrians

    adrians Neuer User

    Registriert seit:
    15 Jan. 2008
    Beiträge:
    20
    Zustimmungen:
    0
    Punkte für Erfolge:
    0
    Interesting... I did put all the settings and yes, I was able to flash the 8.04.34! However, now the problem is that fritz doesnt boot! I ftp again and check the settings. Believe it or not they are reverted back :

    230 User adam2 successfully logged in
    ftp> quote GETENV HWRevision
    HWRevision 66

    200 GETENV command successful
    ftp> quote GETENV firmware_version
    firmware_version avm

    200 GETENV command successful
    ftp> quote GETENV firmware_info
    firmware_info 10.04.34

    200 GETENV command successful
    ftp> quote GETENV annex
    annex A

    200 GETENV command successful
    ftp> quote GETENV kernel_args
    kernel_args A

    200 GETENV command successful

    Do not understand... How I should resolve this? Made some progress, I can flash now, but settings are reverted and the image can not start.
     
  11. adrians

    adrians Neuer User

    Registriert seit:
    15 Jan. 2008
    Beiträge:
    20
    Zustimmungen:
    0
    Punkte für Erfolge:
    0
    R@iner, thanks for your software - its very good... can flash with it, but it seems I have some other problems here.
     
  12. imagomundi

    imagomundi IPPF-Promi

    Registriert seit:
    27 Okt. 2006
    Beiträge:
    3,684
    Zustimmungen:
    2
    Punkte für Erfolge:
    38
    Ort:
    Santiago de Chile
    #12 imagomundi, 15 Okt. 2011
    Zuletzt bearbeitet: 15 Okt. 2011
    This is normal - HWR and Annex changes through ftp are only temporary until next reboot - this is the reason why you must NOT reboot or power off between ftp settings and recover.

    No - you made the big step to 08.04.34 (you wrote 10.04.34 - think it's your writing mistake only) and avm. To look for a final solution: your red is annex A or annex B? If it is B you should first change parameter "kernel_args" to B. If after that box still does not connect have to look into other parameters.

    EDIT: Basic problem is that the latest english fw before 04.49 was 04.26 (which is available also as recover). AVM changed to newer Linux kernel at fw 04.30 (concerning ALL boxes) with a different layout of the flash memory. To go back to 04.26 would require a downgrade to the older kernel and flash memory layout which is difficult and risky but possible and described in this forum.

    04.49 unfortunately got the bug from which you are suffering now: no internet over lan possible.

    Therefore after upgrading an fbf and an fbfw to 04.49 I did with both boxes just what I recommended to you: go back to 04.34 avm substituting additionally the "native" B driver of that fw by the A driver extracted from English A-fw 04.26.

    Only but SIGNIFICANT difference between your box and mine: my boxes were/are genuine B boxes - yours is -as I understand- "born" as A box.
     
  13. adrians

    adrians Neuer User

    Registriert seit:
    15 Jan. 2008
    Beiträge:
    20
    Zustimmungen:
    0
    Punkte für Erfolge:
    0
    Hmmm... Many thanks again for your support.

    Well, I do not reboot, but after the recovery process, which goes fine, the modem reboots and the old settings are back. And I'm not mistaken it is not 08.04.34 it changes to 10.04.34 ?! It is Annex A austrian modem.
     
  14. adrians

    adrians Neuer User

    Registriert seit:
    15 Jan. 2008
    Beiträge:
    20
    Zustimmungen:
    0
    Punkte für Erfolge:
    0
    Another interesting thing: just out of curiosity I have made again adam2 changes as you advised (100 times already) and recovered with the german version of 08.04.49. Believe or not, the fritz box booted! And I was able to go on the webinterface. Now, I rebooted and check the settings with adam2: settings were all reverted Annex A, HW 66 etc but it works and it is in german... strane isnt it?
     
  15. imagomundi

    imagomundi IPPF-Promi

    Registriert seit:
    27 Okt. 2006
    Beiträge:
    3,684
    Zustimmungen:
    2
    Punkte für Erfolge:
    38
    Ort:
    Santiago de Chile
    #15 imagomundi, 15 Okt. 2011
    Zuletzt bearbeitet: 15 Okt. 2011
    There are really some strange aspects: fw 10..? what box is that for? And how can the box get such an fw starting with 10 if you only recover with 08? ALL fw on avm server for fbfw start with 08 - no exception - I checked them all (deutsch --- deutsch-a-ch ---english -- "normal" fw and "recover").

    If you say "it works" - what does that mean? works fine for you - or only "works" but NOT on "internet over lan"?

    EDIT: FW 10..... is FRITZBOX SL Strange in this case that box "says" it is HWRevision 66 - which is FBFWLan.

    In the ancient times of fritzboxes - with fw lower than 04.15- many changes of many parameters were possible. I feel that your box has received a lot of modding since it was produced!
     
  16. adrians

    adrians Neuer User

    Registriert seit:
    15 Jan. 2008
    Beiträge:
    20
    Zustimmungen:
    0
    Punkte für Erfolge:
    0
    Okay... lets recap here:
    Box runs 8.04.49 english (FRITZ.Box_Fon_WLAN.AnnexA.en.08.04.49.image) and it is a FB Fon WLAN

    I have also 2 additional images, (1)fritz.box_fon_wlan.08.04.34.image and(2) FRITZ.Box_Fon_WLAN.AnnexA.en.08.04.49.image and a tool fritz.box_fon_wlan.04.34.recover-image.exe

    1. I use adam2 new settings, bye ftp and directly launch fritz.box_fon_wlan.04.34.recover-image.exe. The tool works, meaning I can flash the box w/o errors. In the end, box restarts automatically, but it doesnt load (goes in the cycle reboot)
    I connect to the box again with adam2 and checking the settings I see they are changed to the old/initial values. In addition this firmware variable displays 10.04.34

    2. Make again changes to the settings via adam2 and this time I use ruKernelTool to push FRITZ.Box_Fon_WLAN.AnnexA.en.08.04.49.image (kernel) into the box. Well this time, after flash completes, the box reboots and it load the image - i can access the box via webinterface.

    My point here is that I can flash and the box runs both versions of 8.04.49, german and english. It doesnt help me of course, because I need the Internet over LAN with PPPoE.
     
  17. adrians

    adrians Neuer User

    Registriert seit:
    15 Jan. 2008
    Beiträge:
    20
    Zustimmungen:
    0
    Punkte für Erfolge:
    0
    do you think my recovery exe is faulty? - cannot be, is downloaded from fritz ftp site... What about using this kdslmod.ko from another image of eumex? to patch my 8.04.49 english? Is this an option for me? Is there already a pacthed image 8.0.49 english with kdslmod.ko that I can use - I have no linux machine!
     
  18. adrians

    adrians Neuer User

    Registriert seit:
    15 Jan. 2008
    Beiträge:
    20
    Zustimmungen:
    0
    Punkte für Erfolge:
    0
    ... and yes, it is FritBox Fon Wlan - this is what is written on it! Dont know why after recovery says 10.04.43! Im getting crazy with this box.
     
  19. imagomundi

    imagomundi IPPF-Promi

    Registriert seit:
    27 Okt. 2006
    Beiträge:
    3,684
    Zustimmungen:
    2
    Punkte für Erfolge:
    38
    Ort:
    Santiago de Chile
    10.04.34 or 10.04.43? What size is your recovery 04.34 after download to your PC?
     
  20. adrians

    adrians Neuer User

    Registriert seit:
    15 Jan. 2008
    Beiträge:
    20
    Zustimmungen:
    0
    Punkte für Erfolge:
    0
    #20 adrians, 15 Okt. 2011
    Zuletzt bearbeitet: 15 Okt. 2011
    okay...dont know if it was smart but I changed the bootloader cat mtd2.bin > /dev/mtdblock3

    I have downloaded 08.04.26 recovery file annex a avme, it detects the box but says incompatible firmware. I assume is because of the firmware_version or firmware_info


    I'm back with adam2 and unfortunatley cannot SETENV (setenv failed) and I see that I left the firmware on avm. Any advise?